Z-Star Microelectronics Corp. ZC0301 WebCam detected (0ac8:301b), but not working - Bad module

Bug #144745 reported by Peng Deng on 2007-09-25
88
This bug affects 4 people
Affects Status Importance Assigned to Milestone
WengoPhone
Invalid
Undecided
Unassigned
cheese (Ubuntu)
Undecided
Unassigned
linux (Ubuntu)
Medium
Stefan Bader
udev (Ubuntu)
Undecided
Unassigned

Bug Description

Short Description:

If zc0301 was loaded first then gspca will occur a conflict and the Webcam will not work,
-- Possible solutions:
 * Load gspca first then zc0301 ;
 * Include zc0301 in '/etc/modprobe.d/blacklist' .

Full Description:

My webcam is detected by the system and can be found by the v4l2 driver in ekiga (i.e. it works in ekiga). But when I open Cheese, it prompts "Unable to find a webcam, SORRY!".

This is a Thinkpad T43 266871U. The system is Ubuntu Gusty, kernel: 2.6.22-12-generic.

Steps to solve this problem:
sudo apt-get install gspca-source
sudo m-a prepare
sudo m-a a-i gspca
and ever run left each reboot:
sudo rmmod zc0301
sudo rmmod gspca
sudo modprobe gspca

### lsusb ###

Bus 005 Device 002: ID 050d:0218 Belkin Components
Bus 005 Device 004: ID 046d:c016 Logitech, Inc. M-UV69a Optical Wheel Mouse
Bus 005 Device 005: ID 0d49:3200 Maxtor
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 003: ID 0483:2016 SGS Thomson Microelectronics Fingerprint Reader
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 007: ID 0ac8:301b Z-Star Microelectronics Corp. ZC0301 WebCam
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

### dmesg ###

[ 2502.084000] usb 2-2: new full speed USB device using uhci_hcd and address 7
[ 2502.280000] usb 2-2: configuration #1 chosen from 1 choice
[ 2502.448000] Linux video capture interface: v2.00
[ 2502.488000] zc0301: V4L2 driver for ZC0301[P] Image Processor and Control Chip v1:1.07
[ 2502.488000] usb 2-2: ZC0301[P] Image Processor and Control Chip detected (vid/pid 0x0AC8:0x301B)
[ 2502.564000] usb 2-2: PB-0330 image sensor detected
[ 2502.976000] usb 2-2: Initialization succeeded
[ 2502.976000] usb 2-2: V4L2 device registered as /dev/video0
[ 2502.976000] usbcore: registered new interface driver zc0301
[ 2502.992000] usbcore: registered new interface driver gspca
[ 2502.992000] /build/buildd/linux-ubuntu-modules-2.6.22-2.6.22/debian/build/build-generic/media/gspcav1/gspca_core.c: gspca driver 01.00.12 registered

### Output when running Cheese ###

** Message: Probing the webcam, please ignore the following, not applicabable tries
** Message: Error running pipeline 'v4l2src ! fakesink': Could not negotiate format [gstbasesrc.c(2062): gst_base_src_start (): /pipeline0/v4l2src0:
Check your filtered caps, if any]
** Message: test pipeline for v4l2src failed:
[v4l2src ! fakesink]: Could not negotiate format
** Message: Error running pipeline 'v4lsrc ! video/x-raw-rgb,width=640,height=480 ! fakesink': Could not get/set settings from/on resource. [v4l_calls.c(89): gst_v4l_get_capabilities (): /pipeline1/v4lsrc0:
error getting capabilities Invalid argument of from device /dev/video0]
** Message: test pipeline for v4lsrc failed:
[v4lsrc ! video/x-raw-rgb,width=640,height=480 ! fakesink]: Could not get/set settings from/on resource.
** Message: Error running pipeline 'v4lsrc ! video/x-raw-yuv,width=640,height=480 ! fakesink': Could not get/set settings from/on resource. [v4l_calls.c(89): gst_v4l_get_capabilities (): /pipeline2/v4lsrc1:
error getting capabilities Invalid argument of from device /dev/video0]
** Message: test pipeline for v4lsrc failed:
[v4lsrc ! video/x-raw-yuv,width=640,height=480 ! fakesink]: Could not get/set settings from/on resource.
** Message: Error running pipeline 'v4lsrc ! video/x-raw-rgb,width=320,height=240 ! fakesink': Could not get/set settings from/on resource. [v4l_calls.c(89): gst_v4l_get_capabilities (): /pipeline3/v4lsrc2:
error getting capabilities Invalid argument of from device /dev/video0]
** Message: test pipeline for v4lsrc failed:
[v4lsrc ! video/x-raw-rgb,width=320,height=240 ! fakesink]: Could not get/set settings from/on resource.
** Message: Error running pipeline 'v4lsrc ! video/x-raw-rgb,width=1280,height=960 ! fakesink': Could not get/set settings from/on resource. [v4l_calls.c(89): gst_v4l_get_capabilities (): /pipeline4/v4lsrc3:
error getting capabilities Invalid argument of from device /dev/video0]
** Message: test pipeline for v4lsrc failed:
[v4lsrc ! video/x-raw-rgb,width=1280,height=960 ! fakesink]: Could not get/set settings from/on resource.
** Message: Error running pipeline 'v4lsrc ! video/x-raw-rgb,width=174,height=144 ! fakesink': Could not get/set settings from/on resource. [v4l_calls.c(89): gst_v4l_get_capabilities (): /pipeline5/v4lsrc4:
error getting capabilities Invalid argument of from device /dev/video0]
** Message: test pipeline for v4lsrc failed:
[v4lsrc ! video/x-raw-rgb,width=174,height=144 ! fakesink]: Could not get/set settings from/on resource.
** Message: Error running pipeline 'v4lsrc ! video/x-raw-rgb,width=160,height=120 ! fakesink': Could not get/set settings from/on resource. [v4l_calls.c(89): gst_v4l_get_capabilities (): /pipeline6/v4lsrc5:
error getting capabilities Invalid argument of from device /dev/video0]
** Message: test pipeline for v4lsrc failed:
[v4lsrc ! video/x-raw-rgb,width=160,height=120 ! fakesink]: Could not get/set settings from/on resource.
** Message: Error running pipeline 'v4lsrc ! fakesink': Could not get/set settings from/on resource. [v4l_calls.c(89): gst_v4l_get_capabilities (): /pipeline7/v4lsrc6:
error getting capabilities Invalid argument of from device /dev/video0]
** Message: test pipeline for v4lsrc failed:
[v4lsrc ! fakesink]: Could not get/set settings from/on resource.
using source: videotestsrc

Revision history for this message
Jeffrey Patrick Lui (punong-bisyonaryo) wrote :

I am also having the same problem ie fails with Camorama and Wengo but works in v4l2 in Ekiga.
It is not a ZC0301 but a ZCO0303

### lsusb ###
Bus 001 Device 002: ID 0ac8:303b Z-Star Microelectronics Corp. ZC0303 WebCam

### dmesg ###
[ 4.284000] usb 1-1: new full speed USB device using ohci_hcd and address 2
[ 4.496000] usb 1-1: configuration #1 chosen from 1 choice
[ 18.152000] usb 1-1: ZC0301[P] Image Processor and Control Chip detected (vid/pid 0x0AC8:0x303B)
[ 18.308000] usb 1-1: PB-0330 image sensor detected
[ 19.064000] usb 1-1: Initialization succeeded
[ 19.064000] usb 1-1: V4L2 device registered as /dev/video0
[ 19.064000] usbcore: registered new interface driver zc0301
[ 19.140000] usbcore: registered new interface driver gspca

Camorama just gives a "Could not connect to video device (/dev/video0)" while Wengo sees the camera, but is unable to access it.

Appreciate any help we can get.

Thanks!

Revision history for this message
Jeffrey Patrick Lui (punong-bisyonaryo) wrote :

I was able to get my webcam working by removing the zc0301 module so that my applications use gspca, as discussed in the ubuntuforums at http://ubuntuforums.org/showthread.php?t=583132, but you probably won't learn anything more than what you know now. What module is loaded in your system? That may give us more insight into this bug.

Changed in wengophone:
status: New → Invalid
Revision history for this message
Peng Deng (d6g) wrote :

The work-around that punong_bisyonaryo posted works for me. Just remove the modules gspca and zc0301 and reload gspca, then the webcam can work in Cheese. But when switching to the video mode in Cheese, my system crashes and a forced (cold) reboot has to be used.

Changed in cheese:
status: New → Confirmed
Changed in linux:
assignee: nobody → kernel-bugs
description: updated
Revision history for this message
Leann Ogasawara (leannogasawara) wrote : Re: Webcam detected, but not working - Bad module

The Hardy Heron Alpha series is currently under development and contains an updated version of the kernel. It would be helpful if you could test the latest Hardy Alpha release: http://www.ubuntu.com/testing . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. Thanks.

Changed in linux:
status: Confirmed → Incomplete
Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

Device clearly exists, so is not a udev bug.

Changed in udev:
status: New → Invalid
Revision history for this message
Peng Deng (d6g) wrote :

I recently upgraded my system from Gutsy to Hardy using "do-release-upgrade -d".

I still have the same problem if zc0301 module is loaded. After it is unloaded, the webcam can work properly. The video recording feature of Cheese works now in Hardy, although a little sluggish during starting and stoping the recording.

Maybe a clean installation should be used for testing.

Revision history for this message
Marcelo Atie (marceloatie) wrote :

I tested it today and finally it's working
For me it's Fix Released. I don't know why Peng Deng had this problem, i don't know so well how zc0301 and gspca are working together so well,

Peng Deng, try upgrade your system and reboot and report if it are working or not, i did a installation from ubuntu 8.04RC and today it's simply working pretty well.

If nobody re-confirm this bug in 3 weeks so the bug will be marked as Fix-Released.

Thz

Changed in cheese:
status: New → Invalid
Revision history for this message
Peng Deng (d6g) wrote :

I upgrade another laptop to Hardy and my webcam works withouth any problem on that one. But it still won't on mine. So I did a comparison of the "lsmod | grep zc" output between 2 laptops.

The one (laptop A) where webcam works has output like:

zc0301 52356 0
compat_ioctl32 2304 1 zc0301
videodev 29440 2 zc0301,gspca
v4l2_common 18304 2 zc0301,videodev
usbcore 146028 8 zc0301,gspca,hci_usb,usb_storage,libusual,ehci_hcd,uhci_hcd

The other one(laptop B):

zc0301 52356 0

compat_ioctl32 2304 1 zc0301

videodev 29440 2 gspca,zc0301

v4l2_common 18304 2 zc0301,videodev

usbcore 146028 7 gspca,zc0301,usbhid,hci_usb,ehci_hcd,uhci_hcd

Realizing the difference in the order of two modules, I manually unloaded both of the modules and reloaded "gspca" first and then "zc0301" on laptop B, therefore the output of lsmod is the same as laptop A.

After doing this, my webcam works again on laptop B.

So, can anyone please tell me howto to control the order when loading two modules? Should I add a new udev rule under /etc/udev/rules.d/?

Revision history for this message
Marcelo Atie (marceloatie) wrote :

I found a simply way to disability the module zc0301

simply go to '/etc/modprobe.d/blacklist' and add at de end of the file:

# replaced by gspca (Ubuntu #144745)
blacklist zc0301

save and reboot ;)

Changed in linux:
status: Incomplete → Confirmed
Revision history for this message
Marcelo Atie (marceloatie) wrote :

Someone of kernel bugs can add it in the default /etc/modprobe.d/blacklist ?

Revision history for this message
Marcelo Atie (marceloatie) wrote :

Peng Deng, can you test if editing /etc/modprobe.d/blacklist will solute the problem in "laptop B" ?

Revision history for this message
Peng Deng (d6g) wrote :

Hi Marcelo, to blacklist the module zc0301 is a workaround already been posted above by punong_bisyonaryo, I've been used it ever since it's posted.

I think, that is a workaround, not a final solution. And the module zc0301, if loaded in a right order, will not cause problem. So blacklist it may still be an approach to let the webcam working, however how to manage the order of loading 2 modules is currently what I try to understand.

Revision history for this message
Marcelo Atie (marceloatie) wrote : Re: [Bug 144745] Re: Webcam detected, but not working - Bad module
  • unnamed Edit (47 bytes, text/html; charset=ISO-8859-1)

why we need load zc0301 if we have gspca ?

Changed in linux:
assignee: kernel-bugs → ubuntu-kernel-team
importance: Undecided → Medium
status: Confirmed → Triaged
Revision history for this message
Marcelo Atie (marceloatie) wrote :
  • unnamed Edit (14 bytes, text/html; charset=ISO-8859-1)

Thanks :D

Revision history for this message
Tito's (rcarrasco) wrote : Re: Webcam detected, but not working - Bad module

Same problem here.

Maxxtro Webcam ( 0c45:6019 Microdia ) works if i blacklist sn9c102 module

Ubuntu hardy last updated jul 5 2008

description: updated
Revision history for this message
Marcelo Atie (marceloatie) wrote :

Attached 'sudo lsusb -vv'

Stefan Bader (smb) on 2008-08-26
Changed in linux:
assignee: ubuntu-kernel-team → stefan-bader-canonical
Revision history for this message
Stefan Bader (smb) wrote :

OK, I digged quite a bit. The solution is probably a bit more complex than it seems. To blacklist a module by default can always break a working system for somebody else. The fact that another driver is better for one device does not mean it is useless. For zc0301 this seems small since there is only one ID which is not handled by the gspca driver, but for sn9c102 there would be 27...

The problem seems really to lie within the loading order. As Peng Deng noted, on one computer it is ok, on another it isn't. I am quite sure the order is defined by modules.usbmap and I could see that the order of the elements there were different on two computers I checked. The gspca driver comes with ubuntu modules and modules there should have precedence over modules in the kernel. There is a configuration file which declares a search order (/etc/depmod.d/ubuntu.conf) in that way. But that did not seem to matter.
In fact the current code of depmod only uses this order when two modules have the same name (which is not the case here). I think the problem can be fixed by changing depmod to scan directories in the order defined, so that ID's of modules under ubuntu are listed before the ones under kernel.

To test this I created updated versions of depmod. Could someone (after saving the original) replace the depmod command with the updated version and check whether (after depmod -a) the behaviour changes?

Revision history for this message
Stefan Bader (smb) wrote :
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Revision history for this message
Stefan Bader (smb) wrote :

Please anyone with that problem on Hardy, try one of the attached depmod commands and let me know whether this improves things or not.

Revision history for this message
Marcelo Atie (marceloatie) wrote :

depmod i386 worked, but i got some problems ...

1 - The image of webcam was in a small quality
2 - Cheese opens my capture card rather than open my webcam.

I still can use 'sudo rmmod zc0301; sudo rmmod gspca; sudo modprobe gspca' do solve all this problems and get my webcam working perfectly.

ps.: I used vlc to test my webcam.

Revision history for this message
Daniel Santibáñez Polanco (dansanti) wrote :

well, i have a laptop dell inspiron 1525 with a integrated webcam, when i been upgrated to ubuntu intrepid, it left to work,i see anithing in the window and when i try to close cheese, it crash and i have to force the close.

Revision history for this message
Ken Pimontel (ken-specialorder) wrote :

I have a similar problem with a Dell SP2208WFP webcam. Ekiga shows it fine, but Cheese gives me either the test images or a gray screen.

In dmesg I have:
[35531.804074] uvcvideo: Found UVC 1.00 device Monitor Webcam (SP2208WFP) (05a9:2643)
[35532.808072] uvcvideo: Failed to query (135) UVC control 1 (unit 0) : -110 (exp. 26).
[35532.830960] input: Monitor Webcam (SP2208WFP) as /devices/pci0000:00/0000:00:1d.7/usb8/8-2/8-2.1/8-2.1:1.0/input/input6

Is there a fix? Anything I can do to help?

Revision history for this message
Fabián Rodríguez (magicfab) wrote :

I have this camera, tested it in Intrepid, same problem.

Workarounds mentioned don't work as gspca doesn't build in Intrepid.

Revision history for this message
wlx (wangliangxu) wrote :

in Intrepid, try this command with skype:

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

please see https://bugs.launchpad.net/ubuntu/+source/libv4l/+bug/260918

Revision history for this message
Andres Mujica (andres.mujica) wrote :

Hi i've marked some dupes from this bug as this is already being worked on. Probably some info could be there (check the bug #293259)

Revision history for this message
Andres Mujica (andres.mujica) wrote :

Stephan, i've got a doubt.. is this the same bug #144745 that is being worked by Andy?

Revision history for this message
Andres Mujica (andres.mujica) wrote :

sorry i meatn bug #292086

Revision history for this message
Andres Mujica (andres.mujica) wrote :

Hi, those affected with this issue can check

https://bugs.edge.launchpad.net/ubuntu/+source/linux/+bug/292086/comments/16

for a solution to this problem. This fix mainly applies for 301 devices, but it could work for others as well.

For those that didn't work, please come back here reporting lsusb for your devices.

Thanks

Revision history for this message
Andres Mujica (andres.mujica) wrote :

for 303 devices, sorry

Revision history for this message
Marcelo Atie (marceloatie) wrote :

Andres, very thanks by found the bug #292086, i hope that we will work together

Revision history for this message
Andres Mujica (andres.mujica) wrote :

Marcelo, no prob, off course we can work together!!!

Are you affected by this issue? the test packages worked for you? which is the lsusb id from your camera?

Thanks!

Revision history for this message
Alessandro (alesandromarkes-linux) wrote :
Download full text (4.2 KiB)

Hi. I have used kubuntu for one year and that is the first time I confirm a bug. I was using kubuntu hardy with my webcam working perfectly. But after a clean install of kubuntu intrepid my webcam can't correctly work with the usual program (skype, vlc, kopete, etc). The images became weird. The kernel is updated, all the packages too. The only way I get it work perfectly is installing the libv4l-0 package and using the commands:
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so vlc
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so kopete

I thing it should not happen that way.

#lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 04fc:0561 Sunplus Technology Co., Ltd Flexcam 100
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

#lsmod | grep video
video 25104 0
output 11008 1 video
videodev 41344 1 gspca_main
v4l1_compat 22404 1 videodev

# dmesg
[ 2.975286] usbcore: registered new interface driver usbfs
[ 2.975316] usbcore: registered new interface driver hub
[ 2.975388] usbcore: registered new device driver usb
[ 3.043677] usb usb1: configuration #1 chosen from 1 choice
[ 3.043705] hub 1-0:1.0: USB hub found
[ 3.043717] hub 1-0:1.0: 8 ports detected
[ 3.260043] ehci_hcd 0000:00:02.1: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
[ 3.260242] usb usb2: configuration #1 chosen from 1 choice
[ 3.260276] hub 2-0:1.0: USB hub found
[ 3.260287] hub 2-0:1.0: 8 ports detected
[ 3.884032] usb 1-6: new full speed USB device using ohci_hcd and address 2
[ 4.096672] usb 1-6: configuration #1 chosen from 1 choice
[ 22.306044] Linux video capture interface: v2.00
[ 22.358641] gspca: main v2.2.0 registered
[ 22.430087] gspca: probing 04fc:0561
[ 22.679486] Linux agpgart interface v0.103
[ 22.984966] gspca: probe ok
[ 22.985001] usbcore: registered new interface driver spca561
[ 22.985039] spca561: registered

# modprobe -l gspc*
/lib/modules/2.6.27-9-generic/kernel/drivers/media/video/gspca/gspca_spca506.ko
/lib/modules/2.6.27-9-generic/kernel/drivers/media/video/gspca/gspca_ov519.ko
/lib/modules/2.6.27-9-generic/kernel/drivers/media/video/gspca/gspca_sonixj.ko
/lib/modules/2.6.27-9-generic/kernel/drivers/media/video/gspca/gspca_spca505.ko
/lib/modules/2.6.27-9-generic/kernel/drivers/media/video/gspca/gspca_sunplus.ko
/lib/modules/2.6.27-9-generic/kernel/drivers/media/video/gspca/gspca_stk014.ko
/lib/modules/2.6.27-9-generic/kernel/drivers/media/video/gspca/gspca_spca508.ko
/lib/modules/2.6.27-9-generic/kernel/d...

Read more...

Revision history for this message
Stefan Bader (smb) wrote :

Just a quick update:

@Andres, it is not the same, just similar. The problem with that cam here 0ac8:301b is that it is claimed by both drivers (gspca and zc301) while with the other bug gspca did not claim the id. Here the issue is rather one of the module utilities which for one do not get only one modules loaded as intended.

@Allesandro, this sounds rather like a different problem. There was a major move to v4l2 while many drivers still stay with v4l1. However the applications should be making use of the compat library. Do you have -proposed enabled for your installation?

Revision history for this message
Alessandro (alesandromarkes-linux) wrote :

Hi, do you mean that the problem is in the applications that should work with the compat library?
I didn't exactly understand your question.
Thanks for the answer.

Revision history for this message
Stefan Bader (smb) wrote :

Hi Allesandro, I meant the use of the v4l1compat should be the default now for these applications. At least with the most current versions. If not you should report a new bug for this (just make sure you are at the latest level for your release and say which release you are on).

Revision history for this message
berduchwal (marcin-maleccy) wrote :

Hi
I am experiencing the same problem.

dmesg
[24255.500046] usb 4-1: new full speed USB device using uhci_hcd and address 2
[24255.760426] usb 4-1: configuration #1 chosen from 1 choice
[24255.889438] Linux video capture interface: v2.00
[24255.897598] zc0301: V4L2 driver for ZC0301[P] Image Processor and Control Chip v1:1.10
[24255.898816] usb 4-1: ZC0301[P] Image Processor and Control Chip detected (vid/pid 0x0AC8:0x303B)
[24255.975104] usb 4-1: No supported image sensor detected
[24255.975951] usbcore: registered new interface driver zc0301

lsusb
Bus 004 Device 003: ID 0ac8:303b Z-Star Microelectronics Corp. ZC0303 WebCam

I have libv4l-0 and:
LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so skype
did not help.

It was working fine under 8.04.

This is repetition of what I put in: http://ubuntuforums.org/showthread.php?p=6546878
before I find this.

Please do let me know if there is anything I might do to help fix the problem.

Revision history for this message
berduchwal (marcin-maleccy) wrote :

Hi
I tried to use the workaround at the top:
----------
Steps to solve this problem:
sudo apt-get install gspca-source
sudo m-a prepare
sudo m-a a-i gspca
and ever run left each reboot:
sudo rmmod zc0301
sudo rmmod gspca
sudo modprobe gspca
----------

but it did not help as gspca did not compile.

after:
 sudo modprobe -r zc0301

dmesg
[ 136.752056] usb 5-1: new full speed USB device using uhci_hcd and address 2
[ 137.019543] usb 5-1: configuration #1 chosen from 1 choice
[ 137.204316] Linux video capture interface: v2.00
[ 137.212426] zc0301: V4L2 driver for ZC0301[P] Image Processor and Control Chip v1:1.10
[ 137.213033] usb 5-1: ZC0301[P] Image Processor and Control Chip detected (vid/pid 0x0AC8:0x303B)
[ 137.291108] usb 5-1: No supported image sensor detected
[ 137.291592] usbcore: registered new interface driver zc0301
[ 165.163750] ppdev0: registered pardevice
[ 165.212091] ppdev0: unregistered pardevice
[ 270.902719] usbcore: deregistering interface driver zc0301
[ 285.352616] process `skype' is using obsolete setsockopt SO_BSDCOMPAT

Revision history for this message
Nils S. (nils-schroeder) wrote :

Hello,
Alessandros way worked for me:

1. Download and unpack http://people.atrpms.net/~hdegoede/libv4l-0.5.0.tar.gz
2. See README, and install: sudo make install
3. Open terminal window
4. $ export LD_PRELOAD=/usr/local/lib/libv4l/v4l1compat.so
5. $ camstream
(see http://play.datalude.com/blog/?p=117)

yes it is a different problem from that one here, just want to tell other people coming from google.

I have a /dev/video0 but my cam was not working with a bunch of programms until I installed v4l from the link above.

uname -a: Linux laptop 2.6.27.2 #1 SMP Thu Nov 27 22:11:44 CET 2008 i686 GNU/Linux

lsusb | grep Cam: Bus 002 Device 004: ID 0ac8:301b Z-Star Microelectronics Corp. ZC0301 WebCam

dmesg:
[ 1398.676084] usb 2-1: new full speed USB device using uhci_hcd and address 5
[ 1398.912793] usb 2-1: configuration #1 chosen from 1 choice
[ 1398.915645] gspca: probing 0ac8:301b
[ 1399.223543] zc3xx: probe sensor -> 0a
[ 1399.223558] zc3xx: Find Sensor PB0330. Chip revision 0
[ 1399.240929] gspca: probe ok

Revision history for this message
berduchwal (marcin-maleccy) wrote :

does not work for:
lsusb
Bus 004 Device 003: ID 0ac8:303b Z-Star Microelectronics Corp. ZC0303 WebCam

still the same in Skype

Revision history for this message
Nils S. (nils-schroeder) wrote :

@berduchwal
You have a 0ac8:303b i think your Bug is may this one:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/292086

Try the 2.6.27-13 kernel out of the Proposed rep.
(https://wiki.ubuntu.com/Testing/EnableProposed)

Revision history for this message
berduchwal (marcin-maleccy) wrote :

Thank you for your help. Problem solved following the link you suggested.

Revision history for this message
Stefan Bader (smb) wrote :

So the missing id went into the latest proposed. Is the original problem (the conflicting drivers) still an issue with the current Jaunty beta? For Hardy, maybe the least intrusive approach might be to remove the initially reported id from the other driver. I try to get some test kernel done for that, so this could get into stable updates.

Revision history for this message
Stefan Bader (smb) wrote :

To try that remove ID approach. Are the kernels at http://people.ubuntu.com/~smb/bug144745/ allowing to use the webcam on Hardy without any special measurements?

Changed in linux (Ubuntu):
status: Triaged → In Progress
Revision history for this message
Stefan Bader (smb) wrote :

I refreshed the test kernels but if nobody tests and reports back I will have to drop this.

Changed in linux (Ubuntu):
status: In Progress → Incomplete
Revision history for this message
ottadini (ben-harrison) wrote :

I have little comprehension of the preceeding discussion. Perhaps someone could summarise the issues met and their solutions?

Selfishly, could someone tell me why on Karmic I cannot access my Z-Star Microelectronics Corp. ZC0301 Webcam?

Essential bits of info (I think):
$ uname -a
Linux ottadini 2.6.31-22-generic #63-Ubuntu SMP Wed Aug 18 22:54:26 UTC 2010 i686 GNU/Linux

$ lsusb | grep cam
Bus 001 Device 005: ID 0ac8:301b Z-Star Microelectronics Corp. ZC0301 Webcam

$ dmesg
[ 28.887501] Linux video capture interface: v2.00
[ 28.912527] gspca: main v2.6.0 registered
[ 28.914649] gspca: probing 0ac8:301b
[ 28.976303] Intel ICH 0000:00:1e.2: PCI INT A -> GSI 23 (level, low) -> IRQ 23
[ 28.976363] Intel ICH 0000:00:1e.2: setting latency timer to 64
[ 28.988869] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 29.400019] intel8x0_measure_ac97_clock: measured 58926 usecs (2839 samples)
[ 29.400024] intel8x0: clocking to 48000
[ 30.608639] zc3xx: probe 2wr ov vga 0x0000
[ 30.708878] zc3xx: probe 3wr vga 1 0x8000
[ 30.711769] zc3xx: probe sensor -> 0014
[ 30.711773] zc3xx: Find Sensor CS2102K?. Chip revision 8000
[ 30.712467] gspca: probe ok
[ 30.712504] usbcore: registered new interface driver zc3xx
[ 30.712510] zc3xx: registered

Revision history for this message
Tormod Volden (tormodvolden) wrote :

This seems to be fine in 3.0.0-12.20. There is no zc0301 module shipped, and the gspca_zc3xx and gspca_main modules are loaded.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Revision history for this message
Plutocrat (plutocrat) wrote :

This has been broken for about a year now. Currently on Ubuntu 13.04. Same deal. Camera is correctly detected when plugged in, modules are loaded, /dev/video0 is created, but no software can actually use it.

uname -a
Linux aardvark 3.8.0-35-generic #50-Ubuntu SMP Tue Dec 3 01:25:33 UTC 2013 i686 i686 i686 GNU/Linux

dmesg:
[ 329.328094] usb 5-1: new full-speed USB device number 3 using uhci_hcd
[ 329.521148] usb 5-1: New USB device found, idVendor=0ac8, idProduct=301b
[ 329.521157] usb 5-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 329.521161] usb 5-1: Product: PC Camera
[ 329.521166] usb 5-1: Manufacturer: Vimicro Corp.
[ 333.854039] input: gspca_zc3xx as /devices/pci0000:00/0000:00:1d.0/usb5/5-1/input/input12
[ 333.854691] usbcore: registered new interface driver gspca_zc3xx

lsmod | grep gspc
gspca_zc3xx 51016 0
gspca_main 27661 1 gspca_zc3xx
videodev 95806 2 gspca_main,gspca_zc3xx

lsusb
Bus 005 Device 003: ID 0ac8:301b Z-Star Microelectronics Corp. ZC0301 Webcam

ls -al /dev/vi*
crw-rw----+ 1 root video 81, 0 Jan 29 07:17 /dev/video0

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers