8086:08b3 Cannot connect to any 802.11n WiFi access points

Bug #1436891 reported by Darren Peets on 2015-03-26
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

When attempting to connect to a 802.11n iptime N104T router (firmware 8.86), two popup messages appear:
Connection 'SSID' deactivated.
The WiFi network could not be found

Expected behaviour: Connects to network.

Minimal demonstration: connect to a WiFi access point by both LAN and WiFi B/G. Log in to access point, change it to B/G/N. Connection is lost, cannot be re-established until reverted to B/G.

Previous troubleshooting located here:
https://www.kubuntuforums.net/showthread.php?67556-Can-t-use-wifi

Description: Ubuntu Vivid Vervet (development branch)
Release: 15.04
linux-firmware 1.143

Can connect normally (with N) from 14.04.2 and 14.10 live CDs. Can connect in 15.04 if and only if N deactivated in access point.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: linux-firmware 1.143
ProcVersionSignature: Ubuntu 3.19.0-10.10-generic 3.19.2
Uname: Linux 3.19.0-10-generic x86_64
ApportVersion: 2.16.2-0ubuntu4
Architecture: amd64
CurrentDesktop: KDE
Date: Fri Mar 27 00:14:58 2015
Dependencies:

InstallationDate: Installed on 2015-03-04 (22 days ago)
InstallationMedia: Kubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20150224.1)
PackageArchitecture: all
SourcePackage: linux-firmware
UpgradeStatus: No upgrade log present (probably fresh install)

Darren Peets (dpeets) wrote :
Joseph Salisbury (jsalisbury) wrote :

Did this issue start happening after an update/upgrade? Was there a prior kernel version where you were not having this particular problem?

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.0 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-rc5-vivid/

affects: linux-firmware (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Medium

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1436891

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

$ sudo apport-collect 1436891
ERROR: Could not import module, is a package upgrade in progress? Error: No module named PyQt4.QtCore

Created duplicate report, on linux:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1437084

This issue happened for all kernel versions I've tried in 15.04, from the beta live CD to the current kernel. The problem does not exist with the 14.10 or 14.04.2 live CDs

It may be a few days before I try the upstream kernel.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Darren Peets (dpeets) wrote :

Actually, installing and running the upstream kernel was much more painless than anticipated

Same problem with 4.0.0-040000rc5-generic

tags: added: kernel-bug-exists-upstream
Darren Peets (dpeets) wrote :

I've now fixed the python thing, let me know if there's anything that would be included by apport-collect that isn't in the duplicate bug.

Darren Peets, the next step is to fully commit bisect from kernel 3.16 to 3.19 in order to identify the last good kernel commit, followed immediately by the first bad one. This will allow for a more expedited analysis of the root cause of your issue. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection ?

Please note, finding adjacent kernel versions is not fully commit bisecting.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

tags: added: kernel-bug-exists-upstream-4.0-rc5 needs-bisect regression-release
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Darren Peets (dpeets) wrote :

Update:

Bug exists in first Vivid version (3.16.0-23.31) that's readily available in pre-packaged .deb format. So I need to start building kernels, I presume, to check 3.16.0-0.1 (since I don't yet have a "good" kernel within Vivid) and bisect from there.

I'm still trying to figure out how to build specific versions. Or, how to find a commit corresponding to the start of Vivid.

I also tried Utopic's 3.16.0-34.45, and the bug is not present there -- I can connect to wifi N just fine with that one. I presume that the versions for Utopic and Vivid don't map directly onto each other?

Butler G. S. P. (butlergsp) wrote :

I found I have the exact same bug, and that my laptop, a Dell Inspiron 5548, is similar to one mentioned in an article which led me here. I discovered the problem on upgrading to 15.04, from 14.10. If I can provide any system information which can help the problem's identification, please tell me what to do.

Intel Corporation Wireless 3160 (rev 83)

Darren Peets (dpeets) wrote :

If you have any idea how to build kernels and have the time to bisect them, that may help. I don't have a lot of time to devote to this, and don't really know what I'm doing or how to do it. I'll leave it up to other people to tell you whether or not another bug report on possibly-different hardware would help.

Butler G. S. P., it would help immensely if you would file a new report via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

YAFU (yafu) wrote :

Could the problem be related to kwalletmanager and password management system? When I try to connect to wifi then KWallet insists on being used. I select "Cancel" and the wifi network is not connected. I've noticed that KWallet takes the control of the system. In previous versions of Kubuntu, I could disable KWallet from systemsettings, but now I can't find this entry. After launching KWallet from the menu and from KWallet settings, I can disable it. But KWallet gets worse, it continues requesting to be used, and if I try to open it from the menu, KWallet freezes. In the end I decided to use it and set a password. The wifi connection was established but the connection falls at few seconds. From LiveDVD I can not connect to wifi too, but KWallet is not open asking to be used in LiveDVD, but I do not know, maybe kwallet is intervening in the background too.

YAFU (yafu) wrote :

Oh my! Who had the bad idea to make "network-manager" and "plasma-desktop" dependent packages? In other versions of Kubuntu I just uninstalled network-manager so that wicd can to work.

Darren Peets (dpeets) wrote :

OK,

I couldn't figure out how to build kernel versions, so I tried to do a commit bisect between 3.16.0-0.1 and 3.16.0-23.31. It didn't do what I thought it would. From what I can tell, it looks like 3.16.0-0.1 is good, but git bisect took it to be bad, and has been bisecting things *before* it.

I might now have worked out how to get git to build a specific kernel version. The weather's supposed to be garbage tomorrow and I don't have all that much else to do, so maybe I'll have a chance to work on this a bit.

Darren Peets (dpeets) wrote :
Download full text (6.2 KiB)

I'm nearly done bisecting, but I'm going to be away for the next ~5 days and won't be able to finish until then. Here's what's left, in hopes that it's narrow enough to be helpful (bisecting the ubuntu-vivid kernel, output of git bisect visualize):

commit b531f5dd9cb84c5ee40156a230f8e28f69083821
Merge: 2ce7598 45ce829
Author: Linus Torvalds <email address hidden>
Date: Sun Sep 7 19:56:38 2014 -0700

    Merge git://git.kernel.org/pub/scm/linux/kernel/git/davem/net

    Pull networking fixes from David Miller:

     1) Fix skb leak in mac802154, from Martin Townsend

     2) Use select not depends on NF_NAT for NFT_NAT, from Pablo Neira
        Ayuso

     3) Fix union initializer bogosity in vxlan, from Gerhard Stenzel

     4) Fix RX checksum configuration in stmmac driver, from Giuseppe
        CAVALLARO

     5) Fix TSO with non-accelerated VLANs in e1000, e1000e, bna, ehea,
        i40e, i40evf, mvneta, and qlge, from Vlad Yasevich

     6) Fix capability checks in phy_init_eee(), from Giuseppe CAVALLARO

     7) Try high order allocations more sanely for SKBs, specifically if a
        high order allocation fails, fall back directly to zero order pages
        rather than iterating down one order at a time. From Eric Dumazet

     8) Fix a memory leak in openvswitch, from Li RongQing

     9) amd-xgbe initializes wrong spinlock, from Thomas Lendacky

    10) RTNL locking was busted in setsockopt for anycast and multicast, fix
        from Sabrina Dubroca

    11) Fix peer address refcount leak in ipv6, from Nicolas Dichtel

    12) DocBook typo fixes, from Masanari Iida

    * git://git.kernel.org/pub/scm/linux/kernel/git/davem/net: (101 commits)
      ipv6: restore the behavior of ipv6_sock_ac_drop()
      amd-xgbe: Enable interrupts for all management counters
      amd-xgbe: Treat certain counter registers as 64 bit
      greth: moved TX ring cleaning to NAPI rx poll func
      cnic : Cleanup CONFIG_IPV6 & VLAN check
      net: treewide: Fix typo found in DocBook/networking.xml
      bnx2x: Fix link problems for 1G SFP RJ45 module
      3c59x: avoid panic in boomerang_start_xmit when finding page address:
      netfilter: add explicit Kconfig for NETFILTER_XT_NAT
      ipv6: use addrconf_get_prefix_route() to remove peer addr
      ipv6: fix a refcnt leak with peer addr
      net-timestamp: only report sw timestamp if reporting bit is set
      drivers/net/fddi/skfp/h/skfbi.h: Remove useless PCI_BASE_2ND macros
      l2tp: fix race while getting PMTU on PPP pseudo-wire
      ipv6: fix rtnl locking in setsockopt for anycast and multicast
      VMXNET3: Check for map error in vmxnet3_set_mc
      openvswitch: distinguish between the dropped and consumed skb
      amd-xgbe: Fix initialization of the wrong spin lock
      openvswitch: fix a memory leak
      netfilter: fix missing dependencies in NETFILTER_XT_TARGET_LOG
      ...

commit 45ce829dd010668c3839a61b25843590eb4677dc
Merge: de185ab 1bd3fa7
Author: David S. Miller <email address hidden>
Date: Sun Sep 7 16:11:10 2014 -0700

    Merge tag 'master-2014-09-04' of git://git.kernel.org/pub/scm/linux/kernel/git/lin...

Read more...

Darren Peets (dpeets) wrote :

OK, bisect result and a caveat:

d88c8958dc13b4e4eb7fc57e3f06dc1c4abc7b1f is the first bad commit
commit d88c8958dc13b4e4eb7fc57e3f06dc1c4abc7b1f
Author: Emmanuel Grumbach <email address hidden>
Date: Mon Sep 1 09:50:14 2014 +0300

    iwlwifi: bump firmware API version to 10 for 7000 and 8000

    New firmware on the way.

    Signed-off-by: Emmanuel Grumbach <email address hidden>

:040000 040000 6fda9a82d01a59a4edeaee8d1fbeb2cce28eeecc 7b61151b4783bc2f3ae31a132fa36c80a84cb978 M drivers

Now, what I tried to do during the bisect was the following:
$ cp /boot/config-3.19.0-14-generic .config
$ make oldconfig
$ make clean
$ make -j `getconf _NPROCESSORS_ONLN` deb-pkg LOCALVERSION=-dpeets??
for ?? an increasing integer, and accepting all default settings for make oldconfig

HOWEVER, for a vast expanse in the middle of this bisect range, building the kernel image failed if started from the 3.19 config file (here's one example):
...
  INSTALL debian/tmp/lib/firmware/cpia2/stv0672_vp4.bin
  INSTALL debian/tmp/lib/firmware/yam/1200.bin
  INSTALL debian/tmp/lib/firmware/yam/9600.bin
  DEPMOD 3.16.0-dpeets22
depmod: ERROR: Found 5 modules in dependency cycles!
depmod: ERROR: Cycle detected: st21nfcb -> ndlc -> nci -> st21nfcb
depmod: ERROR: Cycle detected: nci -> nci
Makefile:1113: recipe for target '_modinst_post' failed
make[2]: *** [_modinst_post] Error 1
scripts/package/Makefile:90: recipe for target 'deb-pkg' failed
make[1]: *** [deb-pkg] Error 2
Makefile:1205: recipe for target 'deb-pkg' failed
make: *** [deb-pkg] Error 2

I'm not in a position to do anything other than accept the defaults, and I'm not about to edit the config file on my own. So for perhaps half of the bisect steps, the starting point for .config was the previous bisect step's .config (without first checking whether a copied 3.19 version worked), or in a couple cases a config file from a known good 3.16 kernel after the 3.19 config file failed. This means that the starting point was not necessarily the same for all steps.

If there are parts of this I should redo or check, config files you'd like (I didn't save them in general, but I have a few), or anything I can test, let me know.

Darren Peets, if the issue is still reproducible with the latest mainline kernel (4.1-rc1) then the issue you are reporting is an upstream one. Could you please report this problem to the appropriate mailing list by following the instructions verbatim at https://wiki.ubuntu.com/Bugs/Upstream/kernel ?

Please provide a direct URL to your e-mail to the mailing list once you have made it so that it may be tracked via http://vger.kernel.org/vger-lists.html . It can take a day for the new e-mail to show up in the respective archive.

Thank you for your understanding.

tags: added: bisect-done
removed: needs-bisect
Changed in linux (Ubuntu):
status: Incomplete → Triaged
summary: - Cannot connect to any WiFi access point which runs wireless-N
+ 8086:08b3 Cannot connect to any 802.11n WiFi access points

Darren Peets, if you could also provide a router manufacturer, model, and firmware version this is reproducible with, that would be most helpful.

Darren Peets (dpeets) wrote :

Router used for testing: iptime N104T, firmware 8.86, in case that's useful here (will be included in report)

Darren Peets (dpeets) wrote :

Bug no longer exists in the mainline kernel. Apparently I was too slow, and it was fixed sometime in the past month.

Darren Peets, could you please advise on which upstream kernel specifically this is no longer reproducible in?

Darren Peets (dpeets) wrote :

v4.1-rc1-vivid Bug absent!
v4.0-vivid Bug present
v4.0-rc7-vivid Bug present
v4.0-rc6-vivid
v4.0-rc5-vivid Bug present

Darren Peets (dpeets) wrote :

I upgraded my other laptop (6.5 years older, i386 rather than amd64) to 15.04, and I get the same issue there. Upstream kernel v4.1-rc1-vivid works, 3.19.0-15 has the bug. Let me know if you'd like another bug report on the older hardware, or if there's anything else I should do.

Darren Peets, regarding the originally reported laptop, the next step is to fully reverse commit bisect from kernel 4.1-rc1 to 4.0 in order to identify the last bad commit, followed immediately by the first good one. Once this commit has been identified, then it may be reviewed as a candidate for backporting into your release. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection#How_do_I_reverse_bisect_the_upstream_kernel.3F ?

Please note, finding adjacent kernel versions is not fully commit bisecting.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Darren Peets (dpeets) wrote :

If I haven't messed up anywhere, this is the first good commit:

$ git bisect bad
afcee962b09842d0f4191beb4a2d08251b4c7705 is the first bad commit
commit afcee962b09842d0f4191beb4a2d08251b4c7705
Author: Eyal Shapira <email address hidden>
Date: Mon Feb 9 15:18:17 2015 +0200

    iwlwifi: mvm: fix BT coex shared antenna activity check

    The shared antenna should be forbidden to use only if there's
    high BT activity. Comparing to BT_OFF was effectively causing
    us to always forbid using the shared antenna for SISO. This
    leads to degraded performance in scenarios where the shared
    antenna would have better performance.

    Signed-off-by: Eyal Shapira <email address hidden>
    Reviewed-by: Johannes Berg <email address hidden>
    Signed-off-by: Emmanuel Grumbach <email address hidden>

:040000 040000 f87bafe5e9fdb8e737a17f748375818f4d147a5f c26fc0cb302adf4e813acbbb6f3cbea1522af9bd M drivers

tags: added: cherry-pick reverse-bisect-done
Changed in linux (Ubuntu):
importance: Medium → High
status: Incomplete → Triaged
description: updated
tags: added: kernel-fixed-upstream kernel-fixed-upstream-4.1-rc1
removed: kernel-bug-exists-upstream kernel-bug-exists-upstream-4.0-rc5
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments