[Toshiba Equium A100-306] WARNING: CPU: 0 PID: 968 at /build/buildd/linux-3.19.0/drivers/gpu/drm/drm_irq.c:1121 drm_wait_one_vblank+0x170/0x180 [drm]()

Bug #1432405 reported by Dave Gilbert on 2015-03-15
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Unassigned

Bug Description

Noticed during boot of vivid after upgrade:

[ 54.762967] ------------[ cut here ]------------
[ 54.763009] WARNING: CPU: 1 PID: 968 at /build/buildd/linux-3.19.0/drivers/gpu/drm/drm_irq.c:1121 drm_wait_one_vblank+0x170/0x180 [drm]()
[ 54.763012] vblank not available on crtc 0, ret=-22
[ 54.763014] Modules linked in: binfmt_misc snd_hda_codec_si3054 arc4 snd_hda_codec_realtek snd_hda_codec_generic snd_hda_intel iwl3945 snd_hda_controller iwlegacy snd_hda_codec mac80211 snd_hwdep pcmcia snd_pcm snd_seq_midi snd_seq_midi_event snd_rawmidi yenta_socket cfg80211 coretemp pcmcia_rsrc tifm_7xx1 snd_seq pcmcia_core tifm_core joydev lpc_ich serio_raw snd_seq_device snd_timer irda snd soundcore toshiba_bluetooth toshiba_haps crc_ccitt 8250_fintek tpm_infineon shpchp mac_hid parport_pc ppdev lp parport autofs4 psmouse firewire_ohci pata_acpi e100 sdhci_pci mii i915 sdhci firewire_core i2c_algo_bit crc_itu_t drm_kms_helper drm video
[ 54.763065] CPU: 1 PID: 968 Comm: Xorg Tainted: G W 3.19.0-9-generic #9-Ubuntu
[ 54.763068] Hardware name: TOSHIBA Equium A100/MPAD-MSAE Customer Reference Boards, BIOS 2.10 10/23/2006
[ 54.763070] ffffffffc02e2b70 ffff8800ba62b738 ffffffff817c09b5 0000000000000007
[ 54.763075] ffff8800ba62b788 ffff8800ba62b778 ffffffff8107595a ffff8800ba62b758
[ 54.763079] ffff880035480000 ffff880035fb2000 0000000000000000 ffff880035480000
[ 54.763083] Call Trace:
[ 54.763094] [<ffffffff817c09b5>] dump_stack+0x45/0x57
[ 54.763099] [<ffffffff8107595a>] warn_slowpath_common+0x8a/0xc0
[ 54.763103] [<ffffffff810759d6>] warn_slowpath_fmt+0x46/0x50
[ 54.763118] [<ffffffffc02b5e80>] drm_wait_one_vblank+0x170/0x180 [drm]
[ 54.763155] [<ffffffffc03c53af>] ? gen4_read32+0x4f/0xc0 [i915]
[ 54.763186] [<ffffffffc0417955>] intel_enable_tv+0x25/0x60 [i915]
[ 54.763212] [<ffffffffc03e2d1b>] i9xx_crtc_enable+0x3fb/0x4c0 [i915]
[ 54.763239] [<ffffffffc03e12b2>] __intel_set_mode+0x882/0xc80 [i915]
[ 54.763266] [<ffffffffc03e6dfd>] intel_set_mode+0x6d/0x90 [i915]
[ 54.763293] [<ffffffffc03e7096>] intel_get_load_detect_pipe+0x276/0x600 [i915]
[ 54.763298] [<ffffffff811989d0>] ? zone_statistics+0x80/0xa0
[ 54.763328] [<ffffffffc0418555>] intel_tv_detect+0x135/0x670 [i915]
[ 54.763342] [<ffffffffc0322b13>] drm_helper_probe_single_connector_modes_merge_bits+0x303/0x460 [drm_kms_helper]
[ 54.763350] [<ffffffffc0322c83>] drm_helper_probe_single_connector_modes+0x13/0x20 [drm_kms_helper]
[ 54.763369] [<ffffffffc02c216f>] drm_mode_getconnector+0x43f/0x4b0 [drm]
[ 54.763383] [<ffffffffc02b3adf>] drm_ioctl+0x1df/0x680 [drm]
[ 54.763390] [<ffffffff812077b0>] do_vfs_ioctl+0x2e0/0x4e0
[ 54.763394] [<ffffffff811f5755>] ? __sb_end_write+0x35/0x70
[ 54.763399] [<ffffffff811f31c2>] ? vfs_write+0x1b2/0x1f0
[ 54.763403] [<ffffffff81207a31>] SyS_ioctl+0x81/0xa0
[ 54.763407] [<ffffffff817c7aed>] system_call_fastpath+0x16/0x1b
[ 54.763410] ---[ end trace 959064f9168f0b5b ]---

repeats quite a few times during the boot.
(3.19.0-9-generic #9-Ubuntu)
Oldish Core2 laptop, internal LCD only running KDE.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: linux-image-generic 3.19.0.9.8
ProcVersionSignature: Ubuntu 3.19.0-9.9-generic 3.19.1
Uname: Linux 3.19.0-9-generic x86_64
ApportVersion: 2.16.2-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dg 2008 F.... pulseaudio
Date: Sun Mar 15 17:49:05 2015
HibernationDevice: RESUME=/dev/mapper/davros--vg-swap_1
InstallationDate: Installed on 2013-11-15 (485 days ago)
InstallationMedia: Ubuntu-Server 14.04 LTS "Trusty Tahr" - Alpha amd64 (20131115)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: TOSHIBA Equium A100
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.19.0-9-generic root=/dev/mapper/hostname--vg-root ro
RelatedPackageVersions:
 linux-restricted-modules-3.19.0-9-generic N/A
 linux-backports-modules-3.19.0-9-generic N/A
 linux-firmware 1.143
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: yes
SourcePackage: linux
UpgradeStatus: Upgraded to vivid on 2015-03-15 (0 days ago)
dmi.bios.date: 10/23/2006
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: 2.10
dmi.board.name: MPAD-MSAE Customer Reference Boards
dmi.board.vendor: Intel Corporation
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvr2.10:bd10/23/2006:svnTOSHIBA:pnEquiumA100:pvrPSAABE-00J008EN:rvnIntelCorporation:rnMPAD-MSAECustomerReferenceBoards:rvrNotApplicable:cvnNoEnclosure:ct1:cvrN/A:
dmi.product.name: Equium A100
dmi.product.version: PSAABE-00J008EN
dmi.sys.vendor: TOSHIBA

Created attachment 113413
EeePC dmesg

Description of the problem:
When I boot up a v3.19 kernel on my EeePC 900 I get various drm_wait_one_vblank warnings.

Steps to reproduce:
1. Boot a v3.19 Linux kernel on an EeePC 900.

Expected results:
No warnings

Actual results:
Warnings like:
[ 0.516749] WARNING: CPU: 0 PID: 10 at drivers/gpu/drm/drm_irq.c:1121 drm_wait_one_vblank+0x138/0x170()
[ 0.516754] vblank not available on crtc 0, ret=-22

How reproducible is the problem?
It is reproducible every time.

Additional information:
Might be related to https://lkml.org/lkml/2015/1/31/198 .

Version information:
Ubuntu 14.04
EeePC 900
xorg 1:7.7+1ubuntu8
xserver-xorg 1:7.7+1ubuntu8
xserver-xorg-video-intel 2:2.99.910-0ubuntu1.4
Linux kernel 3.19

Please try drm-intel-nightly branch of http://cgit.freedesktop.org/drm-intel

Sadly that kernel doesn't boot at all - just an empty black screen.

(In reply to Sitsofe Wheeler from comment #2)
> Sadly that kernel doesn't boot at all - just an empty black screen.

Meh. What if you cherry pick

commit f9b61ff6bce9a44555324b29e593fdffc9a115bc
Author: Daniel Vetter <email address hidden>
Date: Wed Jan 7 13:54:39 2015 +0100

    drm/i915: Push vblank enable/disable past encoder->enable/disable

on top of v3.19?

Created attachment 113465
EeePC dmesg

f9b61ff6bce9a44555324b29e593fdffc9a115bc solves the drm_wait_one_vblank warning but check_crtc_state (pipe state doesn't match!) still remains. Do you want a separate bug for that?

(In reply to Sitsofe Wheeler from comment #4)
> Created attachment 113465 [details]
> EeePC dmesg
>
> f9b61ff6bce9a44555324b29e593fdffc9a115bc solves the drm_wait_one_vblank
> warning but check_crtc_state (pipe state doesn't match!) still remains. Do
> you want a separate bug for that?

Sorry for the delay - yes please. I'll try to get the referenced commit backported to v3.19 stable kernels.

New issue filed as #89209 . Feel free to close this issue as resolved when you're ready Jani!

http://<email address hidden>

Thanks for the report.

Dave Gilbert (ubuntu-treblig) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium

Did this issue start happening after an update/upgrade? Was there a prior kernel version where you were not having this particular problem?

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.0 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0-rc4-vivid/

summary: - WARNING: CPU: 0 PID: 968 at
+ [Toshiba Equium A100-306] WARNING: CPU: 0 PID: 968 at
/build/buildd/linux-3.19.0/drivers/gpu/drm/drm_irq.c:1121
drm_wait_one_vblank+0x170/0x180 [drm]()
tags: added: bios-outdated-600
tags: added: bios-outdated-6.00
removed: bios-outdated-600
Dave Gilbert (ubuntu-treblig) wrote :

To answer the 1st part of the question; 3.16.0-28 from Utopic worked fine (indeed the machine has been running Ubuntu for over 5 years upgrading all the way and hasn't hit this). I'll try latest upstream.

Dave Gilbert (ubuntu-treblig) wrote :

4.0-rc4-vivid works fine

tags: added: kernel-fixed-upstream

Dave Gilbert, the next step is to fully reverse commit bisect from kernel 3.19 to 4.0-rc4 in order to identify the last bad commit, followed immediately by the first good one. Once this commit has been identified, then it may be reviewed as a candidate for backporting into your release. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection#How_do_I_reverse_bisect_the_upstream_kernel.3F ?

Thank you for your understanding.

tags: added: kernel-fixed-upstream-4.0-rc4 needs-reverse-bisect regression-release
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Dave Gilbert (ubuntu-treblig) wrote :

Marked as triaged; see upstream bug report; the backtrace and error is the same and the time of the report is about right.
It looks like we need.
    drm/i915: Push vblank enable/disable past encoder->enable/disable

Changed in linux (Ubuntu):
status: Incomplete → Triaged
Changed in linux:
importance: Unknown → Medium
status: Unknown → Fix Released
tags: added: cherry-pick
removed: needs-reverse-bisect
Joseph Salisbury (jsalisbury) wrote :

I built a Vivid test kernel with a cherry pick of commit: f9b61ff . The test kernel can be downloaded from:
http://kernel.ubuntu.com/~jsalisbury/lp1432405

Can you test this kernel and see if it resolves this bug? If it does, we can request this commit in the upstream stable kernels, Vivid and SRU to Utopic.

Note, you will need to install both the linux-image and linux-image-extra .deb packages.

tags: added: kernel-da-key
Download full text (4.8 KiB)

Still valid for 3.19.3 FWIW, here is my journalctl output:

Mär 27 08:30:08 teefax kernel: [drm] Memory usable by graphics device = 256M
Mär 27 08:30:08 teefax kernel: checking generic (d0000000 130000) vs hw (d0000000 10000000)
Mär 27 08:30:08 teefax kernel: fb: switching to inteldrmfb from VESA VGA
Mär 27 08:30:08 teefax kernel: Console: switching to colour dummy device 80x25
Mär 27 08:30:08 teefax kernel: [drm] Replacing VGA console driver
Mär 27 08:30:08 teefax kernel: [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
Mär 27 08:30:08 teefax kernel: [drm] Driver supports precise vblank timestamp query.
Mär 27 08:30:08 teefax kernel: vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:owns=io+mem
Mär 27 08:30:08 teefax kernel: [drm] initialized overlay support
Mär 27 08:30:08 teefax kernel: [drm] Initialized i915 1.6.0 20141121 for 0000:00:02.0 on minor 0
Mär 27 08:30:08 teefax kernel: ------------[ cut here ]------------
Mär 27 08:30:08 teefax kernel: WARNING: CPU: 0 PID: 80 at drivers/gpu/drm/drm_irq.c:1121 drm_wait_one_vblank+0x154/0x160 [drm]()
Mär 27 08:30:08 teefax kernel: vblank not available on crtc 0, ret=-22
Mär 27 08:30:08 teefax kernel: Modules linked in: i915 iTCO_wdt iTCO_vendor_support ppdev evdev drm_kms_helper gpio_ich mac_hid r8169 pa
Mär 27 08:30:08 teefax kernel: CPU: 0 PID: 80 Comm: kworker/u4:4 Not tainted 3.19.3-1-ck #1
Mär 27 08:30:08 teefax kernel: Hardware name: /D945GSEJT, BIOS JT94510H.86A.0045.2010.0519.1750 05/19/2010
Mär 27 08:30:08 teefax kernel: Workqueue: events_unbound async_run_entry_fn
Mär 27 08:30:08 teefax kernel: c15df987 fe207313 00000000 f51ebab8 c1474bdd f51ebafc f51ebaec c10533ab
Mär 27 08:30:08 teefax kernel: f84e18a8 f51ebb1c 00000050 f84df963 00000461 f84bc194 00000461 f84bc194
Mär 27 08:30:08 teefax kernel: f5c60000 f5c78400 00000000 f51ebb08 c105341e 00000009 f51ebafc f84e18a8
Mär 27 08:30:08 teefax kernel: Call Trace:
Mär 27 08:30:08 teefax kernel: [<c1474bdd>] dump_stack+0x48/0x69
Mär 27 08:30:08 teefax kernel: [<c10533ab>] warn_slowpath_common+0x8b/0xc0
Mär 27 08:30:08 teefax kernel: [<f84bc194>] ? drm_wait_one_vblank+0x154/0x160 [drm]
Mär 27 08:30:08 teefax kernel: [<f84bc194>] ? drm_wait_one_vblank+0x154/0x160 [drm]
Mär 27 08:30:08 teefax kernel: [<c105341e>] warn_slowpath_fmt+0x3e/0x60
Mär 27 08:30:08 teefax kernel: [<f84bc194>] drm_wait_one_vblank+0x154/0x160 [drm]
Mär 27 08:30:08 teefax kernel: [<f87fa6d2>] intel_enable_tv+0x22/0x60 [i915]
Mär 27 08:30:08 teefax kernel: [<f87c7e6d>] i9xx_crtc_enable+0x35d/0x420 [i915]
Mär 27 08:30:08 teefax kernel: [<f87c6775>] __intel_set_mode+0x8d5/0xab0 [i915]
Mär 27 08:30:08 teefax kernel: [<f87cbcb6>] intel_set_mode+0x76/0xb0 [i915]
Mär 27 08:30:08 teefax kernel: [<f87cbeed>] intel_get_load_detect_pipe+0x1fd/0x4a0 [i915]
Mär 27 08:30:08 teefax kernel: [<f87fb236>] intel_tv_detect+0x106/0x5d0 [i915]
Mär 27 08:30:08 teefax kernel: [<c1090001>] ? irq_create_mapping+0x1d1/0x220
Mär 27 08:30:08 teefax kernel: [<f85a27f8>] drm_helper_probe_single_connector_modes_merge_bits+0x2c8/0x410 [drm_kms_helper]
Mär 27 08:30:08 teefax kernel: [<f85a2957>] drm_helper_probe_single_connector_...

Read more...

Please reopen if you can reproduce on v4.0-rc1 or later. The backport request for v3.19.y has been sent, see comment #7, nothing more we can do.

Dave Gilbert (ubuntu-treblig) wrote :

Joseph: Thanks for that kernel build, I can confirm that fixes it.

Linux davros 3.19.0-10-generic #10~lp1432405v1 SMP Mon Mar 23 18:54:51 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

still present in:
-> 3.19.5 and
-> 4.0.0

<snips>
BOOT_IMAGE=/vmlinuz-3.19.5.6 root=UUID=6c3bcf92-5a26-4dde-95e3-78ceb9aaa35b ro i
915.modeset=1 rhgb quiet LANG=de_DE.UTF-8 i915.force_backlight_pmic=0

...
[ 1.213951] [drm] Initialized drm 1.1.0 20060810
[ 1.215856] [drm] Memory usable by graphics device = 2048M
[ 1.215866] checking generic (80000000 8ca000) vs hw (80000000 10000000)
[ 1.215871] fb: switching to inteldrmfb from simple
[ 1.215920] Console: switching to colour dummy device 80x25
[ 1.216086] [drm] Replacing VGA console driver
[ 1.217799] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[ 1.217804] [drm] Driver supports precise vblank timestamp query.
[ 1.217840] [drm:intel_parse_bios] *ERROR* Unknown element
[ 1.217852] [drm:intel_parse_bios] *ERROR* Sequence elements going beyond block itself. Sequence block parsing failed
[ 1.259808] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:owns=io+mem
[ 1.281232] ACPI: Video Device [GFX0] (multi-head: yes rom: no post: no)
[ 1.282662] acpi device:21: registered as cooling_device4
[ 1.282866] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input1
[ 1.282938] [drm] Initialized i915 1.6.0 20141121 for 0000:00:02.0 on minor 0
...
...
[ 1.289898] i8042: PNP: No PS/2 controller found. Probing ports directly.
[ 1.336417] [drm] GMBUS [i915 gmbus dpb] timed out, falling back to bit banging on pin 5
[ 1.350512] fbcon: inteldrmfb (fb0) is primary device
[ 2.333926] i8042: No controller found
...
[ 2.536902] Console: switching to colour frame buffer device 150x120
[ 2.573929] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[ 2.573932] i915 0000:00:02.0: registered panic notifier
...
[ 3.833614] EXT4-fs (mmcblk0p4): mounted filesystem with ordered data mode. Opts: (null)
[ 3.935493] ------------[ cut here ]------------
[ 3.935536] WARNING: CPU: 3 PID: 262 at drivers/gpu/drm/drm_irq.c:1130 drm_wait_one_vblank+0x177/0x180()
[ 3.935546] vblank wait timed out on crtc 0
[ 3.935553] Modules linked in: ax88179_178a usbnet mii
[ 3.935588] CPU: 3 PID: 262 Comm: plymouthd Not tainted 3.19.5.6 #83

If you need more debugs, I have plenty of them...

Download full text (6.9 KiB)

on the yoga 2 851f tablet I am also trying often to get KMS working but like with the 3.19.y branch still no luck.

I am using vanilla kernels, and also with one or two patches of /from the fedlet image derived.

here the short debug from linux-stable v4.0.0 (and all previous versions like rc1 till rc7 too)

BOOT_IMAGE=/vmlinuz-4.0.0.6 root=UUID=6c3bcf92-5a26-4dde-95e3-78ceb9aaa35b ro i915.modeset=1 rhgb quiet LANG=de_DE.UTF-8 i915.force_backlight_pmic=1

lshw:
        *-display
             description: VGA compatible controller
             product: Atom Processor Z36xxx/Z37xxx Series Graphics & Display
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 0d
             width: 32 bits
             clock: 33MHz
             capabilities: pm msi vga_controller bus_master cap_list rom
             configuration: driver=i915 latency=0
             resources: irq:205 memory:90000000-903fffff memory:80000000-8fffffff ioport:1000(size=8)

lspci:
00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0d) (prog-if 00 [VGA controller])
        Subsystem: Intel Corporation Device 7270
        Flags: bus master, fast devsel, latency 0, IRQ 205
        Memory at 90000000 (32-bit, non-prefetchable) [size=4M]
        Memory at 80000000 (32-bit, prefetchable) [size=256M]
        I/O ports at 1000 [size=8]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [d0] Power Management version 2
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [b0] Vendor Specific Information: Len=07 <?>
        Kernel driver in use: i915

snap of dmesg:
[ 1.275627] [drm] Initialized drm 1.1.0 20060810
[ 1.277552] [drm] Memory usable by graphics device = 2048M
[ 1.277574] checking generic (80000000 8ca000) vs hw (80000000 10000000)
[ 1.277579] fb: switching to inteldrmfb from simple
[ 1.277631] Console: switching to colour dummy device 80x25
[ 1.277848] [drm] Replacing VGA console driver
[ 1.279567] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[ 1.279573] [drm] Driver supports precise vblank timestamp query.
[ 1.279600] [drm:intel_parse_bios] *ERROR* Unknown element
[ 1.279611] [drm:intel_parse_bios] *ERROR* Sequence elements going beyond block itself. Sequence block parsing failed
[ 1.317468] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:owns=io+mem
[ 1.331700] ACPI: Video Device [GFX0] (multi-head: yes rom: no post: no)
[ 1.332138] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input1
[ 1.332227] [drm] Initialized i915 1.6.0 20150130 for 0000:00:02.0 on minor 0
...
[ 1.388711] [drm] GMBUS [i915 gmbus dpb] timed out, falling back to bit banging on pin 5
[ 1.402951] fbcon: inteldrmfb (fb0) is primary device
[ 2.382620] i8042: No controller found
[ 2.382647] Switched to clocksource tsc
[ 2.382801] mousedev: PS/2 mouse device common for all mice
[ 2.383565] ACPI Warning: Could not enable fixed event - RealTimeClock (4) (20150204/evxface-654)
[ ...

Read more...

Changed in linux:
status: Fix Released → Confirmed
dhenry (tfc-duke) wrote :

Seems to be fixed in kernel 3.19.0-18, isn't it?

(In reply to Christian Hartmann from comment #11)
> still present in:
> -> 3.19.5 and
> -> 4.0.0

...

> [ 3.935536] WARNING: CPU: 3 PID: 262 at drivers/gpu/drm/drm_irq.c:1130
> drm_wait_one_vblank+0x177/0x180()
> [ 3.935546] vblank wait timed out on crtc 0

Please observe that this is a different warning, and a different bug. Closing again.

Please reopen if you see "vblank not available on crtc 0, ret=-22".

Otherwise, please file a new bug. Or find another bug with your error message. Thank you.

Changed in linux:
status: Confirmed → Fix Released
Download full text (4.6 KiB)

I experience the same issue on kernel 4.2-rc6. Before that I needed to boot with the i915.preliminary_hw_support=1 i915.enable_ips=0 kerne parameters, otherwise switching VTs was broken. Now switching works but I get the vblank issue and graphical artifacts. If you need more info or think this is a different bug, please state it so I can open another one. Also contact me if you need more info.

[ 1.546774] ------------[ cut here ]------------
[ 1.546794] WARNING: CPU: 0 PID: 6 at drivers/gpu/drm/drm_irq.c:1162 drm_wait_one_vblank+0x16e/0x1c0 [drm]()
[ 1.546795] vblank not available on crtc 0, ret=-22
[ 1.546844] Modules linked in: msr arc4 bnep bluetooth snd_hda_codec_hdmi iTCO_wdt iTCO_vendor_support intel_rapl iwlmvm iosf_mbi mac80211 nls_iso8859_1 intel_powerclamp coretemp kvm_intel nls_cp437 kvm vfat fat crct10dif_pclmul evdev crc32_pclmul input_leds mac_hid crc32c_intel psmouse serio_raw iwlwifi ghash_clmulni_intel aesni_intel aes_x86_64 lrw snd_hda_codec_conexant gf128mul glue_helper ablk_helper snd_hda_codec_generic cryptd i915 snd_hda_intel rtsx_pci_ms thinkpad_acpi snd_hda_codec memstick snd_hda_core nvram wmi led_class tpm_tis drm_kms_helper battery tpm cfg80211 acpi_pad drm ac snd_hwdep video mei_me rfkill intel_gtt snd_pcm i2c_algo_bit i2c_i801 snd_timer button mei snd lpc_ich soundcore i2c_core shpchp processor sch_fq_codel ip_tables x_tables ext4 crc16 mbcache jbd2 sd_mod rtsx_pci_sdmmc
[ 1.546852] mmc_core atkbd libps2 ahci libahci xhci_pci ehci_pci libata xhci_hcd ehci_hcd usbcore scsi_mod rtsx_pci usb_common i8042 serio
[ 1.546854] CPU: 0 PID: 6 Comm: kworker/u16:0 Tainted: G U 4.2.0-rc6-ARCH #1
[ 1.546855] Hardware name: LENOVO 20DL0029GE/20DL0029GE, BIOS JEET65WW (1.14 ) 05/30/2015
[ 1.546860] Workqueue: events_unbound async_run_entry_fn
[ 1.546863] 0000000000000000 0000000089ad6b61 ffff8802252cb6e8 ffffffff81559be2
[ 1.546865] 0000000000000000 ffff8802252cb740 ffff8802252cb728 ffffffff81073786
[ 1.546867] 0000000100000000 ffff880223cab800 ffff880223cab800 0000000000000000
[ 1.546867] Call Trace:
[ 1.546872] [<ffffffff81559be2>] dump_stack+0x4c/0x6e
[ 1.546875] [<ffffffff81073786>] warn_slowpath_common+0x86/0xc0
[ 1.546877] [<ffffffff81073815>] warn_slowpath_fmt+0x55/0x70
[ 1.546883] [<ffffffffa031e3fe>] drm_wait_one_vblank+0x16e/0x1c0 [drm]
[ 1.546916] [<ffffffffa054ed82>] intel_finish_crtc_commit+0x162/0x170 [i915]
[ 1.546920] [<ffffffffa04341a0>] drm_atomic_helper_commit_planes+0x170/0x200 [drm_kms_helper]
[ 1.546946] [<ffffffffa054ffad>] __intel_set_mode+0x8ad/0xb80 [i915]
[ 1.546973] [<ffffffffa0556e79>] intel_crtc_set_config+0x2c9/0x600 [i915]
[ 1.546980] [<ffffffffa03269f6>] drm_mode_set_config_internal+0x66/0x100 [drm]
[ 1.546983] [<ffffffffa0437522>] restore_fbdev_mode+0xc2/0xf0 [drm_kms_helper]
[ 1.546987] [<ffffffffa0439489>] drm_fb_helper_restore_fbdev_mode_unlocked+0x29/0x70 [drm_kms_helper]
[ 1.546989] [<ffffffffa04394f2>] drm_fb_helper_set_par+0x22/0x40 [drm_kms_helper]
[ 1.547016] [<ffffffffa05656fa>] intel_fbdev_set_par+0x1a/0x60 [i915]
[ 1.547019] [<ffffffff8131c9e8>] fbcon_init+0x538/0x5c0
[ 1....

Read more...

I just applied the latest patches from the drm-intel-fixes branch on http://cgit.freedesktop.org/drm-intel and the warning as well as the artifacts are gone. So marking this as resolved again. Sorry I did not try before reopening.

Oliver Leitner (shadow333) wrote :

i can confirm the same problem with my hp compaq 610 laptop (rather old laptop, not your new unknown model either)

the problem in my case links back to the i915 kernel module.

full bug output may be found here:

https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1583817

i havent gotten me the new daily kernel within the past 3 days... but theres activity within the kernel dev lists concerning this:

https://www.spinics.net/lists/dri-devel/msg104602.html
https://patchwork.freedesktop.org/patch/87937/
http://blog.gmane.org/gmane.linux.kernel.stable/day=20160502

Oliver Leitner (shadow333) wrote :

i can confirm this with kernels 4.4.x, 4.6.x (stable, drm-intel-next, drm-next, daily from ubuntu mainline)

Sorry, but could someone tell me which package or kernel I have to install to get the fix for this problem? I am on Mint 18.1, and I encounter the bug when using 4.8 kernels (but not 4.4, which are the currently recommended kernels for Mint). The GRUB / kernel boot string workaround does work for me, but I'd rather have the proper fix. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.