Intel PRO/1000 network driver e1000e doesn't always regain connection

Bug #1400365 reported by Frans on 2014-12-08
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux (Ubuntu)
High
Joseph Salisbury
Trusty
High
Joseph Salisbury

Bug Description

On our Dell E6440 laptops we found that the Wired network connection is sometimes not re-established when going from Wifi back to Ethernet, e.g. when booting without LAN and then putting the laptop back in its dock.

The following upstream patch resolved this problem for us in Kubuntu 14.04 LTS kernels 3.13.0-34-generic and 3.13.0-40-generic:

https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/patch/drivers/net/ethernet/intel/e1000e?id=b20a774495671f037e7160ea2ce8789af6b61533

Please incorporate this patch in the Kubuntu kernel so that the /lib/modules/3.13.0-XX-generic/kernel/drivers/net/ethernet/intel/e1000e/e1000e.ko module doesn't have to rebuilt manually every time we follow a kernel update. Thanks.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-40-generic 3.13.0-40.69 [modified: lib/modules/3.13.0-40-generic/kernel/drivers/net/ethernet/intel/e1000e/e1000e.ko]
ProcVersionSignature: Ubuntu 3.13.0-40.69-generic 3.13.11.10
Uname: Linux 3.13.0-40-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.6
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: homa 2299 F.... pulseaudio
                      homa 2573 F.... pulseaudio
 /dev/snd/controlC0: homa 2299 F.... pulseaudio
                      homa 2573 F.... pulseaudio
CurrentDesktop: KDE
Date: Mon Dec 8 16:22:48 2014
HibernationDevice: RESUME=UUID=df0741f0-a429-48cf-9eaf-0b9a31bb32ea
InstallationDate: Installed on 2014-12-05 (3 days ago)
InstallationMedia: Kubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.1)
MachineType: Dell Inc. Latitude E6440
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-40-generic root=UUID=63b4f79f-bbff-4166-9be1-3adf4ea9708b ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-40-generic N/A
 linux-backports-modules-3.13.0-40-generic N/A
 linux-firmware 1.127.10
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/18/2014
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A05
dmi.board.name: 0YX2X3
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA05:bd02/18/2014:svnDellInc.:pnLatitudeE6440:pvr01:rvnDellInc.:rn0YX2X3:rvrA00:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E6440
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.

Frans (frans-de-vries) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: bios-outdated-a07 cherry-pick
Changed in linux (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
tags: added: kernel-da-key
Joseph Salisbury (jsalisbury) wrote :

I built a trusty test kernel with a commit of upstream commit:
commit b20a774495671f037e7160ea2ce8789af6b61533
Author: David Ertman <email address hidden>
Date: Tue Mar 25 04:27:55 2014 +0000

    e1000e: Fix no connectivity when driver loaded with cable out

Can you test this kernel and see if it resolves this bug? It can be downloaded from:
http://kernel.ubuntu.com/~jsalisbury/lp1400365/

You will have to install both the linux-image and linux-image-extra .deb packages.

Frans (frans-de-vries) wrote :

Thanks for picking this up so promptly. I aim to test it this week.

Changed in linux (Ubuntu):
assignee: nobody → Joseph Salisbury (jsalisbury)
status: Triaged → In Progress
Changed in hwe-next:
status: New → Triaged
Frans (frans-de-vries) wrote :

I had a laptop still on the vanilla 3.13.0-40-generic kernel which exhibited the problem: no wired connection (despite many retries) after plugging in the cable after a boot.

With the linux-image and linux-image-extra packages above installed, the wired connection was established right away in the same test. Thanks!

Changed in linux (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Joseph Salisbury (jsalisbury)
Andy Whitcroft (apw) on 2015-01-07
Changed in linux (Ubuntu Trusty):
status: In Progress → Fix Committed
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Changed in hwe-next:
status: Triaged → Fix Committed
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
Frans (frans-de-vries) wrote :

I'm still new to this Kubuntu bug fixing process and the preceding comment doesn't say whether this is directed at the reporter (me), but I went ahead and installed the 3.13.0-45 kernel packages from trusty-proposed yesterday.
Tested on home and office LAN: booted with just Wifi, docked the laptop, and it acquired the wired connection without a hitch.
Encountered no other issues either.

Brad Figg (brad-figg) on 2015-01-21
tags: added: verification-done-trusty
removed: verification-needed-trusty
Launchpad Janitor (janitor) wrote :
Download full text (9.0 KiB)

This bug was fixed in the package linux - 3.13.0-45.74

---------------
linux (3.13.0-45.74) trusty; urgency=low

  [ Seth Forshee ]

  * Release Tracking Bug
    - LP: #1410384

  [ Jesse Barnes ]

  * SAUCE: drm/i915/vlv: assert and de-assert sideband reset at boot and
    resume v3
    - LP: #1401963

  [ K. Y. Srinivasan ]

  * SAUCE: storvsc: force SPC-3 compliance on win8 and win8 r2 hosts
    - LP: #1406867

  [ Timo Aaltonen ]

  * SAUCE: Switch VLV/BYT to use i915_bdw.
    - LP: #1401963

  [ Upstream Kernel Changes ]

  * Revert "xhci: clear root port wake on bits if controller isn't wake-up
    capable"
    - LP: #1408779
  * KVM: PPC: BOOK3S: HV: CMA: Reserve cma region only in hypervisor mode
    - LP: #1400209
  * e1000e: Fix no connectivity when driver loaded with cable out
    - LP: #1400365
  * net/mlx4_core: Enable CQE/EQE stride support
    - LP: #1400127
  * net/mlx4_core: Cache line EQE size support
    - LP: #1400127
  * net/mlx4_en: Add mlx4_en_get_cqe helper
    - LP: #1400127
  * net/mlx4_core: Introduce mlx4_get_module_info for cable module info
    reading
    - LP: #1400127
  * ethtool, net/mlx4_en: Cable info, get_module_info/eeprom ethtool
    support
    - LP: #1400127
  * net/mlx4_core: Introduce ACCESS_REG CMD and eth_prot_ctrl dev cap
    - LP: #1400127
  * net/mlx4_core: Add ethernet backplane autoneg device capability
    - LP: #1400127
  * ethtool, net/mlx4_en: Add 100M, 20G, 56G speeds ethtool reporting
    support
    - LP: #1400127
  * net/mlx4_en: Use PTYS register to query ethtool settings
    - LP: #1400127
  * net/mlx4_en: Use PTYS register to set ethtool settings (Speed)
    - LP: #1400127
  * net/mlx4_en: Add support for setting rxvlan offload OFF/ON
    - LP: #1400127
  * net/mlx4_en: Add ethtool support for [rx|tx]vlan offload set to OFF/ON
    - LP: #1400127
  * net/mlx4_core: Prevent VF from changing port configuration
    - LP: #1400127
  * net/mlx4_en: mlx4_en_set_settings() always fails when autoneg is set
    - LP: #1400127
  * ipv4: fix nexthop attlen check in fib_nh_match
    - LP: #1408779
  * vxlan: fix a use after free in vxlan_encap_bypass
    - LP: #1408779
  * vxlan: using pskb_may_pull as early as possible
    - LP: #1408779
  * vxlan: fix a free after use
    - LP: #1408779
  * ipv4: fix a potential use after free in ip_tunnel_core.c
    - LP: #1408779
  * ax88179_178a: fix bonding failure
    - LP: #1408779
  * tcp: md5: do not use alloc_percpu()
    - LP: #1408779
  * ipv4: dst_entry leak in ip_send_unicast_reply()
    - LP: #1408779
  * drivers/net, ipv6: Select IPv6 fragment idents for virtio UFO packets
    - LP: #1408779
  * drivers/net: macvtap and tun depend on INET
    - LP: #1408779
  * ip6_tunnel: Use ip6_tnl_dev_init as the ndo_init function.
    - LP: #1408779
  * vti6: Use vti6_dev_init as the ndo_init function.
    - LP: #1408779
  * sit: Use ipip6_tunnel_init as the ndo_init function.
    - LP: #1408779
  * gre6: Move the setting of dev->iflink into the ndo_init functions.
    - LP: #1408779
  * vxlan: Do not reuse sockets for a different address family
    - LP: #1408779
  * net: sctp: fix memory leak in auth key management
    - LP: #1408779
  * smsc911x: power-...

Read more...

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released
Keng-Yu Lin (lexical) on 2015-04-21
Changed in hwe-next:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers