Comment 331 for bug 1383184

I tried connecting to 5GHz at work today and it did not work. I am using
adam's copy paste suggestion from earlier posts.

Nomal wifi networks work fine.

On Thu, Nov 5, 2015 at 7:55 PM, Roman <email address hidden> wrote:

> I didn't used the new purposed firmware-package because i installed the
> firmware manually from the ath10k-firmware repository before. If testing
> this one is not valid ignore this post:
>
> Im getting a firmware crash on the 5 GHz network at my university (see
> attachment) with Kernel 4.2.0-16.
> After this one i tested the testing-firmware
> (SW_RM.1.1.1-00157-QCARMSWPZ-1) from the ath10k-firmware repository too. It
> didnt crash but i wasn't able to connect either.
>
>
>
> ** Attachment added: "WLAN.RM.1.1-00141"
>
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1383184/+attachment/4513672/+files/WLAN.RM.1.1-00141
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1383184
>
> Title:
> Atheros Qualcomm Killer N1525 Wireless-AC [168c:003e] is not supported
>
> Status in HWE Next:
> Fix Committed
> Status in HWE Next wily series:
> Fix Committed
> Status in linux package in Ubuntu:
> Fix Released
> Status in linux-firmware package in Ubuntu:
> Fix Released
> Status in linux source package in Wily:
> Fix Released
> Status in linux-firmware source package in Wily:
> Fix Committed
>
> Bug description:
> =========================================================
>
> CURRENT STATUS:
>
> Wily(15.10) could not work with and don't need Adam's dkms package 1.0
> or 1.1
>
> Wily(15.10) has already fixed the driver part, and the firmware part
> is in progress.
>
> For now, you guys could use 15.10(purge the ath10k-dkms if you tried
> installing it), and make a copy of
> https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-
> firmware.git/plain/ath10k/QCA6174 into /lib/firmware/ath10k/
>
> 15.10 will work in a week by a simple `apt upgrade`
>
> Distros before 15.10(lower than 4.2 kernel) please keep using the
> dkms(which will be relocated soon)
>
> =========================================================
>
> Card detail: Qualcomm Atheros Device [168c:003e] (rev 20)
> Subsystem: Bigfoot Networks, Inc. Device [1a56:1525]
>
> This is on a fully updated Ubuntu Server 14.04 installation, with the
> ubuntu-desktop environment installed. This happened in order to get the md
> raid drivers for raid0 on my system, as the desktop version doesn't support
> them.
> ---
> ApportVersion: 2.14.1-0ubuntu3.5
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC1: matanis 2333 F.... pulseaudio
> /dev/snd/controlC0: matanis 2333 F.... pulseaudio
> CRDA: Error: [Errno 2] No such file or directory
> CurrentDesktop: Unity
> DistroRelease: Ubuntu 14.04
> HibernationDevice: RESUME=UUID=1b192ee3-f592-43e9-bdcf-08b91c0aa9b6
> InstallationDate: Installed on 2014-10-16 (3 days ago)
> InstallationMedia: Ubuntu-Server 14.04.1 LTS "Trusty Tahr" - Release
> amd64 (20140722.3)
> IwConfig:
> p2p1 no wireless extensions.
>
> lo no wireless extensions.
> MachineType: Micro-Star International Co., Ltd. GT72 2QE
> NonfreeKernelModules: nvidia
> Package: linux (not installed)
> ProcFB: 0 EFI VGA
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-37-generic.efi.signed
> root=UUID=80998dbb-1f89-4eda-be90-25e35e1c0a90 ro
> ProcVersionSignature: Ubuntu 3.13.0-37.64-generic 3.13.11.7
> RelatedPackageVersions:
> linux-restricted-modules-3.13.0-37-generic N/A
> linux-backports-modules-3.13.0-37-generic N/A
> linux-firmware 1.127.7
> RfKill:
>
> Tags: trusty
> Uname: Linux 3.13.0-37-generic x86_64
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
> _MarkForUpload: True
> dmi.bios.date: 09/15/2014
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: E1781IMS.10D
> dmi.board.asset.tag: To be filled by O.E.M.
> dmi.board.name: MS-1781
> dmi.board.vendor: Micro-Star International Co., Ltd.
> dmi.board.version: REV:0.C
> dmi.chassis.asset.tag: To Be Filled By O.E.M.
> dmi.chassis.type: 3
> dmi.chassis.vendor: To Be Filled By O.E.M.
> dmi.chassis.version: To Be Filled By O.E.M.
> dmi.modalias:
> dmi:bvnAmericanMegatrendsInc.:bvrE1781IMS.10D:bd09/15/2014:svnMicro-StarInternationalCo.,Ltd.:pnGT722QE:pvrREV0.C:rvnMicro-StarInternationalCo.,Ltd.:rnMS-1781:rvrREV0.C:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
> dmi.product.name: GT72 2QE
> dmi.product.version: REV:0.C
> dmi.sys.vendor: Micro-Star International Co., Ltd.
>
> Qualcomm Atheros Device [168c:003e] (rev 20)
>
> mainline commit d63955b33b3bee45d784ffdfafeb93076c765660
>
> [ 6.221281] ath10k_pci 0000:02:00.0: pci irq msi interrupts 1
> irq_mode 0 reset_mode 0
> [ 6.417386] ath10k_pci 0000:02:00.0: Direct firmware load for
> ath10k/cal-pci-0000:02:00.0.bin failed with error -2
> [ 6.417404] ath10k_pci 0000:02:00.0: Direct firmware load for
> ath10k/QCA6174/hw2.1/board-pci-168c:003e:17aa:3044.bin failed with error -2
> [ 6.417407] ath10k_pci 0000:02:00.0: failed to load spec board file,
> falling back to generic: -2
> [ 6.417416] ath10k_pci 0000:02:00.0: Direct firmware load for
> ath10k/QCA6174/hw2.1/board.bin failed with error -2
> [ 6.417418] ath10k_pci 0000:02:00.0: failed to fetch generic board
> data: -2
> [ 6.417420] ath10k_pci 0000:02:00.0: failed to fetch board file: -2
> [ 6.417421] ath10k_pci 0000:02:00.0: could not fetch firmware files
> (-2)
> [ 6.417423] ath10k_pci 0000:02:00.0: could not probe fw (-2)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hwe-next/+bug/1383184/+subscriptions
>