Comment 299 for bug 1372609

Matej (matej-jelic22) wrote :

Well this is just great... xD
I am really confused right now.

So I updated my Kubuntu from 14.10 to 15.04.
Touchpad worked fine with the kernel version 3.16.0-33-generic.

It was working for a while and then I performed an update with:
sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade
And I got the new kernel version: 3.19.0-16-generic

After the update/upgrade my touchpad doesn't work anymore.
Then I tried installing kernel version: 4.0.1-040001-generic
Still doesn't work.

I don't know what am I doing wrong here.
Now my System Settings -> Ponting devices -> Touchpad says "Synaptics driver is not installed (or is not used)" again.
And if I enter the command "synclient" I get this error message: "Couldn't find synaptics properties. No synaptics driver loaded?".

The xorg log (command: "cat /var/log/Xorg.0.log") got my eye on this:
[ 4.901] (II) config/udev: Adding input device PS/2 FocalTech FocalTech Touchpad (/dev/input/mouse0)
[ 4.901] (II) No input driver specified, ignoring this device.
[ 4.901] (II) This device may have been added with another device file.
Full output is here: http://pastebin.com/N78EWUYc

And under my /dev/input/ directory I have 3 mouse files (mouse0, mouse1 and mouse2) all with the size of 0 bytes.
My assumption is that mouse0 is (or should be) the touchpad, mouse1 my real USB mouse, and mouse2 my other real USB mouse that I plugged in my PC on my other USB port.

Anyways... Can anyone help me? How can I get this to finally work? :(
My PC unusable like this...