Asus UX32LN: Brightness keys Fn+F5 and Fn+F6 don't generate evdev event

Bug #1348890 reported by Danila Beketov on 2014-07-26
342
This bug affects 60 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Wishlist
linux (Ubuntu)
Medium
Unassigned

Bug Description

Hello Community,

It seems brightness keys don't work with latest Ubuntu 14.04 LTS for laptop Asus Zenbook UX32LN.

sudo dmidecode -s bios-version
UX32LN.203

I recently received an ASUS UX301 laptop. After installing Fedora 21 and then using a git kernel (v3.16-rc5-152-g59ca9ee42838) things worked well except the brightness keys. (The keys didn't work in the 3.11.10 kernel, or any other kernel I tried either.) After some debugging, I figured out the ACPI events for the keys are never actually being sent to the kernel at all.

Matthew Garrett and I poked at this over the course of a few days and found a few things.

1) _DOD is returning 16 devices. The last device has a device_id of 0x400 and appears to be the device being used.

2) intel_didl_outputs is only looping through and setting up 8 devices in didl. intel_setup_cadls is looping through and blindly assigning the id from didl[i] to cadl[i] even though the active device might not be in the first 8 devices. This probably works on most machines because DIDL is only 8 in length.

3) The AML from this machine is a bit odd, in that it references methods from the LCDD device, which tries to figure out which active device to return in it's CDDS method. Since the active device in question isn't listed in any of the CADL entries, the AML method fails and no events are sent to the kernel.

4) If I blindly slam the returned device_id (0x400) into cadl[0], the brightness keys work as expected with the backlight being adjusted and the OSD in GNOME popping up. Clearly that isn't a solution, but it does lead to some hints as to what the problem is.

The acpidump output for the machine can be found here: https://jwboyer.fedorapeople.org/pub/acpi.dump

description: updated
summary: - Brightness keys Fn+F5 and Fn+F6 doesn't work for Asus UX32LN
+ Brightness keys Fn+F5 and Fn+F6 don't work for Asus UX32LN

acpi-support is not involved in management of brightness keys. Reassigning to udev.

affects: acpi-support (Ubuntu) → systemd (Ubuntu)

Is there anything else I can provide to help this bug along?

Martin Pitt (pitti) wrote :

Can you please install "evtest", run "sudo evtest", then press the brightness keys and copy&paste the entire output? Please annotate it so that I can see which line of output belongs to which particular key.

After that, please give me the output of

  grep -r . /sys/class/dmi/id/

Thanks!

Changed in systemd (Ubuntu):
status: New → Incomplete
summary: - Brightness keys Fn+F5 and Fn+F6 don't work for Asus UX32LN
+ [keymap] Brightness keys Fn+F5 and Fn+F6 don't work for Asus UX32LN

All required logs in attachment files. When evtest running and Fn+F5 or Fn+F6 is pressed nothing happening. But I can adjust brightness through Right Click on Battery Icon -> Power Settings -> screen brightness by moving slide bar.

Martin Pitt (pitti) wrote :

There are no events at all in your log. So either "Asus WMI hotkeys" isn't the right device for the brightness keys, can you try "AT Translated Set 2 keyboard"? Or (more likely in this case), the kernel driver needs to be fixed to actually generate key events for the brightness keys; that's the case if you don't get any events on any of the input devices. Thanks!

I've tried all of them. Nothing.

On Mon, Aug 4, 2014 at 11:24 AM, Martin Pitt <email address hidden> wrote:

> There are no events at all in your log. So either "Asus WMI hotkeys"
> isn't the right device for the brightness keys, can you try "AT
> Translated Set 2 keyboard"? Or (more likely in this case), the kernel
> driver needs to be fixed to actually generate key events for the
> brightness keys; that's the case if you don't get any events on any of
> the input devices. Thanks!
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1348890
>
> Title:
> [keymap] Brightness keys Fn+F5 and Fn+F6 don't work for Asus UX32LN
>
> Status in “systemd” package in Ubuntu:
> Incomplete
>
> Bug description:
> Hello Community,
>
> It seems brightness keys don't work with latest Ubuntu 14.04 LTS for
> laptop Asus Zenbook UX32LN.
>
> sudo dmidecode -s bios-version
> UX32LN.203
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1348890/+subscriptions
>

--
Бекетов Данила

Martin Pitt (pitti) wrote :

Thanks. Reassigning to kernel then.

summary: - [keymap] Brightness keys Fn+F5 and Fn+F6 don't work for Asus UX32LN
+ Asus UX32LN: Brightness keys Fn+F5 and Fn+F6 don't generate evdev event
affects: systemd (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.16 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.16-utopic/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Danila Beketov (danila-beketov) wrote :

No events generated for all points of evtest!

donil@ux32ln:~$ uname -a
Linux ux32ln 3.16.0-031600-generic #201408031935 SMP Sun Aug 3 23:36:11 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

donil@ux32ln:~$ sudo evtest
No device specified, trying to scan all of /dev/input/event*
Available devices:
/dev/input/event0: Lid Switch
/dev/input/event1: Sleep Button
/dev/input/event2: Power Button
/dev/input/event3: AT Translated Set 2 keyboard
/dev/input/event4: Logitech Unifying Device. Wireless PID:400a
/dev/input/event5: ETPS/2 Elantech Touchpad
/dev/input/event6: USB2.0 HD UVC WebCam
/dev/input/event7: Video Bus
/dev/input/event8: Video Bus
/dev/input/event9: HDA Intel HDMI HDMI/DP,pcm=3
/dev/input/event10: HDA Intel HDMI HDMI/DP,pcm=7
/dev/input/event11: HDA Intel HDMI HDMI/DP,pcm=8
/dev/input/event12: Asus WMI hotkeys
/dev/input/event13: HDA Intel PCH Mic
/dev/input/event14: HDA Intel PCH Headphone

tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Almerno (ale-vergara) wrote :

Hello everybody,

I have the same problem with an Asus F551M (dmidecode X551MA.506). I have tried all the tests and get the same results (no events with evtest).

Hannes Hofer (hannes-hofer) wrote :

Hi,

I have the same problem.
there is a workaround although.

add "acpi_osi=" at the and of the kernel boot parameters.

to permanently do this edit /etc/default/grub as root
and add "acpi_osi=" at the end of GRUB_CMDLINE_LINUX_DEFAULT
then run "update-grub" as root

after that brightness and all other hotkeys work
but the ambient light sensor is no longer detected.
But this is not a big problem since there is no standard
ambient light regulation of screen brightness anyway

Almerno (ale-vergara) wrote :

Hi,

I have tried the acpi_osi boot parameter and now the brightness keys work. Thank you! Asus F551M hasn't an ambient light sensor.

So, with this boot parameter (for brightness keys), "options snd-hda-intel model=asus position_fix=1" in alsa-base.conf (for headphones) and updating to kernel 3.16 (for card reader), all computer devices works in Ubuntu.

It's working for me too!

On Sun, Aug 31, 2014 at 1:05 PM, Almerno <email address hidden> wrote:

> Hi,
>
> I have tried the acpi_osi boot parameter and now the brightness keys
> work. Thank you! Asus F551M hasn't an ambient light sensor.
>
> So, with this boot parameter (for brightness keys), "options snd-hda-
> intel model=asus position_fix=1" in alsa-base.conf (for headphones) and
> updating to kernel 3.16 (for card reader), all computer devices works in
> Ubuntu.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1348890
>
> Title:
> Asus UX32LN: Brightness keys Fn+F5 and Fn+F6 don't generate evdev
> event
>
> Status in “linux” package in Ubuntu:
> Confirmed
>
> Bug description:
> Hello Community,
>
> It seems brightness keys don't work with latest Ubuntu 14.04 LTS for
> laptop Asus Zenbook UX32LN.
>
> sudo dmidecode -s bios-version
> UX32LN.203
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1348890/+subscriptions
>

--
Бекетов Данила

ken marfilla (marfillaster) wrote :

setting "acpi_osi=" disables ACPI0008 which is the Ambient Light Sensor. Although I rather have a working fn keys for brightness control for now.

Josh, sorry for the delay. Please try the opregion-didl branch from my repo at http://cgit.freedesktop.org/~jani/drm/log/?h=opregion-didl and attach /sys/kernel/debug/dri/0/i915_opregion. It's still a work-in-progress but should at least go through more devices.

Are you sure _DOD is returning 16 devices, and the one being used is last? Even with the extended didl in my branch it's up to 15 devices.

With debug log level, do you see "More than 8 outputs detected via ACPI" or "More than 8 outputs in connector list" in dmesg? (Or s/8/15/ with my patches.)

Created attachment 105999
/sys/kernel/debug/dri/0/i915_opregion

Hi Jani,

Attached is the i915_opregion file you requested using a kernel built from your opregion-didl branch. I'm not sure if you were expecting it to fix the brightness keys or not, but it doesn't. The slider in GNOME still works.

Yes, DOD is returning more than 15 devices:

[ 2.229265] i915 0000:00:02.0: More than 15 outputs detected via ACPI

In the ssdt7.dsl file, the firmware enumerates devices DD0-DDF and then an additional device LCDD. The LCDD device is what seems to be associated with the function keys via the EC according to ACPI. It gets a device ID of 0x400.

Josh, thanks for the info. I had a good look at this, and unfortunately it looks a bit difficult to fix this in a sane way without regressing

commit 3143751ff51a163b77f7efd389043e038f3e008e
Author: Zhang Rui <email address hidden>
Date: Mon Mar 29 15:12:16 2010 +0800

    drm/i915: set DIDL using the ACPI video output device _ADR method return.

and https://bugzilla.kernel.org/show_bug.cgi?id=15054 at the same time.

Without that commit, we'd have more of a free hand in picking the device IDs for DIDL, and in particular making a sane mapping from our connectors, so we could update CPDL and CADL as well.

Lowering the priority for now.

Yes, when I looked at it I came to a similar conclusion. From my understanding, what would need to be done is essentially having i915 keep a mapping of it's connectors to the ACPI device id's that are returned via the _ADR method. The only way I know how to do that is to decode them according to the opregion spec, but it does seem to be possible. Once that mapping is created, i915 could set CADL whenever the display switches to a new connector.

The shortcut is to just quirk this somehow, but that doesn't sound like a good overall solution.

Alexey Loukianov (lexa2) wrote :

Danila, it seems that you had added tag "kernel-bug-exists-upstream" to this report but I can't find any direct link to a bug on kernel.org. Could you please post it here? Thanks in advance.

Да я не совсем понял что нужно сделать. Меня попросили воспроизвести багу
на последней версии ядра из upstream Убунты. Баг присутствует. Теперь тоже
самое зарегать на kernel.org?

On Fri, Oct 10, 2014 at 8:45 PM, Alexey Loukianov <
<email address hidden>> wrote:

> Danila, it seems that you had added tag "kernel-bug-exists-upstream" to
> this report but I can't find any direct link to a bug on kernel.org.
> Could you please post it here? Thanks in advance.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1348890
>
> Title:
> Asus UX32LN: Brightness keys Fn+F5 and Fn+F6 don't generate evdev
> event
>
> Status in “linux” package in Ubuntu:
> Confirmed
>
> Bug description:
> Hello Community,
>
> It seems brightness keys don't work with latest Ubuntu 14.04 LTS for
> laptop Asus Zenbook UX32LN.
>
> sudo dmidecode -s bios-version
> UX32LN.203
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1348890/+subscriptions
>

--
Бекетов Данила

In russian:
Тег  kernel-bug-exists-upstream предполагает, что этот же баг есть в трекере у поставщика компонента - в данном случае это ядро linux. То есть если тег проставлен - предполагается, что на kernel.org это баг есть и о нём разработчики ядра знают. Так что да. если на kernel.org баг не отрепорчен - надо бы его втуда отрепортить, иначе мало шансов, что баг в итоге починят.

In english:

If a report is marked with "kernel-bug-exists-upstream" tag it implies that the same bug had been reported to upstream vendor of the bugged component in question - it is linux kernel in this particular case. So yep, in case there is no bug report on kernel.org for this bug it would be great if you would report it there so the bug might got noticed by kernel developers and would be eventually fixed.

Tue, 14 Oct 2014 09:41:29 -0000 от Danila Beketov <email address hidden>:
>Да я не совсем понял что нужно сделать. Меня попросили воспроизвести багу
>на последней версии ядра из upstream Убунты. Баг присутствует. Теперь тоже
>самое зарегать на kernel.org?
>
>On Fri, Oct 10, 2014 at 8:45 PM, Alexey Loukianov <
><email address hidden> > wrote:
>
>> Danila, it seems that you had added tag "kernel-bug-exists-upstream" to
>> this report but I can't find any direct link to a bug on kernel.org.
>> Could you please post it here? Thanks in advance.
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1348890
>>
>> Title:
>> Asus UX32LN: Brightness keys Fn+F5 and Fn+F6 don't generate evdev
>> event
>>
>> Status in “linux” package in Ubuntu:
>> Confirmed
>>
>> Bug description:
>> Hello Community,
>>
>> It seems brightness keys don't work with latest Ubuntu 14.04 LTS for
>> laptop Asus Zenbook UX32LN.
>>
>> sudo dmidecode -s bios-version
>> UX32LN.203
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1348890/+subscriptions
>>
>
>
>--
>Бекетов Данила
>
>--
>You received this bug notification because you are subscribed to the bug
>report.
>https://bugs.launchpad.net/bugs/1348890
>
>Title:
>  Asus UX32LN: Brightness keys Fn+F5 and Fn+F6 don't generate evdev
>  event
>
>Status in “linux” package in Ubuntu:
>  Confirmed
>
>Bug description:
>  Hello Community,
>
>  It seems brightness keys don't work with latest Ubuntu 14.04 LTS for
>  laptop Asus Zenbook UX32LN.
>
>  sudo dmidecode -s bios-version
>  UX32LN.203
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1348890/+subscriptions

---
С уважением,
Алексей Лукьянов
System Engineer
*nix Specialist

I have an ASUS UX301LAA notebook running 3.16.5 (and 3.17) kernel and the backlight keys also doesn't work for me.

But - it looks like there might be some clash between backlight providers, there are two providers: acpi_nb_wmi (type:platform) and intel_backlight (type:raw)

# ls -ld /sys/class/backlight/*
lrwxrwxrwx. 1 root root 0 Nov 2 15:12 /sys/class/backlight/asus-nb-wmi -> ../../devices/platform/asus-nb-wmi/backlight/asus-nb-wmi
lrwxrwxrwx. 1 root root 0 Nov 2 15:12 /sys/class/backlight/intel_backlight -> ../../devices/pci0000:00/0000:00:02.0/drm/card0/card0-eDP-1/intel_backlight

Manipulating brightness manually in intel_backlight in fact does change the brightness and I can modify brightness with hacked gsd-backlight-helper that prefers type=raw instead of type=platform using the slider controls in gnome-shell.

I can confirm that keyboard (Fn-F5 and Fn-F6) does not work and they also don't generated any events in xev (keyboard brightness keys do).

There was an Ubuntu patch that added enable_backlight=0 option to the module, so it can be disabled, but alas it doesn't apply on 3.16 anymore. I think it might be usefull to have such option to at least test whether disabling intel_backlight and letting asus_nb_wmi handle the backlight helps. Not sure whether this is bug in i915 or asus_nb_wmi though (or both).

Not sure whether this was helpful, but at least you have one more person to help with debugging.

(In reply to Ondrej Sury from comment #6)
> I have an ASUS UX301LAA notebook running 3.16.5 (and 3.17) kernel and the
> backlight keys also doesn't work for me.
>
> But - it looks like there might be some clash between backlight providers,
> there are two providers: acpi_nb_wmi (type:platform) and intel_backlight
> (type:raw)

Just realized that I had "acpi_osi=Linux acpi_backlight=vendor", without it there's just intel_backlight. But the Fn-keys don't work.

Download full text (5.0 KiB)

(I have copied my post from https://bugzilla.redhat.com/show_bug.cgi?id=1144866, this seems to be a related bug, let me know if this isn't customary)

Hello,
I currently own an Asus Q302la, which seems to have an identical setup to the other Asus laptops that I have seen reported on various redhat,kernel,and freedesktop bugzilla bugs. its Fn+F5 and Fn+F6 keys are not registering events when viewed through input-tools or evemu-record despite various other asus-wmi key-keycombos showing up and do not seem to be affected by any permutation of the boot options: video.use_native_backlight=1, acpi_backlight=vendor, acpi_osi="!Windows 2012", and acpi_osi="!Windows 2009". no scan codes come up with "echo 1> /sys/modules/i8042/parameters/debug" either.

other bugs on this laptop that make me feel as though this is the same hardware configuration are that it has the Focaltech touchpad (FLT0102) that is still being worked on for multitouch support and is stubbornly registering in PS/2 emulation mode, its intel 7270 wireless ac card was on an unkown pci id (recently patched in linux-stable), its "G-sensor" isn't registering, and the ambient light sensor isn't being detected (though its showing up as an ASL device with an HID of ACPI0008, which doesn't seem to be recognized by the kernel yet), which seems to match up with most of the other recent asus laptop bugs.

I've taken it upon myself to use this laptop as an opportunity to break further into kernel development and troubleshooting and have been reading through the source, tinkering around with kprobes, ftrace+friends, and dyndebug.

I am using the mainline linux-stable kernel 3.17.2 compiled from the git v3.17.2 tag on a Ubuntu 14.10 installation.

Ive made some progress on the Fn+F5 and Fn+F6 backlight keys:
it turns out that the ACPI Embedded Controller code is seeing the backlight key combos, but it doesn't seem like its being passed on further in the kernel. I'm still learning about how the ACPI subsystem works, and I feel like later on I'll be better equipped to say definitively where exactly these events are being discarded. I enabled dynamic debug on the embedded controller with:
echo "file drivers/acpi/ec.c +p" > /sys/kernel/debug/dynamic_debug/control

I notice that for Fn+F5 (decrease brightness), this prints out on dmesg:
kern :debug : [ +0.233305] ACPI : EC: ===== IRQ =====
kern :debug : [ +0.000006] ACPI : EC: EC_SC(R) = 0x28 SCI_EVT=1 BURST=0 CMD=1 IBF=0 OBF=0
kern :debug : [ +0.000004] ACPI : EC: EC_SC(R) = 0x28 SCI_EVT=1 BURST=0 CMD=1 IBF=0 OBF=0
kern :debug : [ +0.000001] ACPI : EC: push gpe query to the queue
kern :debug : [ +0.000039] ACPI : EC: ===== TASK =====
kern :debug : [ +0.000003] ACPI : EC: EC_SC(R) = 0x28 SCI_EVT=1 BURST=0 CMD=1 IBF=0 OBF=0
kern :debug : [ +0.000007] ACPI : EC: EC_SC(W) = 0x84
kern :debug : [ +0.000787] ACPI : EC: ===== TASK =====
kern :debug : [ +0.000005] ACPI : EC: EC_SC(R) = 0x28 SCI_EVT=1 BURST=0 CMD=1 IBF=0 OBF=0
kern :debug : [ +0.000075] ACPI : EC: ===== IRQ =====
kern :debug : [ +0.000005] ACPI : EC: EC_SC(R) = 0x09 SCI_EVT=0 BURST=0 CMD=1 IBF=0 OBF=1
kern :debug : [ +0.000004] ACPI : EC: EC_DATA(R) = 0x0e
kern :debug ...

Read more...

Download full text (11.4 KiB)

I'll update this bugzilla thread since it seems to be the most recently updated. I went ahead and recompiled the v3.17.2 kernel with acpi debugging messages and set the following values for acpi.debug_layer and acpi.debug_level:
acpi.debug_layer: 0x10 (ACPI_NAMESPACE)
acpi.debug_level: 0x200 (ACPI_LV_EXEC)

and the values I got out of doing that when first holding down the Fn key, and then pressing Fn+F5 4 times and then Fn+F6 4 times, and then releasing the Fn key are:

kern :warn : [ +1.608662] nseval-0228 ns_evaluate : **** Execute method [\_SB_.PCI0.LPCB.EC0_._QD3] at AML address ffffc90000034afc length FFFFFFFF
kern :warn : [ +0.261245] nseval-0228 ns_evaluate : **** Execute method [\_SB_.PCI0.LPCB.EC0_._QD3] at AML address ffffc90000034afc length FFFFFFFF
kern :warn : [ +0.037287] nseval-0228 ns_evaluate : **** Execute method [\_SB_.PCI0.LPCB.EC0_._QD3] at AML address ffffc90000034afc length FFFFFFFF
kern :warn : [ +0.037325] nseval-0228 ns_evaluate : **** Execute method [\_SB_.PCI0.LPCB.EC0_._QD3] at AML address ffffc90000034afc length FFFFFFFF
kern :warn : [ +0.037946] nseval-0228 ns_evaluate : **** Execute method [\_SB_.PCI0.LPCB.EC0_._QD3] at AML address ffffc90000034afc length FFFFFFFF
kern :warn : [ +0.036701] nseval-0228 ns_evaluate : **** Execute method [\_SB_.PCI0.LPCB.EC0_._QD3] at AML address ffffc90000034afc length FFFFFFFF
kern :warn : [ +0.037328] nseval-0228 ns_evaluate : **** Execute method [\_SB_.PCI0.LPCB.EC0_._QD3] at AML address ffffc90000034afc length FFFFFFFF
kern :warn : [ +0.037335] nseval-0228 ns_evaluate : **** Execute method [\_SB_.PCI0.LPCB.EC0_._QD3] at AML address ffffc90000034afc length FFFFFFFF
kern :warn : [ +0.037332] nseval-0228 ns_evaluate : **** Execute method [\_SB_.PCI0.LPCB.EC0_._QD3] at AML address ffffc90000034afc length FFFFFFFF
kern :warn : [ +0.038215] nseval-0228 ns_evaluate : **** Execute method [\_SB_.PCI0.LPCB.EC0_._QD3] at AML address ffffc90000034afc length FFFFFFFF
kern :warn : [ +0.037337] nseval-0228 ns_evaluate : **** Execute method [\_SB_.PCI0.LPCB.EC0_._QD3] at AML address ffffc90000034afc length FFFFFFFF
kern :warn : [ +0.036424] nseval-0228 ns_evaluate : **** Execute method [\_SB_.PCI0.LPCB.EC0_._QD3] at AML address ffffc90000034afc length FFFFFFFF
kern :warn : [ +0.037342] nseval-0228 ns_evaluate : **** Execute method [\_SB_.PCI0.LPCB.EC0_._QD3] at AML address ffffc90000034afc length FFFFFFFF
kern :warn : [ +0.037254] nseval-0228 ns_evaluate : **** Execute method [\_SB_.PCI0.LPCB.EC0_._QD3] at AML address ffffc90000034afc length FFFFFFFF
kern :warn : [ +0.037327] nseval-0228 ns_evaluate : **** Execute method [\_SB_.PCI0.LPCB.EC0_._QD3] at AML address ffffc90000034afc length FFFFFFFF
kern :warn : [ +0.037359] nseval-0228 ns_evaluate : **** Execute method [\_SB_.PCI0.LPCB.EC0_._QD3] at AML address ffffc90000034afc length FFFFFFFF
kern :warn : [ +0.037338] nseval-0228 ns_evaluate : **** Execute method [\_SB_.PCI0....

Aaron might be interested in comment #8 and comment #9.

I've been referenced to this bug by Aaron after reporting my findings on non-working Fn+F5/F6 with ASUS UX32LN ultrabook in #92391. Looks like my situation is somewhat similar to what Josh got on his UX301 which isn't surprising keeping in mind the same manufacturer and pretty similar hardware configs of these ultrabooks.

What I have on my UX32LN is uninitialized CADL region and uninitialized SANV.DIDX which is expected to contain ID of eDP panel which is in turn expected to conform to pattern ((ID & 0x0F00) == 0x400).

Reading SSDT code it seems that firmware expects didl to contain max 15 entries (_DOD method does not contain logic to return more active devices) which might be a problem in my case which leads to uninitialized CADL - as far as I understand correctly current version of i915 drm in the mainline kernel does not enumerate more than 8 DIDL entries.

I would like to check if my problem could be fixed by using Jani's opregion-didl branch but it seems it had diverged into two separate refs: didl and didl-3.18.
Which one should I use to compile a testing kernel? What Kconfigs are essential to be enabled/disabled for testing purposes and providing valuable debug output?

Thanks in advance for your help.

Download full text (4.6 KiB)

A not-so-small followup. Here are dumps of areas of interest from IGDM and SANV after a fresh bootup of debian 3.18-1~exp1 kernel:

IGDM.DIDL:

root@lx2netbook:~# { dd if=/dev/mem skip=$(( 0xCAAFB018 + 0x120 )) count=32 bs=1; dd if=/dev/mem skip=$(( 0xCAAFB018 + 0x1C4 )) count=28 bs=1 ; } 2>/dev/null | hexdump -v -e ' 4/4 "%.8X " "\n" '
00000100 00000002 00000300 00000301
00000302 00000303 00000304 00000008
00000000 00000000 00000000 00000000
00000000 00000000 00000000

IGDM.CADL:

root@lx2netbook:~# { dd if=/dev/mem skip=$(( 0xCAAFB018 + 0x160 )) count=32 bs=1;} 2>/dev/null | hexdump -v -e ' 4/4 "%.8X " "\n" '
00000100 00000002 00000300 00000301
00000302 00000303 00000304 00000008

SANV.DIDX:
root@lx2netbook:~# dd if=/dev/mem bs=1 skip=$(( 0xCAAFEE18 + 315)) count=4 2>/dev/null | hexdump -v -e ' 4/4 "%.8X " "\n" '
80010410

SANV.EDPV:
root@lx2netbook:~# dd if=/dev/mem bs=1 skip=$(( 0xCAAFEE18 + 310)) count=1 2>-| hexdump -v -e ' 16/1 "%.2X " "\n" '
02

SANV.NDID:
root@lx2netbook:~# dd if=/dev/mem bs=1 skip=$(( 0xCAAFEE18 + 232)) count=1 2>-| hexdump -v -e ' 16/1 "%.2X " "\n" '
08

SANV.DID1 .. SANV.DID8:
root@lx2netbook:~# dd if=/dev/mem bs=1 skip=$(( 0xCAAFEE18 + 233)) count=32 2>/dev/null | hexdump -v -e ' 4/4 "%.8X " "\n" '
80000002 80000100 80000300 80000301
80000302 80000303 80000304 80000008

SANV.DID9 .. SANV.DIDB:
root@lx2netbook:~# dd if=/dev/mem bs=1 skip=$(( 0xCAAFEE18 + 16)) count=12 2>/dev/null | hexdump -v -e ' 4/4 "%.8X " "\n" '
00000000 00000000 00000000

SANV.DIDC .. SANV.DIDF:
root@lx2netbook:~# dd if=/dev/mem bs=1 skip=$(( 0xCAAFEE18 + 101)) count=16 2>/dev/null | hexdump -v -e ' 4/4 "%.8X " "\n" '
00000000 00000000 00000000 00000000

Looks like DIDX and EDPV were somehow initialized (maybe by EFI firmware prior to kernel bootup?) and EDPV value of 2 suggests that it was initialized in DD02._ADR method. It is not exactly clear why DIDX became 0x80010410. For the case when EDPV equals to 2 it should be that SANV.DIDX==SANV.DID2 (initialized in DD02._ADR). SANV.DID2 gets initialized in GFX0._DOD like DID2=SDDL(IGDM.DIDL). Method SDDL transforms DIDL like this: (DIDL & 0x0F0F) | 0x80000000. So it is unclear why is bit 4 is high in the first byte of DID2. The same stands for lowest bit of the third byte. Maybe it is controlled elsewhere either by the ACPI or by the gfx driver or by the hardware.

What seems obvious is that IGDM.DIDL had changed at some point after EDPV and DIDX got initialized. Then the CADL had been "reinitialized" with a new values from the DIDL and the GFX0._DOD method had been invoked resulting in re-population of SANV.DID1..SANV.DIDF.

This findings are consistent through a number of different kernel versions, namely (debian kernels): 3.13.5-1, 3.14.15-2, 3.17-1~exp1 and 3.18-1~exp1.

With old and dusty 3.2.32-1 the behavior is different:

a) i915 fails to load with "[drmi:i915_init] *ERROR* drm/i915 can't work without intel_agp module!" message. This results in lack of kernel modesetting and X falling back to vesa driver.

b) Pressing Fn+F5/F6 at text console results in ACPI related messages in dmesg like:
Feb 17 20:26:08 lx2netbook kernel: [ 342.302819] ACPI Error: Result stack is empty! State=fff...

Read more...

Adem Caliskan (adem.caliskan) wrote :

Also affect Newest Asus model UX303LAB

dmidecode -s bios-version

-> UX303LAB.203

Evtest doesn't receive any events when pressin Fn+F5 or Fn+F6.
Also setting backlight over Preferences doesn't work, but auto dimming in battery mode after 5 minutes seems to work.

Attached lshw and lspci output.

Adem Caliskan (adem.caliskan) wrote :

also affect new broadwell model of ux303lab as mention by Adem Caliskan even on 3.16.0-33 kernel

I forgot to mention that I already try 4.0.0rc3 kernel and still can use brightness key

sorry for wrong comment,

I forgot to mention that I already try 4.0.0rc3 kernel and still "cannnot" use brightness key

Hi, also confirm the problem on UX303LA with 205 BIOS.

dmidecode -s bios-version
UX303LAB.205

evtest or acpi_listen don't show keypress on FN+F5/F6 (interestingly F3 and F4 are captured and are controling not existing keyboard backlight in this model).

Kernel 3.16.0-33-generic with "acpi_osi="

Barry Martin (bmartin4) wrote :

Hello, also confirming this issue on a Asus UX305

dmidecode -s bios-version
UX305FA.206

Unable to adjust brightness at all, using both the function keys and the settings application.

Lucky (kartasasmita) wrote :

Tried with ubuntu 15.04 on ASUS UX305... doesn't work either (including the acpi_osi work-around)

$ sudo dmidecode -s bios-version
UX305FA.206
$ uname -a
Linux UX305FA 3.19.0-9-generic #9-Ubuntu SMP Wed Mar 11 17:50:03 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Zechariah Jibben (threeofsix) wrote :

I can also confirm the bug on Ubuntu 14.10 on ASUS UX303LAB.

$ sudo dmidecode -s bios-version
UX303LAB.205
$ uname -a
Linux UX303 3.16.0-33-generic #44-Ubuntu SMP Thu Mar 12 12:19:35 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

A possible workaround:

I have screen brightness control through the system settings, but not through the Fn+F-keys. This works if acpi_osi=intel is in the boot parameters, or there is no "acpi_osi" mentioned. For example, only "quiet splash". If you install xbacklight from the Ubuntu repositories, the commands

$ xbacklight -dec 12.5
$ xbacklight -inc 12.5

decrease and increase (respectively) the screen brightness by 12.5% (I picked 1/8th total, but another choice will do). So, in keyboard settings I mapped these commands to Alt+F5 and Alt+F6, which seems ok so far. Hopefully this will make things easier until a fix comes out.

Jared Stemen (jstemen) wrote :

The "acpi_osi=" at the end of GRUB_CMDLINE_LINUX_DEFAULT work around works for me on my N56J Asus

Arek (ak-komar) wrote :

Confirming this issue on Kubuntu 15.04 on Asus UX305.
"acpi_osi" hack doesn't fix the problem.
I am able to change brightness using xbacklight.

$ sudo dmidecode -s bios-version
UX305FA.203
$ uname -a
Linux asus 3.19.0-15-generic #15-Ubuntu SMP Thu Apr 16 23:32:37 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

tArKi (djtarki) wrote :

Hi,

I've edited /etc/default/grub as root and added "acpi_osi=" at the and of the kernel boot parameters:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="

Then I've run "update-grub" as root and rebooted the laptop.

Now Fn+ F2/F5/F6 work fine! :) (that is, WiFi and backlight function keys)

$ sudo dmidecode -s bios-version
S301LA.214
$ uname -a
Linux nablanext 3.19.0-15-generic #15-Ubuntu SMP Thu Apr 16 23:32:37 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Best regards

As I mentioned before, the model which has this problem is UX303LN"B" [Broadwell] not UX303LN"A".

This problem is still existing in Ubuntu 15.04!

M2-player (vergil333) wrote :

Thank you tArKi. When I before added "acpi_osi='Windows 2012'" it didn't work. When I got rid of the 'Windows 2012' sentence it started to work. Thanks :)

Asus UX302LA (i7-4500M).

Vasya Pupkin (shadowlmd) wrote :

Same issue on UX301L (UX301LAA) model on Ubuntu 15.04. BIOS: UX301LAA.209. I have to add "acpi_osi=" to get them working, but this is a bad workaround.

verion GmbH (sales-ixsoft) wrote :

This bug affects all current ASUS UX305FA models, tested with BIOS 206 and 207 and Kernel 3.19 and up to Kernel 4.0.4 from mainline. Kernel parameters "acpi_osi=" or "acpi_backlight=intel" do not work at all, "acpi_osi" only disables the WMI control (possibly another bug).

How are these ACPI events generated? If the BIOS does not supply the event, maybe it must be enabled with some control sequence? (acpi_listen mostly doesn't say anything if pressing Fn+F-keys.)

I saw that e.g. for newer hybrid touchpads, you need to initialize the device with an ACPI command so that it will either work in PS2 or I2C mode. Otherwise it will either be "off" or the mode is not what I wanted. Maybe this works the same way here and we only have to enable these key events?

Alexey Loukianov (lexa2) wrote :

Here is this bug reported upstream by me: https://bugzilla.kernel.org/show_bug.cgi?id=92391
It was closed as duplicate with a reference to this one: https://bugs.freedesktop.org/show_bug.cgi?id=81762

It is not a problem with device initialization, it is rather a problem with device driver not initializing some fields in device op.region with a values expected by ACPI code. There was an experimental kernel branch which is expected to fix this bug but I'm not certain what is current status on this. Looks like there is next to none activity in DRM/Intel bugzilla report #81762 so chances seem to be low that we would get a proper fix anytime soon.

LSW (lorax) wrote :

This bug also affects me on a UX303LAB running the 3.19.0-21 kernel under 14.04. Adding the "acpi_osi=" kernel parameter does nothing.

Changed in linux:
importance: Unknown → Wishlist
status: Unknown → Confirmed
Vasya Pupkin (shadowlmd) wrote :

Should we have a patch in Ubuntu knowing that the problem is not going to be fixed in mainline kernel any time soon?

Vasya Pupkin (shadowlmd) wrote :

I'm not sure how helpful this would be but I sent a request to ASUS support. I asked them to look at this bug report and fix BIOS to initialize required regions properly. Maybe if all people who have the same problem will contact ASUS as well, they will actually do something?

Alexey Loukianov (lexa2) wrote :

Vasya, it is not ASUS fault and they have nothing to fix here. This problem is a low priority bug in DRM/Intel and it could only be fixed on DRM/Intel/kernel side. ASUS has nothing to do with it, it is not a bug in their ACPI DSDT code.

Georg Peters (georgpeters) wrote :

Same problem still exists on Asus UX305 with Ubuntu 15.04

sudo dmidecode -s bios-version
UX305FA.206

uname -a
Linux zenbook 3.19.0-23-generic

Adding the "acpi_osi" bootoption does the same as in #32

lechnerlich (lechnerlich) wrote :

also effected

sudo dmidecode -s bios-version
UX303LAB.205

uname -a
Linux zenbuntu 3.19.0-25-generic

adjusting brightness in settings works, but not with fn+f5/f6
acpi_listen does not detect the keys press, evtest detects also nothing.
tested various bootoptions - nothing helped (excepted that then I was also not able to adjust brightness in the settings)

Marcin Mielniczuk (marmistrz) wrote :

A similar problem exists on Asus R556LB, kernel 4.1.2. acpi_listen detects nothing, neither does showkey --scancodes. No usual workaround (acpi_osi=, acpi_backlight=vendor) work

Reproducible on an ASUS UX305LA

$ uname -a
Linux bnasws02 3.16.0-49-generic #65~14.04.1-Ubuntu SMP Wed Sep 9 10:03:23 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
UX305LA.204
07/06/2015

This issue is reproducible also on Asus Zenbook UX303LA with Broadwell:
# dmidecode -s bios-version
UX303LAB.207

Pressing Fn+F5/F6 seems to emit EC Query 0x0e/0x0f, but the backlight intensity does not change and no key press is emitted using the input subsystem.

Ivan Diaz (ivan-diazu) wrote :

Reproducible on an ASUS UX303LB

$ uname -a
Linux NTHX-LLT 3.19.0-30-generic #33-Ubuntu SMP Mon Sep 21 20:58:04 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
UX303LB.206
08/24/2015

DeeKey (privateinf) wrote :

Reproducible on ASUS UX305fa
sudo dmidecode -s bios-version
UX305FA.210

uname -a
Linux 3.19.0-30-generic #33-Ubuntu SMP Mon Sep 21 20:58:04 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Also tried on BIOS version 208. Got the same result.

Still able to control brightness using software methods.

Vasya Pupkin (shadowlmd) wrote :

Bug is still present in Ubuntu 15.10.

Reproducible on ASUS UX501JW

$ uname -a
Linux ASUS-ZENBOOK 4.2.0-16-generic #19-Ubuntu SMP Thu Oct 8 15:35:06 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
N501JW.210
08/03/2015

The "acpi_osi=" work around works it still ignores display turn off combination.

MN (maxim-novozhilov) wrote :

confirmed for me too on asus ux305la

$ uname -a
Linux up 4.2.0-16-generic #19-Ubuntu SMP Thu Oct 8 15:35:06 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
UX305LA.202
04/16/2015

"acpi_osi=" doesn't help

Marek Lipka (marek-lipka) wrote :

Confirmed for me on ASUS UX305LA

$ uname -a
Linux marek-UX305LA 4.2.0-16-generic #19-Ubuntu SMP Thu Oct 8 15:35:06 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
UX305LA.202
04/16/2015

Messing with /etc/default/grub doesn't help at all.

Claude CLERC (claude-clerc) wrote :

Confirmed too on ASUS R511LJ

$ uname -a
Linux ctuxasus 3.19.0-32-generic #37~14.04.1-Ubuntu SMP Thu Oct 22 09:41:40 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
X555LJ.504
08/04/2015

"acpi_osi=" and "acpi_osi=Linux" don't help.

Could people who have an ASUS UX305 add themselves to the bug report here to speed up things:

 https://bugzilla.kernel.org/show_bug.cgi?id=98931

sokai (sokai) wrote :

Confirmed on ASUS UX303LNB, too.

$~# sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
UX303LNB.206
01/22/2015

Brightness settings are working in system settings and in terminal (echo $VALUE > /sys/class/backlight/intel_backlight/brightness).
Thanks for fixing …! :)

Pheppy (geenreactie-dekok) wrote :

Confirmed on ASUS X555LAB running Ubuntu 15.10.

$~# sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
X555LAB.503
08/04/2015

First brightness was not working at all. Adding "acpi_osi=" at the end of GRUB_CMDLINE_LINUX_DEFAULT enables the brightness settings in system settings. Still Fn+F5 and Fn+F6 are not working.
As a workaround I assigned Ctrl+F3 and Ctrl+F4 to "xbacklight -dec 10" and "xbacklight -inc 10" to decrease and increase brightness. However this is suboptimal.
Hope this "Brightness keys Fn+F5 and Fn+F6" problem can be fixed.

Joe Liau (joe) wrote :

Same issue as Pheppy on Ubuntu 15.10

But the brightness setting in system settings still does nothing. FN keys for brightness do nothing.

~$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
UX305FA.208
03/26/2015

Leander Koornneef (bugs-h) wrote :

I can also confirm this problem on Asus X555LAB.503, same as Pheppy (#65). Brightness control does work from system settings and using xbacklight works as well.

tArKi (djtarki) wrote :

I've tried now with an Asus UX303LB-R4109H (2 graphic cards Nvidia and Intel) and Ubuntu 15.10 (kernel 4.2.0-22) : unfortunately I cannot manage to make the FN brightness keys work.

The brightness can be adjusted if the System Settings are used though.

About my BIOS version:
$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
UX303LB.206
08/24/2015

Thanks.

Michael Weimann (m982) wrote :

For me it is working with:

• Add "acpi_osi=" to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub then run update-grub
• Add a file "20-backlight.conf" with the following content to "/usr/share/X11/xorg.conf.d"
Section "Device"
    Identifier "card0"
    Driver "intel"
    Option "Backlight" "intel_backlight"
    BusID "PCI:0:2:0"
EndSection

After a reboot it's working.

Asus Zenbook UX305UA running Ubuntu 15.10 with 4.4 kernel.

Gerard (gerardbdn) wrote :

Confirmed on UX303LB-R4018H with:

Ubuntu 15.10
Kernel 4.2.0-27-generic
Bios: UX303LB.206 08/24/2015

I also can adjust brightness in settings and terminal.

The fix suggested in #69 didn't work for me.

The fix suggested by #69 WORKED for me!

Asus Zenbook UX303LA
Linux mint 17.3
Kernel 4.2.8-040208-generic
Uefi

Not fixed in current mainline for ASUS TP300LA/J Flipbook. fix #69 does not work either. Backlight and Ambient sensor works fine without combinations of acpi_osi= etc. Adding them disables backlight from working at all.

Linux gabrielle.ae.net.nz 4.5.0-0.rc3.git1.2.fc24.x86_64 #1 SMP Tue Feb 9 22:52:55 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

[aenertia@gabrielle ~] $ sudo evtest
No device specified, trying to scan all of /dev/input/event*
Available devices:
/dev/input/event0: Lid Switch
/dev/input/event1: Sleep Button
/dev/input/event2: Power Button
/dev/input/event3: AT Translated Set 2 keyboard
/dev/input/event4: ETPS/2 Elantech Touchpad
/dev/input/event5: Atmel
/dev/input/event6: Video Bus
/dev/input/event7: Video Bus
/dev/input/event8: HDA Intel HDMI HDMI/DP,pcm=3
/dev/input/event9: HDA Intel HDMI HDMI/DP,pcm=7
/dev/input/event10: HDA Intel HDMI HDMI/DP,pcm=8
/dev/input/event11: HDA Intel PCH Headphone
/dev/input/event12: Asus WMI hotkeys
/dev/input/event13: USB2.0 UVC HD Webcam

VV0ll3 (vv0ll3) wrote :

Confirmed on a UX303LB

fix from #69 does not work for me.

sudo dmidecode -s bios-version
UX303LB.206

Add X455LB-WX034D (a.k.a. A455LB-WX034D) to the not working list. Neither solution above works on this machine.

$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
X455LB.206
09/15/2015

I have an ASUS UX303UB and fn plus f5,f6 and f7 don't generate any event.

$ uname -a
Linux ... 4.2.0-30-generic #36~14.04.1-Ubuntu SMP Fri Feb 26 18:49:23 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
# SMBIOS implementations newer than version 2.8 are not
# fully supported by this version of dmidecode.
UX303UB.202
# SMBIOS implementations newer than version 2.8 are not
# fully supported by this version of dmidecode.
08/27/2015

Workaround for X455LB-WX034D:
The keyboard has no backlight, but Fn+F3 & Fn+F4 generates keyboard brightness events which can be remapped to replace Fn+F5 & Fn+F6.

Vasya Pupkin (shadowlmd) wrote :

Just tested with latest and greatest 4.6rc1 kernel, still nothing.

Timo (timo-tk) wrote :

#69 works for fn+F5 and fn+F6 keys. fn+F7 still doesn't work but that is not a problem for me.

Zenbook UX303UA
Ubuntu 15.10
Kernel 4.6.0-040600rc1-generic
Bios: UX303UA.202 08/27/2015

Guy Taylor (thebiggerguy) wrote :

#69 does not work for me. So looks like the UX305FA needs another fix.

Zenbook UX305FA
Ubuntu 15.10
Kernel: 4.5.0-040500-generic
BIOS: UX305FA.210

lspci:
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)

Joe Liau (joe) wrote :

UX305FA still has this problem on Ubuntu 16.04

The Zenbook series of laptops is very popular. What can be done to speed up the implementation of a fix?

Am I right in understanding that the problem is actually in the intel driver - http://www.spinics.net/lists/intel-gfx/msg79628.html? Maybe intel should be contacted and pressured over this?

setting acpi_osi='' to grub worked for me.
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
UX32LN.202
02/24/2014
and
uname -a
Linux toretto 4.5.2-040502-generic #201604200335 SMP Wed Apr 20 07:37:26 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

*setting in grub not to

Jakob (notjakob) wrote :

"Workaround for X455LB-WX034D:
The keyboard has no backlight, but Fn+F3 & Fn+F4 generates keyboard brightness events which can be remapped to replace Fn+F5 & Fn+F6."

@ #76 how can you remapp fn+f4 and fn+f3 to get it to work?

Marie (captainmalu) wrote :

I've the UX303UB (processor i7-6500U) with kernel 4.8 and Ubuntu 16.10.
I have the same problem but "acpi_osi=" in the grub file is working for me but the ambient-light sensor (fn+A) isn't working.

Vincent Gerris (vgerris) wrote :

I have a UX305FA. I do not use any kernel parameters and the graphical controls work when doing:
sudo apt-get install xbacklight

Then under open Settings>keyboard>shortcuts

Add custom shortcut keys with:

xbacklight -dec 10

xbacklight -inc 10

I used ALT+F5 and F6.

I didn't notice the ambiant sensor on the A until now :).
It doesn't work for me either.

Does anyone know which event should be send so we can remap it as a work around?

I run Ubuntu 16.10 with 4.8.0-27 kernel.

I hope some developers can pick this up? A lot of folks are affected.

Vincent Gerris (vgerris) wrote :

I remembered someone writing a good article and found it:
http://hansdegoede.livejournal.com/13889.html

For me this command shows events
sudo evemu-record /dev/input/event3

but not for my FN+F5, F6 or A combination.

According to his article, it should be filed as a kernel bug.

For everyone else, please check the article and see where your issue is and file the proper bug.
Good luck :)

Vincent Gerris (vgerris) wrote :

Sorry, I forgot to add something.
Earlier I added a x11 conf file:
/usr/share/X11/xorg.conf.d/20-intel.conf
with content:
Section "Device"
        Identifier "card0"
        Driver "intel"
        Option "Backlight" "intel_backlight"
        BusID "PCI:0:2:0"
EndSection

This seems to be needed to actually have the :
xbacklight -dec 10
xbacklight -inc 10
working.

(the device is there and doing this as root will still work without conf:
echo 220 > /sys/class/backlight/intel_backlight/brightness ).

I am going to see if I can fix this and otherwise file a kernel bug.

Vincent Gerris (vgerris) wrote :

Great news for at least Asus UX305FA users and a lot more!
It turns out that a lot of issues are fixed in the drm-intel-next branch of the kernel (I was tipped off by Hans de Goede, thank you Hans).

I tried todays build that can be found here:
http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-next/

Install the debs as usual (dkpg -i), reboot.
For me the brightness buttons just work and send an event properly now, I also get the indicator.

I hope this works for more people, it will be a matter of time before it's in the main line I guess.
cheers

I can confirm that #90 fixed the issue on my UX303LAB. Thanks!

MN (maxim-novozhilov) wrote :

> Linux up 4.9.0-997-generic #201611212212 SMP Tue Nov 22 03:14:21 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
#90 fixed the issue, as well as "air plane mode"

thanks a lot!

Denny Valliant (denuno) wrote :

The drm-intel-next/2016-11-22 kernel fixed the missing brightness (and "air plane mode") input events here too, on an Asus GL551JW-DS74.

Many thanks to the author of the fix, and to Vincent & Hans for the heads-up!

Vasya Pupkin (shadowlmd) wrote :

I can confirm that current drm-intel-next kernel fixes issue for UX301LA as well.

Worked for Asus UX303LN as well.

Is there an ETA when it (if at all) will be merged in the mainline kernel, or for which kind of commit massage I have to lookout for?

Denny Valliant (denuno) wrote :

I'm wondering the same. How can I track when this is merged? I looked at the docs for the drm-intel cycle, and it seemed like it'd make it into 4.9, but thus far I haven't seen it... dunno if we have to flag it somehow to get it backported or some such (if it's not already on someone's radar-- I saw a note about fixes falling through the cracks every now and again in the merge docs) or just wait for like 4.10 or whatever.

Denny Valliant (denuno) wrote :

Ah, it looks like this is probably it:

http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=200453bfced58c0d67c26daeeb845f24f7fee1df

Slated for 4.10 it looks like, though I'm not really sure how/if/when backporting is done, so maybe it'll make its way back down at some point.

Magiczny Gibon (mgibon) wrote :

drm-intel-next kernel worked for my UX303LN too, although apparently it broke Bluetooth.

Changed in linux:
status: Confirmed → Fix Released
grumrick (grum-rick) wrote :

I have been casually following this thread for some time and tried the drm-intel-next kernel fix on my ASUS F555L. While it fixed my Airplane Mode (it was on permanently) and all other functions seem to be working, alas the two brightness functions f5 and f6 still don't work. Pity. Do I need to post a seperate Bug?

Kai-Heng Feng (kaihengfeng) wrote :

@grumrick

Please do. It's a different model.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.