[Fujitsu LIFEBOOK P7010] Black screen coming back from standby

Bug #1333123 reported by ruediger on 2014-06-23
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I sent the laptop to standby using the menu. Coming back from standby, I see a black screen with backlight on, and cannot do anything. Shutting down the system using the power button works however from this state (interestingly, xubuntu screen with waiting animation comes up).

WORKAROUND: sudo pm-suspend

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-29-generic 3.13.0-29.53
ProcVersionSignature: Ubuntu 3.13.0-29.53-generic 3.13.11.2
Uname: Linux 3.13.0-29-generic i686
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: kaefer 1968 F.... pulseaudio
 /dev/snd/pcmC0D0p: kaefer 1968 F...m pulseaudio
CurrentDesktop: XFCE
Date: Mon Jun 23 09:49:14 2014
HibernationDevice: RESUME=UUID=fde94fbd-94f3-4182-b8e1-1306022eca14
InstallationDate: Installed on 2014-05-11 (42 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20140416.2)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: FUJITSU SIEMENS LIFEBOOK P7010
PccardctlIdent:
 Socket 0:
   no product info available
 Socket 1:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
 Socket 1:
   no card
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-29-generic root=UUID=2e433c98-0ca4-4bff-83b0-733b90d0ccb8 ro forcepae quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-29-generic N/A
 linux-backports-modules-3.13.0-29-generic N/A
 linux-firmware 1.127.2
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/15/2007
dmi.bios.vendor: FUJITSU // Phoenix Technologies Ltd.
dmi.bios.version: Version 1.29
dmi.board.name: FJNB189
dmi.board.vendor: FUJITSU
dmi.chassis.type: 10
dmi.chassis.vendor: FUJITSU SIEMENS
dmi.chassis.version: P70__
dmi.modalias: dmi:bvnFUJITSU//PhoenixTechnologiesLtd.:bvrVersion1.29:bd08/15/2007:svnFUJITSUSIEMENS:pnLIFEBOOKP7010:pvr:rvnFUJITSU:rnFJNB189:rvr:cvnFUJITSUSIEMENS:ct10:cvrP70__:
dmi.product.name: LIFEBOOK P7010
dmi.sys.vendor: FUJITSU SIEMENS

ruediger (ruediger05) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.16 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.16-rc1-utopic/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
ruediger (ruediger05) on 2014-06-23
tags: added: kernel-unable-to-test-upstream
ruediger (ruediger05) wrote :

Hi,

I tried upstream v3.16-rc2 utopic, and encountered a similar issue when booting up. The result was again a black screen. Before that, the waiting xubuntu screen was shown with reduced bit depth, and even before that there was a single line on the screen saying something like

[36.xxxx] i9xx pipe underrun

I could not log on (all I had was a black screen), so I pressed the power button again to turn the laptop off, which it did. As a result, I could not test for the bug, but the problems are somewhat similar.

Cheers

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

ruediger, did this problem not occur in a release prior to Trusty?

tags: added: latest-bios-1.29
description: updated
summary: - Black screen coming back from standby
+ [Fujitsu LIFEBOOK P7010] Black screen coming back from standby
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
ruediger (ruediger05) wrote :

I guess the only version that was ever running (very shortly) on this machine was ubuntu 12.04. It booted fine, but I can't remember if I used the standby mode then. Otherwise, this machine ran Windows XP.

ruediger, for regression testing purposes, could you please test 12.04.0 via http://old-releases.ubuntu.com/releases/12.04.0/ and advise to the results?

Thales (ceolin) wrote :

Hello!
I can confirm this bug also happens on 12.04 with trustry-lts kernel.

Thales, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into the default Ubuntu kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

ruediger (ruediger05) wrote :

(apologies for the delay)

I finally made ubuntu 12.04.0 work (live-system from USB).
Before that, I double-checked and the problem persisted.
It worked fine on 12.04, yet I could not successfully enable that I am prompted for my password after suspend.
Back on 14.04, I wanted to check if I had set that option, and fiddled around with Light Locker and hooray it worked (dunno what I had set).

I have now Light Locker and "lock on suspend" enabled.
Coming back from suspend, I see a black screen with backlight on, then the mouse arrow appears for a glimpse, and the screen turns black with backlight off. Then, I can make the login screen appear by pressing a key on the keyboard or moving the mouse.

To make the problem re-appear until the next reboot, I can do the following:
* sudo pm-suspend in terminal -> suspended. Pressing the powerbutton, the laptop comes back from suspend WITHOUT login form
* choose suspend from menu -> suspended. Pressing the power button. The old problem is back.

Without Light Locker, everything is fine, just as with Light Locker and without "lock on suspend"

Re-enabling "lock on suspend", the problem was back. Then, I rebooted, and we are back in the situation as above Light Locker and "lock on suspend".

ruediger (ruediger05) on 2014-08-13
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: regression-release

ruediger, the next step is to fully commit bisect the kernel in order to identify the offending commit. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection ?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers