No Unity 3D support with Radeon APU E2-4000 with R2 Graphics [1002:9853]

Bug #1323967 reported by Yung Shen on 2014-05-28
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Alberto Milone
Nominated for Trusty by Yung Shen
Nominated for Utopic by Yung Shen
xserver-xorg-video-ati (Ubuntu)
Medium
Unassigned
Nominated for Trusty by Yung Shen
Nominated for Utopic by Yung Shen

Bug Description

The interface is very slow when 14.04 running on hardware with AMD CPU, E1-6010 APU with AMD Radeon R2 Graphics.

Compiz does not fully supported:
$ /usr/lib/nux/unity_support_test -c -p
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits)
OpenGL version string: 1.4 (2.1 Mesa 10.1.0)

Not software rendered: no
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes

Compiz supported: no

-

For the status of fglrx driver on this system, please check related bug 1324001

-

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-24-generic 3.13.0-24.46 [modified: boot/vmlinuz-3.13.0-24-generic]
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1640 F.... pulseaudio
CurrentDesktop: Unity
Date: Wed May 28 02:09:50 2014
HibernationDevice: RESUME=UUID=63f7549b-e124-4907-a497-768e5cc958aa
InstallationDate: Installed on 2014-05-28 (0 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: Dell Inc. Vostro 3445
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic root=UUID=2fef7b9b-8ecf-4187-9d4a-3203bfdc7f71 ro rootdelay=60 quiet splash initcall_debug vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-24-generic N/A
 linux-backports-modules-3.13.0-24-generic N/A
 linux-firmware 1.127
SourcePackage: linux
StagingDrivers: rts5139
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/20/2014
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A00
dmi.board.name: Vostro 3445
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: Not Specified
dmi.modalias: dmi:bvnDellInc.:bvrA00:bd03/20/2014:svnDellInc.:pnVostro3445:pvrNotSpecified:rvnDellInc.:rnVostro3445:rvrA00:cvnDellInc.:ct8:cvrNotSpecified:
dmi.product.name: Vostro 3445
dmi.product.version: Not Specified
dmi.sys.vendor: Dell Inc.

Yung Shen (kaxing) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Yung Shen (kaxing) on 2014-05-28
tags: added: 201403-14842 blocks-hwcert taipei-lab
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.15 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.15-rc7-utopic/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Yung Shen (kaxing) wrote :
Yung Shen (kaxing) on 2014-05-28
description: updated
Yung Shen (kaxing) on 2014-05-29
tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → New
Brad Figg (brad-figg) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Alberto Milone (albertomilone) wrote :

Please attach /var/log/Xorg.0.log and the output of dmesg

Yung Shen (kaxing) wrote :
Yung Shen (kaxing) wrote :

please also check the Xorg.0.log in comment #7

Alberto Milone (albertomilone) wrote :

I don't think that device is supported by the kernel module or, if it is, radeon is blacklisted.

Please try the kernel available here:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.15-utopic/

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
assignee: nobody → Alberto Milone (albertomilone)
Daniel Manrique (roadmr) on 2014-06-11
Changed in xserver-xorg-video-ati (Ubuntu):
importance: Undecided → Medium
madbiologist (me-again) wrote :

Alberto is correct, support for your "Beema" E1-6010 APU's graphics was added in the upstream 3.15 kernel.

madbiologist (me-again) wrote :

You will also need libdrm 2.4.54 and mesa 10.2.

madbiologist (me-again) wrote :

Let me know if you want the commit references.

You probably already know that you can get libdrm 2.4.54 and mesa 10.3 from Oibaf's PPA at https://launchpad.net/~oibaf/+archive/graphics-drivers

Yung Shen (kaxing) wrote :

Thank you @me-again , I was looking for it. I will verify this later when I had access to it.

Yung Shen (kaxing) wrote :

With kernel 3.15, mesa 10.3 and libdrm 2.4.54
Still quite laggy and no 3d support for unity.

madbiologist (me-again) wrote :

You will also need to copy the 6 files that are prefixed with "MULLINS" from http://people.freedesktop.org/~agd5f/radeon_ucode/ to /lib/firmware/radeon and probably reboot afterwards.

Yung Shen (kaxing) wrote :

@me-again thanks for the hint,

Now the unity works as expected, system performance are acceptable as well.

Using same packages as mention in Comment #14 and firmware files mention in comment #15.

ubuntu@201403-14842:~$ /usr/lib/nux/unity_support_test -c -p
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD MULLINS
OpenGL version string: 3.0 Mesa 10.3.0-devel (git-6c2d815 trusty-oibaf-ppa)

Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes

Compiz supported: yes

madbiologist (me-again) wrote :

The necessary firmware files are now available for Trusty in linux-firmware 1.127.4.

Kernel 3.15.0-6.11, libdrm 2.4.54-1 and mesa 10.2.1-2ubuntu2 are now available in Ubuntu 14.04 "Utopic Unicorn". The necessary firmware files are also available in Utopic in linux-firmware 1.132. Marking this bug as fix released based on your test results in comment #16.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Fix Released
Yung Shen (kaxing) wrote :

The issue still here with even with linux-3.16.0-25, linux-firmware 1.127.8 on trusty.

I've nominated both utopic and trusty series for better tracking.

Changed in linux (Ubuntu):
status: Fix Released → New
Changed in xserver-xorg-video-ati (Ubuntu):
status: Fix Released → New
Brad Figg (brad-figg) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Taihsiang Ho (taihsiangho) wrote :

Dell Inspiron 3441 (CID 201403-14840) has the same issue.
Please refer to LP: #1391430 as well.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
Yung Shen (kaxing) wrote :

I can still reproduce this issue on the same system with linux-generic-lts-utopic 3.16.0.28.21

OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits)
OpenGL version string: 2.1 Mesa 10.1.3

Not software rendered: no
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes

Compiz supported: no

Po-Hsu Lin (cypressyew) wrote :

Also affects AMD A4-6210 APU with AMD Radeon R3 Graphics [1002:9850]

ubuntu@201403-14860:~$ /usr/lib/nux/unity_support_test -c -p
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits)
OpenGL version string: 2.1 Mesa 10.1.3

Not software rendered: no
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes

Compiz supported: no

tags: added: 201403-14860
madbiologist (me-again) wrote :

Yung Shen and Po-Hsu Lin - the info that you both posted shows that you are both using Mesa 10.1.3. As per comment #11, you need Mesa 10.2. Ubuntu 14.10 "Utopic Unicorn" currently has mesa 10.3.0-0ubuntu3 and mesa 10.3.2-0ubuntu0.1 is currently in utopic-proposed.

I could not find any mention in the upstream changelogs of the new hardware support being backported to mesa 10.1.x point releases, nor is there any mention of it in the Ubuntu mesa changelog for Trusty at https://launchpad.net/ubuntu/+source/mesa/+changelog

Mesa 10.3 or 10.3.2 will probably be included in Ubuntu "Trusty Tahr " 14.04.2, which is scheduled for release on 5th February 2015.

Kamalakar Agashe (kagashe) wrote :

Works on Ubuntu 14.04.2
$ /usr/lib/nux/unity_support_test -c -p
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD MULLINS
OpenGL version string: 3.0 Mesa 10.3.2

Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes

Compiz supported: yes

madbiologist (me-again) on 2015-06-11
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers