Realtek Wifi card RTL8723BE drops connection with MSI enabled

Bug #1320070 reported by Adam Lee on 2014-05-16
234
This bug affects 46 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Adam Lee
Trusty
High
Adam Lee
Utopic
High
Adam Lee

Bug Description

As my testing result with ThinkPad E540 and other users' report[1], RTL8723BE drops connection with MSI enabled, need to backport 329d6e299f92a591acb3a80f6d597a5f9dce7e6d "rtlwifi: rtl8723be: disable MSI interrupts mode"

[1] https://bugs.launchpad.net/bugs/1240940

Tips for RTL8188EE [10ec:8179] and RTL8723BE [10ec:b723] users: those hardware modules have MSI compatibility issue, on some certain platforms they work fine with MSI but break connections without MSI, on some other certain platforms it's opposite. You could try to toggle its module parameter "msi"

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1296591

CVE References

Adam Lee (adam8157) wrote :

patch has been sent to kernel-team@

Tim Gardner (timg-tpi) on 2014-05-16
Changed in linux (Ubuntu Trusty):
assignee: nobody → Adam Lee (adam8157)
status: New → In Progress
Stanko Metodiev (metodiew) wrote :

Sorry if I'm pain in the ass, no I have to ask is there a way to update this until we are waiting for the fix ?
And if yes, from where I could change rtlpci->msi_support = true; to false?

Thanks in advance :)

Adam Lee (adam8157) on 2014-05-19
Changed in linux (Ubuntu Trusty):
importance: Undecided → High
Adam Lee (adam8157) wrote :

@Stanko

Please wait for updating or use this kernel I built for you: http://kernel.ubuntu.com/~adamlee/lp1320070_rtl8723be_nomsi/

(http://kernel.ubuntu.com seems down right now, please try later)

Thanks.

Tim Gardner (timg-tpi) on 2014-05-19
Changed in linux (Ubuntu Trusty):
status: In Progress → Fix Committed
Peter Storgaard (storgaard1234) wrote :
Download full text (4.2 KiB)

Dont know if this belongs here but just tried latest kernel from proposed

And it keeps crashing the kernel:

[ 246.383091] ------------[ cut here ]------------
[ 246.383108] WARNING: CPU: 1 PID: 1128 at /build/buildd/linux-3.13.0/net/mac80211/sta_info.c:432 sta_info_insert_rcu+0xb7/0xe0 [mac80211]()
[ 246.383109] Modules linked in: ctr ccm bnep rfcomm nls_iso8859_1 snd_hda_codec_realtek snd_hda_codec_hdmi x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel kvm arc4 crct10dif_pclmul crc32_pclmul ghash_clmulni_intel aesni_intel rtl8723be uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core aes_x86_64 lrw videodev btcoexist rtl8723_common gf128mul glue_helper rtl_pci rtlwifi nouveau ablk_helper mxm_wmi cryptd thinkpad_acpi ttm mac80211 snd_hda_intel snd_hda_codec i915 snd_hwdep snd_pcm btusb joydev nvram snd_page_alloc cfg80211 snd_seq_midi drm_kms_helper bluetooth snd_seq_midi_event drm snd_rawmidi snd_seq serio_raw i2c_algo_bit snd_seq_device snd_timer mei_me mei snd soundcore lpc_ich video wmi mac_hid parport_pc ppdev lp parport hid_logitech_dj usbhid hid psmouse r8169 ahci mii libahci
[ 246.383143] CPU: 1 PID: 1128 Comm: wpa_supplicant Tainted: G W 3.13.0-27-generic #50-Ubuntu
[ 246.383144] Hardware name: LENOVO 80B6QB0/80B6QB0, BIOS J7ET27WW (1.04 ) 08/08/2013
[ 246.383145] 0000000000000009 ffff8800bf4437b8 ffffffff817199c4 0000000000000000
[ 246.383147] ffff8800bf4437f0 ffffffff810676bd ffff8801285c6800 ffff8800bdb78600
[ 246.383149] 00000000ffffffea ffff8800a9d70b9a 000000000000000c ffff8800bf443800
[ 246.383151] Call Trace:
[ 246.383156] [<ffffffff817199c4>] dump_stack+0x45/0x56
[ 246.383159] [<ffffffff810676bd>] warn_slowpath_common+0x7d/0xa0
[ 246.383161] [<ffffffff8106779a>] warn_slowpath_null+0x1a/0x20
[ 246.383166] [<ffffffffa042f057>] sta_info_insert_rcu+0xb7/0xe0 [mac80211]
[ 246.383172] [<ffffffffa042f08e>] sta_info_insert+0xe/0x10 [mac80211]
[ 246.383182] [<ffffffffa046b200>] ieee80211_prep_connection+0x3b0/0x7c0 [mac80211]
[ 246.383191] [<ffffffffa0470dfd>] ieee80211_mgd_auth+0x27d/0x310 [mac80211]
[ 246.383198] [<ffffffffa0443c78>] ieee80211_auth+0x18/0x20 [mac80211]
[ 246.383209] [<ffffffffa02385b7>] cfg80211_mlme_auth+0x167/0x200 [cfg80211]
[ 246.383216] [<ffffffffa022456f>] nl80211_authenticate+0x2af/0x310 [cfg80211]
[ 246.383220] [<ffffffff8164d02d>] genl_family_rcv_msg+0x18d/0x370
[ 246.383223] [<ffffffff8164d210>] ? genl_family_rcv_msg+0x370/0x370
[ 246.383224] [<ffffffff8164d2a1>] genl_rcv_msg+0x91/0xd0
[ 246.383226] [<ffffffff8164b329>] netlink_rcv_skb+0xa9/0xc0
[ 246.383228] [<ffffffff8164b828>] genl_rcv+0x28/0x40
[ 246.383230] [<ffffffff8164a955>] netlink_unicast+0xd5/0x1b0
[ 246.383232] [<ffffffff8164ad2f>] netlink_sendmsg+0x2ff/0x740
[ 246.383234] [<ffffffff8160581b>] sock_sendmsg+0x8b/0xc0
[ 246.383237] [<ffffffff8160550e>] ? move_addr_to_kernel.part.16+0x1e/0x60
[ 246.383239] [<ffffffff816060d1>] ? move_addr_to_kernel+0x21/0x30
[ 246.383241] [<ffffffff816060a3>] ___sys_sendmsg+0x3c3/0x3d0
[ 246.383243] [<ffffffff817259a4>] ? __do_page_fault+0x204/0x560
[ 246.383246] [<ffffffff811112ec>] ? acct_account_cputime+0x1c/0x20
[ 246.383248]...

Read more...

Adam Lee (adam8157) wrote :

@Peter, this fix is not in -proposed yet.

Michel-Ekimia (michel.ekimia) wrote :

kernel 3.13.0-28.51 is in Ubunt PPA and contains the fix "Disable MSI" from the 25/04 from adam lee , So it should work correctly... I guess.

Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
Loki (niceloki) wrote :

Please specify which package you need to upgrade - proposed in anything connected with the kernel not found

Adam Lee (adam8157) wrote :

@Loki, it is the 3.13.0-29.52 kernel, maybe the mirror was not ready yet, please try again

Loki (niceloki) wrote :

Indeed it was in the mirror.

Updated kernel. Now wifi works perfectly - the connection and the sites themselves, ssh, and the rest.

You can confirm this verification.

Thanks.

$ uname -a
Linux tp-lenovo-b5400-ubuntu 3.13.0-29-generic #52-Ubuntu SMP Wed May 28 12:42:47 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

$ dmesg | grep rtl
[ 16.459882] rtl8723be: Using firmware rtlwifi/rtl8723befw.bin
[ 16.486218] Modules linked in: uvcvideo snd_rawmidi i915(+) rt2x00lib rtl8723be lrw gf128mul btcoexist drm_kms_helper videobuf2_vmalloc videobuf2_memops joydev serio_raw glue_helper btusb ablk_helper cryptd crc_ccitt videobuf2_core rtl8723_common rtl_pci i2c_algo_bit snd_seq rtlwifi nvidia(POF) snd_seq_device mac80211 usbhid cfg80211 bluetooth snd_timer hid videodev wmi mei_me lpc_ich parport_pc snd drm mei ppdev soundcore lp parport video mac_hid psmouse ahci r8169 libahci mii
[ 16.814133] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[ 16.814303] rtlwifi: wireless switch is on

Adam Lee (adam8157) wrote :

set tag to verification-done-trusty as #10, thanks to @Loki

tags: added: verification-done-trusty
removed: verification-needed-trusty
rikonen (rikonen) wrote :

I confirm that the problem dissappeared with #52 kernel, the WiFi works now fine on Lenovo G50-70.

$ uname -a
Linux Lenovo 3.13.0-29-generic #52-Ubuntu SMP Wed May 28 12:42:47 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
$ dmesg | grep rtl
[ 10.182680] rtl8723be: Using firmware rtlwifi/rtl8723befw.bin
[ 11.050940] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[ 11.051205] rtlwifi: wireless switch is on

Many thanks for all supported persons!

Loki (niceloki) wrote :

There is some problem with the wifi.
After an hour or two of the connection falls off.

The logs found nothing interesting.
How to catch the problem?

Notebook is Lenovo B5400

$ dmesg
[ 52.943279] audit_printk_skb: 123 callbacks suppressed
[ 52.943282] type=1400 audit(1401691960.498:68): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/cups/backend/cups-pdf" pid=2367 comm="apparmor_parser"
[ 52.943287] type=1400 audit(1401691960.498:69): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/cupsd" pid=2367 comm="apparmor_parser"
[ 52.943605] type=1400 audit(1401691960.498:70): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/cupsd" pid=2367 comm="apparmor_parser"

$ cat /var/log/syslog
Jun 2 11:47:33 tp-lenovo-b5400-ubuntu NetworkManager[847]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted

$ uname -a
Linux tp-lenovo-b5400-ubuntu 3.13.0-29-generic #52-Ubuntu SMP Wed May 28 12:42:47 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Michel-Ekimia (michel.ekimia) wrote :

Hi I tested the 3.13.0-29-generic proposed kernel in Trusty with the indicated firmware :

Worked really great at 90 Mbits Speed reception rate for few hours.

After few hours the connection didn't work anymore and I had to rmmod/modprobe the module.

I'm tesing on a Clevo W310CZ.

Do we know when the linux firmware package will include the needed firmware ?

Loki (niceloki) wrote :

Tried the firmware of this commit.
Also breaks the connection - like even faster :(

Adam Lee (adam8157) wrote :

@Loki, your problem looks like a PM issue, also please check the latest mainline kernel, if it has this issue too please report to upstream.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.13.0-29.53

---------------
linux (3.13.0-29.53) trusty; urgency=low

  [ Upstream Kernel Changes ]

  * futex-prevent-requeue-pi-on-same-futex.patch futex: Forbid uaddr ==
    uaddr2 in futex_requeue(..., requeue_pi=1)
    - LP: #1326367
    - CVE-2014-3153
  * futex: Validate atomic acquisition in futex_lock_pi_atomic()
    - LP: #1326367
    - CVE-2014-3153
  * futex: Always cleanup owner tid in unlock_pi
    - LP: #1326367
    - CVE-2014-3153
  * futex: Make lookup_pi_state more robust
    - LP: #1326367
    - CVE-2014-3153
 -- Brad Figg <email address hidden> Wed, 04 Jun 2014 08:25:41 -0700

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released
Daniel Qian (chanjarster) wrote :

I upgrade kernel to 3.13.0-29 but still doesn't work, did i miss something?

I have a thinkpad E440

12:55 $ uname -a
Linux qianjia-dell 3.13.0-29-generic #53-Ubuntu SMP Wed Jun 4 21:00:20 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

12:58 $ dmesg |grep rtl
[ 3.104525] rtl8723be: Using firmware rtlwifi/rtl8723befw.bin
[ 3.131159] rtl8723be 0000:05:00.0: Direct firmware load failed with error -2
[ 3.131163] rtl8723be 0000:05:00.0: Falling back to user helper
[ 3.135313] rtlwifi: Firmware rtlwifi/rtl8723befw.bin not available

Michel-Ekimia (michel.ekimia) wrote :

@Dabiel , you have to put the firmware manually for now it seems. Adam should add the link to the bug description. You can get it here

https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/plain/rtlwifi/rtl8723befw.bin?id=9341fb9cf5a364ca29b254a26951bbe69d837222

Loki (niceloki) wrote :

@Adam , i upgrade kernel to 2.13.0-29 #53 and get the firmware from previous comment.
Connection still breaking up :(

I need to create a new bug?

Daniel Qian (chanjarster) wrote :

@Ekimia That helped, thanks

Jean-Philippe (jp-pellerin) wrote :

I'm having the same problem with my Lenovo Flex 2 with the same rtl8723be wireless card.

Kernel :
3.13.0-29-generic #52-Ubuntu SMP Wed May 28 12:42:47 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

gets the card to work. Internet works for extended periods of time, but will require the occasional reboot to get it back working. I tried upgrading to the v.3.15-rc8 I would break. I would get notification that it connected to the WiFi (DNS and all) but would never get any internet connection.

Reverted back to kernel above and back in a working state - till my next reboot. Not sure if this information helps at all.

Loki (niceloki) wrote :

@Jean-Philippe you can reload only the module:
sudo rmmod rtl8723be && sudo modprobe rtl8723be
This will help without reboot

@Adam so the new kernel does not solve the problem :(

Michel-Ekimia (michel.ekimia) wrote :

Just for my understanding : Do people from realtek are working on this ?

I know Realtek deliver high quality drivers for years but each time it takes several YEARS to make it work normally on the current LTS Ubuntu release.

Isn't it in their interest that their products work great on Ubuntu OOTB ?

We choose realtek for our Ubuntu preinstalled machines because we knew they would support GNU/LInux, but that ain't really true at last.

Adam Lee (adam8157) wrote :

@Loki and @Jean, check https://bugs.launchpad.net/bugs/1296591 's description

Launchpad Janitor (janitor) wrote :
Download full text (8.4 KiB)

This bug was fixed in the package linux - 3.15.0-6.11

---------------
linux (3.15.0-6.11) utopic; urgency=low

  [ Adam Conrad ]

  * Enable building the sata-modules udeb on ppc64el.
    - LP: #1323980
  * [Packaging] Set bootloader and loader on ppc64el to grub

  [ Adam Lee ]

  * SAUCE: (no-up) rtlwifi: rtl8723be: disable MSI interrupts mode
    - LP: #1310512, #1320070

  [ Alex Hung ]

  * SAUCE: (no-up) dell-led: add mic mute led interface
    - LP: #1308297

  [ Andy Whitcroft ]

  * [Config] d-i -- add hyperv_keyboard to serial-modules udeb
    - LP: #1285434
  * [Config] tools -- enable cpupower on ppc64el
  * [Config] ppc64el -- enable perf tools
  * [Config] powerpc -- enable perf tools
  * [Config] ppc64el -- reduce MAX_ORDER with 64k pages
  * [Config] arm64 -- enable tools
    - LP: #1326050
  * [Config] switch hyper-keyboard to virtual
    - LP: #1325306
  * [Config] fix up Breaks/Replaces on linux-cloud-tools-common to fix
    upgrades
  * SAUCE: kvm: BIOS disabled kvm support should be a warning
    - LP: #1300247
  * SAUCE: nouveau: missing outputs should be warnings
    - LP: #1300244
  * [Config] d-i -- add nvme devices to block-modules udeb
    - LP: #1303710

  [ Anton Blanchard ]

  * SAUCE: (no-up) powerpc: 64bit sendfile is capped at 2GB
    - LP: #1328230

  [ Colin Ian King ]

  * SAUCE: intel_pstate: inform user that thermald is worth considering

  [ Dave Chiluk ]

  * [Config] Enable CONFIG_IP_VS_IPV6=y
    - LP: #1300739

  [ Paolo Pisati ]

  * [Config] build vexpress a9 dtb
    - LP: #1303657

  [ Tetsuo Handa ]

  * SAUCE: kthread: Do not leave kthread_create() immediately upon SIGKILL.

  [ Tim Gardner ]

  * Release Tracking Bug
    - LP: #1329045
  * [Debian] Treat vdso install as an environment variable
    - LP: #1325713
  * [Config] Treat vdso install as an environment variable
    - LP: #1325713
  * [config] Set IPMI suppoort default to "y"
  * [Config] powerpc -- CONFIG_SCSI_IBMVSCSI=y
  * [Config] CONFIG_RT_GROUP_SCHED=n
    - LP: #1284731
  * [Config] ppc64el -- switch to 64K system pages
  * [Config] CONFIG_MICROCODE_EARLY=y
  * [Config] SND_DAVINCI_SOC && SND_AM33XX_SOC_EVM =m
  * [Config] armhf: DRM_TILCDC=m
  * SAUCE: (no-up) mei_me: Add module parameter to disable MSI
  * [Config] arm64: KVM=y
  * [Config] armhf: LEDS_TRIGGER_HEARTBEAT=y
  * [Config] armhf: generic: disable CPU_IDLE
  * [Config] armhf: CPU_FREQ=y
  * [Config] Add new mlx modules to d-i
  * [Config] Added Muti-Arch support for linux-headers-PKGVER-ABINUM, linux-tools-common, and linux-cloud-tools-common
    - LP: #1295112
  * [Config] CONFIG_EXYNOS_ADC=n, CONFIG_HW_RANDOM_EXYNOS=n, CONFIG_MMC_DW_EXYNOS=n, CONFIG_USB_DWC3_EXYNOS=n
    - LP: #1294353
  * [Config] CONFIG_ABX500_CORE=y for ppc64el
  * [Config] CONFIG_ALX=m for powerpc
  * [Config] CONFIG_ACENIC_OMIT_TIGON_I=n for ppc64el
  * [Config] CONFIG_ACORN_PARTITION_*=n for ppc64el
  * [Config] CONFIG_ANDROID=n for powerpc
  * [Config] CONFIG_ASYNC_RAID6_TEST=m for ppc64el
  * [Config] CONFIG_BIG_KEYS=y for ppc64el
  * [Config] CONFIG_BSD_PROCESS_ACCT=y for ppc64el
  * rebase to v3.15
  * [Config] CONFIG_PHY_XGENE=y
  * [Config] CONFIG_MLX4_DEBUG=y
    - LP: #1328256
  * [C...

Read more...

Changed in linux (Ubuntu Utopic):
status: In Progress → Fix Released
madpentiste (antoine-messiah) wrote :

I have tried the following on several kernels (under 12.04 and 14.04) and so far it has worked well :

sudo apt-get install linux-headers-generic build-essential git
    # needed only if you don't have yet that package
git clone http://github.com/lwfinger/rtl8723be
                           # needed only if you don't have yet downloaded rtl8723be

cd rtl8723be
git checkout 604aa9058fb9e5bb1cf571c99989d081f8fc8b9
make clean
make

sudo make install

sudo modprobe rtl8723be

echo "options rtl8723be fwlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf

References :

http://ubuntuforums.org/showthread.php?t=2205497 (post 9 dated 17 feb 2014)
http://doc.ubuntu-fr.org/clevo_w310cz#realtek_rtl8723be

Karl Reid (karlr42) wrote :

I would recommend against following the instructions in #29. For me it causes a kernel panic I had to fix by blacklisting the rtl8723be driver in recovery mode, and the makefile also seemed to delete the existing driver already in the kernel, so I ended up reinstalling the OS to fix it.

As for how I got my wifi working:

Installed 14.04 from the live disk.
Did a full update and upgrade of packages while connected via ethernet.
This should give you the 3.13.0-29-generic #53-Ubuntu kernel.
When you reboot into this kernel, you will see the error in #19 in your dmesg about missing firmware.
As mentioned in #20, you will need to download the rtl8723befw.bin firmware and then copy it to /lib/firmware/rtlwifi/
Reboot and wifi will work.

So two questions-

Will this firmware be included in a future kernel update for Trusty?

Will there be an updated iso for Trusty at some point with a newer kernel, so that this wifi card will work out of the box?

Adam Lee (adam8157) wrote :

Tips for RTL8188EE [10ec:8179] and RTL8723BE [10ec:b723] users: those hardware modules have MSI compatibility issue, on some certain platforms they work fine with MSI but break connections without MSI, on some other certain platforms it's opposite. You could try to toggle its module parameter "msi"

fsanchez (fransan-met) wrote :

Hi Adam, all,

Sorry to botter but, which is the status of this bug? Has it been solved? This is because I have to install Kubuntu 14.04 in a Lenovo G50-70, but the liveUSB version doesn't even let me turn on wireless.

Regards,

Francisco

Michel-Ekimia (michel.ekimia) wrote :

@fsanchez : yes normal, because the 14.04.0 iso does not have the fix, you have to install all the updates to get it

TommyFro (thomas-fromherz) wrote :

Hi Adam,

thanks for putting so much efforts into solving this annoying bug. With respect to your comment #31, how can on toogle the msi parameter?

fsanchez (fransan-met) wrote :

Thank you Ekimia for your answer. Regards

larry (ludovic-bernard) wrote :

Hi, first used the procedure described on post #29 (before I found this bug thread)
Then I ugraded to 3.15.0-031500-generic, and I saw in the update that the firmware for rtl8723be was in.

Today, I have the firmware file in lib/firmware/rtlwifi but nothing pops up in dmesg when i look for grep rtl8723befw.bin, so i'm guessing my system isn't loading it.

My wifi works but drops all the time ....

I'm lost :)

Sergio Castillo (s-cast-lara) wrote :

I have a Lenovo B5400. When I installed Ubuntu 14.04 wifi didn't work.

I followed the instructions provided by #30 and wifi now works, but I have the same problem as #13 and #24 : the connection, after 1h or so, falls off.

I installed the kernel v.3.15 and I had the same problem as #24 when he did it (wifi appeared to work, but it didn't). I reverted back to 3.13.0-29-generic and when the wifi doesn't work I have to run the following command:

sudo rmmod rtl8723be && sudo modprobe rtl8723be

Will this be solved? Is someone working on it?

Thanks in advance!

Jarek Zgoda (jarek-zgoda) wrote :

> sudo rmmod rtl8723be && sudo modprobe rtl8723be

This doesn't work for me - connection once dropped can not be established anymore, I need to reboot.

$ uname -a
Linux JAZG-LENOVO 3.13.0-32-generic #57-Ubuntu SMP Tue Jul 15 03:51:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

$ dmesg | grep rtl
[ 6.619502] rtl8723be: Using firmware rtlwifi/rtl8723befw.bin
[ 6.632732] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[ 6.632936] rtlwifi: wireless switch is on

This is Lenovo B5400

Michel-Ekimia (michel.ekimia) wrote :

the behaviour seems different from a machine to another.

However, disabling the sleep feature of the driver seems to correct the problem on a Gigabyte Brix here :

So you could try :

echo "options rtl8723be fwlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf

And report the results.

Obviously using the very latest main kernel which is 3.13.0-32 today.

Sayantan Das (sayantan13) wrote :

Running Lenovo Flex 2 with the same Wifi card. Same problem even after setting options.

robert (rsokolewicz) wrote :

Running Ubuntu 14.04 on a HP Pavilion E-15. The kernel I use: 3.13.0-32-generic

Solution #39 works on my machine.

Thanks Ekimia!

xkill (info-xkill) wrote :

Workaround #39 also works on my machine Acer Aspire E1-772 :-)

Xubuntu 14:04
Kernel: 3.13.0-33

Thanks!

fsanchez (fransan-met) wrote :

Hello,

Workaround #39 work partially for me: connection is dropped after certain random time, but I can establish it canceling the password window, and opening wifi connection settings.

fsanchez (fransan-met) wrote :

Sorry, forgot to add that I have a Lenovo G50
$ uname -a
Linux Francisco-Lenovo 3.13.0-34-generic #60-Ubuntu SMP Wed Aug 13 15:45:27 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
$ lspci | grep Net
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter

larry (ludovic-bernard) wrote :

It seems that workaround #39 does nothing for me.
But I(ve been following the instruction on this thread

http://ubuntuforums.org/showthread.php?t=2239932

And my connection has improved, it's still not ok, I have deconnections all the time, but I'm not stuck with an unusable wifi. before I was unable to reconnect and had to reboot. That's not the case anymore.

So my understanding is now that, there is a driver problem, but that's not all, it seems that the card doesn't want to stay on an SSID .....it's an anarchist !!!!!

hope that helps

cj (cjen1987) wrote :
Sayantan Das (sayantan13) wrote :

#46 doesnt solve my problem.

How do I set msi to 1?

 modinfo rtl8723be
filename: /lib/modules/3.16.3-031603-generic/kernel/drivers/net/wireless/rtlwifi/rtl8723be/rtl8723be.ko
firmware: rtlwifi/rtl8723befw.bin
description: Realtek 8723BE 802.11n PCI wireless
license: GPL
author: Realtek WlanFAE <email address hidden>
author: PageHe <email address hidden>
srcversion: 8630CF9344D90D47240D1FF
alias: pci:v000010ECd0000B723sv*sd*bc*sc*i*
depends: rtlwifi,rtl_pci,btcoexist,mac80211
vermagic: 3.16.3-031603-generic SMP mod_unload modversions
parm: swlps:bool
parm: swenc:using hardware crypto (default 0 [hardware])
 (bool)
parm: ips:using no link power save (default 1 is open)
 (bool)
parm: fwlps:using linked fw control power save (default 1 is open)
 (bool)
parm: msi:Set to 1 to use MSI interrupts mode (default 0)

parm: debug:Set debug level (0-5) (default 0) (int)
parm: disable_watchdog:Set to 1 to disable the watchdog (default 0)
 (bool)

Paweł Kowalik (pkowalik) wrote :

From https://bugzilla.kernel.org/show_bug.cgi?id=83641#c1

"There is a new version of this driver at GitHub. You will need to have the package with the kernel headers installed.

git clone http://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi_new
make
sudo make install

This version of the driver will be submitted for inclusion in kernel 3.18. I ran it for 39 hours with no disconnects."

#46 works fine for me. 2 hours and no disconnection.

Antonio Tobón (antonio-tobon) wrote :

I found this solution, and worked perfectly on a Lenovo g40-30 so i guess it should work in other lenovo pc...

quote:

for one time test:

    sudo rmmod ideapad_laptop

for working after reboot:

    echo "blacklist ideapad_laptop" | sudo tee -a /etc/modprobe.d/blacklist-ideapad.conf

found it in: http://askubuntu.com/questions/507470/wifi-not-working-on-ubuntu-14-04-lenovo-g-50-30/535976#535976

prior to that I re-installed the module, updated the kernel to 3.16, and none of that worked.
this piece of code did make the realtek run

Stanko Metodiev (metodiew) wrote :

My WiFi drop issues started again after kernel update:
Linux metodiew 3.17.0-031700rc4-generic #201409071935 SMP Sun Sep 7 23:36:45 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

I tried solution from #48, but I got this error:
metodiew@metodiew:~/Software$ cd rtlwifi_new/
metodiew@metodiew:~/Software/rtlwifi_new$ make
make -C /lib/modules/3.17.0-031700rc4-generic/build M=/home/metodiew/Software/rtlwifi_new modules
make: *** /lib/modules/3.17.0-031700rc4-generic/build: No such file or directory. Stop.
make: *** [all] Error 2

Is there something I'm doing not right or there is some issues with kernel 3.17?

Vikram (animated-vikram) wrote :

I upgraded to the latest stable kernel 3.17.3, yet the problem persisted, however the solution in post #48 fixed this issue for me.

Timocheck (timocheck) wrote :

System became instable with kernel 3.15.10, using the rtlwifi_new driver on lenovo G50-45

kelu (x8ro) wrote :

Lenovo ThinkPad E540 - ubuntu 14.04 - after random time connection is dropped !!!

$ uname -a
Linux lenovo 3.13.0-43-generic #72-Ubuntu SMP Mon Dec 8 19:35:06 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

$ dmesg | grep rtl
[ 1.833497] rtl8723be: Using firmware rtlwifi/rtl8723befw.bin
[ 1.841524] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[ 1.841730] rtlwifi: wireless switch is on
[ 445.799362] rtl8723be: Using firmware rtlwifi/rtl8723befw.bin
[ 445.799807] ieee80211 phy1: Selected rate control algorithm 'rtl_rc'
[ 445.800095] rtlwifi: wireless switch is on

Davi Dagostin (zankuro) wrote :

For me, the text "options rtl8723be fwlps=N ips=N" in "/etc/modprobe.d/rtl8723be.conf" fixes the problem.

My Kernel is "3.16.0-30-generic".
My Board is "03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter".

Ales (w-ales) wrote :

HP ProBook 450 G2,
RTL8723BE PCIe Wireless Network Adapter, Realtek Semiconductor, Using firmware rtlwifi/rtl8723befw.bin,
Kubuntu 14.10,
kernel 3.16.0-30-generic #40-Ubuntu SMP Mon Jan 12 22:06:37 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux.

It drops connection from time to time - not very often. I can fix it with:

   sudo rmmod rtl8723be
   sudo modprobe rtl8723be

y s (yusuhail) wrote :

I see the same bug on my Lenovo G50-45. Unloading and reloading the module as in #56 gets me back online. However, its not a permanent solution as it will again drop intermittently.

Kernel info:
 3.16.0-34-generic #45~14.04.1-Ubuntu SMP

According to http://askubuntu.com/questions/526214/how-to-set-parameters-for-realtek-wifi-rtl8723 the culprit could be powersave.

Looking at the module parameters, it seems msi is 0 by default.

modinfo rtl8723be
filename: /lib/modules/3.16.0-34-generic/kernel/drivers/net/wireless/rtlwifi/rtl8723be/rtl8723be.ko
firmware: rtlwifi/rtl8723befw.bin
description: Realtek 8723BE 802.11n PCI wireless
license: GPL
author: Realtek WlanFAE <email address hidden>
author: PageHe <email address hidden>
srcversion: C94095C986767A931B924EF
alias: pci:v000010ECd0000B723sv*sd*bc*sc*i*
depends: rtlwifi,rtl8723-common,rtl_pci,btcoexist,mac80211
intree: Y
vermagic: 3.16.0-34-generic SMP mod_unload modversions
signer: Magrathea: Glacier signing key
sig_key: 4A:55:71:9E:5C:6C:61:54:BE:06:25:D0:48:83:AE:41:1B:76:41:AD
sig_hashalgo: sha512
parm: swlps:bool
parm: swenc:using hardware crypto (default 0 [hardware])
 (bool)
parm: ips:using no link power save (default 1 is open)
 (bool)
parm: fwlps:using linked fw control power save (default 1 is open)
 (bool)
parm: msi:Set to 1 to use MSI interrupts mode (default 0)
 (bool)
parm: debug:Set debug level (0-5) (default 0) (int)

How can I help (by testing) to get this fixed? Is there a way for me to look at logs or some module/device state to see if msi or power save triggered the problem?

Sebastian (s-plaza) wrote :

The same behaviour on my Lenovo M30-70 with rtl8723be wifi.
I am using the current beta of Ubuntu 15.04 with 3.19.0-14-generic and wifi is still losing connection.

The workaround from #56 is ok but sometimes it is frustrating.
I also tried #48 and "options rtl8723be fwlps=0" entry in /etc/modprobe.d/rtl8723be.conf but no change.

leafcutter (shaziajuna) wrote :

I agree with the comments in #58. I also have a Lenovo M30-70 I installed Ubuntu 14.10. I tried lots of ideas suggested in the forums on google . The kernel updates made things worse, so I would not recommend it. I had to reinstall Ubuntu from scratch, that was not a problem for me as I have been setting my new laptop.
I found that the workaround in #55 pretty effective however, the wifi connection dropped and in some cases i would not be able to reconnect until the laptop was rebooted. The connection would drop randomly sometimes after 2 hours and sometimes 10 minutes, only rebooting the system allowed it to reconnect. Then I stumbled upon a post in the Opensuse forums which mentioned that deactivating the bluetooth as a a default setting may improve the stability of the connection. It has worked for me. My recommendation would be to change the settings as suggested in #55 and if you are not bothered about bluetooth turn it off. I monitored the connection in the terminal (i used wavemon) for various solutions this gave me the best result. Without turning off bluetooth gave me a max of 2 hours of wifi connection. Whilst the connection has been stable and not dropped for 19 hours if I applied #55 and deactivating the bluetooth. I hope this might be of help.

I tried #55 followed by #56 to apply it on a live session of xubuntu 15.10 daily live for April 4th 2015 (linux 3.19)
the system locked up, used reisub to reboot
before running that i did run
sudo rmmod ideapad_laptop

leveno g50-30

Marius Nuennerich (mwrius) wrote :

Can this bug please be re-opened?
The bug still exists on 15.04 on a Lenovo M30-70.

@Marius
i had this issue on a G50-30, i made a script yesterday to get it working
http://pastebin.com/LiC7PA1M

Paul (pdavies91) wrote :

Thanks https://launchpad.net/~pqwoerituytrueiwoq, this worked for me ...

Cheers,

Paul

Sebastian (s-plaza) wrote :

I also tried #62, but it still drops connection on my Lenovo M30-70.
Anyway, this bug still exists on Ubuntu 15.04.
Non of the solutions worked so far :-(

Adam Lee (adam8157) wrote :

This bug only fixed one issue, also it needs a kernel parameter. Please check the "Bug Description" and report new bugs if you want.

It makes nonsense to reopen this one, because it's a MSI compatibility issue, and all we could do it providing a switching parameter.

description: updated
Sebastian (s-plaza) wrote :

Ok..
I finally want to report that the solution #65 works for me (Lenovo M30-70) very fine and stable :-)

sadegh (ms-houshmand) wrote :

my machin is thinkpad-E550 and #48 worked for me.
uname -a
Linux ThinkPad 3.19.0-25-generic #26~14.04.1-Ubuntu SMP Fri Jul 24 21:16:20 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

BUT MODULE VERIFICATION FAILED! signature is not validu!??? please explain what should i do?

$ dmesg | grep rtl
[ 10.250033] rtlwifi: module verification failed: signature and/or required key missing - tainting kernel
[ 10.510565] Using firmware rtlwifi/rtl8723befw.bin
[ 10.513766] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[ 10.514272] rtlwifi: wireless switch is on

lspci -v

u04:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
 Subsystem: Lenovo Device b736
 Flags: bus master, fast devsel, latency 0, IRQ 18
 I/O ports at 4000 [size=256]
 Memory at f1200000 (64-bit, non-prefetchable) [size=16K]
 Capabilities: [40] Power Management version 3
 Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
 Capabilities: [70] Express Endpoint, MSI 00
 Capabilities: [100] Advanced Error Reporting
 Capabilities: [140] Device Serial Number 00-23-b7-fe-ff-4c-e0-00
 Capabilities: [150] Latency Tolerance Reporting
 Capabilities: [158] L1 PM Substates
 Kernel driver in use: rtl8723be

xkill (info-xkill) wrote :

Workaround #39 solved this issue in Ubuntu (Vivid Vervet) for me a couple of month ago.

Last week I upgraded to Ubuntu 15.10 (Wily Werewolf) and this issue returns.
Neither workaround #39 nor workaround #55 "fix" this issue for me.

Any hints?

Ramesh Navi (rameshnavi) wrote :

This bug irritating my Lenovo g50-70.
Somebody give me some working solution please.!!!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.