8086:0412 [Gigabyte Z87X-UD3H] bug in the Ubuntu backport of BDW stuff for 14.04, where it tries to treat your hardware as Broadwell, and gets confused when your hardware behaves like Haswell.

Bug #1317865 reported by akaWolf on 2014-05-09
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Timo Aaltonen
Trusty
Low
Timo Aaltonen

Bug Description

bug in the Ubuntu backport of BDW stuff for 14.04, where it tries to treat your hardware as Broadwell, and gets confused when your hardware behaves like Haswell.

WORKAROUND: Blacklist i915_bdw

---
AlsaVersion: Advanced Linux Sound Architecture Driver Version k3.13.0-24-generic.
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: akawolf 4092 F.... pulseaudio
Card1.Amixer.info:
 Card hw:1 'PCH'/'HDA Intel PCH at 0xf0530000 irq 44'
   Mixer name : 'Realtek ALC898'
   Components : 'HDA:10ec0899,1458a002,00100003'
   Controls : 63
   Simple ctrls : 25
CurrentDesktop: KDE
DistroRelease: Ubuntu 14.04
InstallationDate: Installed on 2013-06-30 (313 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
IwConfig:
 eth0 no wireless extensions.

 lo no wireless extensions.
MachineType: Gigabyte Technology Co., Ltd. Z87X-UD3H
Package: linux 3.8.0.35.53 [origin: unknown]
PackageArchitecture: amd64
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic root=UUID=19480476-0eee-4186-ad56-112e81e19c81 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.13.0-24.47-generic 3.13.9
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-24-generic N/A
 linux-backports-modules-3.13.0-24-generic N/A
 linux-firmware 1.127
RfKill:

Tags: trusty third-party-packages
Uname: Linux 3.13.0-24-generic x86_64
UnreportableReason: This is not an official Ubuntu package. Please remove any third party package and try again.
UpgradeStatus: Upgraded to trusty on 2014-02-28 (69 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 05/16/2013
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: F5
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: Z87X-UD3H-CF
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrF5:bd05/16/2013:svnGigabyteTechnologyCo.,Ltd.:pnZ87X-UD3H:pvrTobefilledbyO.E.M.:rvnGigabyteTechnologyCo.,Ltd.:rnZ87X-UD3H-CF:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: Z87X-UD3H
dmi.product.version: To be filled by O.E.M.
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1317865

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: trusty

apport information

tags: added: apport-collected third-party-packages
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

akaWolf (dangerous-wolf) wrote :
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.15 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.15-rc4-utopic/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: kernel-da-key
description: updated
tags: added: bios-outdated-f9

akaWolf, as per http://www.gigabyte.us/products/product-page.aspx?pid=4481&dl=1#bios an update to your BIOS is available (F9). If you update to this following https://help.ubuntu.com/community/BiosUpdate does it change anything? If it doesn't, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

Please note your current BIOS is already in the Bug Description, so posting this on the old BIOS would not be helpful.

For more on BIOS updates and linux, please see https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette .

Thank you for your understanding.

Changed in linux (Ubuntu):
importance: Medium → Low
tags: added: needs-bisect regression-release
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
summary: - bug in the Ubuntu backport of BDW stuff for 14.04, where it tries to
- treat your hardware as Broadwell, and gets confused when your hardware
- behaves like Haswell.
+ 8086:0412 [Gigabyte Z87X-UD3H] bug in the Ubuntu backport of BDW stuff
+ for 14.04, where it tries to treat your hardware as Broadwell, and gets
+ confused when your hardware behaves like Haswell.
Timo Aaltonen (tjaalton) wrote :

this has nothing to do with the bios

the i915_bdw lists a duplicate symbol, and your system decided to load the module instead of i915 likely due to that

tags: removed: needs-bisect
tags: removed: bios-outdated-f9
Changed in linux (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
status: Incomplete → Triaged
tags: added: bios-outdated-f9
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
Timo Aaltonen (tjaalton) wrote :

non-issue on utopic, opened a task for trusty and verified the fix myself

tags: added: verification-done-trusty
removed: verification-needed-trusty
Changed in linux (Ubuntu Trusty):
assignee: nobody → Timo Aaltonen (tjaalton)
importance: Undecided → Low
status: New → Triaged
Changed in linux (Ubuntu):
status: Triaged → Invalid
Bill Danielson (bigbrd) wrote :

The workaround didn't work for me. My HDMI audio interfaces still weren't found
by the kernel.

While if eliminates the kernel message about duplicate symbols, the kernel
now can't find the routines needed for the power_well
stuff because It thinks those are in the bdw driver and so it doesn't initialize the HDMI audio devices.

The issue seems to be that with two drivers with the same symbols (i915 and i915_bdw) ,
moddep creates symbols files with some aliases pointing to i915_bdw and some pointing
to i915.

I had to rename i915_bwd_ko file to i915_bwd_konomore and then
run depmod -a to get a reasonable symbols file that only has aliases to load i915.ko.

After that, my HDMI audio interfaces were working again.

It there a way to tell depmod to ignore certain kernel modules?

Launchpad Janitor (janitor) wrote :
Download full text (19.3 KiB)

This bug was fixed in the package linux - 3.13.0-30.54

---------------
linux (3.13.0-30.54) trusty; urgency=low

  [ Adam Conrad ]

  * [Config] Enable building the sata-modules udeb on ppc64el.
    - LP: #1323980

  [ Anton Blanchard ]

  * SAUCE: (no-up) powerpc: 64bit sendfile is capped at 2GB
    - LP: #1328230

  [ Ben Widawsky ]

  * SAUCE: i915_bdw: drm/i915: Fix PSR programming
    - LP: #1321729
  * SAUCE: i915_bdw: drm/i915: Correct PPGTT total size
    - LP: #1321729

  [ Chris Wilson ]

  * SAUCE: i915_bdw: drm/i915: Broadwell expands ACTHD to 64bit
    - LP: #1321729

  [ Damien Lespiau ]

  * SAUCE: i915_bdw: drm/i915/bdw: Implement
    Wa4x4STCOptimizationDisable:bdw
    - LP: #1321729

  [ Dave Chiluk ]

  * [Config] Enable CONFIG_IP_VS_IPV6=y
    - LP: #1300739

  [ Kamal Mostafa ]

  * [Config] add debian/gbp.conf
  * Release Tracking Bug
    - LP: #1328286

  [ Mika Kuoppala ]

  * SAUCE: i915_bdw: drm/i915: add render state initialization
    - LP: #1321729

  [ Paulo Zanoni ]

  * SAUCE: i915_bdw: drm/i915: fix assert_cursor on BDW
    - LP: #1321729

  [ Steven Rostedt ]

  * SAUCE: i915_bdw: drm/i915: Do not dereference pointers from ring buffer
    in evict event
    - LP: #1321729

  [ Tim Gardner ]

  * [Config] CONFIG_POWERNV_CPUFREQ=y for ppc64el
    - LP: #1324571
  * [Debian] Treat vdso install as an environment variable
  * [Config] Treat vdso install as an environment variable
  * [Config] CONFIG_MLX4_DEBUG=y
    - LP: #1328256
  * [Config] CONFIG_I40EVF=m, CONFIG_I40E_DCB=y, CONFIG_I40E_VXLAN=y
    - LP: #1328037

  [ Timo Aaltonen ]

  * SAUCE: i915_bdw: Rebase to drm-intel-next-2014-03-07 + fixes
    - LP: #1321729
  * SAUCE: i915_bdw: Add BDW specific power well calls
    - LP: #1317865

  [ Upstream Kernel Changes ]

  * drm: expose subpixel order name routine v3
  * drm: dp helper: Add DP test sink CRC definition.
  * drm: export cmdline and preferred mode functions from fb helper
  * hugetlb: ensure hugepage access is denied if hugepages are not
    supported
    - LP: #1328251
  * powerpc/powernv: Move SG list structure to header file
    - LP: #1326015
  * powerpc/powernv: Read OPAL error log and export it through sysfs
    - LP: #1326015
  * powerpc/powernv Platform dump interface
    - LP: #1326015
  * pci_regs.h: Add PCI bus link speed and width defines
    - LP: #1328037
  * net_tstamp: Add SIOCGHWTSTAMP ioctl to match SIOCSHWTSTAMP
    - LP: #1328037
  * PCI/MSI: Add pci_enable_msi_range() and pci_enable_msix_range()
    - LP: #1328037
  * net: Change skb_get_rxhash to skb_get_hash
    - LP: #1328037
  * net: Add utility functions to clear rxhash
    - LP: #1328037
  * net: Add function to set the rxhash
    - LP: #1328037
  * i40e: set pf_id based on device and function numbers
    - LP: #1328037
  * i40e: register file updates
    - LP: #1328037
  * i40e: clear AQ head and tail registers
    - LP: #1328037
  * i40e: simplify aq head-tail-len setups
    - LP: #1328037
  * i40e: firmware version fields offsets update
    - LP: #1328037
  * i40e: allow one more vector for VFs
    - LP: #1328037
  * i40e: select reset counters correctly
    - LP: #1328037
  * i40e: retry call on timeout
    - LP: #...

Changed in linux (Ubuntu Trusty):
status: Triaged → Fix Released
Timo Aaltonen (tjaalton) wrote :

Bill, please double-check the kernel version you tested on.. The one with the bugfix should be now in trusty-updates

Changed in linux (Ubuntu Trusty):
status: Fix Released → Incomplete
Bill Danielson (bigbrd) wrote :

Removed workaround and updated to kernel 3.13.0-30.54-generic 3.13.11.2 and bug is fixed.

Timo Aaltonen (tjaalton) wrote :

thanks for confirming it

Changed in linux (Ubuntu Trusty):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers