8086:0a16 [Dell Inspiron 17R 5737] Video looks interlaced

Bug #1300349 reported by Peter-jezdec on 2014-03-31
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

The video looks like interlaced video where every other line is shifted. This occurs in 12.04.3 - 14.04 beta2. This doesn't occur in 12.04.0.

---
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ubuntu 2164 F.... pulseaudio
 /dev/snd/controlC0: ubuntu 2164 F.... pulseaudio
CasperVersion: 1.339
CurrentDesktop: Unity
DistroRelease: Ubuntu 14.04
LiveMediaBuild: Ubuntu 14.04 LTS "Trusty Tahr" - Beta amd64 (20140326)
MachineType: Dell Inc. Inspiron 5737
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
ProcVersionSignature: Ubuntu 3.13.0-19.40-generic 3.13.6
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-19-generic N/A
 linux-backports-modules-3.13.0-19-generic N/A
 linux-firmware 1.126
StagingDrivers: rts5139
Tags: trusty staging
Uname: Linux 3.13.0-19-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 11/12/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A07
dmi.board.name: 04X8RP
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A07
dmi.modalias: dmi:bvnDellInc.:bvrA07:bd11/12/2013:svnDellInc.:pnInspiron5737:pvrA07:rvnDellInc.:rn04X8RP:rvrA00:cvnDellInc.:ct8:cvrA07:
dmi.product.name: Inspiron 5737
dmi.product.version: A07
dmi.sys.vendor: Dell Inc.

Peter-jezdec (peter-jezdec) wrote :

I presume the problem here is that there is no support for this chip set, even in 14.04.

There is some more information in https://answers.launchpad.net/ubuntu/+question/246229

Peter-jezdec (peter-jezdec) wrote :

In the original description 12.04.2 is a typo, it should read 12.04.0. And, the comment is appropriate to 12.04.1 as well.

tags: added: 14.04

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1300349/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Peter-jezdec (peter-jezdec) wrote :

Problem shows up while booting the live cd.

affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1300349

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected staging trusty
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Persists in trusty with
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b) (prog-if 00 [VGA controller])
        Subsystem: Lenovo Device 2217
        Flags: bus master, fast devsel, latency 0, IRQ 59
        Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 3000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: <access denied>
        Kernel driver in use: i915

I've red, that this is a uxa problem which won't accour with sxa, can't find where though. I'd prefer to use uxa anyway though

Ray-Ven (ray-ven) wrote :

this leads to graphic glitches and unreadable fonts sometimes

Peter-jezdec (peter-jezdec) wrote :

I tested SNA on 13.10 and video is bad in the same way as with UXA.

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.14 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.14-trusty/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Peter-jezdec (peter-jezdec) wrote :

Since the bug exists in the upstream v3.14 kernel[0], is there some mechanism for sending this bug report upstream? Or, is that something I should do?

GortiZ (mlista6) wrote :

I can confirm all those issue on the 32bit installation of all those versions too.

tags: added: latest-bios-a06
removed: 14.04
tags: added: regression-release
description: updated
summary: - Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
+ 8086:0a16 [Dell Inspiron 17R 5737] Video looks interlaced

Peter-jezdec, the next step is to bisect from 12.04.0 to 12.04.3 in order to identify the offending commit. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection ?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Peter-jezdec (peter-jezdec) wrote :

I've made some progress in testing. I've seen three states that any particular configuration boots into. I wrote pass for the one where the video appears normal, fail for the one where the video appears interlaced (also with strange colors), and blank for a third possibility where the screen is blank. Some of the comments below apply to other kernels than the ones I list them with, but I only listed them with the kernel versions I positively tested them on:

ubuntu-12.04.1-desktop-amd64.iso combined with any appropriate kernel is a pass:
3.2.0-23: pass, linux console has huge font, flashes trash on mode switch
3.2.0-60: pass, linux console has normal font, becomes blank (irreversibly) when switching virtual terminals or logging out (but not when shutting down)
3.2.0-61: pass

ubuntu-12.04.2-desktop-amd64.iso: mixed, see below
3.5.0-23:fail, linux console has normal font
3.5.0-23 comes with the iso; the other kernels I tested, I got by git checkout from git://kernel.ubuntu.com/ubuntu/ubuntu-quantal.git. Here is the version range that seems interesting:
    3.5.0-16.25: pass
    3.5.0-17.26: blank
    3.5.0-17.27
    3.5.0-17.28: blank
    3.5.0-18.29: blank
    3.5.0-19.30
    3.5.0-20.31
    3.5.0-21.32: fail
I presume that the appropriate range for bisection is 3.5.0-16.25 to 3.5.0-17.26. I need to learn about git bisect, but I get the impression that it amounts to automated checkout of versions for a binary search for the offending commit.

Peter-jezdec (peter-jezdec) wrote :

penalvch, I did not get very far with git bisect, would you confirm if the following seems appropriate?

I am following the KernelBisection wiki, and the command

git log --oneline Ubuntu-3.5.0-16.25..Ubuntu-3.5.0-17.26

gives

git bisect start Ubuntu-3.5.0-17.26 Ubuntu-3.5.0-16.25
Bisecting: a merge base must be tested
[d61ed4631511b08d2e14924eab16a9ddaed44df6] Linux 3.5.4

the command

git rev-list Ubuntu-3.5.0-17.26 | grep $(git log --pretty=oneline -1 Ubuntu-3.5.0-16.25 | cut -d' ' -f1)

does not produce sha1 or any other output. So, although my debian and debian.master folders did not disappear, I think should switch to mainline bisection. From http://kernel.ubuntu.com/~kernel-ppa/info/kernel-version-map.html I get 3.5.4 .. 3.5.5 in section Quantal (master-next -0). In git://kernel.ubuntu.com/ubuntu/ubuntu-quantal.git, I don't see any tags 3.5.4 or 3.5.5. So I should git clone something else. In git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git I see similar tags. So, I think I should be bisecting between tags v3.5-rc4 and v3.5-rc5 in git://kernel.ubuntu.com/ubuntu/ubuntu-quantal.git .

Peter-jezdec, it would be appropriate to switch to the mainline kernel and continue on that.

Peter-jezdec (peter-jezdec) wrote :

After much confusion on my part, I believe the bisect is done:

da612d880fbc598ac0efcef579355fb90d4bca4e is the first bad commit
commit da612d880fbc598ac0efcef579355fb90d4bca4e
Author: Paulo Zanoni <email address hidden>
Date: Mon Aug 6 18:45:01 2012 -0300

    drm/i915: add more Haswell PCI IDs

    Also properly indent the HB IDs.

    Reviewed-by: Rodrigo Vivi <email address hidden>
    Signed-off-by: Paulo Zanoni <email address hidden>
    Signed-off-by: Daniel Vetter <email address hidden>

:040000 040000 fb462a83c40d63ddfb6a20c9c7c920b56e3ea693 d70ab73c5d1ad1121746364d2e91bc58840ff0b4 M drivers

# bad: [a0d271cbfed1dd50278c6b06bead3d00ba0a88f9] Linux 3.6
# good: [0d7614f09c1ebdbaa1599a5aba7593f147bf96ee] Linux 3.6-rc1
git bisect start 'v3.6' 'v3.6-rc1'
# bad: [4ae4614712e0a354c9e6c286c0db1612246766ce] Merge branch 'merge' of git://git.kernel.org/pub/scm/linux/kernel/git/benh/powerpc
git bisect bad 4ae4614712e0a354c9e6c286c0db1612246766ce
# bad: [96ff705638e3d61b1e45a047c0f9f3bb622fa32f] apple_gmux: Add support for newer hardware
git bisect bad 96ff705638e3d61b1e45a047c0f9f3bb622fa32f
# good: [88de3d0d714bff03b2e0a3fcd5b8b346a392e9ea] Merge tag 'fixes-for-linus' of git://git.kernel.org/pub/scm/linux/kernel/git/arm/arm-soc
git bisect good 88de3d0d714bff03b2e0a3fcd5b8b346a392e9ea
# bad: [d3b8e0dc828f8ec9cc895bb46e8c51b2763e9d2c] Merge branch 'drm-fixes' of git://people.freedesktop.org/~airlied/linux
git bisect bad d3b8e0dc828f8ec9cc895bb46e8c51b2763e9d2c
# good: [3bf671af14d591ede9251acb0085e8017f3705e7] Merge branch 'fixes-for-3.6' of git://git.kernel.org/pub/scm/linux/kernel/git/cooloney/linux-leds
git bisect good 3bf671af14d591ede9251acb0085e8017f3705e7
# bad: [f00245f182fab57c5eed28a50764600b2bf1ccdb] drm/radeon/kms: reorder code in r600_check_texture_resource
git bisect bad f00245f182fab57c5eed28a50764600b2bf1ccdb
# bad: [959f724728b6a1cb5185230972119dd7bc8b610e] drm/udl: Use ERR_CAST inlined function instead of ERR_PTR(PTR_ERR(.. [1]
git bisect bad 959f724728b6a1cb5185230972119dd7bc8b610e
# good: [f00f979145756e39b5512d7d4e4050534d1c3d7f] i915: don't map imported dma-bufs for dmar.
git bisect good f00f979145756e39b5512d7d4e4050534d1c3d7f
# bad: [da612d880fbc598ac0efcef579355fb90d4bca4e] drm/i915: add more Haswell PCI IDs
git bisect bad da612d880fbc598ac0efcef579355fb90d4bca4e
# good: [bcf9dcc1e6269fac674e41f25d007ff75f76e840] drm/i915: Workaround hang with BSD and forcewake on SandyBridge
git bisect good bcf9dcc1e6269fac674e41f25d007ff75f76e840
# good: [5ab3633d6907018b0b830a720e877c3884d679c3] drm/i915: make rc6 in sysfs functions conditional
git bisect good 5ab3633d6907018b0b830a720e877c3884d679c3

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Peter-jezdec, could you please test the latest mainline kernel via http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.15-rc2-trusty/ and advise to the results?

tags: added: bisect-done
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-bug-exists-upstream-v3.14
removed: kernel-bug-exists-upstream
Peter-jezdec (peter-jezdec) wrote :

Yes, that kernel works. So, it's actually been taken care of already...

tags: added: kernel-fixed-upstream-v3.15-rc2 needs-reverse-bisect
removed: kernel-bug-exists-upstream-v3.14
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
GortiZ (mlista6) wrote :

Just a question: shoud we expect the bugfix to be backported on a next update of kernel 3.13 or should we install kernel 3.15 when it will exit rc?

GortiZ, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

GortiZ (mlista6) wrote :

Since this bug is still open and it looks similar to mine #1318531 I suggest to the people following this channel to check if the 3.13 kernel posted on bug #1318531 fixes this bug so that we can mark one of the two as the duplicate of the other.

Regards,
Giuseppe.

Peter-jezdec (peter-jezdec) wrote :

I will definitely try your kernel. However, I am now traveling, and will not be home to try it out until August. I am also interested in your question of if we should expect the bugfix to be backported: https://answers.launchpad.net/ubuntu/+question/251252

Peter-jezdec (peter-jezdec) wrote :

This bug is affecting the upstream kernel v3.15.6-utopic. It had been fixed all the way through v3.15.5-utopic.

Peter-jezdec (peter-jezdec) wrote :

GortiZ, I tried the kernel posted on bug #1318531, and it does fix this problem. I am also interested in a backport.

GortiZ (mlista6) wrote :

Hi Peter, as you may have seen I didn't bake the fix by myself.
I've just helped @jsalisbury to find the commit which broke the kernel.
I've requested both him and @penalvch to backport the fix to the *ubuntu kernel, even because canonical is the one in charge to keep the LTS for the 14.04 kernel which has ben dropped by mainstream.
Unfortunately i don't know the procedure to find a developer willing to export the patch and submit upstream.

Peter-jezdec (peter-jezdec) wrote :

I did the bisection again, this time on the v3.15.6 version and found that 1c46b5d7cd5d9912687a9e65626cdc24b1074ae1 is the first bad commit.
commit 1c46b5d7cd5d9912687a9e65626cdc24b1074ae1
Author: Dave Airlie <email address hidden>
Date: Mon Jul 14 11:04:39 2014 +1000

    Revert "drm/i915: reverse dp link param selection, prefer fast over wide again"

    commit c6930992948adf0f8fc1f6ff1da51c5002a2cf95 upstream.

    This reverts commit 38aecea0ccbb909d635619cba22f1891e589b434.

    This breaks Haswell Thinkpad + Lenovo dock in SST mode with a HDMI monitor attached.

    Before this we can 1920x1200 mode, after this we only ever get 1024x768, and
    a lot of deferring.

    This didn't revert clean, but this should be fine.

    bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=1117008
    Signed-off-by: Dave Airlie <email address hidden>
    Signed-off-by: Daniel Vetter <email address hidden>
    Signed-off-by: Greg Kroah-Hartman <email address hidden>

:040000 040000 a60449ba7deb5b270c514321ed0c60051d1f8c79 4edb98fefb9abc338b3b8314dbbf4c210a4ac67b M drivers

tags: added: kernel-bug-exists-upstream
Peter-jezdec (peter-jezdec) wrote :

I made a patch file that fixes this in the ubuntu kernel. If you are interested in using this, use git://kernel.ubuntu.com/ubuntu/ubuntu-trusty.git and follow wiki.ubuntu.com/Kernel/BuildYourOwnKernel with patch -p0 < fix_dp.diff

tags: added: patch
Merlin (merlin-skinner) wrote :

I've just tried Utopic Unicorn (14.10), and the issue remains there too. This has comes with kernel 3.16.0-24-generic #32-Ubuntu. Installing 3.15.0-031500rc3-generic #201404280035 fixes it, though.

Peter-jezdec, could you please test the latest live environment via http://cdimage.ubuntu.com/daily-live/current/ and advise to the results?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Peter-jezdec (peter-jezdec) wrote :
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: vivid

Peter-jezdec, could you please test the latest mainline kernel (3.18-rc4) and advise to the results? If it doesn't provide a testable environment please test the next newest release until one allows you to test to the issue.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Peter-jezdec (peter-jezdec) wrote :

Christopher, linux-image-3.18.0-031800rc4-generic_3.18.0-031800rc4.201411091835_amd64.deb is not affected.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Peter-jezdec, the next step is to fully reverse commit bisect from kernel 3.16 to 3.18-rc4 in order to identify the last bad commit, followed immediately by the first good one. Once this commit has been identified, then it may be reviewed as a candidate for backporting into your release. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection#How_do_I_reverse_bisect_the_upstream_kernel.3F ? Please note, finding adjacent kernel versions is not fully commit bisecting.

Thank you for your understanding.
Helpful bug reporting tips: https://wiki.ubuntu.com/ReportingBugs

tags: added: kernel-fixed-upstream-v3.18-rc4
removed: kernel-fixed-upstream-v3.15-rc2
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Peter-jezdec (peter-jezdec) wrote :

Christopher, the first good commit is 344c5bbcb7a282cc59e2f111c8801106c4fe315c.

Fortunately I learned something from the first time I did this. Since the problem was in the function intel_dp_compute_config in the file drivers/gpu/drm/i915/intel_dp.c, there were only 4 commits to check. The first good commit was one of them, but the later commit 2d65a9f48fcdf7866aab6457bc707ca233e0c791 looks like a further refinement.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: cherry-pick reverse-bisect-done
removed: needs-reverse-bisect
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Merlin (merlin-skinner) wrote :

I can confirm that this works "out of the box" with 15.04!

Merlin (merlin-skinner) wrote :

I think there is a regression with 18.04. This issue has re-appeared. "nomodeset" "fixes" it but obviously isn't ideal.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.