hyper-v: Keyboard dysfunctional while booting 14.04 Generation 2 virtual machines on Hyper-V

Bug #1285434 reported by Abhishek Gupta on 2014-02-27
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Andy Whitcroft

Bug Description

Hi folks,

While booting in to Generation 2 virtual machine mode, I noticed that the keyboard stops functioning. It appears that the keyboard is operational during the Grub 2 menu (see attached picture) but when we get to the screen to select a language, the keyboard stops responding. Is it feasible for you to check if the Hyper-V keyboard driver has been included from here:

http://git.kernel.org/cgit/linux/kernel/git/next/linux-next.git/tree/drivers/input/serio/hyperv-keyboard.c?id=HEAD

Please let me know.
Thanks,
Abhishek

Abhishek Gupta (abgupta) wrote :

Grub Image showing that grub menu is functional.

Abhishek Gupta (abgupta) wrote :

Language menu hangs and keyboard is not operational.

summary: - Keyboard dysfunctional while booting Generation 2 virtual machines on
- Hyper-v
+ Keyboard dysfunctional while booting 14.04 Generation 2 virtual machines
+ on Hyper-v
summary: Keyboard dysfunctional while booting 14.04 Generation 2 virtual machines
- on Hyper-v
+ on Hyper-V

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1285434

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: trusty

No bug files are required. Description and pictures attached.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Abhishek Gupta (abgupta) wrote :

To repro this issue you may disable the secure boot check as indicated in the attached picture.

Abhishek Gupta (abgupta) on 2014-02-27
description: updated
Changed in linux (Ubuntu):
importance: Undecided → Medium
Abhishek Gupta (abgupta) wrote :

Hi folks, This is a high priority scenario. Without a fix we will not have UEFI based virtual machine support for Ubuntu. Please increase priority to high if possible.
Thanks,
Abhishek

Joseph Salisbury (jsalisbury) wrote :

Yes, the Hyper-V keyboard driver does exist in Trusty. Trusty has the two upstream commits:

c3c4d99485ea51cd354ed3cd955a8310703456b6 Input: hyperv-keyboard - pass through 0xE1 prefix
aed06b9cfcabf8644ac5f6f108c0b3d01522f88b Input: add a driver to support Hyper-V synthetic keyboard

Do you happen to know if this issue just start happening after a recent update or upgrade? Also, does this issue also happen if you boot the latest mainline kernel, which is v3.14-rc4? It can be downloaded from:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.14-rc4-trusty/

tags: added: kernel-da-key
Abhishek Gupta (abgupta) wrote :

Thanks for confirming Joseph. This is the first time I tested with Generation 2 VMs so not sure if it was caused by a recent update.

I have not tested with upstream kernel because this is happening while the installer is running. I could try out the upstream kernel if I could get past the installation stage.

Do you think the keyboard driver is active when the installer is running? Please take a look at the attached pictures to get more context and let me know how I may help further.

Thanks,
Abhishek

Abhishek Gupta (abgupta) wrote :

Btw, I picked up the latest binaries from here: http://cdimage.ubuntu.com/ubuntu-server/daily/current/

Andy Whitcroft (apw) wrote :

The extra keyboard commits requested were pulled in under: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1282699. It is possible that the driver is not available in the installer if you are using a server alternate installer.

Changed in linux (Ubuntu):
importance: Medium → High
assignee: nobody → Andy Whitcroft (apw)
Andy Whitcroft (apw) on 2014-02-27
summary: - Keyboard dysfunctional while booting 14.04 Generation 2 virtual machines
- on Hyper-V
+ hyper-v: Keyboard dysfunctional while booting 14.04 Generation 2 virtual
+ machines on Hyper-V
Abhishek Gupta (abgupta) wrote :

Hi Andy, I do think that might be the case. The installer does look different from the regular Ubuntu installer which is activated for non-UEFI based virtual machines. Is it possible for you to verify this theory at your end as well? I will try to debug from host side and send a confirmation today.
Thanks,
Abhishek

Andy Whitcroft (apw) wrote :

I suspect you will find you have no hyperv_keyboard module loaded to support the console. I will try adding this to the installer and see if that sorts things out.

Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
Abhishek Gupta (abgupta) wrote :

Thanks Andy! Would you like to share privates with me or should I wait until the next daily build comes out? Please let me know.
Thanks,
Abhishek

Andy Whitcroft (apw) wrote :

These images are pretty hard to build outside the infrastructure so we'll have to wait on an official image. You are looking for the 3.13.0-14 kernel.

Abhishek Gupta (abgupta) wrote :

No problem. I shall wait. Thanks Andy!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.13.0-14.34

---------------
linux (3.13.0-14.34) trusty; urgency=low

  [ Tim Gardner ]

  * Release Tracking Bug
    - LP: #1285851

  [ Andy Whitcroft ]

  * [Config] d-i -- add hyperv_keyboard to serial-modules udeb
    - LP: #1285434

  [ Hannes Frederic Sowa ]

  * SAUCE: ipv6: honor IPV6_PKTINFO with v4 mapped addresses on sendmsg
    - LP: #1284535

  [ Jason Wang ]

  * SAUCE: x86, hyperv: bypass the timer_irq_works() check
    - LP: #1282693

  [ Paolo Pisati ]

  * [Config] disable FB_OMAP2, DRM_OMAP=m

  [ Upstream Kernel Changes ]

  * ipv6: make IPV6_RECVPKTINFO work for ipv4 datagrams
    - LP: #1284535
  * mei: remove flash_work_queue
  * mei: drop redundant list_del_init
  * mei: cleanup mei_irq_read_handler
  * mei: enable marking internal commands
  * mei: me: set dma mask using DMA mapping API
  * Documentation/misc-devices/mei/mei-amt-version.c: remove unneeded call
    of mei_deinit()
  * mei: do not run reset flow from the interrupt thread
  * mei: nfc: mei_nfc_free has to be called under lock
  * mei: fix syntax in comments and debug output
  * mei: revamp mei reset state machine
  * mei: limit the number of consecutive resets
  * mei: set client's read_cb to NULL when flow control fails
 -- Tim Gardner <email address hidden> Wed, 26 Feb 2014 08:43:20 -0500

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Andy Whitcroft (apw) wrote :

This ought to be in the appropriate images now, and available for testing.

Abhishek Gupta (abgupta) wrote :

I shall test it today and let you know Andy. Thank you for the quick response.
Abhishek

Abhishek Gupta (abgupta) wrote :

Hi Andy, That solved the keyboard problem but now the installer cannot read the CDROM device. See attached picture.

Perhaps we need to include all other Hyper-V drivers as well so that block devices can be accessed. Is it possible for you to include all Hyper-V drivers in the installer? If not then I think we should at least put storvsc and netvsc in. Let me know your thoughts.

Thanks,
Abhishek

Abhishek Gupta (abgupta) wrote :

Hi Andy, Please let us know what your plan is in this regard. Our Generation 2 testing is blocked on this.
Thanks,
Abhishek

Andy Whitcroft (apw) on 2014-03-07
tags: added: hyper-v
tags: added: kernel-hyper-v
removed: hyper-v
Abhishek Gupta (abgupta) wrote :

Hey Andy, should we file a new bug for the remaining drivers? Please let us know.
Thanks,
Abhishek

Andy Whitcroft (apw) wrote :

The additional drivers are being tracked under: LP# 1292216

Michał Semeniuk (s3m3n) wrote :

Hi, this bug seems to be fixed, but after installing Ubuntu 14.04 with Hyper-V as generation 2 VM I cannot enter passphrase of the encrypted drive (standard LUKS encryption) after GRUB menu. Keyboard is not responding at all. Is there any solution available?

Jamie (donoja) wrote :

I indeed have an exact same issue with Hyper-V gen 2. In Lubuntu I came across that after install I couldn't press enter to continue reboot after media eject. Also, if restarted manually, it gets stuck at hd encryption password query. Indeed the fix has been partial as it is not system-wide.

Jamie (donoja) wrote :

I should add that I've tried Ubuntu distro too, Xubuntu install for some reason failed entirely. Affects version 14.10 equally with install-time downloads enabled.

Michał Semeniuk (s3m3n) wrote :

Jamie do you know who should we mention to get noticed?

Lockywolf (lockywolf) wrote :

The bug is still there.

Windows 10 x86_64, Hyper-V, Ubuntu 16.04 LTS mini.iso installer.

How to reproduce:

1)Enable Generation 2 VM
2)Enable Secure Boot
3)Boot from dvd
4)In the GRUB menu, select "Expert Install" (the keyboard works).
5)In the next menu, the keyboard doesn't work.

Jeff Waugh (jdub) wrote :

Can confirm I've seen the same thing per #27 (though with the server installer, not a big difference). Turn off secure boot and it's fine.

Evan (evancox10) wrote :

Can also confirm bug is present. Trying to install Ubuntu 16.04 LTS server in a Gen 2 Hyper-V VM with secure boot enabled. Keyboard does not work.

simulant (0oe) wrote :

I got through the install of Ubuntu Desktop 16.04.1 under Gen2 Hyper-V , Win 10 Anniversary update, with secure boot disabled. However, when it rebooted after the install and asked for the encrypted hard drive password, the keyboard did not work. Further reset/reboots resulted in a black screen in the VM. Trying again without encrypting the drive this time....

Joshua R. Poulson (jrp) wrote :

The new reports from #27 forward are likely caused by hyperv_keyboard issing from initrd, and was fixed here: https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1567107
You should upgrade and try again.

Since this bug is marked "Fix Released" it's better to open a new one if you are encountering an issue. For Hyper-V issues, please include "[Hyper-V]" at the front of the subject line, and CC me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers