[Hyper-V] hyperv_keyboard module needed for Generation 2 VMs

Bug #1567107 reported by Joshua R. Poulson on 2016-04-06
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
High
Andy Whitcroft
Xenial
High
Andy Whitcroft

Bug Description

Because Generation 2 virtual machines in Hyper-V are presented with a minimal set of EFI hardware, the kernel module "hyperv_keyboard" must be present to interact with the console keyboard. On systems with disk encryption, the user will be prompted for the key to decrypt the disk, but cannot enter the password because no keyboard driver is present.

This issue appears to exist in all Ubuntu releases that support EFI and are therefore eligible to be used as Generation 2 VMs, most recently tried with the April 5 ISO of the day for 16.04 (pre-release).

This module *is* present when the grub menu is presented and later when the kernel is fully loaded.
FYI, if some mechanism requires a mouse or touch, the hid_hyperv module will also be needed.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1567107

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Joshua R. Poulson (jrp) wrote :

apport-collect cannot be run when there's no keyboard.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: kernel-da-key kernel-hyper-v
Changed in linux (Ubuntu):
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
importance: Medium → High
status: Confirmed → Triaged
Tim Gardner (timg-tpi) on 2016-04-13
affects: linux (Ubuntu Xenial) → initramfs-tools (Ubuntu Xenial)
Changed in initramfs-tools (Ubuntu Xenial):
assignee: Canonical Kernel Team (canonical-kernel-team) → Andy Whitcroft (apw)
Andy Whitcroft (apw) on 2016-04-13
Changed in initramfs-tools (Ubuntu Xenial):
milestone: none → ubuntu-16.04
status: Triaged → In Progress
Andy Whitcroft (apw) wrote :

We have confirmed that this hyperv-keyboard.ko is already included in the serio udeb. For the live installer it is not in initramfs.

I have spun an update which includes hyperv-keyboard.ko in the initramfs and have also confirmed that hid-hyperv.ko is already included in the initramfs.

Tim Gardner (timg-tpi) on 2016-04-14
Changed in initramfs-tools (Ubuntu Xenial):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.122ubuntu7

---------------
initramfs-tools (0.122ubuntu7) xenial; urgency=medium

  * hook-functions: add hyperv-keyboard for Generation 2 VMs
    (LP: #1567107)

 -- Andy Whitcroft <email address hidden> Wed, 13 Apr 2016 18:39:27 +0100

Changed in initramfs-tools (Ubuntu Xenial):
status: Fix Committed → Fix Released
can avar (canafar) on 2017-08-12
no longer affects: initramfs-tools
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers