[Dell XPS 13 (L322X)] Laptop often suspends once immediately after resume

Bug #1261753 reported by Owen Williams on 2013-12-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

It takes 10-15 seconds for the second suspend to trigger. I can tell I'm going to get a double-suspend when the network doesn't come up after resume. I have tried the nmcli nm sleep false trick.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: linux-image-3.11.0-14-generic 3.11.0-14.21
ProcVersionSignature: Ubuntu 3.11.0-14.21-generic 3.11.7
Uname: Linux 3.11.0-14-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: owen 3549 F.... pulseaudio
Date: Tue Dec 17 08:36:36 2013
DistributionChannelDescriptor:
 # This is a distribution channel descriptor
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-precise-amd64-20120703-2
HibernationDevice: RESUME=UUID=63d09ac9-b778-40a5-b221-ea0f78eef4d9
InstallationDate: Installed on 2013-04-16 (244 days ago)
InstallationMedia: Ubuntu 12.04 "Precise" - Build amd64 LIVE Binary 20120703-15:08
MachineType: Dell Inc. Dell System XPS L322X
MarkForUpload: True
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-14-generic root=UUID=524d735f-a2c1-4fc2-bc9a-cc2ea6dddcae ro crashkernel=384M-2G:64M,2G-:128M quiet splash i8042.reset i8042.nomux vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.11.0-14-generic N/A
 linux-backports-modules-3.11.0-14-generic N/A
 linux-firmware 1.116
SourcePackage: linux
UpgradeStatus: Upgraded to saucy on 2013-11-23 (23 days ago)
dmi.bios.date: 01/22/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A07
dmi.board.name: 0PJHXN
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA07:bd01/22/2013:svnDellInc.:pnDellSystemXPSL322X:pvr:rvnDellInc.:rn0PJHXN:rvrA00:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System XPS L322X
dmi.sys.vendor: Dell Inc.

Owen Williams (ywwg) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: bios-outdated-a10
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
summary: - Laptop often suspends once immediately after resume
+ [Dell XPS 13 (L322X)] Laptop often suspends once immediately after
+ resume
Owen Williams (ywwg) wrote :

I still get the same behavior -- after a long pause, I get the "Failed to execute operation" error message and then another suspend:

Lid closed.
Suspending...
Failed to execute operation: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Suspending...
Operation finished.
Lid opened.

bios version is A10 and release date is 08/28/2013.

tags: added: latest-bios-a10
removed: bios-outdated-a10
tags: added: needs-upstream-testing regression-potential
Owen Williams (ywwg) wrote :

Another thing that seems related: it used to be that I could close the lid with AC plugged in, and the laptop wouldn't suspend (that's how I have it set). Then, if I removed the AC power, it still wouldn't suspend. Now, if I remove power it does seem to check that the lid is closed and it suspends.

I think this is related because I can prevent the double-suspend by either plugging or unplugging the AC adapter before resuming. As long as I reverse the state versus the power source at the time of suspend, the laptop stays on.

Owen Williams (ywwg) wrote :

This thread is on point -- there is something wrong with the lid detection: http://ubuntuforums.org/showthread.php?t=2184892

In my case I'm not running xfce power manager, but the symptoms are the same. (I have upowerd and indicator-power-service running)

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Owen Williams (ywwg) wrote :

Still happens on 14.04, 3.13.0-24-generic

Changed in linux (Ubuntu):
status: Expired → Incomplete

Owen Williams, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-3.15-rc2

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: trusty
Owen Williams (ywwg) wrote :

Still happens. The most consistent way to reproduce is:

* Have laptop plugged in by AC
* Close lid
* Remove AC
* Wait for suspend.
* Open lid, leave AC unplugged.
* Wait several seconds, laptop resuspends

The best workaround is disabling suspend-on-lid-close.

tags: added: kernel-bug-exists-upstream kernel-bug-exists-upstream-3.15.0-031500rc2
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Owen Williams, did this problem not occur in a release prior to Saucy?

description: updated
tags: added: kernel-bug-exists-upstream-3.15-rc2
removed: kernel-bug-exists-upstream-3.15.0-031500rc2 needs-upstream-testing
Owen Williams (ywwg) wrote :

I tried testing again with the newest Ubuntu liveCD, and at least in that environment it works correctly. And the wifi reconnects much more quickly too. It's looking more likely that this is some strange quirk of my system which has been upgraded a few times and may have some bad config hiding somewhere.

Is there an accepted way to reinstall Ubuntu on top of an existing installation, preserving at least the home directory? Otherwise I'll just flatten and reinstall and see if that fixes it.

Owen Williams (ywwg) wrote :

Did a Reinstall (preserving user files) and the problem went away. Sorry for the trouble.

Changed in linux (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers