0a12:0001 Bluetooth Dongle (Cambridge Silicon Radio, Ltd) doesn't work after upgrading to Saucy

Bug #1245150 reported by Aditya on 2013-10-27
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

After upgrading to Saucy, the bluetooth-indicator was no longer present in the taskbar. If I go to System Settings >> Bluetooth; it shows as "Bluetooth is disabled" and toggling the On|Off Switch doesn't enable it: http://i.stack.imgur.com/vwfEo.png

I have installed the Blueman Device Manager to solve this issue and its bluetooth indicator is shown on the taskbar, but it doesn't function. However, toggling the On|Off switch in System Settings >> Bluetooth, grays out the icon of Blueman indicator in the taskbar.

To debug the issue, I am following the instructions mentioned at https://wiki.ubuntu.com/Kernel/KernelBisection. I have downloaded and installed the kernals from https://launchpad.net/ubuntu/saucy/+source/linux:
- 3.9.0-7.15 works for me
- 3.10.0-0.6 doesn't work

For further commit bisecting, I have downloaded the git repository of `ubuntu-saucy` by running: git clone git://kernel.ubuntu.com/ubuntu/ubuntu-saucy.git

To see how many commits are there in between, I run the following command:
git log --oneline Ubuntu-3.9.0-7.15..Ubuntu-3.10.0-0.6 | wc
14802 117434 922801

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: linux-image-3.11.0-12-generic 3.11.0-12.19
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic i686
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: aditya 1767 F.... pulseaudio
 /dev/snd/pcmC0D0c: aditya 1767 F...m pulseaudio
 /dev/snd/pcmC0D0p: aditya 1767 F...m pulseaudio
CurrentDmesg:
 [ 23.616595] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
 [ 23.617367] alx 0000:02:00.0 eth0: NIC Up: 100 Mbps Full
 [ 23.617591] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Date: Sun Oct 27 15:17:38 2013
HibernationDevice: RESUME=UUID=98bed5fe-b467-4bb4-9173-177ee22f8c76
InstallationDate: Installed on 2013-07-06 (112 days ago)
InstallationMedia: This
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: Gigabyte Technology Co., Ltd. GA-78LMT-S2PT
MarkForUpload: True
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-12-generic root=UUID=1274a22c-31b4-4c65-8a0f-8eede0288fea ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.11.0-12-generic N/A
 linux-backports-modules-3.11.0-12-generic N/A
 linux-firmware 1.116
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: Upgraded to saucy on 2013-10-18 (8 days ago)
dmi.bios.date: 11/05/2012
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: FC
dmi.board.name: GA-78LMT-S2PT
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrFC:bd11/05/2012:svnGigabyteTechnologyCo.,Ltd.:pnGA-78LMT-S2PT:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-78LMT-S2PT:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-78LMT-S2PT
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Aditya (code-aditya) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: latest-bios-fc needs-upstream-testing regression-release
summary: - Bluetooth Dongle (Cambridge Silicon Radio, Ltd) doesn't work after
- upgrading to Saucy
+ 0a12:0001 Bluetooth Dongle (Cambridge Silicon Radio, Ltd) doesn't work
+ after upgrading to Saucy
description: updated
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: needs-bisect performing-bisect
Aditya (code-aditya) wrote :

Christopher,

The linked article mentions the command to run as:

$ git bisect start <BAD> <GOOD>

In my case, Bad is `Ubuntu-3.10.0-0.6`; and Good is `Ubuntu-3.9.0-7.15`

So, I think I am supposed to run:

$ git bisect start Ubuntu-3.10.0-0.6 Ubuntu-3.9.0-7.15

Please confirm the same. Moreover, I think I would have to build the kernals myself which would be time-consuming on my machine. Is it somehow possible to use Launchpad PPA's service to download the built kernals and install them?

This is the first time I am attempting something like this, so please forgive my ignorance about it.

Cheers :-)

Aditya, you are correct, it's BAD GOOD, not GOOD BAD.

>"Moreover, I think I would have to build the kernals myself which would be time-consuming on my machine. Is it somehow possible to use Launchpad PPA's service to download the built kernals and install them?"

Not that I am aware.

Aditya (code-aditya) wrote :

Christopher, while trying to bisect my debian and debian.master folders disappeared because I am commit bisecting Ubuntu kernel versions across non-linear tags (I don't know what that means :-)) as per this https://wiki.ubuntu.com/Kernel/KernelBisection#Commit_bisecting_Ubuntu_kernel_versions_across_non-linear_tags

So, I would have to bisect the upstream kernal versions.. I am first of all going to do KernalBisection by downloading and installing the mainline kernals from http://kernel.ubuntu.com/~kernel-ppa/mainline/

Thereafter, I would need to do CommitBisection. I am reading up on it, but let me know would I have to download the whole MEGABYTES of another Git repository? If so, which one - I haven't found yet...

Thanks for your support :-)

Aditya (code-aditya) wrote :

I have downloaded and installed v3.9.11-saucy, v3.10-rc1-saucy and v3.10-rc2-saucy from the mainline build repository: http://kernel.ubuntu.com/~kernel-ppa/mainline/

Out of this:
- v3.9.11-saucy works well
- v3.10-rc1-saucy did seem to install but doesn't boot for me
- v3.10-rc2-saucy doesn't work

So, the problem is between v3.9.11-saucy and v3.10-rc2-saucy in the mainline builds.

v3.9.11-saucy is GOOD
v3.10-rc2-saucy is BAD

(BTW, both these mainline builds broke my Network connection. I hope that doesn't affect us. My network connection was and is fine in all the other kernals.)

Please guide me through the next step.

Aditya, following https://wiki.ubuntu.com/Kernel/KernelBisection#Commit_bisecting_upstream_kernel_versions the next step is to download the entire upstream git repository (which may take a while and take multiple attempts) via:
git clone git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git

and bisect between the two mainline kernel points:
git bisect start v3.10-rc2 v3.9.11

Aditya (code-aditya) wrote :

Hi Christopher,

I made an attempt to compile the mainline kernel. It took more than 90 minutes on my machine to compile the packages for i386. However, there are a few anomalies. It created 4 .deb packages for me:

- linux-firmware-image_3.9.0-adi01-1_i386.deb (1.1 MB)
- linux-headers-3.9.0-adi01_3.9.0-adi01-1_i386.deb (8.4 MB)
- linux-image-3.9.0-adi01_3.9.0-adi01-1_i386.deb (711.9 MB)
- linux-libc-dev_3.9.0-adi01-1_i386.deb (941.8 kB)

I don't know why it compiled v3.9.0 (maybe I made some mistake somewhere). Moreover, the size of linux-image is too huge in my opinion. Should I attempt to install these .deb packages? Or, there is something wrong with them because of its huge size. (Generally the size of update for ubuntu-kernal happens to be ~60 MB).

Aditya, if you followed the instructions verbatim then give it a go and see if it allows you to boot to it.

Aditya (code-aditya) wrote :

Chistopher, I am not feeling comfortable installing that right now. I have my exams during the next three weeks and I can't risk an unstable system till that time. CommitBisection would also requrie me to build and install the kernel atleast 13 times. So, I would get back to this bug after 21st November and restart the Commit Bisection process at that time.

Hope you would help me then and thanks for your patience.

Aditya (code-aditya) wrote :

@Christopher, I once again started the bisecting process, for me the size of kernnels built are abnormal, however I have installed them.

I had built and installed the 1st bisection. It turned out to be good and bluetooth was working on it. Then, I built the 2nd bisection. I have installed the files generated from 2nd bisection, but I can't boot to it. So, I am stuck in this bisection process and can't proceed further.

Following is the output of `git bisect log`:

$ git bisect log
# bad: [c7788792a5e7b0d5d7f96d0766b4cb6112d47d75] Linux 3.10-rc2
# good: [896f5009ed1fbaec43f360c4ebf022639cd61d5f] Linux 3.9.11
git bisect start 'v3.10-rc2' 'v3.9.11'
# good: [c1be5a5b1b355d40e6cf79cc979eb66dafa24ad1] Linux 3.9
git bisect good c1be5a5b1b355d40e6cf79cc979eb66dafa24ad1

Aditya, if the 2nd bisection can't boot, just increment one/few commit(s) away.

Aditya (code-aditya) wrote :

I have not yet given up hope.. I am trying to do the bisection, but everytime I get into the situation of not being able to boot the kernel. For someone who hasn't done anything like this before; building the kernels and bisecting it to get hold of the bad commit is a pretty daunting task indeed. Any it takes upwards to 2.5hours to build the kernel on my system.

So, I am still doing the bisection as and when possible and would report things in due course.

However, is it possible to provide more parameters to `git bisect start` in order to cut down the number of bisections required in this case; as mentioned over here:

https://www.kernel.org/pub/software/scm/git/docs/git-bisect.html#_cutting_down_bisection_by_giving_more_parameters_to_bisect_start

Aditya (code-aditya) wrote :

@Christopher

I have found Bug No. 60824 on Linux Bug Tracker: https://bugzilla.kernel.org/show_bug.cgi?id=60824

It looks like the same problem as this one. There is a patch provided by Gustavo Padovan in Comment no. 6: https://bugzilla.kernel.org/show_bug.cgi?id=60824#c6

Can you help me in applying this patch to the kernel... I have read https://www.kernel.org/doc/Documentation/applying-patches.txt but I am not sure if I need to change branches using git...

Right now, my git repo reports as:

$ git remote -v
origin http://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/ (fetch)
origin http://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/ (push)

The repo is fully updated as of today and right now I am on the master branch... Could you please hand-hold me to apply the patch mentioned above?

Aditya (code-aditya) wrote :

@Christopher..

YAY... That patch worked.. The kernel compiled well and I can use bluetooth once again.. Please do the needful to merge that patch in the kernel. Let me know if you require any more information in this regard.

tags: added: cherry-pick
removed: needs-bisect performing-bisect
tags: removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Aditya (code-aditya) wrote :

I have just tested v3.14-rc6-trusty from mainline kernel and the issue seems to have been fixed.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.14-rc6-trusty/

tags: added: kernel-fixed-upstream
ken Code (kencode) wrote :
Download full text (4.3 KiB)

Hi guys, I'm starting to think this is a hardware issue and not Linux, but here's what I got so far.
New laptop with the K810 bluetooth keyboard. Linuxmint latest with latest update.
I hate to send the K810 back, its frign awesome. Maybe a dongle would work??

Here's my specs:

from: http://blog.chschmid.com/?p=1537#comment-136700

hcitool scan – shows nothing, it just scans forever it seems.
thoughts? please and thanx :)

kc@kC-laptop ~ $ lsusb
Bus 001 Device 002: ID 8087:8000 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 005: ID 03eb:8a1d Atmel Corp.
Bus 002 Device 004: ID 0bda:b728 Realtek Semiconductor Corp.
Bus 002 Device 003: ID 5986:055e Acer, Inc
Bus 002 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
kc@kC-laptop ~ $ lsmod | grep bluetooth
bluetooth 391136 22 bnep,btusb,rfcomm
kc@kC-laptop ~ $ dmesg | grep -i bluetooth
[ 2.221447] usb 2-6: Product: Bluetooth Radio
[ 3.886309] Bluetooth: Core ver 2.17
[ 3.886328] Bluetooth: HCI device and connection manager initialized
[ 3.886336] Bluetooth: HCI socket layer initialized
[ 3.886339] Bluetooth: L2CAP socket layer initialized
[ 3.886343] Bluetooth: SCO socket layer initialized
[ 4.096788] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 4.096792] Bluetooth: BNEP filters: protocol multicast
[ 4.096800] Bluetooth: BNEP socket layer initialized
[ 4.106031] Bluetooth: RFCOMM TTY layer initialized
[ 4.106042] Bluetooth: RFCOMM socket layer initialized
[ 4.106047] Bluetooth: RFCOMM ver 1.11
kc@kC-laptop ~ $ lspci -nnk
00:00.0 Host bridge [0600]: Intel Corporation Haswell-ULT DRAM Controller [8086:0a04] (rev 0b)
Subsystem: Lenovo Device [17aa:3978]
00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 0b)
Subsystem: Lenovo Device [17aa:3978]
Kernel driver in use: i915
00:03.0 Audio device [0403]: Intel Corporation Haswell-ULT HD Audio Controller [8086:0a0c] (rev 0b)
Subsystem: Lenovo Device [17aa:3978]
Kernel driver in use: snd_hda_intel
00:14.0 USB controller [0c03]: Intel Corporation Lynx Point-LP USB xHCI HC [8086:9c31] (rev 04)
Subsystem: Lenovo Device [17aa:3978]
Kernel driver in use: xhci_hcd
00:16.0 Communication controller [0780]: Intel Corporation Lynx Point-LP HECI #0 [8086:9c3a] (rev 04)
Subsystem: Lenovo Device [17aa:3978]
Kernel driver in use: mei_me
00:1b.0 Audio device [0403]: Intel Corporation Lynx Point-LP HD Audio Controller [8086:9c20] (rev 04)
Subsystem: Lenovo Device [17aa:3978]
Kernel driver in use: snd_hda_intel
00:1c.0 PCI bridge [0604]: Intel Corporation Lynx Point-LP PCI Express Root Port 1 [8086:9c10] (rev e4)
Kernel driver in use: pcieport
00:1c.2 PCI bridge [0604]: Intel Corporation Lynx Point-LP PCI Express Root Port 3 [8086:9c14] (rev e4)
Kernel driver in use: pcieport
00:1c.3 PCI bridge [0604]: Intel Corporation Lynx Point-LP PCI Express Root Port 4 [8086:9c16] (rev e4)
Kernel driver in use: pcieport
00:1c.4 PCI bridge [0604]: Intel Corporation Lynx Point-LP PCI Express Root Port 5 [8086:9c18] (rev e4)
Kernel drive...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.