[Hewlett-Packard HP Pavilion g7 Notebook PC] suspend/resume failure [non-free: fglrx]

Bug #1238203 reported by lokz on 2013-10-10
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Arch Linux)
New
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned

Bug Description

When lid is closed on laptop, computer does not come back from standby. Just not I installed latest updates and tried, error remains.

BR,

ProblemType: KernelOops
DistroRelease: Ubuntu 13.10
Package: linux-image-3.11.0-12-generic 3.11.0-12.19
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic x86_64
NonfreeKernelModules: fglrx
Annotation: This occured during a previous suspend and prevented it from resuming properly.
ApportVersion: 2.12.5-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: korisnik 1828 F.... pulseaudio
 /dev/snd/controlC0: korisnik 1828 F.... pulseaudio
Date: Thu Oct 10 20:41:08 2013
ExecutablePath: /usr/share/apport/apportcheckresume
Failure: suspend/resume
HibernationDevice: RESUME=UUID=5445a60b-3ee9-4e92-b571-d7422ee0bffa
InstallationDate: Installed on 2013-10-03 (6 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Beta amd64 (20130925.1)
InterpreterPath: /usr/bin/python3.3
MachineType: Hewlett-Packard HP Pavilion g7 Notebook PC
MarkForUpload: True
ProcCmdline: /usr/bin/python3 /usr/share/apport/apportcheckresume
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
ProcFB: 0 EFI VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-12-generic.efi.signed root=UUID=3fbbaf75-40d1-47ae-a558-8a4ac49ed928 ro quiet splash vt.handoff=7
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: Daemon not responding.
RelatedPackageVersions:
 linux-restricted-modules-3.11.0-12-generic N/A
 linux-backports-modules-3.11.0-12-generic N/A
 linux-firmware 1.116
SourcePackage: linux
Title: [Hewlett-Packard HP Pavilion g7 Notebook PC] suspend/resume failure [non-free: fglrx]
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 02/21/2013
dmi.bios.vendor: Insyde
dmi.bios.version: F.26
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 184C
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 57.35
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsyde:bvrF.26:bd02/21/2013:svnHewlett-Packard:pnHPPaviliong7NotebookPC:pvr0791100000205610000620100:rvnHewlett-Packard:rn184C:rvr57.35:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP Pavilion g7 Notebook PC
dmi.product.version: 0791100000205610000620100
dmi.sys.vendor: Hewlett-Packard

lokz (lokz) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.12 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-rc4-saucy/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
lokz (lokz) wrote :

Hello, I installed latest kernel:

Linux HP-Pavilion-g7-LV 3.12.0-031200-generic #201311031935 SMP Mon Nov 4 00:36:54 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

However, problem remains. Comuter does not comes from standby initiated from menu or by closing lid.

lokz (lokz) wrote :

New situation. After last night Ubuntu "base" update, suspend works, but after resume WiFi is not present (it does not show network adapters).
To connect WiFi only solution is to restart.

Jason (jason-pfeil) wrote :

I'm having the same issue -- my ubuntu 13.10 is the most current version and, while I can still suspend I cannot resume. My system resumes but then freezes immediately. I have an HP dv7t quad edition with the most up-to-date BIOS. I tried the latest mainline kernel and had the exact same result. I have the latest fglrx from Ubuntu installed.

ii fglrx 2:13.101-0ubuntu3 amd64 Video driver for the AMD graphics accelerators
ii fglrx-amdcccle 2:13.101-0ubuntu3 amd64 Catalyst Control Center for the AMD graphics accelerators
ii fglrx-dev 2:13.101-0ubuntu3 amd64 Video driver for the AMD graphics accelerators (devel files)
ii fglrx-pxpress 0.4 all Tools to enable AMD's PowerXpress

According to /var/log/pm-suspend.log, the resume completes, but then the system locks up. Any help or any other diagnostics that you need, please let me know.

Thank you!

--Jason

I can confirm that this bug also affects g7s running Arch Linux. Same results on all fronts. Appears to be a kernel bug.

lokz (lokz) wrote :

Update: Bug is still very present. So sleep does not work, resuming does not work.

This is fixed for me on Arch Linux with kernel 3.12.7 and fglrx as the driver.

It is partially fixed with the radeon driver, but the screen refuses to turn on and no combination of suspend quirks or ACPI/DPMS/brightness fiddling would get it to turn back on without a reboot (issued over SSH).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers