8086:0166 [Dell XPS 13 L322X] Plymouth screen refresh is bad when Live USB is started in UEFI mode

Bug #1234546 reported by Romuald on 2013-10-03
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

Test computer : Dell XPS 13 L322x with Intel Graphics HD4000.

I burnt a Live Ubuntu Gnome 13.10 USB, first with the Beta 1, and with the 2013-09-30 daily image. This USB key has been created with Rufus under Windows and is compliant for both UEFI and Bios mode. If I boot the key in UEFI mode (SecureBoot is disabled), I see the first screen. After having chosen "test only", plymouth starts but the screen refresh frequency is bad, so I have many footprints on the screen, etc. Everything seems to run fine also, except this screen refresh frequency.

WORKAROUND: If I boot on the key in Bios mode, no problem, I see the first screen in text mode (Install, test only...). After having chosen "test only", I see the Gnome footprint and everything runs.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: plymouth 0.8.8-0ubuntu8
ProcVersionSignature: Ubuntu 3.11.0-9.16-generic 3.11.2
Uname: Linux 3.11.0-9-generic x86_64
ApportVersion: 2.12.5-0ubuntu1
Architecture: amd64
Date: Thu Oct 3 09:00:43 2013
DefaultPlymouth: /lib/plymouth/themes/ubuntu-gnome-logo/ubuntu-gnome-logo.plymouth
InstallationDate: Installed on 2013-09-22 (10 days ago)
InstallationMedia: Ubuntu-GNOME 13.10 "Saucy Salamander" - Alpha amd64 (20130903)
MachineType: Dell Inc. Dell System XPS L322X
MarkForUpload: True
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-9-generic.efi.signed root=UUID=529ee009-cfab-4b00-832d-5390f382f988 ro quiet splash vt.handoff=7
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-9-generic.efi.signed root=UUID=529ee009-cfab-4b00-832d-5390f382f988 ro quiet splash vt.handoff=7
SourcePackage: plymouth
TextPlymouth: /lib/plymouth/themes/ubuntu-gnome-text/ubuntu-gnome-text.plymouth
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/15/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A09
dmi.board.name: 0PJHXN
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA09:bd05/15/2013:svnDellInc.:pnDellSystemXPSL322X:pvr:rvnDellInc.:rn0PJHXN:rvrA00:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System XPS L322X
dmi.sys.vendor: Dell Inc.

Romuald (romu70) wrote :
Steve Langasek (vorlon) on 2013-10-03
affects: plymouth (Ubuntu) → linux (Ubuntu)

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Oups, forgot to write that this affects all Ubuntu flavours. I also tested with a Xubuntu 13.10 Beta Live USB.

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.12 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-rc3-saucy/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete

Just tested with the mainline kernel 3.12.0 RC3 from the 2013-09-29. Same
issue.

On Thu, Oct 3, 2013 at 5:27 PM, Joseph Salisbury <
<email address hidden>> wrote:

> Would it be possible for you to test the latest upstream kernel? Refer
> to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest
> v3.12 kernel[0].
>
> If this bug is fixed in the mainline kernel, please add the following
> tag 'kernel-fixed-upstream'.
>
> If the mainline kernel does not fix this bug, please add the tag:
> 'kernel-bug-exists-upstream'.
>
> If you are unable to test the mainline kernel, for example it will not
> boot, please add the tag: 'kernel-unable-to-test-upstream'.
> Once testing of the upstream kernel is complete, please mark this bug as
> "Confirmed".
>
>
> Thanks in advance.
>
> [0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-rc3-saucy/
>
> ** Changed in: linux (Ubuntu)
> Importance: Undecided => Medium
>
> ** Changed in: linux (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1234546
>
> Title:
> Plymouth screen refresh is bad when Live USB is started in UEFI mode
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1234546/+subscriptions
>

tags: added: kernel-bug-exists-upstream

Added the "kernel-bug-exists-upstream" tag.

Romuald (romu70) wrote :

Hi,
Could someone tell me why this bug is incomplete and what can be done to complete it?

Thanks.

Joseph Salisbury (jsalisbury) wrote :

Did this issue start happening after an update/upgrade? Was there a kernel version where you were not having this particular problem? This will help determine if the problem you are seeing is the result of the introduction of a regression, and when this regression was introduced. If this is a regression, we can perform a kernel bisect to identify the commit that introduced the problem.

Hi Joseph,
I first tried to install in UEFI with Ubuntu Gnome 13.10 Beta 1, and this
is when I first met the issue. I never tried with 13.04 but I can if you
think that might be interesting.

On Mon, Oct 7, 2013 at 11:16 PM, Joseph Salisbury <
<email address hidden>> wrote:

> Did this issue start happening after an update/upgrade? Was there a
> kernel version where you were not having this particular problem? This
> will help determine if the problem you are seeing is the result of the
> introduction of a regression, and when this regression was introduced.
> If this is a regression, we can perform a kernel bisect to identify the
> commit that introduced the problem.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1234546
>
> Title:
> Plymouth screen refresh is bad when Live USB is started in UEFI mode
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1234546/+subscriptions
>

Hi Joseph.
Just tried with Ubuntu 13.04 :
- there is NO this screen refresh issue
- but there is an issue with the screen backlight which is not handled at all on my XPS13

So the refresh issue has been introduced between 13.04 and 13.10.

Sam Van den Eynde (samvde) wrote :

I confirm this bug and I would like to extend it: it is not limited to the installer LiveUSB. When using the Dell XPS 13 and booting using UEFI, the screen goes crazy with lots of ghost images etc. as the OP describes.

I unfortunately use EFI to boot several instances of Ubuntu, making saucy unusable for me for the time being. Which is unfortunate on a linux "branded" machine.

I installed using BIOS and migrated to EFI afterwards.

Steve Beaulac (steve-sagacity) wrote :

I confirm this bug,

I also have the EFI booting turn on, and have the brightness issue since kernel 3.8.0-30-generic.
https://bugs.launchpad.net/dell-sputnik/+bug/1169376

When I use kernel 3.8.0-29-generic from ubuntu 13.04 in 13.10 I don't have the screen refresh issue or the brightness issue.

When I remove the QUIRK_NO_PCH_PWM_ENABLE quirk from my kernel build I get my brightness control back. even in vanilla 3.12.0 kernel. However, the screen refresh issue still exist.

Sam Van den Eynde (samvde) wrote :

I confirm the bug still exists in latest mainline kernel 3.12.0-031200rc5.

Can we please increase the priority on this? If I would have followed the 13.04 dist upgrade suggestion, I would have ended up with a non-functional system. This is an Ubuntu promoted machine!

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Steve Beaulac (steve-sagacity) wrote :

I was able to get UEFI working with kernel 3.11.0-12-generic on my XPS 13 L322x HD

I booted into my XPS bios setup, navigated to the boot tab, and configure the setting as below;

Secure Boot: Disable
Load Legacy Option Rom: Enabled
Boot List Option: UEFI

As stated in my previous comment (#12) I had the backlight and screen refresh issues. Now I can see my desktop and adjust my brightness.

Sam Van den Eynde (samvde) wrote :

Hi Steve

Thank you for this workaround, I confirm this also works for me!

I _think_ this brings you in USB bios mode per default when installing?

That's the way I use 13.10 on my XPS. But I'm pretty sure, in that case,
you just start in Bios mode and not in UEFI. That's why it works. I made
several testing with USB key, booting in Bios mode always works, booting in
UEFI never.

On Sat, Oct 19, 2013 at 5:57 AM, Steve Beaulac
<email address hidden>wrote:

> I was able to get UEFI working with kernel 3.11.0-12-generic on my XPS
> 13 L322x HD
>
> I booted into my XPS bios setup, navigated to the boot tab, and
> configure the setting as below;
>
> Secure Boot: Disable
> Load Legacy Option Rom: Enabled
> Boot List Option: UEFI
>
> As stated in my previous comment (#12) I had the backlight and screen
> refresh issues. Now I can see my desktop and adjust my brightness.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1234546
>
> Title:
> Plymouth screen refresh is bad when Live USB is started in UEFI mode
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1234546/+subscriptions
>

I'm sure when you enabled the "Load Legacy Option Rom" the bios initialize some of the hardware differently then when that option is disabled.

I'm sure that I'm booting with the efi kernel

Command line: BOOT_IMAGE=/boot/vmlinuz-3.11.0-12-generic.efi.signed

Sam Van den Eynde (samvde) wrote :

I am definitely booting in EFI, as my laptop does not have a Bios enabled bootloader installed.

Installation from USB will probably bring you in Bios mode though meaning you will have to fix the EFI afterwards.

description: updated
tags: added: bios-outdated-a10
tags: added: kernel-bug-exists-upstream-v3.12-rc3
removed: kernel-bug-exists-upstream
tags: added: regression-release
summary: - Plymouth screen refresh is bad when Live USB is started in UEFI mode
+ [Dell XPS 13 L322X] Plymouth screen refresh is bad when Live USB is
+ started in UEFI mode
summary: - [Dell XPS 13 L322X] Plymouth screen refresh is bad when Live USB is
- started in UEFI mode
+ 8086:0166 [Dell XPS 13 L322X] Plymouth screen refresh is bad when Live
+ USB is started in UEFI mode
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
importance: Medium → Low
Download full text (5.0 KiB)

Hi Christopher,
I've been running the A10 for few weeks now, and it doesn't fix the issue.
Your command output is:
A10
8/28/2013

On Sat, Nov 30, 2013 at 10:53 PM, Christopher M. Penalver <
<email address hidden>> wrote:

> Romuald, as per
> http://www.dell.com/support/drivers/us/en/19/Product/xps-13-l321x-mlk an
> update is available for your BIOS (A10). If you update to this following
> https://help.ubuntu.com/community/BiosUpdate , does it change anything?
> If it doesn't, could you please both specify what happened, and provide the
> output of the following terminal command:
> sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
>
> Please note your current BIOS is already in the Bug Description, so
> posting this on the old BIOS would not be helpful.
>
> For more on BIOS updates and linux, please see
> https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette
> .
>
> Thank you for your understanding.
>
> ** Description changed:
>
> Test computer : Dell XPS 13 L322x with Intel Graphics HD4000.
>
> I burnt a Live Ubuntu Gnome 13.10 USB, first with the Beta 1, and with
> the 2013-09-30 daily image. This USB key has been created with Rufus
> - under Windows and is compliant for both UEFI and Bios mode.
> + under Windows and is compliant for both UEFI and Bios mode. If I boot
> + the key in UEFI mode (SecureBoot is disabled), I see the first screen.
> + After having chosen "test only", plymouth starts but the screen refresh
> + frequency is bad, so I have many footprints on the screen, etc.
> + Everything seems to run fine also, except this screen refresh frequency.
>
> - If I boot on the key in Bios mode, no problem, I see the first screen in
> - text mode (Install, test only...). After having chosen "test only", I
> - see the Gnome footprint and everything runs.
> -
> - If I boot the key in UEFI mode (SecureBoot is disabled), I see the first
> - screen. After having chosen "test only", plymouth starts but the screen
> - refresh frequency is bad, so I have many footprints on the screen, etc.
> -
> - Everything seems to run fine also, except this screen refresh frequency.
> + WORKAROUND: If I boot on the key in Bios mode, no problem, I see the
> + first screen in text mode (Install, test only...). After having chosen
> + "test only", I see the Gnome footprint and everything runs.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.10
> Package: plymouth 0.8.8-0ubuntu8
> ProcVersionSignature: Ubuntu 3.11.0-9.16-generic 3.11.2
> Uname: Linux 3.11.0-9-generic x86_64
> ApportVersion: 2.12.5-0ubuntu1
> Architecture: amd64
> Date: Thu Oct 3 09:00:43 2013
> DefaultPlymouth:
> /lib/plymouth/themes/ubuntu-gnome-logo/ubuntu-gnome-logo.plymouth
> InstallationDate: Installed on 2013-09-22 (10 days ago)
> InstallationMedia: Ubuntu-GNOME 13.10 "Saucy Salamander" - Alpha amd64
> (20130903)
> MachineType: Dell Inc. Dell System XPS L322X
> MarkForUpload: True
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-9-generic.efi.signed
> root=UUID=529ee009-cfab-4b00-832d-5390f382f988 ro quiet splash vt.handoff=7
> ProcFB: 0 inteldrmfb
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-9-gene...

Read more...

tags: added: latest-bios-a10
removed: bios-outdated-a10
Romuald (romu70) wrote :

Hi Christopher,
I'm already running the A10 Bios, and no change. Your command output is:

"A10
08/28/2013"

I've just tested with a days old 14.04 image and the results are:
- this bug is fixed, I could use the live CD almost normally
- but the screen backlight is not controlled at all, the screen is so dark than nobody can seriously work with such conditions.

Romuald, thank you for providing the requested information, and for testing Trusty. Regarding the problem noted in the Bug Description, would you need a backport to a release prior to Trusty LTS, or may this be closed as Status Invalid?

Regarding screen backlight not being controllable, it would be best to file a new report about it via a terminal:
ubuntu-bug linux

Romuald (romu70) wrote :

Personaly I can live like this. The workaround is pretty simple (a bios setting), and to be fully honest, I plan to leave Ubuntu pretty soon. I'm a Gnome fan, and it's time to say Ubuntu is not really a Gnome distrib anymore.

Romuald, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1234546/comments/22 regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers