Raring update to 3.8.13.10 stable release (including 3.8.13.9 also)

Bug #1233227 reported by Steve Conklin on 2013-09-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Raring
Undecided
Unassigned

Bug Description

SRU Justification

    Impact:
       The upstream process for stable tree updates is quite similar
       in scope to the Ubuntu SRU process, e.g., each patch has to
       demonstrably fix a bug, and each patch is vetted by upstream
       by originating either directly from Linus' tree or in a minimally
       backported form of that patch. The 3.8.13.10 upstream stable
       patch set is now available. It should be included in the Ubuntu
       kernel as well.

       git://kernel.ubuntu.com/ubuntu/linux.git

    TEST CASE: TBD

       The following patches are in the 3.8.13.9 3.8.13.10 stable releases:

* ARM: update FIQ support for relocation of vectors
* ARM: Fix FIQ code on VIVT CPUs
* regmap: Add another missing header for !CONFIG_REGMAP stubs
* ALSA: hda - Add inverted digital mic fixup for Acer Aspire One
* mac80211: add missing channel context release
* iwl4965: fix rfkill set state regression
* ath9k_htc: Restore skb headroom when returning skb to mac80211
* ath9k: Enable PLL fix only for AR9340/AR9330
* ALSA: hda - Fix NULL dereference with CONFIG_SND_DYNAMIC_MINORS=n
* lparcfg: don't bother saving pointer to proc_dir_entry
* powerpc/pseries/lparcfg: Fix possible overflow are more than 1026
* powerpc: Don't Oops when accessing /proc/powerpc/lparcfg without hypervisor
* powerpc: Work around gcc miscompilation of __pa() on 64-bit
* powerpc/hvsi: Increase handshake timeout from 200ms to 400ms.
* net: Check the correct namespace when spoofing pid over SCM_RIGHTS
* ALSA: opti9xx: Fix conflicting driver object name
* SUNRPC: Fix memory corruption issue on 32-bit highmem systems
* drivers/base/memory.c: fix show_mem_removable() to handle missing sections
* memcg: check that kmem_cache has memcg_params before accessing it
* workqueue: cond_resched() after processing each work item
* drm/i915: ivb: fix edp voltage swing reg val
* drm/vmwgfx: Split GMR2_REMAP commands if they are to large
* af_key: initialize satype in key_notify_policy_flush()
* Linux 3.8.13.9
* Revert "net/core/sock.c: add missing VSOCK string in af_family_*_key_strings"
* zram: allow request end to coincide with disksize
* mtd: nand: fix NAND_BUSWIDTH_AUTO for x16 devices
* HID: hidraw: correctly deallocate memory on device disconnect
* xen-gnt: prevent adding duplicate gnt callbacks
* ath9k: always clear ps filter bit on new assoc
* ceph: Don't forget the 'up_read(&osdc->map_sem)' if met error.
* libceph: unregister request in __map_request failed and nofail == false
* usb: config->desc.bLength may not exceed amount of data returned by the device
* USB: cdc-wdm: fix race between interrupt handler and tasklet
* powerpc: Handle unaligned ldbrx/stdbrx
* intel-iommu: Fix leaks in pagetable freeing
* drivers/misc/hpilo: Correct panic when an AUX iLO is detected
* USB: handle LPM errors during device suspend correctly
* xhci-plat: Don't enable legacy PCI interrupts.
* ath9k: fix rx descriptor related race condition
* ath9k: avoid accessing MRC registers on single-chain devices
* brcmsmac: Fix WARNING caused by lack of calls to dma_mapping_error()
* ext4: simplify truncation code in ext4_setattr()
* ext4: fix lost truncate due to race with writeback
* ASoC: wm8960: Fix PLL register writes
* rculist: list_first_or_null_rcu() should use list_entry_rcu()
* USB: mos7720: use GFP_ATOMIC under spinlock
* USB: mos7720: fix big-endian control requests
* arm64: perf: fix group validation when using enable_on_exec
* arm64: perf: fix ARMv8 EVTYPE_MASK to include NSH bit
* staging: comedi: dt282x: dt282x_ai_insn_read() always fails
* usb: ehci-mxc: check for pdata before dereferencing
* mmc: tmio_mmc_dma: fix PIO fallback on SDHI
* proc: Restrict mounting the proc filesystem
* usb: xhci: Disable runtime PM suspend for quirky controllers
* USB: OHCI: Allow runtime PM without system sleep
* pinctrl: at91: fix get_pullup/down function return
* ACPI / EC: Add HP Folio 13 to ec_dmi_table in order to skip DSDT scan
* ACPI / EC: Add ASUSTEK L4R to quirk list in order to validate ECDT
* HID: validate HID report id size
* cpuidle: coupled: abort idle if pokes are pending
* cpuidle: coupled: disable interrupts after entering safe state
* cpuidle: coupled: fix race condition between pokes and safe state
* of: Fix missing memory initialization on FDT unflattening
* leds: wm831x-status: Request a REG resource
* USB: fix build error when CONFIG_PM_SLEEP isn't enabled
* clk: wm831x: Initialise wm831x pointer on init
* drm/edid: add quirk for Medion MD30217PG
* drm/radeon: fix endian bugs in hw i2c atom routines
* drm/radeon: update line buffer allocation for dce4.1/5
* drm/radeon: update line buffer allocation for dce6
* drm/radeon: fix LCD record parsing
* drm/radeon: fix resume on some rs4xx boards (v2)
* drm/radeon: fix handling of variable sized arrays for router objects
* radeon kms: fix uninitialised hotplug work usage in r100_irq_process()
* pidns: Fix hang in zap_pid_ns_processes by sending a potentially extra wakeup
* x86, smap: Handle csum_partial_copy_*_user()
* Introduce [compat_]save_altstack_ex() to unbreak x86 SMAP
* drm: fix DRM_IOCTL_MODE_GETFB handle-leak
* HID: picolcd: Prevent NULL pointer dereference on _remove()
* HID: battery: don't do DMA from stack
* ALSA: hda - hdmi: Fallback to ALSA allocation when selecting CA
* fuse: postpone end_page_writeback() in fuse_writepage_locked()
* fuse: invalidate inode attributes on xattr modification
* media: coda: Fix DT driver data pointer for i.MX27
* s5p-g2d: Fix registration failure
* DocBook: upgrade media_api DocBook version to 4.2
* v4l2: added missing mutex.h include to v4l2-ctrls.h
* hdpvr: fix iteration over uninitialized lists in hdpvr_probe()
* exynos-gsc: Register v4l2 device
* fuse: readdir: check for slash in names
* MIPS: ath79: Fix ar933x watchdog clock
* libceph: use pg_num_mask instead of pgp_num_mask for pg.seed calc
* HID: pantherlord: validate output report details
* HID: ntrig: validate feature report details
* HID: sensor-hub: validate feature report details
* HID: picolcd_core: validate output report details
* HID: check for NULL field when setting values
* ARM: PCI: versatile: Fix map_irq function to match hardware
* ARM: PCI: versatile: Fix PCI I/O
* ARM: PCI: versatile: Fix SMAP register offsets
* net: mvneta: properly disable HW PHY polling and ensure adjust_link() works
* drm/i915: try not to lose backlight CBLV precision
* crypto: api - Fix race condition in larval lookup
* cifs: ensure that srv_mutex is held when dealing with ssocket pointer
* CIFS: Fix a memory leak when a lease break comes
* ALSA: hda - Add Toshiba Satellite C870 to MSI blacklist
* lguest: Point to the right directory for the lguest launcher
* powerpc: Default arch idle could cede processor on pseries
* ASoC: mc13783: add spi errata fix
* sd: Fix potential out-of-bounds access
* pidns: fix vfork() after unshare(CLONE_NEWPID)
* ocfs2: fix the end cluster offset of FIEMAP
* mm/huge_memory.c: fix potential NULL pointer dereference
* mm: fix aio performance regression for database caused by THP
* memcg: fix multiple large threshold notifications
* Linux 3.8.13.10

Steve Conklin (sconklin) on 2013-09-30
tags: added: kernel-stable-tracking-bug
Steve Conklin (sconklin) on 2013-09-30
description: updated
summary: - Raring update to 3.8.13.10 stable release
+ Raring update to 3.8.13.10 stable release (including 3.8.13.9 also)
Launchpad Janitor (janitor) wrote :
Download full text (9.5 KiB)

This bug was fixed in the package linux - 3.8.0-32.47

---------------
linux (3.8.0-32.47) raring; urgency=low

  [Steve Conklin]

  * Release Tracking Bug
    - LP: #1233777

  [ Upstream Kernel Changes ]

  * Revert "net/core/sock.c: add missing VSOCK string in
    af_family_*_key_strings"
    - LP: #1233227
  * Input: cypress_ps2 - Return zero finger count if palm is detected.
    - LP: #1229361
  * isofs: Refuse RW mount of the filesystem instead of making it RO
    - LP: #1228751
  * udf: Standardize return values in mount sequence
    - LP: #1228751
  * udf: Refuse RW mount of the filesystem instead of making it RO
    - LP: #1228751
  * ARM: update FIQ support for relocation of vectors
    - LP: #1233227
  * ARM: Fix FIQ code on VIVT CPUs
    - LP: #1233227
  * regmap: Add another missing header for !CONFIG_REGMAP stubs
    - LP: #1233227
  * ALSA: hda - Add inverted digital mic fixup for Acer Aspire One
    - LP: #1233227
  * mac80211: add missing channel context release
    - LP: #1233227
  * iwl4965: fix rfkill set state regression
    - LP: #1233227
  * ath9k_htc: Restore skb headroom when returning skb to mac80211
    - LP: #1233227
  * ath9k: Enable PLL fix only for AR9340/AR9330
    - LP: #1233227
  * ALSA: hda - Fix NULL dereference with CONFIG_SND_DYNAMIC_MINORS=n
    - LP: #1233227
  * lparcfg: don't bother saving pointer to proc_dir_entry
    - LP: #1233227
  * powerpc/pseries/lparcfg: Fix possible overflow are more than 1026
    - LP: #1233227
  * powerpc: Don't Oops when accessing /proc/powerpc/lparcfg without
    hypervisor
    - LP: #1233227
  * powerpc: Work around gcc miscompilation of __pa() on 64-bit
    - LP: #1233227
  * powerpc/hvsi: Increase handshake timeout from 200ms to 400ms.
    - LP: #1233227
  * net: Check the correct namespace when spoofing pid over SCM_RIGHTS
    - LP: #1233227
  * ALSA: opti9xx: Fix conflicting driver object name
    - LP: #1233227
  * SUNRPC: Fix memory corruption issue on 32-bit highmem systems
    - LP: #1233227
  * drivers/base/memory.c: fix show_mem_removable() to handle missing
    sections
    - LP: #1233227
  * memcg: check that kmem_cache has memcg_params before accessing it
    - LP: #1233227
  * workqueue: cond_resched() after processing each work item
    - LP: #1233227
  * drm/i915: ivb: fix edp voltage swing reg val
    - LP: #1233227
  * drm/vmwgfx: Split GMR2_REMAP commands if they are to large
    - LP: #1233227
  * af_key: initialize satype in key_notify_policy_flush()
    - LP: #1233227
  * Linux 3.8.13.9
    - LP: #1233227
  * zram: allow request end to coincide with disksize
    - LP: #1233227
  * mtd: nand: fix NAND_BUSWIDTH_AUTO for x16 devices
    - LP: #1233227
  * HID: hidraw: correctly deallocate memory on device disconnect
    - LP: #1233227
  * xen-gnt: prevent adding duplicate gnt callbacks
    - LP: #1233227
  * ath9k: always clear ps filter bit on new assoc
    - LP: #1233227
  * ceph: Don't forget the 'up_read(&osdc->map_sem)' if met error.
    - LP: #1233227
  * libceph: unregister request in __map_request failed and nofail == false
    - LP: #1233227
  * usb: config->desc.bLength may not exceed amount of data returned by the
    device
    - LP: #12332...

Read more...

Changed in linux (Ubuntu Raring):
status: New → Fix Released
Changed in linux (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers