[Dell XPS 13] Horizontal/Vertical scrolling feature on touchpad [CyPS/2 Cypress Trackpad] does not work.

Bug #1218166 reported by Po-Hsu Lin on 2013-08-29
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
HWE Next
Medium
Jesse Sung
linux (Ubuntu)
Medium
Jesse Sung

Bug Description

CID: 201209-11840 Dell XPS 13

Both of the edge scrolling feature (horizontal and vertical) does not work on this system.

ubuntu@201209-11840:~$ xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ CyPS/2 Cypress Trackpad id=12 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ Sleep Button id=9 [slave keyboard (3)]
    ↳ Laptop_Integrated_Webcam_1.3M id=10 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=11 [slave keyboard (3)]
    ↳ Dell WMI hotkeys id=13 [slave keyboard (3)]

There is no E7 value in dmesg, and the only EC value is:
ubuntu@201209-11840:~$ cat /var/log/dmesg| grep EC
[ 0.156762] ACPI: EC: Look up EC in DSDT
[ 0.181523] ACPI: EC: GPE = 0x17, I/O: command/status = 0x66, data = 0x62

This problem does not exist in 12.04.2

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.8.0-29-generic 3.8.0-29.42~precise1 [modified: boot/vmlinuz-3.8.0-29-generic]
ProcVersionSignature: Ubuntu 3.8.0-29.42~precise1-generic 3.8.13.5
Uname: Linux 3.8.0-29-generic x86_64
ApportVersion: 2.0.1-0ubuntu17.4
Architecture: amd64
Date: Wed Aug 28 22:40:56 2013
InstallationMedia: Ubuntu 12.04.3 LTS "Precise Pangolin" - Release amd64 (20130820.1)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: linux-lts-raring
UpgradeStatus: No upgrade log present (probably fresh install)
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version k3.8.0-29-generic.
ApportVersion: 2.0.1-0ubuntu17.4
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC275 Analog [ALC275 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1558 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xd0510000 irq 45'
   Mixer name : 'Intel PantherPoint HDMI'
   Components : 'HDA:10ec0275,1028058b,00100008 HDA:80862806,80860101,00100000'
   Controls : 29
   Simple ctrls : 11
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=7cf28595-73f5-41ba-b4a2-c7839c56eaec
InstallationMedia: Ubuntu 12.04.3 LTS "Precise Pangolin" - Release amd64 (20130820.1)
MachineType: Dell Inc. Dell System XPS L322X
MarkForUpload: True
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-29-generic.efi.signed root=UUID=f0ed3242-8409-4aac-b950-6e8b8cd1ff74 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.8.0-29.42~precise1-generic 3.8.13.5
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-29-generic N/A
 linux-backports-modules-3.8.0-29-generic N/A
 linux-firmware 1.79.6
Tags: precise running-unity
Uname: Linux 3.8.0-29-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 04/18/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A08
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA08:bd04/18/2013:svnDellInc.:pnDellSystemXPSL322X:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System XPS L322X
dmi.sys.vendor: Dell Inc.

Po-Hsu Lin (cypressyew) wrote :

apport information

affects: linux-lts-raring (Ubuntu) → linux (Ubuntu)
tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
Changed in linux (Ubuntu):
assignee: Anthony Wong (anthonywong) → Jesse Sung (wenchien)
Jesse Sung (wenchien) on 2013-09-12
Changed in linux (Ubuntu):
status: Confirmed → In Progress

Re-installed 12.04.2 and found that:

* On a fresh installed 12.04.2 with kernel 3.5.0-23, edge scroll works.
* After a system upgrade, kernel bumped to 3.5.0-40, and edge scroll stops working.
* Use the same file system above and boot with 3.5.0-23, edge scroll works again.

Something between 3.5.0-23 and 3.5.0-40 breaks the edge scroll support.

Po-Hsu Lin (cypressyew) on 2013-09-12
summary: - [Dell XPS 13] Horizontal/Vertical scrolling feature on touchpad does not
- work.
+ [Dell XPS 13] Horizontal/Vertical scrolling feature on touchpad [CyPS/2
+ Cypress Trackpad] does not work.
Jesse Sung (wenchien) wrote :

The breakage is between 3.5.0-27 and 3.5.0-28.

Ara Pulido (ara) on 2013-09-13
tags: added: blocks-hwcert-enablement
Bib (bybeu) on 2013-09-30
tags: added: l322x
Anthony Wong (anthonywong) wrote :

@jesse, wonder if the latest kernel has fixed this?

Changed in hwe-next:
importance: Undecided → Medium
assignee: nobody → Jesse Sung (wenchien)
Po-Hsu Lin (cypressyew) wrote :

Hello Anthony, Jesse
Verified with 14.04.1 stock image (3.13.0-32)
Both horizontal / vertical scrolling (two-finger) are working now.

Therefore I will mark this bug as fix-released.
Thanks

Changed in hwe-next:
status: New → Fix Released
Changed in linux (Ubuntu):
status: In Progress → Fix Released
Po-Hsu Lin (cypressyew) wrote :

BTW, with some more test, I found that the edge scrolling (both vertical and horizontal) are still not working.
Not even with 3.16 kernel (14.04.2 stock image)
I will revert the bug status after confirming this is a blocker.

Po-Hsu Lin (cypressyew) wrote :

Base on our certificate coverage guide, it will be a blocker if edge scrolling does not work, I will revert the bug status to confirmed, thanks!

Changed in hwe-next:
status: Fix Released → Confirmed
Changed in linux (Ubuntu):
status: Fix Released → Confirmed
Po-Hsu Lin (cypressyew) wrote :

Verified with the latest 3.13 kernel (3.13.0-46), it's still not working.
Also not working with 14.10 LiveUSB, not working with the latest mainline kernel 4.0.0-rc4

Jesse Sung (wenchien) wrote :

This is caused by the fix of lp:1103594.

The vital_statics_supported is disabled for fw_version >= 11 because it would introduce errors on XPS12. However the scrolling feature depends on the vital_statics_supported, and the touchpad of XPS13 reports that its fw_version is 11. I've tried to enable vital_statics_supported on XPS13 and found that scrolling works again.

Changed in hwe-next:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers