Imon LCD device number changes each boot

Bug #1186569 reported by mtbdrew
42
This bug affects 9 people
Affects Status Importance Assigned to Milestone
lcdproc (Ubuntu)
High
Dominique Dumont
linux (Ubuntu)
Low
Unassigned
udev (Ubuntu)
Wishlist
Unassigned

Bug Description

LCD display does not output anything, only back light works. sudo LCDd -f -r 4 gives follow output:

Server running in foreground
Listening for queries on 127.0.0.1:13666
imonlcd: using Device /dev/lcd0
imonlcd: ERROR opening /dev/lcd0 (No such file or directory).
imonlcd: Did you load the iMON kernel module?
Driver [imonlcd] init failed, return code -1
Module /usr/lib/lcdproc/imonlcd.so could not be loaded
Could not load driver imonlcd
There is no output driver
Critical error while initializing, abort.

Display worked correctly on Ubuntu 12.04

Andrew

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: lcdproc 0.5.5-2
ProcVersionSignature: Ubuntu 3.9.0-3.8-generic 3.9.4
Uname: Linux 3.9.0-3-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.10.2-0ubuntu1
Architecture: amd64
Date: Sat Jun 1 10:50:02 2013
InstallationDate: Installed on 2013-05-30 (2 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130529)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_US
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: lcdproc
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
mtbdrew (mtbdrew) wrote :
Revision history for this message
mtbdrew (mtbdrew) wrote :

Okay managed to figure this one out. Obviously the lcdproc install didn't/doesn't detect the actual /dev/lcd# used. /ect/LCDd.conf showed default settings for imon and imonlcd

# Select the output device to use [default: /dev/lcd0]
Device=/dev/lcd0

After checking /dev/ directory found only lcd2 device so changed the above line to:

# Select the output device to use [default: /dev/lcd0]
Device=/dev/lcd2

restarted LCDd:

sudo /etc/init.d/LCDd restart

And now display is working correctly.

Revision history for this message
Daniel Leidert (dleidert-deactivatedaccount) wrote :

It doesn't sound like a bug then.

Changed in lcdproc (Ubuntu):
status: New → Invalid
Revision history for this message
Bengt Nilsson (bnilsson11) wrote :

I have a related problem.
Exactly same symptoms and cause, except that the reason is that the device keeps changing between boots, sometimes /dev/lcd0, sometimes /dev/lcd1. Can it be "fixed" to a stable value?

Revision history for this message
Bonne Eggleston (bonne) wrote :

I think this is a valid bug, but probably not in lcdproc.

I have the same issue where the device number changes each boot between /dev/lcd0 /dev/lcd3 etc.

A bug in the imon kernel module?

Changed in lcdproc (Ubuntu):
status: Invalid → New
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lcdproc (Ubuntu):
status: New → Confirmed
Bonne Eggleston (bonne)
summary: - Imon LCD does not display anything
+ Imon LCD device number changes each boot
Changed in lcdproc (Ubuntu):
importance: Undecided → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu):
status: New → Confirmed
affects: linux → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

The package "lcdproc" is the one which has the kernel module, not the "Linux" one (http://www.mythtv.org/wiki/Imon#Introduction).

Changed in linux (Ubuntu):
status: Confirmed → Invalid
Changed in lcdproc (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
Joel Ebel (jbebel) wrote :

The module creating the node on my system is /lib/modules/3.11.0-15-generic/kernel/drivers/media/rc/imon.ko which is part of linux-image-3.11.0-15-generic.

Changed in linux (Ubuntu):
status: Invalid → Confirmed
Revision history for this message
Joel Ebel (jbebel) wrote :

Might be something udev could handle, like the persistent net and cd files in /etc/udev/rules.d.

Changed in udev (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
Revision history for this message
Martin Pitt (pitti) wrote :

Preferably lxcproc should stop using hardcoded names and detect devices it wants to talk to by their subsystem and properties. If it wants to it could ship some udev rules to help with identification or creating symlinks; but symlinks aren't supposed to help programs find devices, they are mostly a "human readable" thing. Thus wontfix in udev itself.

Changed in udev (Ubuntu):
status: Confirmed → Won't Fix
Revision history for this message
Joel Ebel (jbebel) wrote :

So this used to (At least as recently as 12.04) stably sit on /dev/lcd0, and now, as this bug indicates, it seems to pick randomly between /dev/lcd0 and /dev/lcd2. Is the kernel responsible for that? lcdproc is a pretty simple, and rather unmaintained program. Getting it to automatically detect which device is on what dev node seems rather out of its scope, particularly when I only have one lcd device, as I imagine most people with an lcd device do. It should always be in the same place.

Revision history for this message
Martin Pitt (pitti) wrote : Re: [Bug 1186569] Re: Imon LCD device number changes each boot

Joel Ebel [2014-02-10 3:23 -0000]:
> So this used to (At least as recently as 12.04) stably sit on /dev/lcd0,
> and now, as this bug indicates, it seems to pick randomly between
> /dev/lcd0 and /dev/lcd2. Is the kernel responsible for that?

Yes. It's indeed weird why it wouldn't start enumerating them at 0
always.

Revision history for this message
Dominique Dumont (domi-dumont) wrote :

Unless someone objects, I'll follow the suggestion given on this link http://linhes.org/issues/652#note-3 and modify lcdproc package to install a udev rules in /lib/udev/rules.d/79-imon-lcd.rules.

I'll tweak the proposed rules to be a little bit more restrictive.

I'll also patch server/drivers/imon.c to use the file created by the udev rule by default.

Thoughts ?

Changed in lcdproc (Ubuntu):
assignee: nobody → Dominique Dumont (domi-dumont)
Revision history for this message
Joel Ebel (jbebel) wrote :

In the absence of any explanation or solution as to why the device are showing up in different places, I think the udev solution makes the most sense.

Revision history for this message
Bengt Nilsson (bnilsson11) wrote :

This is the same as Bug #1216366.
Maybe they could be merged?

Changed in lcdproc (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Dominique Dumont (domi-dumont) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lcdproc - 0.5.7-2

---------------
lcdproc (0.5.7-2) unstable; urgency=medium

  * stop/start LCDd on suspend/wakeup (LP: #365474)
  * provide and use permanent symlink for imon device file (LP: #1186569)
    This requires udev for Linux.
  * control:
    + added depends on udev and libconfig-model-lcdproc-perl (>= 2.042-2)
    + added dependency on libconfig-model-perl >= 2.059 to avoid a bug

 -- Dominique Dumont <email address hidden> Sun, 06 Jul 2014 19:20:33 +0200

Changed in lcdproc (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers