Comment 3 for bug 1175533

That PCI ID is new to me, and I cannot find details about the actual part so I am hesitant to write a real patch. Paulo have you seen that one?

Since very limited people have access to HSW hardware at this point, you should be working through Intel or whatever vendor provided the HW to you for the proper fix. Also, as far as I can tell, the Haswell model you specify doesn't exist in any official Intel documentation. For that reason, I would again recommend you through whichever vendor provided the hardware to you (and close this bug)

With all that disclaimer above... If you'd like to fix it yourself, patches are welcome. In drivers/gpu/drm/i915/i915_drv.c, copy one and modify with your PCI ID.

        INTEL_VGA_DEVICE(0x0D02, &intel_haswell_d_info), /* CRW GT1 desktop */
        INTEL_VGA_DEVICE(0x0D12, &intel_haswell_d_info), /* CRW GT2 desktop */
        INTEL_VGA_DEVICE(0x0D22, &intel_haswell_d_info), /* CRW GT2 desktop */
        INTEL_VGA_DEVICE(0x0D0A, &intel_haswell_d_info), /* CRW GT1 server */
        INTEL_VGA_DEVICE(0x0D1A, &intel_haswell_d_info), /* CRW GT2 server */
        INTEL_VGA_DEVICE(0x0D2A, &intel_haswell_d_info), /* CRW GT2 server */
        INTEL_VGA_DEVICE(0x0D06, &intel_haswell_m_info), /* CRW GT1 mobile */
        INTEL_VGA_DEVICE(0x0D16, &intel_haswell_m_info), /* CRW GT2 mobile */
        INTEL_VGA_DEVICE(0x0D26, &intel_haswell_m_info), /* CRW GT2 mobile */

Keep in mind, just about every graphics component which needs PCI ids will have the same problem.