alx: network does not resume correctly

Bug #1172415 reported by Tim Gardner on 2013-04-24
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Tim Gardner
Nominated for Precise by AceLan Kao
Quantal
Undecided
Tim Gardner
Raring
Undecided
Tim Gardner
Saucy
Undecided
Tim Gardner

Bug Description

The alx driver fails to power up the device if the network interface is not running.

Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Quantal):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in linux (Ubuntu Raring):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Tim Gardner (timg-tpi) wrote :

SRU Justification:

Impact - network unavailable after suspend/resume

Patch description - remove check for netif_running() before the device is powered up.

tags: added: patch
Tim Gardner (timg-tpi) on 2013-05-06
Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Raring):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Saucy):
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-quantal
tags: added: verification-needed-raring
Tim Gardner (timg-tpi) wrote :

Tested on Lenovo x120e

tags: added: verification-done-quantal verification-done-raring
removed: verification-needed-quantal verification-needed-raring
AceLan Kao (acelankao) on 2013-05-23
tags: added: blocks-hwcert-enablement

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

AceLan Kao (acelankao) on 2013-06-13
Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Raring):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers