Samsung Laptop support module doesn't load

Bug #1170885 reported by David Schoen
72
This bug affects 16 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Similarly to Bug #1012284 "Samsung Laptop support module refuse to load for Samsung 900X3C" I'm trying to load "samsung_laptop" in to the kernel so that I can access functionality provided under /sys/devices/platform/samsung (like keyboard backlight control).

When doing a modprobe I get "No such device":
# modprobe samsung-laptop
FATAL: Error inserting samsung_laptop (/lib/modules/3.5.0-27-generic/kernel/drivers/platform/x86/samsung-laptop.ko): No such device

I also tried a mainline build, as per https://wiki.ubuntu.com/KernelMainlineBuilds , and got the same result:
# modprobe samsung-laptop
FATAL: Error inserting samsung_laptop (/lib/modules/3.9.0-999-generic/kernel/drivers/platform/x86/samsung-laptop.ko): No such device
# uname -a
Linux sammy.lyte 3.9.0-999-generic #201304190456 SMP Fri Apr 19 08:57:39 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

I'm not sure if this is a regression from the previous fix or simply slightly different hardware.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-generic 3.5.0.27.43
ProcVersionSignature: Ubuntu 3.5.0-27.46-generic 3.5.7.7
Uname: Linux 3.5.0-27-generic x86_64
ApportVersion: 2.6.1-0ubuntu10
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dschoen 2693 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory: 'iw'
Date: Sat Apr 20 15:12:20 2013
HibernationDevice: RESUME=UUID=de097eb6-c8eb-47b8-b020-f209468bcb36
InstallationDate: Installed on 2012-12-10 (130 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: SAMSUNG ELECTRONICS CO., LTD. 900X3C/900X3D/900X4C/900X4D
MarkForUpload: True
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.5.0-27-generic root=/dev/mapper/sammy-root ro rootflags=subvol=@
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-27-generic N/A
 linux-backports-modules-3.5.0-27-generic N/A
 linux-firmware 1.95
SourcePackage: linux
UpgradeStatus: Upgraded to quantal on 2013-03-09 (42 days ago)
dmi.bios.date: 09/19/2012
dmi.bios.vendor: Phoenix Technologies Ltd.
dmi.bios.version: P02ABK
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: NP900X3C-A06AU
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: FAB1
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvrP02ABK:bd09/19/2012:svnSAMSUNGELECTRONICSCO.,LTD.:pn900X3C/900X3D/900X4C/900X4D:pvr0.1:rvnSAMSUNGELECTRONICSCO.,LTD.:rnNP900X3C-A06AU:rvrFAB1:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvr0.1:
dmi.product.name: 900X3C/900X3D/900X4C/900X4D
dmi.product.version: 0.1
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

Revision history for this message
David Schoen (neerolyte) wrote :
Revision history for this message
Brad Figg (brad-figg) wrote : Status changed to Confirmed

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: kernel-bug-exists-upstream
Revision history for this message
Joseph Salisbury (jsalisbury) wrote : Re: Samsung Laptop support module doesn't load for Samsung NP900X3C-A06AU

It would be good to know if this is a regression, or if a new quirk is needed. Can you test the final v3.2 kernel to see if the bug exists there as well:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-precise/

tags: added: kernel-da-key
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Roland G (rolandg) wrote :

Same here on Ubuntu 13.04 64bit..

$ uname -a
Linux nbk-iselba 3.8.0-19-generic #30-Ubuntu SMP Wed May 1 16:35:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

# modprobe samsung-laptop debug=1
ERROR: could not insert 'samsung_laptop': No such device

My Laptop is Samsung 900X4c

Revision history for this message
Herczeg Zsolt (herczegzsolt) wrote :

I have the same bug on my Samsung Series 7 notebook. The modul would be important to set the keyboard backlight.

# modprobe samsung-laptop
ERROR: could not insert 'samsung_laptop': No such device

I've tried to compile and insert the latest samsung_laptop module from the git repos, but it fails with the same message:

# insmod Asztal/samsung-laptop-dkms-master/drivers/platform/x86/samsung-laptop.ko
Error: could not insert module Asztal/samsung-laptop-dkms-master/drivers/platform/x86/samsung-laptop.ko: No such device

I'll try it now with a Precise Pangolin live CD to see if it loads.

How can I help more on fixing this bug?

Revision history for this message
Herczeg Zsolt (herczegzsolt) wrote :

Results on a brand new Precise Pangolin Live CD with a Samsung Series 7 Chronos book.

root@ubuntu:/sys# uname -a
Linux ubuntu 3.5.0-23-generic #35~precise1-Ubuntu SMP Fri Jan 25 17:13:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
root@ubuntu:/sys# modprobe samsung-laptop
FATAL: Error inserting samsung_laptop (/lib/modules/3.5.0-23-generic/kernel/drivers/platform/x86/samsung-laptop.ko): No such device

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

A new Precise install will now contain the 3.5 Quantal kernel. I'd like to see if this regression was introduced in the 3.5 kernel. Can folks affected by this confirm that the bug does not exist with the 3.2 kernel? The 3.2 final kernel can be downloaded from:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-precise/

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

I think this commit in Quantal is causing this bug:

commit 59344775ade604f9817e21e0951cf4aa3799ec6d
Author: Matt Fleming <email address hidden>
Date: Thu Jan 3 09:02:37 2013 +0000

    samsung-laptop: Disable on EFI hardware

Can folks affected by this confirm their machines are EFI capable?

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

If you have EFI hardware, it is documented in the Quantal release notes[0] that it should be booted in legacy BIOS mode. It looks like this is still the case with Raring as well.

[0] https://wiki.ubuntu.com/QuantalQuetzal/ReleaseNotes/UbuntuDesktop

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

This is the latest commit to samsung-laptop in mainline, so this behavior is still expected.

commit e0094244e41c4d0c7ad69920681972fc45d8ce34
Author: Matt Fleming <email address hidden>
Date: Thu Jan 3 09:02:37 2013 +0000

    samsung-laptop: Disable on EFI hardware

Changed in linux (Ubuntu):
status: Incomplete → Invalid
Alix Axel (alix-axel)
Changed in linux (Ubuntu):
status: Invalid → Opinion
Revision history for this message
Vins (stmos) wrote :

If I understand correctly, the module samsung-laptop can't be loaded in EFI mode. And this is "by choice". Are there any plans to support UEFI mode? Is anyone working on this or it will never be resolved? Thanks!

Revision history for this message
Peter Ries (peterriesde) wrote :

Another Laptop here (Samsung Ativ Book 7 - type: 730U3E-X04DE). It's not on the list of hardware known to brick in UEFI mode. So I installed it in UEFI mode. Samsung-laptop is not loaded here as well so some minimal things are not working properly (keyboard illumination, fan-control, WiFi switch).

I'd like to know if it's worth waiting for a reactivation of the kernel module in UEFI mode or if I should switch my installation to BIOS (CSM) mode.

Thanks for any information on this!

Revision history for this message
Fabio (mr-fabio90) wrote :

Any news with this module? CSM mode seems to be much faster than UEFI one on my samsung 535u3c. Any plans to reactivate this module on samsung laptops?

Revision history for this message
sqr163 (sqr163) wrote :

$ sudo dmidecode | grep -A 2 -i 'base board'
Base Board Information
 Manufacturer: SAMSUNG ELECTRONICS CO., LTD.
 Product Name: NP740U3M-K01US

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04.3 LTS"

$ sudo modprobe samsung-laptop
modprobe: ERROR: could not insert 'samsung_laptop': No such device

$ file /sys/firmware/efi
/sys/firmware/efi: directory

summary: - Samsung Laptop support module doesn't load for Samsung NP900X3C-A06AU
+ Samsung Laptop support module doesn't load
Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

sqr163, please file a new bug, thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers