Support of specific Atheros 3012 device for precise kernel

Bug #1168852 reported by Sergey on 2013-04-14
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Joseph Salisbury
Precise
Medium
Joseph Salisbury
Quantal
Medium
Joseph Salisbury

Bug Description

Hello!

I'm using an Acer Aspire S3 laptop with Atheros 3012 bluetooth module. The problem is that I cannot detect nor pair to any bluetooth device. The list of detected bluetooth devices always remains empty.

Further inspection revealed that it is a well-known problem that can be solved by adding the proper device id to the following two files:

/drivers/bluetooth/btusb.c
/drivers/bluetooth/ath3k.c

I've downloaded the current precise kernel source from the git repository and looked at these two files. There are a total of 8 different Atheros AR3012 device ids supported , however my particular device id (0x04ca 0x3004) was not mentioned. The id is exactly (0x04ca 0x3004) and not the (apparently more popular) (0x04ca 0x3005) and (0x0cf3 0x3004) which are present in these lists.

I propose fixing this problem by adding my device id into these two files.

Here's the output of usb-devices command:

T: Bus=01 Lev=02 Prnt=02 Port=03 Cnt=01 Dev#= 3 Spd=12 MxCh= 0
D: Ver= 1.10 Cls=e0(wlcon) Sub=01 Prot=01 MxPS=64 #Cfgs= 1
P: Vendor=04ca ProdID=3004 Rev=00.01
S: Manufacturer=Atheros Communications
S: Product=Bluetooth USB Host Controller
S: SerialNumber=Alaska Day 2006
C: #Ifs= 2 Cfg#= 1 Atr=e0 MxPwr=100mA
I: If#= 0 Alt= 0 #EPs= 3 Cls=e0(wlcon) Sub=01 Prot=01 Driver=btusb
I: If#= 1 Alt= 0 #EPs= 2 Cls=e0(wlcon) Sub=01 Prot=01 Driver=btusb
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.25.
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC271X Analog [ALC271X Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: 1896 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xc0500000 irq 43'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:10ec0269,10250635,00100100 HDA:80862805,80860101,00100000'
   Controls : 20
   Simple ctrls : 8
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=0e415410-e4d2-4ade-b8d8-700f2f15a55e
MachineType: Acer Aspire S3
MarkForUpload: True
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-27-generic root=UUID=1c28506d-5e2e-41b0-a914-b67ae54edac0 ro crashkernel=384M-2G:64M,2G-:128M quiet splash pcie_aspm=force i915.semaphores=1 i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1 acpi_osi=Linux acpi_backlight=vendor elevator=noop vt.handoff=7
ProcVersionSignature: Ubuntu 3.5.0-27.46~precise1-generic 3.5.7.7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-27-generic N/A
 linux-backports-modules-3.5.0-27-generic N/A
 linux-firmware 1.79.1
StagingDrivers: rts5139
Tags: precise running-unity staging
Uname: Linux 3.5.0-27-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 09/28/2011
dmi.bios.vendor: INSYDE
dmi.bios.version: 1.15
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Aspire S3
dmi.board.vendor: Acer
dmi.board.version: 1.15
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvr1.15:bd09/28/2011:svnAcer:pnAspireS3:pvr1.15:rvnAcer:rnAspireS3:rvr1.15:cvnAcer:ct10:cvrChassisVersion:
dmi.product.name: Aspire S3
dmi.product.version: 1.15
dmi.sys.vendor: Acer

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1168852

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: precise

apport information

tags: added: apport-collected running-unity staging
description: updated

apport information

apport information

Sergey (islife) wrote : BootDmesg.txt

apport information

Sergey (islife) wrote : CRDA.txt

apport information

apport information

apport information

apport information

apport information

Sergey (islife) wrote : IwConfig.txt

apport information

Sergey (islife) wrote : Lspci.txt

apport information

Sergey (islife) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

apport information

Sergey (islife) wrote : RfKill.txt

apport information

Sergey (islife) wrote : UdevDb.txt

apport information

Sergey (islife) wrote : UdevLog.txt

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Joseph Salisbury (jsalisbury)
status: Confirmed → In Progress
Joseph Salisbury (jsalisbury) wrote :

It appears this bug is already fixed in the mainline kernel with commit: 3f63c34

I'll cherrypick this commit into Precise and build a test kernel. I'll post a link shortly.

Joseph Salisbury (jsalisbury) wrote :

I built a test kernel with the following mainline commit applied: 3f63c34

The test kernel can be downloaded from:
http://people.canonical.com/~jsalisbury/lp1168852

Can you test that kernel and report back if it has the bug or not?

Thanks in advance

Sergey (islife) wrote :

Thank you very much!
I've downloaded and installed the kernel you gave to me. And the bluetooth module now appears to be working correctly.

In the meantime I attempted to make a custom kernel based on quantal repository. (Of course, I failed, as I am new to linux :). My builds were not even able to load the filesystem correctly). However, given the fact that there is no that particular fix present in the quantal git repository (at least I was unable to find it by the prefix you mentioned in gitk), this problem should also exist for 3.5 kernels.

Sergey (islife) on 2013-04-15
description: updated
Joseph Salisbury (jsalisbury) wrote :

Thanks for testing! I'll submit an SRU request to have commit 3f63c34 included in Precise and Quantal.

Changed in linux (Ubuntu Precise):
status: New → In Progress
Changed in linux (Ubuntu Quantal):
status: New → In Progress
Changed in linux (Ubuntu Precise):
importance: Undecided → Medium
Changed in linux (Ubuntu Quantal):
importance: Undecided → Medium
Changed in linux (Ubuntu Precise):
assignee: nobody → Joseph Salisbury (jsalisbury)
Changed in linux (Ubuntu Quantal):
assignee: nobody → Joseph Salisbury (jsalisbury)
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-precise
tags: added: verification-needed-quantal
Brad Figg (brad-figg) on 2013-05-17
Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Brad Figg (brad-figg) wrote :

This was just the addition of the appropriate USB id added to the appropriate tables.

tags: added: verification-done-precise verification-done-quantal
removed: verification-needed-precise verification-needed-quantal

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Julian Wiedmann (jwiedmann) wrote :

Released with 3.2.0-44.69 and 3.5.0-31.52.

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
Julian Wiedmann (jwiedmann) wrote :

commit 3f63c340a72f2872a9362245cb2e03f3d2bb73a6
Author: Josh Boyer <email address hidden>
Date: Tue Feb 19 11:54:16 2013 -0500

    Bluetooth: Add support for atheros 04ca:3004 device to ath3k

also landed in Saucy (with 3.9rc4), but is missing from Raring.
Kamal (subscribed), looks like a candidate for your 3.8.y series?

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers