1002:9808 [Lenovo E435, M490s]: Brightness controls do not work

Bug #1157440 reported by Jeff Marcom on 2013-03-19
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
amd
Undecided
Jammy Zhou
linux (Ubuntu)
Medium
James M. Leddy
Precise
Undecided
Unassigned

Bug Description

Problem:

Brightness keys or brightness settings controls do not change the brightness or display as intended.

However, If I run the following command it works perfectly:
xrandr --output LVDS --brightness 0.5

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.5.0-23-generic 3.5.0-23.35~precise1
ProcVersionSignature: Ubuntu 3.5.0-23.35~precise1-generic 3.5.7.2
Uname: Linux 3.5.0-23-generic x86_64
NonfreeKernelModules: wl
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.25.
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 1: Generic_1 [HD-Audio Generic], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ubuntu 2137 F.... pulseaudio
 /dev/snd/controlC0: ubuntu 2137 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Generic'/'HD-Audio Generic at 0xf0544000 irq 46'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 6
   Simple ctrls : 1
Card0.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Card1.Amixer.info:
 Card hw:1 'Generic_1'/'HD-Audio Generic at 0xf0540000 irq 16'
   Mixer name : 'Conexant CX20590'
   Components : 'HDA:14f1506e,17aa5108,00100003'
   Controls : 20
   Simple ctrls : 10
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw unknown'
   Mixer name : 'ThinkPad EC (unknown)'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Tue Mar 19 17:49:29 2013
HibernationDevice: RESUME=UUID=ee9d3e8f-05df-494c-afc6-36438c39723b
InstallationMedia: Ubuntu 12.04.2 LTS "Precise Pangolin" - Release amd64 (20130213)
MachineType: LENOVO 3469C01
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-23-generic root=UUID=5396c06a-e550-4e31-b4f5-d953a397915f ro quiet splash initcall_debug vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-23-generic N/A
 linux-backports-modules-3.5.0-23-generic N/A
 linux-firmware 1.79.1
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/30/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: HNET14WW (1.01 )
dmi.board.asset.tag: Not Available
dmi.board.name: 3469C01
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrHNET14WW(1.01):bd05/30/2012:svnLENOVO:pn3469C01:pvrThinkPadEdgeE435:rvnLENOVO:rn3469C01:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 3469C01
dmi.product.version: ThinkPad Edge E435
dmi.sys.vendor: LENOVO

Jeff Marcom (jeffmarcom) wrote :
Changed in linux (Ubuntu):
assignee: nobody → Canonical Hardware Enablement Team (canonical-hwe-team)
tags: added: 201205-11037 blocks-hwcert blocks-hwcert-enablement lexington-lab

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

This has never worked. The enablement team has narrowed down to an AMD driver issue, but AMD never fixed their proprietary driver.

James M. Leddy (jm-leddy) wrote :

Anthony mentioned in https://bugs.launchpad.net/certify-planning/+bug/1061210 that brightness keys are grey-list. Is this still the case?

Changed in linux (Ubuntu):
assignee: Canonical Hardware Enablement Team (canonical-hwe-team) → James M. Leddy (jm-leddy)
status: Confirmed → Incomplete
Jeff Marcom (jeffmarcom) wrote :

@ James, yes keys are grey-list however the software controls in gnome-control-center Sound also don't work.

Changed in linux (Ubuntu):
status: Incomplete → New

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu Precise):
status: New → Confirmed
Daniel Manrique (roadmr) on 2013-05-25
Changed in linux (Ubuntu):
importance: Undecided → Medium

Still an issue in 12.04.3

tags: added: 201211-12079
summary: - [Lenovo E435]: Brightness controls do not work
+ [Lenovo E435, M490s]: Brightness controls do not work

Hi Jeff,

I'll raise this to AMD, but I don't think it's going to be a high priority since it is not cert blocker and it is not blocking shipment.

Changed in amd:
assignee: nobody → Jammy Zhou (jammy-zhou)
Jeff Marcom (jeffmarcom) wrote :

It is a blocker though, neither the keys or the settings control allow you to change the brightness settings appropriately.

James M. Leddy (jm-leddy) wrote :

There is an inconsistency, insofar that we never resolved the hardware private bug 979884, but we marked the same hardware certified on the pre-install image. I'll ask AMD to take a look.

James M. Leddy (jm-leddy) wrote :

AMD has fixed a similar issue on other platforms. This fix is different on each hardware, and ASIC. AMD may have to take a look at the actual hardware to fix it.

James M. Leddy (jm-leddy) wrote :

Jeff, are we able to ship the hardware to AMD so that they can fix the problem?

Changed in amd:
status: New → Incomplete
summary: - [Lenovo E435, M490s]: Brightness controls do not work
+ 1002:9808 [Lenovo E435, M490s]: Brightness controls do not work

Jeff Marcom, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, please just make a comment to this.

If reproducible, could you also please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc6

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: bios-outdated-1.03
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-upstream-testing
Diego-MX (diego-mx) wrote :

I have this problem on Ubuntu 15.04, my laptop is Lenovo Ideapad P500.
This is a fresh install.
I already tried several workaround from stack overflow, and none worked.

Diego-MX, it will help immensely if you filed a new report via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

Diego-MX (diego-mx) wrote :

Thank you Christopher.
I was able to solve the problem by modifying some GRUB settings that I found in an Archlinux post; strangely, the others that I found in StackExchange properly for Ubuntu didn't do the job.

I wondered if you still recommend posting about it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers