HP Envy 23 AIO - No way to dim display

Bug #1152544 reported by Jeff Lane on 2013-03-08
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
HWE Next
High
Unassigned
linux (Ubuntu)
High
Unassigned

Bug Description

There is a test for cert that dims the display automatically to 50% and then raises the brightness back to 100%. This test failed to change the brightness at all on the Envy 23.

I then tried using the Brightness and Lock too in the System Settings menu, and the Brightness slider had no effect at all on the display.

There is no working method to alter screen brightness.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.5.0-23-generic 3.5.0-23.35~precise1
ProcVersionSignature: Ubuntu 3.5.0-23.35~precise1-generic 3.5.7.2
Uname: Linux 3.5.0-23-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.25.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1708 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf7c00000 irq 51'
   Mixer name : 'IDT 92HD91BXX'
   Components : 'HDA:111d76e0,103c2adc,00100102'
   Controls : 18
   Simple ctrls : 9
Date: Fri Mar 8 05:41:43 2013
HibernationDevice: RESUME=UUID=5a0be338-b72f-4759-947d-2c799a9951e2
InstallationMedia: Ubuntu 12.04.2 LTS "Precise Pangolin" - Release amd64 (20130213)
MachineType: Hewlett-Packard 520-1299
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-23-generic root=UUID=759df16a-1f46-4f4e-b7b7-bff65b4d6bec ro quiet splash initcall_debug vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-23-generic N/A
 linux-backports-modules-3.5.0-23-generic N/A
 linux-firmware 1.79.1
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
StagingDrivers: rts_pstor
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/25/2012
dmi.bios.vendor: AMI
dmi.bios.version: 8.10
dmi.board.asset.tag: 3CR2080BJX
dmi.board.name: 2ADC
dmi.board.vendor: PEGATRON CORPORATION
dmi.board.version: 1.05
dmi.chassis.asset.tag: 3CR2080BJX
dmi.chassis.type: 3
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnAMI:bvr8.10:bd09/25/2012:svnHewlett-Packard:pn520-1299:pvr1.00:rvnPEGATRONCORPORATION:rn2ADC:rvr1.05:cvnHewlett-Packard:ct3:cvr:
dmi.product.name: 520-1299
dmi.product.version: 1.00
dmi.sys.vendor: Hewlett-Packard

Jeff Lane (bladernr) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Anthony Wong (anthonywong) wrote :

This issue was caused by a BIOS bug but should already been fixed, need to investigate why it happens again.

Changed in linux (Ubuntu):
assignee: Canonical Hardware Enablement Team (canonical-hwe-team) → Keng-Yu Lin (lexical)
Anthony Wong (anthonywong) wrote :

Keng-yu, please see bug 1023760/1015475 for reference.

Keng-Yu Lin (lexical) wrote :
Changed in linux (Ubuntu):
importance: Undecided → High

Jeff Lane, could you please provide the full computer model as noted on the sticker (ex. HP ENVY 23-1060 All-in-One Desktop PC)?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-full-computer-model
Joshua Lee (lee-joshwa) wrote :

I experience the same behavior from the following machine:

HP ENVY 23se-d494

No backlight interface is detected.

Joshua Lee, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Joshua Lee (lee-joshwa) wrote :

Christopher M. Penalver, thank you for your response. I have filed a new bug report with multiple files and have also tested the upstream kernel. The new bug report may be located here:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1287528

Keng-Yu Lin (lexical) on 2014-03-12
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
importance: High → Medium
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Changed in linux (Ubuntu):
importance: Medium → High
assignee: Keng-Yu Lin (lexical) → Edward Lin (airken)
Edward Lin (airken) wrote :

Tried "acpi_backlight=vendor" and "video.use_native_backlight=1", the bug still exists.

Tried to downgrade BIOS mentioned in https://bugs.launchpad.net/stella/hwe-stella/+bug/1023760/comments/12
Failed to reflash the BIOS.

And I can't access the BIOS mentioned in https://bugs.launchpad.net/stella/hwe-stella/+bug/1023760/comments/24

Edward Lin (airken) on 2014-06-05
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Edward Lin (airken) wrote :

Unable to downgrade BIOS 804 mentioned in https://bugs.launchpad.net/stella/hwe-stella/+bug/1023760/comments/24
I suspect that bug #1023760 does not verify HP Envy 23 AIO (heineken5)

Edward Lin (airken) wrote :

According to https://bugs.launchpad.net/stella/hwe-stella/+bug/1023760/comments/13 ,
the backlight function should work on 12.04 if BIOS fixed this issue.

But backlight function is still broken on 12.04(amd64, i386), 11.04 and 14.04.

Changed in linux (Ubuntu):
assignee: Edward Lin (airken) → nobody
Changed in hwe-next:
importance: Undecided → High
assignee: nobody → Alex Hung (alexhung)
Alex Hung (alexhung) wrote :

I checked BIOS 8.10 (current version), and the ACPI device DD02 has _BCL/_BCM/_BQC methods unlike the BIOS that fixed it in https://bugs.launchpad.net/stella/hwe-stella/+bug/1023760/comments/13.

If the ACPI device LCD0 is used (ex. calling its _BCM), the brightness will change accordingly. It seems newer BIOS from HP removed the original fix.

I am not certain new BIOS update for this bug is possible since it is from 2012...

Changed in hwe-next:
status: New → Incomplete
assignee: Alex Hung (alexhung) → Anthony Wong (anthonywong)
Anthony Wong (anthonywong) wrote :

According to the above investigation, it is a bios regression and not much we can do about it.

Changed in hwe-next:
assignee: Anthony Wong (anthonywong) → nobody
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers