[Toshiba Satellite A80] Kernel 3.8.x Panic when disconnecting from network manager via ppp0

Bug #1144322 reported by Gurvender.Bahia on 2013-03-04
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Arch Linux
Fix Released
Undecided
Unassigned
Gentoo Linux
Fix Released
Medium
linux (Ubuntu)
High
Unassigned

Bug Description

Using: "Ubuntu 12.04 (precise) 32-bit" Machine: Laptop / old Toshiba / Celeron processor
Installing Kernel from: "http://kernel.ubuntu.com/~kernel-ppa/mainline/"

Apport disabled and uninstalled, so can't provide debug/log details (this to make the machine run a bit faster, have been doing so since 10.04). Have no problem with Kernel upto 3.7.10 (have been upgrading to Kernel 3.5/3.6/3.7/3.8, when ever new builds are available) But when using Kernel 3.8.0/3.8.1/3.8.2, get Kernel Panic & machine crashes & freezes, have to hard boot.

Machine connects to net using "ppp0" (modem on phone), then if you disconnect the modem "ppp0" & try to reconnect, the Kernel Panics & crashes, or then if you disconnect by unchecking "Enable Networking" & then rechecking "Enable Networking", the Kernel Panics & crashes.

First faced this problem with Kernel 3.8.0 so went back to using 3.7.9, then same story repeated with Kernel 3.8.1 & 3.8.2, currently using Kernel 3.7.10. Think there is some REGRESSION in Kernel 3.8

below details are provided using "HardInfo 0.5.1" :
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1144322/+attachment/3761201/+files/hardinfo
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu17.3
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1880 F.... pulseaudio
 /dev/snd/seq: timidity 1424 F.... timidity
Card0.Amixer.info:
 Card hw:0 'ICH6'/'Intel ICH6 with ALC250 at irq 17'
   Mixer name : 'Realtek ALC250 rev 2'
   Components : 'AC97a:414c4752'
   Controls : 33
   Simple ctrls : 21
DistroRelease: Ubuntu 12.04
MachineType: TOSHIBA Satellite A80
MarkForUpload: True
Package: linux (not installed)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-51-generic-pae root=UUID=4dda5c0a-3583-45f5-b6c4-b5aef19935c8 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-51.77-generic-pae 3.2.48
PulseList:
 Error: command ['pacmd', 'list'] failed with exit code 1: Home directory /home/ubuntu not ours.
 No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-51-generic-pae N/A
 linux-backports-modules-3.2.0-51-generic-pae N/A
 linux-firmware 1.79.6
Tags: precise
Uname: Linux 3.2.0-51-generic-pae i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 10/25/2006
dmi.bios.vendor: TOSHIBA
dmi.bios.version: V2.80
dmi.board.name: EAT10/EAT20
dmi.board.vendor: TOSHIBA
dmi.board.version: Null
dmi.chassis.asset.tag: *
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnTOSHIBA:bvrV2.80:bd10/25/2006:svnTOSHIBA:pnSatelliteA80:pvrPSA80L-043003:rvnTOSHIBA:rnEAT10/EAT20:rvrNull:cvnTOSHIBA:ct10:cvrN/A:
dmi.product.name: Satellite A80
dmi.product.version: PSA80L-043003
dmi.sys.vendor: TOSHIBA

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1144322

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → New
Download full text (29.3 KiB)

Dear Brad

I have no Apport installed, this is what I get:
______________________________________
ubuntu@HSB:~$ apport-collect 1144322
The program 'apport-collect' is currently not installed. You can install it
by typing:
sudo apt-get install apport
ubuntu@HSB:~$
______________________________________

Kernel 3.7.10 is working fine, get problem only with kernel 3.8.0 to 3.8.2

 Warm Regards,
ਗੁਰਵਿੰਦਰ ਪਾਲ ਸਿੰਘ ਬਾਹਿਆ ।।
Gurvender Bahia.

____________________________
*sent from Ubuntu(LINUX) on Aircel-3G**

*
HSB ©®

On Mon, Mar 4, 2013 at 6:30 PM, Brad Figg <email address hidden> wrote:

> This bug is missing log files that will aid in diagnosing the problem.
> >From a terminal window please run:
>
> apport-collect 1144322
>
> and then change the status of the bug to 'Confirmed'.
>
> If, due to the nature of the issue you have encountered, you are unable
> to run this command, please add a comment stating that fact and change
> the bug status to 'Confirmed'.
>
> This change has been made by an automated script, maintained by the
> Ubuntu Kernel Team.
>
> ** Changed in: linux (Ubuntu)
> Status: New => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1144322
>
> Title:
> Kernel Panic in 3.8.0, 3.8.1 & 3.8.2 when diconnecting from network
> manager, using ppp0 to connect to net
>
> Status in “linux” package in Ubuntu:
> New
>
> Bug description:
> Using: "Ubuntu 12.04 (precise) 32-bit"
> Machine: Laptop / old Toshiba / Celeron processor
> Installing Kernel from: "http://kernel.ubuntu.com/~kernel-ppa/mainline/"
>
> Apport disabled and uninstalled, so can't provide debug/log details
> (this to make the machine run a bit faster, have been doing so since
> 10.04)
>
> Have no problem with Kernel upto 3.7.10 (have been upgrading to Kernel
> 3.5/3.6/3.7/3.8, when ever new builds are available)
> But when using Kernel 3.8.0/3.8.1/3.8.2, get Kernel Panic & machine
> crashes & freezes, have to hard boot.
>
> PROBLEM #############################################
> Machine connects to net using "ppp0" (modem on phone), then if you
> disconnect the modem "ppp0" & try to reconnect, the Kernel Panics &
> crashes.
>
> Machine connects to net using "ppp0" (modem on phone), then if you
> disconnect by unchecking "Enable Networking" & then rechecking "Enable
> Networking", the Kernel Panics & crashes.
>
> ####################################################
>
> First faced this problem with Kernel 3.8.0 so went back to using
> 3.7.9, then same story repeated with Kernel 3.8.1 & 3.8.2, currently
> using Kernel 3.7.10. Think there is some REGRESSION in Kernel 3.8
>
> I really apologize for not able to provide Apport logs as I have
> uninstalled it a long time ago. I'm not a hard core techie, I'm self
> taught Linux user & enthusiast. My main machine is Ubuntu since 2007.
>
>
>
>
>
>
> _________________________________________________
>
> below details are provided using "HardInfo 0.5.1" :
>
> ComputerSummary
> Computer
> Processor Intel(R) Celeron(R) M processor 1.40GHz
> Memory ...

Download full text (29.8 KiB)

Dear Brad

I have no Apport installed, this is what I get:
______________________________________
ubuntu@HSB:~$ apport-collect 1144322
The program 'apport-collect' is currently not installed. You can install it
by typing:
sudo apt-get install apport
ubuntu@HSB:~$
______________________________________

Kernel 3.7.10 is working fine, get problem only with kernel 3.8.0 to 3.8.2

1) I have to install Apport
2) I have to reinstall Kernel 3.8.2
3) My Kernel logs are written to /tmp, hence they get deleted upon restart,
I have to reset the path of the Kernel logs

Please don't take it otherwise, It will take too much of time (I know other
people time is also more important) but I have to work on a deadline & all
I want to do is help by reporting this this bug in kernel 3.8.0
Surely I will try to manage time and do all the above 3 steps, but it will
a little hard for me now. I really really apologize.

 Warm Regards,
ਗੁਰਵਿੰਦਰ ਪਾਲ ਸਿੰਘ ਬਾਹਿਆ ।।
Gurvender Bahia.

____________________________
*sent from Ubuntu(LINUX) on Aircel-3G**

*
HSB ©®

On Mon, Mar 4, 2013 at 6:30 PM, Brad Figg <email address hidden> wrote:

> This bug is missing log files that will aid in diagnosing the problem.
> >From a terminal window please run:
>
> apport-collect 1144322
>
> and then change the status of the bug to 'Confirmed'.
>
> If, due to the nature of the issue you have encountered, you are unable
> to run this command, please add a comment stating that fact and change
> the bug status to 'Confirmed'.
>
> This change has been made by an automated script, maintained by the
> Ubuntu Kernel Team.
>
> ** Changed in: linux (Ubuntu)
> Status: New => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1144322
>
> Title:
> Kernel Panic in 3.8.0, 3.8.1 & 3.8.2 when diconnecting from network
> manager, using ppp0 to connect to net
>
> Status in “linux” package in Ubuntu:
> New
>
> Bug description:
> Using: "Ubuntu 12.04 (precise) 32-bit"
> Machine: Laptop / old Toshiba / Celeron processor
> Installing Kernel from: "http://kernel.ubuntu.com/~kernel-ppa/mainline/"
>
> Apport disabled and uninstalled, so can't provide debug/log details
> (this to make the machine run a bit faster, have been doing so since
> 10.04)
>
> Have no problem with Kernel upto 3.7.10 (have been upgrading to Kernel
> 3.5/3.6/3.7/3.8, when ever new builds are available)
> But when using Kernel 3.8.0/3.8.1/3.8.2, get Kernel Panic & machine
> crashes & freezes, have to hard boot.
>
> PROBLEM #############################################
> Machine connects to net using "ppp0" (modem on phone), then if you
> disconnect the modem "ppp0" & try to reconnect, the Kernel Panics &
> crashes.
>
> Machine connects to net using "ppp0" (modem on phone), then if you
> disconnect by unchecking "Enable Networking" & then rechecking "Enable
> Networking", the Kernel Panics & crashes.
>
> ####################################################
>
> First faced this problem with Kernel 3.8.0 so went back to using
> 3.7.9, then same story repeated with Kernel 3.8.1 & 3.8.2, currently
> using K...

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1144322

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

I have no Apport installed, this is what I get:
______________________________________
ubuntu@HSB:~$ apport-collect 1144322
The program 'apport-collect' is currently not installed. You can install it by typing:
 sudo apt-get install apport
ubuntu@HSB:~$
______________________________________

Kernel 3.7.10 is working fine, get problem only with kernel 3.8.0 to 3.8.2

1) I have to install Apport
2) I have to reinstall Kernel 3.8.2
3) My Kernel logs are written to /tmp, hence they get deleted upon restart, I have to reset the path of the Kernel logs

Please don't take it otherwise, It will take too much of time (I know other people time is also more important) but I have to work on a deadline & all I want to do is help by reporting this this bug in kernel 3.8.0
Surely I will try to manage time and do all the above 3 steps, but it will a little hard for me now. I really really apologize.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → New

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1144322

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

I'd like to perform a bisect to figure out what commit caused this regression. It would be very helpful to know the earliest kernel where the issue started happening as well as the latest kernel that did not have this issue.

Can you test the following kernels and report back? We are looking for the first kernel version that exhibits this bug:

v3.8-rc4: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8-rc4-raring/

If v3.8-rc4 does not exhibit the bug then test v3.8-rc6:
v3.8-rc6: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8-rc6-raring/

If v3.8-rc4 does exhibit the bug then test v3.8-rc2:
v3.8-rc2: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8-rc2-raring/

You don't have to test every kernel, just up until the kernel that first has this bug.

One thing to note, you will need to install both the linux-image and linux-image-extra .deb packages.

Thanks in advance!

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: bot-stop-nagging
tags: added: performing-bisect raring

I encountered this bug when I installed the final version of 3.8.0, in didn't try any RC builds, I tried 3.8.1 & 3.8.2 hoping the bug is resolved, but the bug remained and kernel panic kept on happening.

If I go back to 3.7 (3.7.8 or 3.7.9 or 3.7.10) its normal.

I installed from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8.2-raring/
    linux-headers-3.8.2-030802-generic_3.8.2-030802.201303031906_i386.deb
    linux-headers-3.8.2-030802_3.8.2-030802.201303031906_all.deb
    linux-image-3.8.2-030802-generic_3.8.2-030802.201303031906_i386.deb
    linux-image-extra-3.8.2-030802-generic_3.8.2-030802.201303031906_i386.deb

I really want to provide with the logs but I don't have apport installed, also my kernel logs are written to /tmp & are deleted upon restart, also I think the way Kernel Panics and I can't recover it and have to hard restart the machine, I doubt any logs will be written by kernel even if I install apport. I will try with 3.8.3, then I will install apport also. But as of now I have uninstalled 3.8.2 and deleted the downloaded files. In order to redownload the same it will take 1 hr on my slow internet.

Kernel 3.7 to 3.7.10 is fine, this happened when I tried final version of 3.8

Thanks for everything

Sergio Callegari (callegar) wrote :

Same happens here.

On a dell E6500 with kubuntu quantal, trying 3.8 kernels from the mainline ppa.

When connecting to the internet via a mobile phone using bluetooth and DUN, on disconnection the kernel panics.

This with all the 3.8.x kernels.

Happens every time.

3.7.x is latest working kernel.

Changed in linux (Ubuntu):
status: Incomplete → New

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1144322

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

We know that v3.7 final is the last version to not have this bug. We also need to know the first kernel version that introduced this bug. It may be the v3.8-rc1 kernel. Can you test the v3.8-rc1 kernel[0] to confirm it contains the bug? If it does, then I'll bisect between v3.7 and v3.8-rc1.

Thanks in advance!

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8-rc1-raring/

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Sergio Callegari (callegar) wrote :

Bug still present as of 3.8.5

Joseph Salisbury (jsalisbury) wrote :

Were you able to test the v3.8-rc1 mentioned in comment #11?

Bug persists in version 3.9,

Downloaded & installed today:
linux-headers-3.9.0-030900_3.9.0-030900.201304291257_all.deb
linux-headers-3.9.0-030900-generic_3.9.0-030900.201304291257_i386.deb
linux-image-3.9.0-030900-generic_3.9.0-030900.201304291257_i386.deb

Disappointed to say that the bug introduced in kernel 3.8 is still not resolved.

Last stable release which is free from this bug is version 3.7.10

Am uninstalling kernel 3.9 now, as after kernel panic there is no option but to force restart the computer by keeping the start button pressed for a minute.

I am using pppoe on my cellphone, internet speed is 12-15KBps (96-120kbps) so I don't have the heart to download version 3.8.rc1 to 3.8.rc8

But I will try.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → New

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1144322

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

Today I tried
Kernel v3.8-rc1-raring
and
Kernel v3.9.1-saucy

Both crash:
1) Connect to net using pppoe over Bluetooth (using my mobile phone modem to connect to Internet)
2) uncheck "Enable Networking"
3) check "Enable Networking"
4) Try connecting to net using "pppoe" again.

On step 4), a Kernel Panic occurs and the screen goes to Black Text screen and everything freezes.
The only option left is to Reboot by pressing the start button on the Laptop/Notebook and keep it pressed for 30+ seconds, nothing else works.

I can safely state that this REGRESSION happened in "Kernel v3.8-rc1-raring" & the last Kernel without this bug is 3.7.10
"Kernel v3.8-rc1-raring" is where this regression was introduced & it is present even in "Kernel v3.9.1-saucy"

I cannot provide any logs as the whole system freezes and nothing responds.

The ball is in your court now. I really hope that this regression is fixed. Lets all make Linux Kernel more robust & bug free.

Changing status to "Confirmed" again.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → New

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1144322

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

I'm really sorry, but no logs get generated when this Kernel Panic happens, everything just freezes & the only option is to Force restart the computer by pressing the Start button for more than 30 seconds.

------------------------------------------------------------------

Today I tried
Kernel v3.8-rc1-raring
and
Kernel v3.9.1-saucy

Both crash:
1) Connect to net using pppoe over Bluetooth (using my mobile phone modem to connect to Internet)
2) uncheck "Enable Networking"
3) check "Enable Networking"
4) Try connecting to net using "pppoe" again.

On step 4), a Kernel Panic occurs and the screen goes to Black Text screen and everything freezes.
The only option left is to Reboot by pressing the start button on the Laptop/Notebook and keep it pressed for 30+ seconds, nothing else works.

I can safely state that this REGRESSION happened in "Kernel v3.8-rc1-raring" & the last Kernel without this bug is 3.7.10
"Kernel v3.8-rc1-raring" is where this regression was introduced & it is present even in "Kernel v3.9.1-saucy"

I cannot provide any logs as the whole system freezes and nothing responds.

The ball is in your court now. I really hope that this regression is fixed. Lets all make Linux Kernel more robust & bug free.

Changing status to "Confirmed" again.
------------------------------------------------------------------

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Thanks for testing the v3.8-rc1-raring kernel. I will start a kernel bisect between v3.7 final and v3.8-rc1.

In the meantime, can you also test the latest mainline kernel which is v3.10-rc1:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.10-rc1-saucy/

I will post a link to the first bisect test kernel shortly.

Thanks, I'm really happy that someone is at last going to resolve this bug.

Joseph Salisbury (jsalisbury) wrote :

I built the first test kernel, up to the following commit:
6be35c700f742e911ecedd07fcc43d4439922334

The test kernel can be downloaded from:
http://kernel.ubuntu.com/~jsalisbury/lp1144322

Can you test that kernel and report back if it has the bug or not. I will build the next test kernel based on your test results.

Thanks in advance

Hi

Today I downloaded kernel from: http://kernel.ubuntu.com/~jsalisbury/lp1144322
& installed these 5 packages:
linux-headers-3.7.0-030700_3.7.0-030700.201305131528_all.deb
linux-headers-3.7.0-030700-generic_3.7.0-030700.201305131528_i386.deb
linux-image-3.7.0-030700-generic_3.7.0-030700.201305131528_i386.deb
linux-source-3.7.0_3.7.0-030700.201305131528_all.deb
linux-tools-common_3.7.0-030700.201305131528_all.deb

--------------------------------------

After installing this kernel:
1) connected to "pppoe" (using mobile phone modem over bluetooth, EDGE connecting speed-230kbps), ok
2) disconnected from pppoe, got a error & screen went to black window with text. I was able to move mouse, I pressed "CTRL+ALT+F1", then I pressed "CTRL+ALT+F7" & I was able to again see my desktop. (I was able to copy & save "kern.log", which I'm attaching below)
------------------------
one interesting line in this kern.log is:
May 15 20:13:58 HSB kernel: [ 100.190599] Kernel BUG at c106539a [verbose debug info unavailable]
------------------------
3) Tried unsuccessfully to connect to pppoe again.
4) unchecked "Enable Networking" & our old friend the Regression BUG resurfaced. I got a black window with text.
The last 2 lines of error on this screen which I wrote down are below:
-------------------------
[ 303.190936] Kernel panic - not syncing: Fatal exception in interrupt
[ 303.192790] panic occurred, switching back to text console
-------------------------
Now since the computer was in a complete frozen state from which I couldn't recover I had to restart the machine by pressing the START button for 30 plus seconds.

Networking+pppoe_Screenshot

Joseph Salisbury (jsalisbury) wrote :

Was the panic you saw while testing the kernel from comment #22 the same panic you saw and caused you to open this bug?

Yes, the last two lines which I noted down, were exactly same.
******************************
[ 303.190936] Kernel panic - not syncing: Fatal exception in interrupt
 [ 303.192790] panic occurred, switching back to text console
******************************

Joseph Salisbury (jsalisbury) wrote :

Thanks for the update.

I built the next test kernel, up to the following commit:
97ebe8f55ae99059c0ad3d3be5c0417647f5e3e0

The test kernel can be downloaded from:
http://kernel.ubuntu.com/~jsalisbury/lp1144322

Can you test that kernel and report back if it has the bug or not. I will build the next test kernel based on your test results.

Thanks in advance

Peter Curtis (secondary) wrote :

I am seeing the same problem on a MSI Wind U100 with a system based on Ubuntu 13.04 (kernel 3.8.0) whick locks with screen of text as described above immediately on disconnection of a bluetooth PPP connection in the Network Manager but not if the connection is terminated at the phone end.

Does this not merit a higher importance than medium when it causes a complete lock up of the machine? It is a show stopper for me and I am back to Gnome-PPP (which does not show the problem) for mobile operation.

Today I installed kernel from : "http://kernel.ubuntu.com/~jsalisbury/lp1144322", connected my mobile phone using USB cable & trying pppoe, connecting pppoe, disconnecting pppoe, unchecking and rechecking "Enable Networking", no errors but the mouse becomes erratic/jerky while performing the above tasks, seems something is not right.

Disconnected the USB cable from the phone, using pppoe over bluetooth, connecting and disconnecting pppoe, screen turn black with text, am able to recover by pressing "CTRL+ALT+F7", copying some logs file from "/var/log" to home folder (my "/var/log" folder is configured to be a temp folder, so it deletes logs on every restart). Am attaching these log files above. Trying to zip these log files and viola our friendly bug resurfaces, everything freezes and the have to hard restart the machine, the last two error lines are the same
******************************
[ 303.190936] Kernel panic - not syncing: Fatal exception in interrupt
[ 303.192790] panic occurred, switching back to text console
*****************************

Hence we can say that the bug is still present in this test kernel also.

Thanks in advance

//Someone in the previous comment is also facing the same issue.

Joseph Salisbury (jsalisbury) wrote :

I built the next test kernel, up to the following commit:
7bcb57cde66c19df378f3468ea342166a8a4504d

The test kernel can be downloaded from:
http://kernel.ubuntu.com/~jsalisbury/lp1144322

Can you test that kernel and report back if it has the bug or not. I will build the next test kernel based on your test results.

Thanks in advance

Phew ... at last for once the kernel didn't crash, restarted the machine twice and checked while performing the steps mentioned below.

1) Connected using PPPOE to mobile phone modem through USB
2) Connected using PPPOE to mobile phone modem through Blue-tooth
3) Disconnected and reconnected both multiple times
4) Also checking & un-checking "Enable Networking" while performing the above steps

The computer didn't crash, no kernel panic errors, nothing.

But I was checking the Logs in "/var/log" folder & I noticed that in both "kern.log + syslog" there is some unusual activity in the new Test Kernel, while the older stable 3.7.10 seemed a calm to my liking. I'm sure it will be of interest to you, so am attaching the logs for both kernels.

//Note: I will be out of station for 15 days from 03Jun2013 (will be climbing some mountain), so I wont be able to test any kernels till at-least 18Jun2013.

Looking forward for 3.10 / 3.11 kernel without this nasty bug.

Thanks in advance.

Jussi Saarinen (jussaar) wrote :

I ran in to this same bug with my ArchLinux installion.

Also someone stumbled upon this same bug with Gentoo Linux:
http://forums.gentoo.org/viewtopic-p-7330116.html

Joseph Salisbury (jsalisbury) wrote :

Can you test the v3.10-rc6 kernel before we continue the bisect? It can be downloaded from:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.10-rc6-saucy/

Installed 3.10rc6 kernel

Normal PPPOE seems fine when connecting mobile ph using USB cable

Sadly, Bug remains when using Blue-tooth & using PPPOE over Blue-tooth

Had to Hard restart by pressing the Start button for more than 30 seconds

//Attaching screen-shots of kernel panic

Thanks in Advance

2 comments hidden view all 108 comments

Created attachment 351696
WARN/stack dump/oops in the bluetooth rfcomm code introduced in raw kernel 3.8.x

This is an *UPSTREAM* bug and also some collation of known information of the nature of this bug.

A bug that was introduced upstream by the bluetooth developers in 3.8.x which remains in 3.9.x will cause the machine to crash with an oops when rfcomm is disconnected while a tty is connected. This is unexpected behavior. While in 3.10-rc5 the behavior changed, the bug still exists.

The initial method to trigger this bug was listed in

http://forums.gentoo.org/viewtopic-t-961421-highlight-.html

In brief, set up any bluetooth rfcomm connection and then rip up the bluetooth connection (/etc/init.d/bluetooth stop, rfcomm release, use blueman to disconnect Dial Up Networking/Serial). (I believe that pulling the bluetooth USB device from the plug also will trigger this issue, but I'd call that nonnatural behavior.) The kernel will then stomp over another kernel structure and cause the kernel to get corrupted, making other subsystem oops.

As Gentoo appears to not have bluetooth setup for networkmanager, it should not be affected unless someone is using rfcomm directly to communicate with a bluetooth serial device, say over minicom for a bluetooth device or using pppd directly to access a bluetooth modem. I hit the bug because I have a /etc/portage/patches/net-misc/networkmanager patch file to allow bluetooth rfcomm links.

As far as I can tell and from reports/tests upstream, this is probably due to bluetooth rfcomm not following standard tty procedures ripping up connected applications if the bluetooth link is torn down without cleaning up the tty. A patch to expose the bad rfcomm behavior was posted on LKML on 2013 May 15, which also prevents the machine from hanging/crashing by stopping the memory corruption. It does not fix the problem, merely instruments it (and also prevents other subsystems from dying, causing potential data loss).

The patch that Peter Hurley wrote was:

diff --git a/drivers/tty/tty_port.c b/drivers/tty/tty_port.c
index 6d9e0b2..a4f4fa9 100644
--- a/drivers/tty/tty_port.c
+++ b/drivers/tty/tty_port.c
@@ -140,6 +140,10 @@ EXPORT_SYMBOL(tty_port_destroy);
  static void tty_port_destructor(struct kref *kref)
  {
      struct tty_port *port = container_of(kref, struct tty_port, kref);
+
+ /* check if last port ref was dropped before tty release */
+ if (WARN_ON(port->itty))
+ return;
      if (port->xmit_buf)
          free_page((unsigned long)port->xmit_buf);
      tty_port_destroy(port);

Attached is the warnings and errors generated when I disable rfcomm from blueman with the above patch showing the correct trace. Without the above patch, corruption will tend to make other functions show incorrect information and tends to completely crash/hang the machine shortly after disconnection.

Changed in linux (Ubuntu):
importance: Medium → High

Seems the upstream patch has been rejected; and on Launchpad, people wait too.

There seems to have been a flame war on this on LKML on what to do when the illegal situation arises. Alex's original patch was to BUG() when the problem occurs, got rejected, but Peter suggested to WARN() on the issue. Either should be fine to notify in syslog/console trace when the improper procedure to tear down the tty occurs.

Either way, it's still just instrumenting the bug. There still appears to be no true fixes are in sight. On June 25 LKML there was a message reply to the subject "BUG: tty: memory corruption through tty_release/tty_ldisc_release" that indicates the bug can also be triggered by having the link open and suspend/resume the machine (ouch).

I suppose it's just because not many people use BT else this would be a fairly serious bug...

3 comments hidden view all 108 comments
Joseph Salisbury (jsalisbury) wrote :

I built the next test kernel, up to the following commit:
8966961b31c251b854169e9886394c2a20f2cea7

The test kernel can be downloaded from:
http://kernel.ubuntu.com/~jsalisbury/lp1144322

Can you test that kernel and report back if it has the bug or not. I will build the next test kernel based on your test results.

Thanks in advance

Dear

Test Kernel: "http://kernel.ubuntu.com/~jsalisbury/lp1144322" is free of this bug & works fine as it should.

Thanks

3 comments hidden view all 108 comments

Saw a message come by on linux-bluetooth/linux-serial mail lists, dated Jul 6 2013 from Gianluka Anzolin who submitted a patch versus 3.10 which may fix this issue, but the same doubts exist - people aren't sure how this piece of software really works :(

Though it was suggested that it stopped the crash from happening.

Jussi Saarinen (jussaar) on 2013-07-18
Changed in gentoo:
importance: Undecided → Unknown
status: New → Unknown
Changed in gentoo:
importance: Unknown → Medium
status: Unknown → New
tags: added: needs-kernel-logs needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-full-computer-model
tags: added: apport-collected precise
description: updated
description: updated
tags: removed: apport-collected
28 comments hidden view all 108 comments

apport information

tags: added: apport-collected
description: updated

Hello

Installed:
linux-headers-3.2.0-51_3.2.0-51.77_all.deb
linux-headers-3.2.0-51-generic-pae_3.2.0-51.77_i386.deb
linux-image-3.2.0-51-generic-pae_3.2.0-51.77_i386.deb

ran:
sudo apport-collect 1144322

Done

Thanks

Gurvender.Bahia, could you please provide the full computer model as noted on the sticker (ex. Satellite A80-S178TD)?

tags: removed: needs-kernel-logs

Hello

I don't think that the model number of the Notebook/Laptop will help much in this case:
1) This Notebook/Laptop has no built-in Blue-tooth, I have a external USB Blue-tooth adapter attached.
2) Other people are also facing the same issue (as seen in the attachment)
3) Up-till kernel 3.7.10 everything worked fine, from kernel version 3.8.0 this regression surfaced and is present in kernel version 3.9, 3.10 & 3.11.

In the other forum, I was reading and someone mentioned that this bug was introduced with a huge Blue-tooth update that happened in 3.8.0 & since then it hasn't been resolved.

//Note: Tomorrow I can provide you with the model number of the laptop (I'm away from my Linux machine now), but I won't be able to provide the model number for the USB Blue-tooth dongle other than that it has "ENTER" logo on it & is made in China, I'm using this dongle for 3-4 years without any issues. I really think that this isn't an isolated H/W issue, or why else is this same Blue-tooth H/W working fine on Kernels 3.7.10 & 3.2 (that I installed today as asked).

Thank for all your efforts & really hope this bug gets sorted out.

Thanks again

Hi

Model: Toshiba Satellite A80
Part Number: PSA80L-043003

Thanks

Gurvender.Bahia, could you please confirm this issue exists with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ . If the issue remains, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.11-rc4

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: latest-bios-2.80
tags: removed: needs-full-computer-model
summary: - Kernel Panic in 3.8.0, 3.8.1 & 3.8.2 when diconnecting from network
- manager, using ppp0 to connect to net
+ [Toshiba Satellite A80] Kernel 3.8.x Panic when disconnecting from
+ network manager via ppp0

Hello

Sorry, but I won't be able to install the latest test ISO

1) I'm using LTS 12.04.1, will use this till this version is officially supported and then will replace my old laptop along with the newer version of available ISO then.
2) I have spent too much time and effort on this version to make it run perfectly with minimum resources and up to my liking, formatting this and installing new ISO will waste everything.
3) I can live with Kernel 3.7.10, I just wanted to help the community by pointing to a possible bug in Blue-Tooth which was introduced with Kernel version 3.8.0 when a massive Blue-Tooth update was merged with kernel 3.8.0. Now if others don't want the kernel to be perfect, I can't do anything.

Anyways I give up now.

Take care & Bye

Thanks for everything

Also, I did test several mainline kernels and test kernels as you can see from the previous comments and I don't think that this bug has been resolved, people aren't complaining as not many connect to the internet using the mobile phone modem over bluetooth.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Gurvender.Bahia, a test of the live environment would be helpful instead of a full install.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete

(In reply to Ben from comment #3)
> Saw a message come by on linux-bluetooth/linux-serial mail lists, dated Jul
> 6 2013 from Gianluka Anzolin who submitted a patch versus 3.10 which may fix
> this issue, but the same doubts exist - people aren't sure how this piece of
> software really works :(
>
> Though it was suggested that it stopped the crash from happening.

Do you have a link to this particular message?

Thank you for finding it back in advance.

Here's the latest thread I saw on the mailing list: I hope Peter's mail is indicating this will be committed into a kernel soon:

http://marc.info/?l=linux-bluetooth&m=137511052832458&w=2

Changed in gentoo:
status: New → Unknown
1 comments hidden view all 108 comments
1 comments hidden view all 108 comments

(In reply to Jussi Saarinen from comment #6)
> Gianluca Anzolin's patches have now been merged to bluetooth-next.
> Eventually they should find their way to mainline and stable kernels.
>
> ...

Cool, will see if these apply on top of genpatches.

1 comments hidden view all 108 comments

The patch series is apparently "too extensive to consider for -stable" [1]. So another solution is required for stable kernels. Gianluca's fix should eventually end up in mainline though (3.12 hopefully).

[1] http://marc.info/?l=linux-bluetooth&m=137762583515880&w=2

1 comments hidden view all 108 comments

Gianluca Anzolin writes on bluetooth-linux mailing list that though his tty refcount patch series is needed, more work is required to fix the problem. If I understood his mailing list message correctly, the system locks up when the device is released even after his patches have been applied.

Source:

http://marc.info/?l=linux-bluetooth&m=137788497602145&w=2

Thank you for reporting the status of the patches, we will await them.

Gianluca Azolin's patches were merged to net-next day before yesterday. And yesterday they were merged to Linus' master branch. So patches will be in 3.12 rc1.

I've tried 3.12-rc2, as far as I can tell just opening and closing the rfcomm in BT seems to no longer crash the box - however, some characteristics changed and NetworkManager no longer accepts /dev/rfcomm* as a valid communications device as before, so I can't fully test it.

A bit tricky - using the same userland,

Linux-3.5.7-gentoo - works flawlessly
Linux-3.8.13-gentoo - crashes when BT rfcomm is closed
Linux-3.12-rc2 (raw from kernel.org) - blueman able to set up rfcomm but networkmanager does not notice that rfcomm was setup. Supposedly NM should notify blueman via dbus that it acknowledges the device, but blueman times out waiting and NM does not recognize the device. In trying to diagnose the problem I tried using busybox microcom on /dev/rfcomm0 directly. I was able to send my modem AT commands like on previous kernels, indicating the bluetooth link indeed works. I was able to shutdown the rfcomm link on blueman as well after sending those bytes through. No crash - a positive sign... but it may depend on the number of bytes sent.

I'll need to see why NM does not like the rfcomm device now, but I am no NM or dbus expert...

Seems that is indeed in all 3.12 related versions.

 # git tag --contains cc998ff8811530be521f6b316f37ab7676a07938
v3.12
v3.12-rc1
v3.12-rc2
v3.12-rc3
v3.12-rc4
v3.12-rc5
v3.12-rc6
v3.12-rc7

Can you try to see if the rest of the odd behavior has since been fixed?

Drat. 3.12-release still reports that the "connection is unusable" in blueman whereas 3.6.11 (last kernel I have built that works)... still works...

hmm...needs more debug now...

Installed 3.12 ... unable to connect using BlueTooth PPPOE at all ...Timing out.

Upgraded to 3.12.1 just now ... unable to connect to Internet using BlueTooth PPPOE ... timing out, instead having to use USB cable to connect to Internet.

All BlueTooth changes should be reverted back to 3.7.10, thats when everything worked without any hitch.

tags: added: unable-to-test-kernel-v3.12.1

(In reply to Ben from comment #15)
> Drat. 3.12-release still reports that the "connection is unusable" in
> blueman whereas 3.6.11 (last kernel I have built that works)... still
> works...
>
> hmm...needs more debug now...

Aw, then this isn't the right patch to backport; can you check if this still happens in more recent versions? (gentoo-sources and git-sources)

Changed in gentoo:
status: Unknown → New

Yes, 3.12-release has the same behavior as the release candidates - they no longer crash the machine but it was not fixed correctly/completely (meaning that behavior is not quite correct.) Will have to check future versions to find one that behaves correctly.

Debugging networkmanager will be ugly... Sigh.

I think we finally have a winner patchset here.

On Linux-Bluetooth there are two patches that showed up that, when patched against 3.12.6, seemingly completely fixes the longstanding problem. I don't know when these will show up in mainline.

The patch names are "rfc3.patch" and "modman.patch" from Gianluca Anzolin. I'll attach the patches here.

Thanks for all of Gentoo staff for tolerating bugs like this. I've been posting in the Ubuntu forums about this and all I get is flak.

Created attachment 366926
part one of 3.12.6 userspace bug of rfcomm

Created attachment 366928
part two of 3.12.6 patch to fix userspace differences in rfcomm

Created attachment 368038
Patch for inclusion - Part 1

Ben, can you test the 4 part series of which this is part 1? I backported the four from upstream.

Created attachment 368044
Patch for inclusion 2/4

Created attachment 368046
Patch for inclusion 3/4

Created attachment 368048
Patch for inclusion 42/4

What kernel version will these patches be against? I'm not sure what patches that went into 3.12.6 fixed the large part of the issue (i.e. the crashing) ...

Sorry, please apply against 3.12.8.

Changed in gentoo:
status: New → Unknown

The patches apply against 3.12.8 fine and NetworkManager finds the rfcomm interface just fine once more.

(Now I just need to move to systemd/gnome3...ugh...)

Thanks!

Ben, it's been awhile and I can't imagine the appropriate patches aren't in 3.14.
Please comment if that is not the case and there are still issues.

Changed in gentoo:
status: Unknown → Fix Released
Jussi Saarinen (jussaar) wrote :

I managed to find one more bug report similar to this one. So now there are at least four bug reports (including this one) here in Launchpad on this problem:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1144322

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1165433

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1189998

https://bugs.launchpad.net/ubuntu/+source/linux-lts-raring/+bug/1256811

Anyway, if these are about the same bug that I think they are, the bug has now been completely fixed in kernel version 3.14, though kernel version 3.12 included some of the fix. Also there was one previous fix that is also needed that I think was backported to stable before 3.12.

I think I manged to list all the necessary commits, Here are links to the commits, in case they need to be backported:

The first fix (pre 3.12?):
https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=1d9e689c934bd5ecb0f273c6c65e0655c5cfee5f

The fixes in 3.12:
https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=396dc223dd36edd218650d042a07c5e61f022c5b

https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=ebe937f74b8a72cf3ceeae5c2194a160bb092901

https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=54b926a1434e817ca84cb090f36b56763e192470

https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=cad348a17e170451ea8688b532a6ca3e98c63b60

https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=ece3150dea382c7c961fe2604332ed3474960d25

https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=ffe6b68cc5999a3f91a15b6667e69e14186e337d

https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=29cd718beba999bda4bdbbf59b5a4d25c07e1547

And finally the fixes in 3.14:
https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=5b899241874dcc1a2b932a668731c80a3a869575

https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=e228b63390536f5b737056059a9a04ea016b1abf

https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=4a2fb3ecc7467c775b154813861f25a0ddc11aa0

https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=f86772af6a0f643d3e13eb3f4f9213ae0c333ee4

Jussi Saarinen (jussaar) wrote :

Since ArchLinux has currently kernel 3.15.3, I'm marking this fixed in ArchLinux

affects: linux (Arch Linux) → archlinux
Changed in archlinux:
status: New → Fix Released
Displaying first 40 and last 40 comments. View all 108 comments or add a comment.