Ubuntu

Unable to change brightness at all

Reported by Jeff Lane on 2013-02-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Canonical Hardware Enablement Team

Bug Description

Installed 12.04.2 on this system and performing certification tests. I tried changing the screen brightness using the brightness keys, the brightness and lock tool and using a test that directly dims the screen to 50% and returns it to full.

None of those methods worked and there is no way at all to change the brightness on this machine.

Also, this is running the latest update kernel for 12.04.2

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.5.0-25-generic 3.5.0-25.39~precise1
ProcVersionSignature: Ubuntu 3.5.0-25.39~precise1-generic 3.5.7.4
Uname: Linux 3.5.0-25-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.25.
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 1: Generic [HD-Audio Generic], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ubuntu 1654 F.... pulseaudio
 /dev/snd/pcmC1D0c: ubuntu 1654 F...m pulseaudio
 /dev/snd/controlC0: ubuntu 1654 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'HDMI'/'HDA ATI HDMI at 0x90344000 irq 47'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100300'
   Controls : 6
   Simple ctrls : 1
Card0.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Card1.Amixer.info:
 Card hw:1 'Generic'/'HD-Audio Generic at 0x90340000 irq 16'
   Mixer name : 'IDT 92HD99BXX'
   Components : 'HDA:111d76e5,103c1937,00100303'
   Controls : 18
   Simple ctrls : 10
Date: Wed Feb 27 05:14:38 2013
HibernationDevice: RESUME=UUID=675c5759-cc72-47fa-8bd7-7ee264d629d9
InstallationMedia: Ubuntu 12.04.2 LTS "Precise Pangolin" - Release amd64 (20130213)
MachineType: Hewlett-Packard HP Pavilion Sleekbook 14 PC
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-25-generic root=UUID=5ad98b2c-223e-4f66-a6c5-d6c9007b9386 ro quiet splash initcall_debug vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-25-generic N/A
 linux-backports-modules-3.5.0-25-generic N/A
 linux-firmware 1.79.1
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/01/2012
dmi.bios.vendor: Insyde
dmi.bios.version: F.13
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 1937
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 87.0B
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsyde:bvrF.13:bd11/01/2012:svnHewlett-Packard:pnHPPavilionSleekbook14PC:pvr0892110000005900000320100:rvnHewlett-Packard:rn1937:rvr87.0B:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP Pavilion Sleekbook 14 PC
dmi.product.version: 0892110000005900000320100
dmi.sys.vendor: Hewlett-Packard

Jeff Lane (bladernr) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Anthony Wong (anthonywong) wrote :

Looks like this is radeon driver issue. Could you install fglrx and try again?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Daniel Manrique (roadmr) on 2013-05-25
Changed in linux (Ubuntu):
importance: Undecided → Medium
Ara Pulido (apulido) wrote :

Marking as Won't Fix, as the system works with the proprietary driver

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
Taihsiang Ho (taihsiangho) wrote :

use the proprietary driver in comment4 to clean out this bug:

dumping information by "dpkg -l | grep fglrx":

ii fglrx-amdcccle-experimental-13 2:13.101-0ubuntu0.0.2 Catalyst Control Center for the AMD graphics accelerators
ii fglrx-experimental-13 2:13.101-0ubuntu0.0.2 Video driver for the AMD graphics accelerators

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers