Due to possibly "bricking" the system, the samsung-laptop driver should not be allowed to run if booting from EFI

Bug #1111689 reported by Brad Figg
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Invalid
Undecided
Brad Figg
Precise
Fix Released
Undecided
Brad Figg
Quantal
Fix Released
Undecided
Brad Figg

Bug Description

SRU Justification:

Impact:
With the existing code there is still the chance that the samsung-laptop driver can run if the given system is booting a 32-bit kernel with 64-bit EFI firmware (or vice versa). This
can lead to a system that is "bricked" and can not be recovered.

Fix:
First, we will need to revert the existing commit we have for the samsung-laptop/EFI
issue:
    2fe5d5c565ad7ed16d5a01eee1f03dfd91dfa6a0 (Quantal tree)

Then we need to cherry-pick/backport the following two commits from Linus' tree
    83e68189745ad931c2afd45d8ee3303929233e7f
    e0094244e41c4d0c7ad69920681972fc45d8ce34

Brad Figg (brad-figg)
Changed in linux (Ubuntu):
status: New → In Progress
assignee: nobody → Brad Figg (brad-figg)
description: updated
Changed in linux (Ubuntu Quantal):
status: New → In Progress
assignee: nobody → Brad Figg (brad-figg)
Brad Figg (brad-figg)
Changed in linux (Ubuntu Precise):
status: New → In Progress
assignee: nobody → Brad Figg (brad-figg)
Brad Figg (brad-figg)
Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Committed
Revision history for this message
Brad Figg (brad-figg) wrote :

There are a larger number of commits involved in pulling this functionality back into Precise. Test kernels can be found at:
http://people.canonical.com/~bradf/lp1111689/

Revision history for this message
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Quantal in -proposed solves the problem (3.5.0-24.37). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-quantal' to 'verification-done-quantal'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-quantal
Revision history for this message
Fabri Velas (fabrivelas) wrote :

Dear Bratt, I have a samsung 530u3c on which I installed a recent daily image of precise with the kernel 3.5.0-23-generic #35~precise1-Ubuntu SMP Fri Jan 25 17:13:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
In my update-manager I have your kernel (3.5.0-24.37) as an update in the proposed updates. In the changelog is written
 * Revert "SAUCE: samsung-laptop: disable in UEFI mode"
I don't really want samsung-laptop to run, but with this changelog message it looks as if it is re-instated. I am not sure if I should update now, because I don't want to run samsung-laptop and risk to brick my samsung. Now in the title of this bug report it is written that samsung-laptop should not be run in uefi mode... I am confused. If you can reassure me that samsung-laptop does not run under uefi with this kernel I could try it.

Revision history for this message
Brad Figg (brad-figg) wrote :

@fabri

We reverted an earlier version of the patch to disable the samsung-laptop driver and then committed a newer, better version of the patch that came from upstream.

Revision history for this message
Brad Figg (brad-figg) wrote :

I don't actually have a Samsung laptop to try this on however, the patches were clean cherry-picks of the upstream commits which have been Linus' tree for a little while so should have gotten some testing. I recommend that we accept these changes and I'm going go to ahead and mark this as verified.

tags: added: verification-done-quantal
removed: verification-needed-quantal
Revision history for this message
Fabri Velas (fabrivelas) wrote :

Just checked the kernel on my samsung 530u3c laptop, and it works, thanks Brad.

Revision history for this message
Adam Conrad (adconrad) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (28.9 KiB)

This bug was fixed in the package linux - 3.5.0-24.37

---------------
linux (3.5.0-24.37) quantal-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1117492

  [ Tim Gardner ]

  * [Config] CONFIG_ALX=m for x86 only
    - LP: #927782

linux (3.5.0-24.36) quantal-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1116501

  [ Adam Lee ]

  * [Config] Enable RTSX_PCI modules
    - LP: #1057089

  [ Andy Whitcroft ]

  * [Config] enable various HVC consoles
    - LP: #1102206

  [ Brad Figg ]

  * Revert "SAUCE: samsung-laptop: disable in UEFI mode"
    - LP: #1111689

  [ Herton Ronaldo Krzesinski ]

  * [Config] updateconfigs for 3.5.7.3 stable update
  * d-i: Add mellanox ethernet drivers to nic-modules
    - LP: #1015339

  [ Kamal Mostafa ]

  * SAUCE: alx driver import script
    - LP: #927782

  [ Qualcomm Atheros, Inc ]

  * SAUCE: alx: Update to heads/master
    - LP: #927782

  [ Seth Forshee ]

  * SAUCE: samsung-laptop: Add quirk for broken acpi_video backlight on
    N250P
    - LP: #1086921

  [ Stefan Bader ]

  * (config) Move 9p modules into generic package
    - LP: #1107658

  [ Tim Gardner ]

  * [debian] Remove dangling symlink from headers package
    - LP: #1112442
  * [config] CONFIG_ALX=m
    - LP: #927782
  * [Config] Add alx to d-i nic-modules
    - LP: #927782

  [ Upstream Kernel Changes ]

  * Revert "8139cp: revert "set ring address before enabling receiver""
    - LP: #1102417
  * Revert "ath9k_hw: Update AR9003 high_power tx gain table"
    - LP: #1102417
  * Revert "drm/i915: no lvds quirk for Zotac ZDBOX SD ID12/ID13"
    - LP: #1102417
  * Revert "ALSA: hda - Shut up pins at power-saving mode with Conexnat
    codecs"
    - LP: #1106966, #886975
  * be2net: don't call vid_config() when there's no vlan config
    - LP: #1083088
  * be2net: cleanup be_vid_config()
    - LP: #1083088
  * be2net: do not modify PCI MaxReadReq size
    - LP: #1083088
  * be2net: fix reporting number of actual rx queues
    - LP: #1083088
  * be2net: do not use SCRATCHPAD register
    - LP: #1083088
  * be2net: Fix driver load for VFs for Lancer
    - LP: #1083088
  * be2net: Explicitly clear the reserved field in the Tx Descriptor
    - LP: #1083088
  * be2net: Regression bug wherein VFs creation broken for multiple cards.
    - LP: #1083088
  * be2net: Fix to trim skb for padded vlan packets to workaround an ASIC
    Bug
    - LP: #1083088
  * be2net: Fix Endian
    - LP: #1083088
  * be2net: Fix error while toggling autoneg of pause parameters
    - LP: #1083088
  * be2net : Fix die temperature stat for Lancer
    - LP: #1083088
  * be2net: Fix initialization sequence for Lancer
    - LP: #1083088
  * be2net: Activate new FW after FW download for Lancer
    - LP: #1083088
  * be2net: Fix cleanup path when EQ creation fails
    - LP: #1083088
  * be2net: Enable RSS UDP hashing for Lancer and Skyhawk
    - LP: #1083088
  * be2net: dont pull too much data in skb linear part
    - LP: #1083088
  * be2net: Fix VF driver load for Lancer
    - LP: #1083088
  * be2net: Ignore physical link async event for Lancer
    - LP: #1083088
  * be2net: Fix to parse RSS hash from Receive compl...

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
Revision history for this message
Christopher M. Peñalver (penalvch) wrote :
Changed in linux (Ubuntu):
status: In Progress → Incomplete
Brad Figg (brad-figg)
Changed in linux (Ubuntu):
status: Incomplete → Invalid
Changed in linux (Ubuntu Precise):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers