No support for Ivybridge Server GPUs in 12.04

Bug #1091068 reported by Yung Shen on 2012-12-17
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libdrm (Ubuntu)
High
Robert Hooker
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
linux (Ubuntu)
High
Unassigned
Precise
High
Unassigned
Quantal
High
Unassigned
mesa (Ubuntu)
High
Robert Hooker
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
High
Robert Hooker
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

[Impact]

Support for server variants of Intel Ivybridge GPUs were included prior to precise releasing, but the PCI IDs for this specific model that is in the wild weren't added until after. Without these fixes, the desktop will not be accelerated. The uploads only add new PCI IDs, nothing else.

[Test Case]

* Verify your graphics device is 8086:016a in lspci -vvnn
* Install appropriate kernel from https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1087302/comments/1
* Update to libdrm 2.4.32-1ubuntu1.1, and xserver-xorg-video-intel 2:2.17.0-1ubuntu4.3
* Reboot
* Verify i915 loads correctly and intel_drv.so is loaded in /var/log/Xorg.0.log

[Regression Potential]

* The fixes included in libdrm and xserver-xorg-video-intel have no way of regressing anything besides these devices, they only allow the new device to work. The devices are identical to the desktop versions with a different PCI ID so there should be no regression. If a regression were to happen, it would be limited to these devices that previously did not work.

===Original Message===
cid:201201-10376

There are three ports, two DisplayPorts and one VGA, only the initial cold plugged port will work, and others will not work if you try to hot swap, but the initial one remains working if you plug back.

And the system became really laggy when plugged DisplayPort, no matter it's coldplugged or hot swap later.

Trying to hotplug on DisplayPort, getting following messages from syslog:

Dec 16 21:50:49 201201-10376 kernel: [ 223.751560] irq 16: nobody cared (try booting with the "irqpoll" option)
Dec 16 21:50:49 201201-10376 kernel: [ 223.751567] Pid: 0, comm: swapper/0 Tainted: G C 3.2.0-34-generic #53-Ubuntu
Dec 16 21:50:49 201201-10376 kernel: [ 223.751569] Call Trace:
Dec 16 21:50:49 201201-10376 kernel: [ 223.751571] <IRQ> [<ffffffff810db2bd>] __report_bad_irq+0x3d/0xe0
Dec 16 21:50:49 201201-10376 kernel: [ 223.751584] [<ffffffff810db545>] note_interrupt+0x135/0x190
Dec 16 21:50:49 201201-10376 kernel: [ 223.751588] [<ffffffff810d8dba>] handle_irq_event_percpu+0xaa/0x210
Dec 16 21:50:49 201201-10376 kernel: [ 223.751592] [<ffffffff810d8f71>] handle_irq_event+0x51/0x80
Dec 16 21:50:49 201201-10376 kernel: [ 223.751596] [<ffffffff810dbf9a>] handle_fasteoi_irq+0x6a/0x110
Dec 16 21:50:49 201201-10376 kernel: [ 223.751601] [<ffffffff81015282>] handle_irq+0x22/0x40
Dec 16 21:50:49 201201-10376 kernel: [ 223.751606] [<ffffffff81666eda>] do_IRQ+0x5a/0xe0
Dec 16 21:50:49 201201-10376 kernel: [ 223.751610] [<ffffffff8165c26e>] common_interrupt+0x6e/0x6e
Dec 16 21:50:49 201201-10376 kernel: [ 223.751612] <EOI> [<ffffffff8108e189>] ? enqueue_hrtimer+0x39/0xc0
Dec 16 21:50:49 201201-10376 kernel: [ 223.751623] [<ffffffff8139521a>] ? arch_local_irq_enable+0xb/0xd
Dec 16 21:50:49 201201-10376 kernel: [ 223.751627] [<ffffffff81395e1d>] acpi_idle_enter_c1+0x95/0xbf
Dec 16 21:50:49 201201-10376 kernel: [ 223.751632] [<ffffffff81507261>] cpuidle_idle_call+0xc1/0x280
Dec 16 21:50:49 201201-10376 kernel: [ 223.751636] [<ffffffff8101222a>] cpu_idle+0xca/0x120
Dec 16 21:50:49 201201-10376 kernel: [ 223.751642] [<ffffffff8162241e>] rest_init+0x72/0x74
Dec 16 21:50:49 201201-10376 kernel: [ 223.751647] [<ffffffff81cfbc03>] start_kernel+0x3b0/0x3bd
Dec 16 21:50:49 201201-10376 kernel: [ 223.751652] [<ffffffff81cfb388>] x86_64_start_reservations+0x132/0x136
Dec 16 21:50:49 201201-10376 kernel: [ 223.751657] [<ffffffff81cfb140>] ? early_idt_handlers+0x140/0x140
Dec 16 21:50:49 201201-10376 kernel: [ 223.751661] [<ffffffff81cfb459>] x86_64_start_kernel+0xcd/0xdc
Dec 16 21:50:49 201201-10376 kernel: [ 223.751663] handlers:
Dec 16 21:50:49 201201-10376 kernel: [ 223.751667] [<ffffffff81492740>] usb_hcd_irq
Dec 16 21:50:49 201201-10376 kernel: [ 223.751669] Disabling IRQ #16

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-34-generic 3.2.0-34.53
ProcVersionSignature: Ubuntu 3.2.0-34.53-generic 3.2.33
Uname: Linux 3.2.0-34-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu15
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1476 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf7c30000 irq 46'
   Mixer name : 'Intel PantherPoint HDMI'
   Components : 'HDA:10ec0269,1028053a,00100100 HDA:80862806,80860101,00100000'
   Controls : 38
   Simple ctrls : 16
Date: Sun Dec 16 21:55:26 2012
HibernationDevice: RESUME=UUID=722ec9f2-392d-40de-b3d6-5aa702f4b5be
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: Dell Inc. Precision T1650
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-34-generic root=UUID=ed31dac2-f2b8-4a04-9295-8534f1cfe58b ro quiet splash initcall_debug vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-34-generic N/A
 linux-backports-modules-3.2.0-34-generic N/A
 linux-firmware 1.79.1
RfKill:

SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/09/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: X72
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 6
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrX72:bd08/09/2012:svnDellInc.:pnPrecisionT1650:pvr01:rvnDellInc.:rn:rvr:cvnDellInc.:ct6:cvr:
dmi.product.name: Precision T1650
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.

Yung Shen (kaxing) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Yung Shen (kaxing) on 2012-12-17
description: updated
Yung Shen (kaxing) on 2012-12-17
description: updated
Yung Shen (kaxing) on 2012-12-17
tags: added: blocks-hwcert

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.7 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.7-raring/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Robert Hooker (sarvatt) wrote :

00:02.0 VGA compatible controller [0300]: Intel Corporation Ivy Bridge Graphics Controller [8086:016a] (rev 08) (prog-if 00 [VGA controller])

So the problem here is that the pci id for this device didn't make it into precise's libdrm/xserver-xorg-video-intel/mesa/kernel. It is the same as a desktop Ivybridge GT2 variant, just missing a trivial pci id addition to make the intel drivers work.

The kernel side of this bug is being tracked in
https://launchpad.net/bugs/1087302

The commit to fix this in xserver-xorg-video-intel is
http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=ea36f2c4a3fa9afa8184eeaf944af9924c080368

The commit to fix it in libdrm is
http://cgit.freedesktop.org/mesa/drm/commit/?id=e057a56448e2e785f74bc13dbd6ead8572ebed91

The commit to fix it in mesa is
http://cgit.freedesktop.org/mesa/mesa/commit/?h=8.0&id=bf7407f631424d55354369cc66a9d27fcf888068

All of them are fixed in raring, all but the kernel are fixed in quantal, I'll prepare SRUs for the userspace packages in precise shortly.

Changed in libdrm (Ubuntu):
assignee: nobody → Robert Hooker (sarvatt)
importance: Undecided → High
milestone: none → precise-updates
status: New → In Progress
Changed in mesa (Ubuntu):
assignee: nobody → Robert Hooker (sarvatt)
importance: Undecided → High
milestone: none → precise-updates
status: New → In Progress
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Robert Hooker (sarvatt)
importance: Undecided → High
milestone: none → precise-updates
status: New → In Progress
Robert Hooker (sarvatt) wrote :

The mesa commit is in 8.0.4 that is already in precise-updates

Changed in mesa (Ubuntu):
status: In Progress → Fix Released
Robert Hooker (sarvatt) wrote :

Debdiff for libdrm

libdrm (2.4.32-1ubuntu1.1) precise-proposed; urgency=low

  * Add 108-Add-support-for-IVB-GT2-server.patch: Backport a commit from a
    later release that adds the Ivybridge Server GT2 PCI id used in newer
    Xeon processors. (lp: #1091068)

 -- Robert Hooker <email address hidden> Mon, 17 Dec 2012 13:36:46 -0500

tags: added: patch

The attachment "libdrm_2.4.32-1ubuntu1.1.debdiff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

Robert Hooker (sarvatt) on 2012-12-17
description: updated
description: updated
summary: - [Dell Precision T1650] DisplayPort not working, no hotplug support.
+ No support for Ivybridge Server GPUs in 12.04
Yung Shen (kaxing) wrote :

@sarvatt

By following Test Case in description, using Kernel from latest v3.7 kernel[0] and @leannogasawara's test kernel[1] , both fixes the DisplayPort and hotplug Issues,

but for xserver-xorg-video-intel_2.17.0-1ubuntu4.3.debdiff , i'm having trouble to build it after patched, please check .log , and therefore it is still no support for Compiz:

$/usr/lib/nux/unity_support_test -c -p
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x300)
OpenGL version string: 2.1 Mesa 8.0.4

Not software rendered: no
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes

Compiz supported: no

[0]http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.7-raring/
[1]https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1087302/comments/1

Robert Hooker (sarvatt) wrote :

Sorry about that! This is the correct debdiff

It's also available in https://launchpad.net/~sarvatt/+archive/sru9

Yung Shen (kaxing) wrote :

Thanks, I've succefully build with this debdiff, now gpu works with kernel 3.7, but it is not working with @leannogasawara's kernel

$ uname -a
Linux 201201-10376 3.2.0-35-generic #55-Ubuntu SMP Wed Dec 5 17:42:16 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
ubuntu@201201-10376:~$ ^C
ubuntu@201201-10376:~$ /usr/lib/nux/unity_support_test -c -p
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x300)
OpenGL version string: 2.1 Mesa 8.0.4

Not software rendered: no
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes

Compiz supported: no

Ara Pulido (ara) on 2012-12-21
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Changed in linux (Ubuntu Precise):
importance: Undecided → Medium
status: New → Triaged
Changed in linux (Ubuntu Quantal):
importance: Undecided → Medium
status: New → Triaged
Changed in linux (Ubuntu):
importance: Medium → High
Changed in linux (Ubuntu Precise):
importance: Medium → High
Changed in linux (Ubuntu Quantal):
importance: Medium → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libdrm (Ubuntu Precise):
status: New → Confirmed
Changed in libdrm (Ubuntu Quantal):
status: New → Confirmed
Changed in mesa (Ubuntu Precise):
status: New → Confirmed
Changed in mesa (Ubuntu Quantal):
status: New → Confirmed
Changed in xserver-xorg-video-intel (Ubuntu Precise):
status: New → Confirmed
Changed in xserver-xorg-video-intel (Ubuntu Quantal):
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

Robert: unsubscribing ubuntu-sponsors, since you can upload these yourself.

Changed in linux (Ubuntu):
status: Triaged → Fix Released
Timo Aaltonen (tjaalton) wrote :

fixed in raring

Changed in libdrm (Ubuntu):
status: In Progress → Fix Released
Changed in xserver-xorg-video-intel (Ubuntu):
status: In Progress → Fix Released
Robert Hooker (sarvatt) wrote :

libdrm in precise-proposed contains the fix, that debdiff on this bug is not needed anymore

libdrm (2.4.39-0ubuntu0.1) precise-proposed; urgency=low

  * Copy libdrm from quantal. (LP: #1086345)
 -- Maarten Lankhorst <email address hidden> Fri, 18 Jan 2013 16:30:10 +0100

Changed in xserver-xorg-video-intel (Ubuntu Quantal):
status: Confirmed → Fix Released
Changed in mesa (Ubuntu Quantal):
status: Confirmed → Fix Released
Changed in libdrm (Ubuntu Quantal):
status: Confirmed → Fix Released
Changed in libdrm (Ubuntu Precise):
status: Confirmed → Fix Committed
Changed in mesa (Ubuntu Precise):
status: Confirmed → Fix Released
Robert Hooker (sarvatt) on 2013-01-24
Changed in xserver-xorg-video-intel (Ubuntu Precise):
status: Confirmed → In Progress

Hello Yung, or anyone else affected,

Accepted xserver-xorg-video-intel into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xserver-xorg-video-intel/2:2.17.0-1ubuntu4.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xserver-xorg-video-intel (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Kent Baxley (kentb) wrote :

Confirmed with the xserver-xorg-video-intel package from proposed along with the latest libdrm from proposed and the kernel where the fixes landed.

With this combination everything looks good.

Thanks!

Robert Hooker (sarvatt) on 2013-01-29
tags: added: verification-done
removed: verification-needed
Adam Conrad (adconrad) on 2013-01-29
Changed in linux (Ubuntu Precise):
status: Triaged → Fix Released
Changed in linux (Ubuntu Quantal):
status: Triaged → Fix Released
Robert Hooker (sarvatt) on 2013-01-29
Changed in libdrm (Ubuntu Precise):
status: Fix Committed → Fix Released
David H (david-houlder) wrote :

Yes, this seems to be fixed for me now on Kubuntu 12.04 using libdrm from precise-proposed on a Dell Precision T1650 with Xeon E3-1225 V2 CPU P4000 integrated graphics.

Thanks - much appreciated.

root@blackbox:~# lspci -nnvv | fgrep Graphics
00:02.0 VGA compatible controller [0300]: Intel Corporation Ivy Bridge Graphics Controller [8086:016a] (rev 09) (prog-if 00 [VGA controller])
root@blackbox:~#

david@blackbox:~$
david@blackbox:~$ dpkg-query -W 'libdrm*'
libdrm-dev
libdrm-intel1 2.4.39-0ubuntu0.1
libdrm-nouveau1
libdrm-nouveau1a 2.4.39-0ubuntu0.1
libdrm-radeon1 2.4.39-0ubuntu0.1
libdrm2 2.4.39-0ubuntu0.1

david@blackbox:~$ lsmod | fgrep i915
i915 477602 3
drm_kms_helper 46978 1 i915
drm 241971 4 i915,drm_kms_helper
i2c_algo_bit 13423 1 i915
video 19596 1 i915

david@blackbox:~$ uname -a
Linux blackbox 3.2.0-36-generic #57-Ubuntu SMP Tue Jan 8 21:44:52 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

david@blackbox:~$ grep -i 'load.*intel' /var/log/Xorg.0.log
[ 16.183] (II) LoadModule: "intel"
[ 16.183] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[ 16.547] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.17.0-1ubuntu4.3

---------------
xserver-xorg-video-intel (2:2.17.0-1ubuntu4.3) precise-proposed; urgency=low

  * Add 108-Add-support-for-IVB-GT2-server.patch: Backport a commit from a
    later release that adds the Ivybridge Server GT2 PCI id used in newer
    Xeon processors. (lp: #1091068)
 -- Robert Hooker <email address hidden> Mon, 17 Dec 2012 13:28:49 -0500

Changed in xserver-xorg-video-intel (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.