Touchpad not recognised on Dell Latitude E6230, 6330, 6430, 6530, 5430, 5530

Bug #1089413 reported by Erno Kuusela on 2012-12-12
62
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Linux
Confirmed
Medium
OEM Priority Project
Medium
James M. Leddy
Precise
Medium
Unassigned
Quantal
Medium
James M. Leddy
Raring
Medium
James M. Leddy
linux (Ubuntu)
Medium
Tim Gardner
Precise
Undecided
Unassigned
Quantal
Undecided
James M. Leddy
Raring
Medium
Tim Gardner
linux-lts-quantal (Ubuntu)
Low
Unassigned
Precise
Undecided
James M. Leddy

Bug Description

lsinput just shows a PS/2 mouse.

This would be important to fix because the touchpad isn't configurable and is hard to use because it's
so close to kb & can't configure to ignore touches coinciding with keypresses.

It looks like similar bugs were recently fixed in Precise for some other Dell models: #606238 and #978807

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-34-generic 3.2.0-34.53
ProcVersionSignature: Ubuntu 3.2.0-34.53-generic 3.2.33
Uname: Linux 3.2.0-34-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu15
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: erno 11662 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf7e30000 irq 48'
   Mixer name : 'Intel PantherPoint HDMI'
   Components : 'HDA:111d76df,10280532,00100203 HDA:80862806,80860101,00100000'
   Controls : 38
   Simple ctrls : 14
Date: Wed Dec 12 16:36:19 2012
HibernationDevice: RESUME=UUID=c6e93863-3d4b-45af-9443-4bbaa3228533
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: Dell Inc. Latitude E6230
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-34-generic root=UUID=cf99adf8-a273-41e1-a40d-d65b6d9e1f21 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-34-generic N/A
 linux-backports-modules-3.2.0-34-generic N/A
 linux-firmware 1.79.1
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/25/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A01
dmi.board.name: 0R6V5Y
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA01:bd04/25/2012:svnDellInc.:pnLatitudeE6230:pvr01:rvnDellInc.:rn0R6V5Y:rvrA00:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E6230
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.

Erno Kuusela (erno-iki) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

You are well right posting a new bug. Bug 606238 was really too crowded.

As far as I am aware, no, there is nothing in the current ubuntu kernel for having this issue fixed.

I hacked a dklm replacement, building on top of Dave Turvene's and Ben Gamari's work. Code is here.

git://github.com/emmanuelthome/psmouse-alps.git

Real place for this fix is upstream, though. I haven't contacted upstream yet, being busy at other things.

E.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
status: Incomplete → Triaged
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.7 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.7-raring/

Changed in linux (Ubuntu):
status: Triaged → Incomplete
tags: added: kernel-da-key
Erno Kuusela (erno-iki) wrote :
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-bug-exists-upstream
Erno Kuusela (erno-iki) wrote :

@emmanuel-thome: that seems to work, nice job! But too hard for average user, this needs to be fixed in Ubuntu too.

Joseph Salisbury (jsalisbury) wrote :

@emmanuel-thome,

Do you plan on sending your fixes upstream?

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Kent Baxley (kentb) wrote :

These are the patches that I think have gone upstream and look to be in 3.9rc1

http://thread.gmane.org/gmane.linux.kernel.input/29102
https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/log/drivers/input/mouse/alps.c?id=refs/tags/v3.9-rc1

The patches have been confirmed to work on Latitude 6230, 6530, and 6430 hardware.

summary: - Touchpad not recognised on Dell Latitude E6230
+ Touchpad not recognised on Dell Latitude E6230, 6330, 6430, 6530, 5430,
+ 5530
no longer affects: oem-priority/oneiric
Joseph Salisbury (jsalisbury) wrote :

Do you know if these patches were also requested for inclusion in the upsteam linux-stable trees?

Kent Baxley (kentb) wrote :

@ Joseph, I'm not sure what the status is with regard to linux-stable. I know that Fedora is carrying the support as patches in their F17 / F18 kernels for the time being: https://bugzilla.redhat.com/show_bug.cgi?id=812111#c88

James M. Leddy (jm-leddy) wrote :

In addition, we need commit 3b112923, and "[PATCH V2 06/14] Input: ALPS - Use function pointers for different protocol handlers" from the list needs to be reworked since we never backported b4adbbef to the ubuntu kernel.

I don't think -stable accepts patchsets like this, but I'd be willing to post there if we can find evidence otherwise.

Changed in linux (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Joseph Salisbury (jsalisbury)
James M. Leddy (jm-leddy) wrote :

I've built a test kernel with an updated v3.9-rc1 driver that can be found at:

http://people.canonical.com/~jmleddy/.private/updatealps/

Also kentb has done some testing on at least 3 Dell skus and has found that kernel to fix the existing problems.

Tim Gardner (timg-tpi) on 2013-03-19
Changed in linux (Ubuntu Raring):
assignee: Joseph Salisbury (jsalisbury) → Tim Gardner (timg-tpi)
Tim Gardner (timg-tpi) wrote :

I applied all ALPS patches since v3.8:

git log --pretty=oneline v3.8..v3.9-rc3 -- drivers/input/mouse/alps.*

Changed in linux (Ubuntu Raring):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.8.0-14.24

---------------
linux (3.8.0-14.24) raring; urgency=low

  [ Paolo Pisati ]

  * [Config] rename omap flavour to generic
  * [Config] USB_MUSB_HDRC=m

  [ Roger Quadros ]

  * SAUCE: mfd: omap-usb-host: Fix clk warnings at boot

  [ Seth Forshee ]

  * SAUCE: Revert "brcmsmac: support 4313iPA"
    - LP: #1157190

  [ Tim Gardner ]

  * [Config] CONFIG_SERIAL_8250_DW=m across all arches
    - LP: #1031162
  * [debian] Build extras package only for specific arches
  * [config] Set do_extras_package=true for x86en
  * Rebase to 3.8.4
  * Release Tracking Bug
    - LP: #1158863

  [ Upstream Kernel Changes ]

  * Input: ALPS - document the alps.h data structures
    - LP: #1089413
  * Input: ALPS - copy "model" info into alps_data struct
    - LP: #1089413
  * Input: ALPS - move alps_get_model() down below hw_init code
    - LP: #1089413
  * Input: ALPS - introduce helper function for repeated commands
    - LP: #1089413
  * Input: ALPS - rework detection sequence
    - LP: #1089413
  * Input: ALPS - use function pointers for different protocol handlers
    - LP: #1089413
  * Input: ALPS - move {addr,nibble}_command settings into
    alps_set_defaults()
    - LP: #1089413
  * Input: ALPS - rework detection of Pinnacle AGx touchpads
    - LP: #1089413
  * Input: ALPS - fix command mode check
    - LP: #1089413
  * Input: ALPS - move pixel and bitmap info into alps_data struct
    - LP: #1089413
  * Input: ALPS - make the V3 packet field decoder "pluggable"
    - LP: #1089413
  * Input: ALPS - add support for "Rushmore" touchpads
    - LP: #1089413
  * Input: ALPS - enable trackstick on Rushmore touchpads
    - LP: #1089413
  * Input: ALPS - remove unused argument to alps_enter_command_mode()
    - LP: #1089413
  * Input: ALPS - add "Dolphin V1" touchpad support
    - LP: #1089413
  * serial: 8250_dw: Use ifdef with ACPI
    - LP: #1031162

  [ Upstream Kernel Changes ]

  * rebase to v3.8.4
 -- Tim Gardner <email address hidden> Tue, 19 Mar 2013 07:37:36 -0600

Changed in linux (Ubuntu Raring):
status: Fix Committed → Fix Released
Tim Gardner (timg-tpi) on 2013-04-11
Changed in linux (Ubuntu Quantal):
assignee: nobody → James M. Leddy (jm-leddy)
status: New → Fix Committed
James M. Leddy (jm-leddy) wrote :

Adding linux-lts-quantal for clarity, since obviously this will come to precise through the backports kernel.

no longer affects: linux-lts-quantal (Ubuntu Raring)
no longer affects: linux-lts-quantal (Ubuntu Quantal)
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-quantal
Tim Gardner (timg-tpi) on 2013-05-08
Changed in linux-lts-quantal (Ubuntu Precise):
assignee: nobody → James M. Leddy (jm-leddy)
status: New → Fix Committed
Changed in linux-lts-quantal (Ubuntu):
status: New → Invalid
Changed in linux (Ubuntu Precise):
status: New → Invalid
Kent Baxley (kentb) wrote :

Tested -proposed kernel on a Latitude E5430.

xinput now sees the touchpad as "AlpsPS/2 ALPS DualPoint Touchpad".

There are options now in mouse and touchpad preferences to configure edge and horizontal scrolling (There is also an option to do two-finger scrolling but it currently doesn't work, and I don't think that's actually been fixed anywhere, yet, so that's ok for now...single-finger scrolling is welcome enough at this point).

I can also enable and disable the touchpad via the fn+F5 hotkeys on this laptop.

Nice work, and thanks for pulling in the patches.

tags: added: verification-done-quantal
removed: verification-needed-quantal
Erno Kuusela (erno-iki) wrote :

 Fix works on E6230 on precise, after enabling proposed & getting linux-image-generic-lts-quantal

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Julian Wiedmann (jwiedmann) wrote :

Released with 3.5.0-31.52.

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
Daniel Manrique (roadmr) on 2013-07-16
Changed in linux-lts-quantal (Ubuntu):
importance: Undecided → Low
Ara Pulido (ara) on 2013-11-28
Changed in linux-lts-quantal (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.