[Regression] SATA reset failing since Linux 3.6

Bug #1084783 reported by Gannet on 2012-11-29
58
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
High
linux (Ubuntu)
High
Tim Gardner
Raring
High
Tim Gardner

Bug Description

Looks like kernel 3.5.0-18 uses pata_jmicron kernel module for driving controller, but since kernel 3.6 (and later) pata_acpi module used instead, and it's fail to work with controller properly. Alan Cox thinks the problem is in distro kernel: https://bugzilla.kernel.org/show_bug.cgi?id=48631#c22

ata7: ACPI get timing mode failed (AE 0x300b)
ata7: ACPI get timing mode failed (AE 0x300b)
ata7: ACPI get timing mode failed (AE 0x300b)
ata7: prereset failed (errno=-19)
ata7: reset failed, giving up

ata8: ACPI get timing mode failed (AE 0x300b)
ata8: ACPI get timing mode failed (AE 0x300b)
ata8: ACPI get timing mode failed (AE 0x300b)
ata8: prereset failed (errno=-19)
ata8: reset failed, giving up

Gave up waiting for root device. Common problems:
- Boot args (cat /proc/cmdline)
  - Check rootdelay= (did the system wait long enough?)
  - Check root= (did the system wait for the right device?)
- Missing modules (cat /proc/modules; ls /dev)

ALERT! /dev/disk/by-uuid/8e6ab4ba-b981-4821-8683-9fa908a748e5 does not exist.
Dropping to a shell!

BusyBos v1.19.3 (Ubuntu 1:1.19.3-7ubuntu1) built-in shell (ash)
Enter 'help' for a list of built-in commands
(initramfs)

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-3.5.0-18-generic 3.5.0-18.29
ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7
Uname: Linux 3.5.0-18-generic x86_64
ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: eugene 2262 F.... pulseaudio
 /dev/snd/controlC2: eugene 2262 F.... pulseaudio
 /dev/snd/controlC0: eugene 2262 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Date: Fri Nov 30 00:17:39 2012
HibernationDevice: RESUME=UUID=bbb18b0e-b95b-4f14-8b8f-9b9400eb5665
InstallationDate: Installed on 2012-05-06 (207 days ago)
InstallationMedia: Kubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120423)
MachineType: System manufacturer System Product Name
MarkForUpload: True
ProcEnviron:
 LANGUAGE=uk_UA
 TERM=xterm
 PATH=(custom, no user)
 LANG=uk_UA.UTF-8
 SHELL=/bin/bash
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-18-generic root=UUID=8e6ab4ba-b981-4821-8683-9fa908a748e5 ro quiet splash
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-18-generic N/A
 linux-backports-modules-3.5.0-18-generic N/A
 linux-firmware 1.97
RfKill:

SourcePackage: linux
UpgradeStatus: Upgraded to quantal on 2012-10-08 (52 days ago)
dmi.bios.date: 09/30/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1238
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5B-Deluxe
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1238:bd09/30/2008:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5B-Deluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Related branches

Gannet (ken20001) wrote :
tags: added: regression-update
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.7 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.7-rc7-raring/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: kernel-da-key raring
removed: quantal
Changed in linux:
importance: Unknown → High
status: Unknown → In Progress
Gannet (ken20001) wrote :

I've already tested latest Raring LiveCD with kernel 3.7 a few days ago. System was not booted.

tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → New
summary: - [Regression] SATA reset failing in 3.6
+ [Regression] SATA reset failing since Linux 3.6
description: updated
Changed in linux (Ubuntu):
status: New → Triaged
Changed in linux:
status: In Progress → Invalid
Gannet (ken20001) wrote :

Recently checked Kernel RC5. The problem still is. My system isn't booting.

mcelrath (bob+launchpad) wrote :

I just tried the 3.7.6 mainline, and the problem is still present.

The module pata_acpi should NOT be compiled-in, per the recommendation of the kernel maintainers in the bug description. That is what is causing this bug, and what is preventing the workaround (it prevents pata_acpi from being blacklisted). The pata_acpi driver should be tried LAST, and by compiling it in, we prevent more specific drivers (such as pata_jmicron in my case) from being used at all.

Gannet (ken20001) wrote :

Recently checked newly released kernel 3.8. Nothing's changed. It seems nobody working on this problem.

Joseph Salisbury (jsalisbury) wrote :

I reviewed the upstream bug. I'll build a test kernel with the CONFIG_PATA_ACPI option unset and post a link to it shortly.

Changed in linux (Ubuntu):
status: Triaged → Confirmed
tags: added: kernel-key
Joseph Salisbury (jsalisbury) wrote :

I created a test kernel with CONFIG_PATA_ACPI unset. The test kernel can be downloaded from:
http://people.canonical.com/~jsalisbury/lp1084783/

Can folks affected by this bug please test that kernel to see if it has this bug or not?

Thanks in advance!

Joseph Salisbury (jsalisbury) wrote :

Also, please be sure to install both the linux-image and linux-image-extras packages.

Gannet (ken20001) wrote :

Hello. Recently tested your kernel and it booted well. Also you can examine my dmesg attached if you interested.

Gannet (ken20001) wrote :

But soon I've got several GPU lockups and one freeze. You can see about it in syslog file.

Jan Sembera (fis) wrote :

I can also confirm that disabling PATA_ACPI works just fine. Will try with PATA_ACPI=m today. But anyway, having it built in is apparently not the right way to do - per earlier referenced kernel bug and this: http://marc.info/?l=linux-ide&m=136196893315200&w=2

Changed in linux (Ubuntu Raring):
importance: Medium → High
status: Confirmed → Triaged
Tim Gardner (timg-tpi) wrote :

Indeed, CONFIG_PATA_ACPI=y is just plain wrong as it matches any PCI_CLASS_STORAGE_IDE PCI ID.

Changed in linux (Ubuntu Raring):
assignee: nobody → Tim Gardner (timg-tpi)
status: Triaged → In Progress
Tim Gardner (timg-tpi) on 2013-02-27
Changed in linux (Ubuntu Raring):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.8.0-9.18

---------------
linux (3.8.0-9.18) raring; urgency=low

  [Tim Gardner]

  * Release Tracking Bug
    - LP: #1135937
  * [Config] CONFIG_PATA_ACPI=m
    - LP: #1084783

  [ Upstream Kernel Changes ]

  * intel_idle: stop using driver_data for static flags
    - LP: #1083993
  * intel_idle: support Haswell
    - LP: #1083993
  * i2c: i801: SMBus patch for Intel Avoton DeviceIDs
    - LP: #1083965
  * ahci: AHCI-mode SATA patch for Intel Avoton DeviceIDs
    - LP: #1083965
  * ata_piix: IDE-mode SATA patch for Intel Avoton DeviceIDs
    - LP: #1083965

  [ Upstream Kernel Changes ]

  * rebase to v3.8.1
    - LP: #1011792
 -- Tim Gardner <email address hidden> Wed, 27 Feb 2013 06:10:52 -0700

Changed in linux (Ubuntu Raring):
status: Fix Committed → Fix Released

Thank you for fix!

Gannet (ken20001) wrote :

Yes, thanks from me too.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.