[Lenovo ThinkPad T530] External display does not work through Display port or VGA

Bug #1079933 reported by Jeff Marcom
72
This bug affects 13 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Incomplete
Medium
Alberto Milone
Precise
Won't Fix
Medium
Alberto Milone

Bug Description

Problem:
Connecting a display through the display port does nothing. I can try to press the key combo fn + f7 or trigger the monitor to refresh and the display is still blank on the external monitor.

udev does not seem to notice the display port connection either.

Expected result: External display should be mirrored when inserting a display port or VGA connection.

Video info

[ 0.729694] pci 0000:00:02.0: Boot video device
[ 13.071619] Linux video capture interface: v2.00
[ 13.099290] uvcvideo: Found UVC 1.00 device Integrated Camera (5986:02d2)
[ 13.101511] usbcore: registered new interface driver uvcvideo
[ 13.101512] USB Video Class driver (1.1.1)
[ 13.182383] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:00/input/input7
[ 13.183068] ACPI: Video Device [VID] (multi-head: yes rom: no post: no)
ubuntu@201205-11132:~$ dmesg | grep -i graphics
[ 12.371300] [drm] MTRR allocation failed. Graphics performance may suffer.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-29-generic 3.2.0-29.46
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Uname: Linux 3.2.0-29-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269VC Analog [ALC269VC Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1539 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf2530000 irq 46'
   Mixer name : 'Intel PantherPoint HDMI'
   Components : 'HDA:10ec0269,17aa21f6,00100203 HDA:80862806,80860101,00100000'
   Controls : 36
   Simple ctrls : 13
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw unknown'
   Mixer name : 'ThinkPad EC (unknown)'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Fri Nov 16 18:44:51 2012
HibernationDevice: RESUME=UUID=33af243d-8694-4458-a1eb-5c94d7303d8e
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
MachineType: LENOVO 235923U
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-29-generic root=UUID=212db818-8dcd-4bbd-94a9-0a9ca8d086a3 ro quiet splash initcall_debug vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-29-generic N/A
 linux-backports-modules-3.2.0-29-generic N/A
 linux-firmware 1.79
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/29/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: G4ET37WW (1.12 )
dmi.board.asset.tag: Not Available
dmi.board.name: 235923U
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrG4ET37WW(1.12):bd05/29/2012:svnLENOVO:pn235923U:pvrThinkPadT530:rvnLENOVO:rn235923U:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 235923U
dmi.product.version: ThinkPad T530
dmi.sys.vendor: LENOVO

Revision history for this message
Jeff Marcom (jeffmarcom) wrote :
tags: added: blocks-hwcert
Revision history for this message
Brad Figg (brad-figg) wrote : Status changed to Confirmed

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Revision history for this message
Jeff Marcom (jeffmarcom) wrote : Re: [Lenovo T530, W530]: External display does not work through Display port or VGA

The w530s have nividia graphics. However it does not matter whether the mode is set to Nvidia Optimus, discrete, or integrated, there is no external video output.

Driver available through jockey is experimental.

summary: - [Lenovo T530]: External display does not work through Display port or
- VGA
+ [Lenovo T530, W530]: External display does not work through Display port
+ or VGA
Ara Pulido (ara)
tags: added: blocks-hwcert-enablement
Changed in linux (Ubuntu):
importance: Undecided → Medium
Changed in linux (Ubuntu Precise):
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
James M. Leddy (jm-leddy) wrote :

oem bug 934528

Hi Jeff,

The thing that's throwing me for a loop is that I don't see any nvidia VGA adapters in the lspci output. Also, would you try installing the latest nvidia driver manually to see if that makes a difference?

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
Changed in linux (Ubuntu Precise):
status: Confirmed → Incomplete
Changed in linux (Ubuntu):
status: Won't Fix → Incomplete
assignee: James M. Leddy (jm-leddy) → Alberto Milone (albertomilone)
Changed in linux (Ubuntu Precise):
assignee: nobody → Alberto Milone (albertomilone)
Revision history for this message
James M. Leddy (jm-leddy) wrote :

In enablement, we had a case of the driver not loading that was causing this issue bug 934528. Additionally there was a report of the video switch hotkey not functioning, but that was because the driver was not installed by jockey bug 959438. If we're in optimus mode and jockey is installing the nvidia driver, and we're still having problems with video out, then this looks to be a regression from oneiric.

Revision history for this message
Imre Gergely (cemc) wrote :

I have a similar problem with my Lenovo W530. Maybe the two problems are related. See bug #1108144 .

Revision history for this message
Jeff Marcom (jeffmarcom) wrote :
Revision history for this message
Jeff Marcom (jeffmarcom) wrote :
Revision history for this message
Jeff Marcom (jeffmarcom) wrote :
Changed in linux (Ubuntu Precise):
status: Incomplete → New
Changed in linux (Ubuntu):
status: Incomplete → New
Revision history for this message
Brad Figg (brad-figg) wrote : Status changed to Confirmed

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu Precise):
status: New → Confirmed
Revision history for this message
James M. Leddy (jm-leddy) wrote : Re: [Lenovo T530, W530]: External display does not work through Display port or VGA

Hello, would you please try with the following driver version? This driver fixes a number of known issues on late model machines, one of which is external displays not working:

http://people.canonical.com/~tjaalton/i915-dkms/release/

Revision history for this message
Michel Filipe (mfilipe) wrote :

@jm-leddy, sorry for the big delay. So, I tried install your package but I got errors. I attached the make.log.

Revision history for this message
srd (sr-gimp) wrote :

After updating to 13.04, the external VGA port is accessable on my T530 through xrandr (using intel graphics), so it may very well be a driver issue. Haven't tried the hotkeys yet.

However, the display port still doesn't work, even when switching to nvidia graphics in the BIOS. I don't know how the graphics chips are wired to the external display ports, it could be that the display port accessability is an nvidia driver issue and not accessible from the intel chipset at all.

Revision history for this message
Shuhao (shuhao) wrote :

So on the W530 the external display ports are not wired to the intel chip and only to the nvidia chip.

Under linux, if you want to use the external ports, you must switch to discrete only. I am able to drive two external monitors using this approach no problem (VGA, Display port -> VGA)

Revision history for this message
Anthony Wong (anthonywong) wrote :

Hi Jeff, can you try the Discrete mode as suggested in #14?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Jeff Marcom (jeffmarcom) wrote :

Please see comment #3

Changed in linux (Ubuntu):
status: Incomplete → New
Revision history for this message
Brad Figg (brad-figg) wrote : Status changed to Confirmed

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: bios-outdated-2.57
summary: - [Lenovo T530, W530]: External display does not work through Display port
- or VGA
+ [Lenovo ThinkPad T530] External display does not work through Display
+ port or VGA
summary: - [Lenovo ThinkPad T530] External display does not work through Display
- port or VGA
+ 8086:0166 [Lenovo ThinkPad T530] External display does not work through
+ Display port or VGA
Revision history for this message
Christopher M. Peñalver (penalvch) wrote : Re: 8086:0166 [Lenovo ThinkPad T530] External display does not work through Display port or VGA

Jeff Marcom, as per http://download.lenovo.com/express/ddfm.html an update is available for your BIOS (2.58). If you update to this following https://help.ubuntu.com/community/BiosUpdate , does it change anything? If it doesn't, could you please both specify what happened, and just provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

Thank you for your understanding.

tags: added: bios-outdated-2.58
removed: bios-outdated-2.57
summary: - 8086:0166 [Lenovo ThinkPad T530] External display does not work through
- Display port or VGA
+ [Lenovo ThinkPad T530] External display does not work through Display
+ port or VGA
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Alberto Milone (albertomilone) wrote :

This should work in Ubuntu 14.04. If displayport or VGA are connected to the NVIDIA card, then you'll have to launch the nvidia-settings panel and enable any connected outputs from there.

Revision history for this message
Alberto Milone (albertomilone) wrote :

LP: #1290711 is the relevant bug report for 14.04

Changed in linux (Ubuntu Precise):
status: Confirmed → Won't Fix
Revision history for this message
Patrice (patrice-dum-0) wrote :

Same problem as described in fisrt post.

Lenovo ThinkPas e531
xUbuntu 14.04 LTS

(Fn-F7 key combination to toggle between internal, mirror, external works very fine with Windows7 installed dual boot).

Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

Patrice, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into the default Ubuntu kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
https://wiki.ubuntu.com/Kernel/Policies/DuplicateBugs
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

As well, please do not announce in this report you created a new bug report.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

To post a comment you must log in.