[VMWare Player 5.0.x] Quantal+ as guest hangs at end of install

Bug #1077440 reported by David Balažic on 2012-11-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Installing Ubuntu 12.10 Desktop i386 (ubuntu-12.10-desktop-i386.iso) in VMware player hangs at the end of installation.

I tried on two PC's each time it hung at slightly different spot:
 - desktop PC with Windows 7 Home Premium Sp1 64 bit, VMWare Player 5.0.0: hangs when installation is complete on the reboot, last message on screen is:
Asking all remaining processes to terminate...

 - same PC, VMWare Player 5.0.1 : exactly same situation
 - laptop with Windows 7 Professional SP1 64 bit, VMWare Player 5.0.0: installation succeeds, but hangs on first boot up, last message on screen is: * Checking battery state...
---
ApportVersion: 2.9.2-0ubuntu8
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 3088 F.... pulseaudio
                      ubuntu 4936 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
CasperVersion: 1.331
CurrentDmesg: [ 9.788092] pcnet32 0000:02:01.0 eth0: link up
DistroRelease: Ubuntu 13.04
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
LiveMediaBuild: Ubuntu 13.04 "Raring Ringtail" - Release i386 (20130424)
Lsusb:
 Bus 002 Device 002: ID 0e0f:0003 VMware, Inc. Virtual Mouse
 Bus 002 Device 003: ID 0e0f:0002 VMware, Inc. Virtual USB Hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: VMware, Inc. VMware Virtual Platform
MarkForUpload: True
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 svgadrmfb
ProcKernelCmdLine: file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-19-generic N/A
 linux-backports-modules-3.8.0-19-generic N/A
 linux-firmware 1.106
RfKill:

Tags: raring
Uname: Linux 3.8.0-19-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 07/02/2012
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: 6.00
dmi.board.name: 440BX Desktop Reference Platform
dmi.board.vendor: Intel Corporation
dmi.board.version: None
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvr6.00:bd07/02/2012:svnVMware,Inc.:pnVMwareVirtualPlatform:pvrNone:rvnIntelCorporation:rn440BXDesktopReferencePlatform:rvrNone:cvnNoEnclosure:ct1:cvrN/A:
dmi.product.name: VMware Virtual Platform
dmi.product.version: None
dmi.sys.vendor: VMware, Inc.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1077440/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
David Balažic (xerces8) on 2012-11-10
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1077440

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: quantal

As it freezes, I can not collect any logs.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Did you have an issue using previous Ubuntu releases ? Would it be possible for you to see if the 12.04 version installs without the hang?

Changed in linux (Ubuntu):
importance: Undecided → Medium

David Balažic, could you please confirm this issue exists with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ . If the issue remains, could you please run the following command in the live environment from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

tags: added: needs-kernel-logs needs-upstream-testing regression-potential
tags: added: regression-release
removed: regression-potential
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
summary: - Quantal as vmware guest hang
+ [VMWare Player 5.0.1] Quantal as guest hangs at end of install

I downloaded saucy-desktop-i386 (at about 13:00 UTC today, the web page on your link says : saucy-desktop-i386.iso 10-Aug-2013 08:19 878M

I used VMware Player 5.0.2 build-1031769 on Windows 8 Pro 64 bit.

After booting the ISO I got this screen: attachment first_screen.png

I can not continue, as every screen is like that (went one further) and half of it is not visible, including the Next button, I would have to "navigate blind".

Also (later), with the blue circle icon menu at the "top" I turned on High Contrast mode, but then there is no way to turn it off.

tags: added: saucy
summary: - [VMWare Player 5.0.1] Quantal as guest hangs at end of install
+ [VMWare Player 5.0.x] Quantal+ as guest hangs at end of install
David Balažic (xerces8) wrote :

There is no crash.

David Balažic (xerces8) wrote :

There is no hang either.
Just a gfx corruption. As pictured on the screenshot. I doubt there is a line like "due to reason x, the screen is shown 300 pixels lower than normal" in any log.

David Balažic, it would be helpful if we had the log from the point it starts the graphics corruption. Could you please capture this following https://help.ubuntu.com/community/DebuggingSystemCrash ?

David Balažic (xerces8) wrote :

Here is the /var/log/kern.log (attached)

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

apport information

tags: added: apport-collected raring
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

David Balažic (xerces8) wrote :

I sent the above from ubuntu 13.04 desktop i386.
In the terminal I got also this:
ubuntu@ubuntu:~$ apport-collect 1077440
The authorization page:
 (https://launchpad.net/+authorize-token?oauth_token=lNbKz0hWlWG9m84gbnjC&allow_permission=DESKTOP_INTEGRATION)
should be opening in your browser. Use your browser to authorize
this program to access Launchpad on your behalf.
Press any key to continue or wait (5) seconds...
Waiting to hear from Launchpad about your decision...

(process:5730): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
ERROR: hook /usr/share/apport/general-hooks/cloud_archive.py crashed:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/apport/report.py", line 197, in _run_hook
    symb['add_info'](report, ui)
  File "/usr/share/apport/general-hooks/cloud_archive.py", line 18, in add_info
    if '~cloud' in packaging.get_version(package) and \
  File "/usr/lib/python2.7/dist-packages/apport/packaging_impl.py", line 123, in get_version
    raise ValueError('package %s does not exist' % package)
ValueError: package linux does not exist
dpkg-query: no packages found matching linux
ubuntu@ubuntu:~$

tags: removed: needs-kernel-logs
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
David Balažic (xerces8) wrote :

I see the same graphic problem an a real PC. So:
 - it is hardware independent (read: if you're interested, you can most probably reproduce it)
 - this is not actually the bug I opened here (hang versus broken toolbar)

David Balažic (xerces8) wrote :

I just tried 12.04 again, and it hung again after clicking the Reboot button.
After a few minutes I pressed ctrl-c and then after a second it rebooted.

Given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We are approaching release and would like to confirm if this bug is still present. Please test again with the latest development kernel and indicate in the bug if this issue still exists or not.

You can update to the latest development kernel by simply running the following commands in a terminal window:

    sudo apt-get update
    sudo apt-get dist-upgrade

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.11.0-7.14
David Balažic (xerces8) wrote :

The above is not possible for the installation scenario, changed status back to Confirmed.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

David Balažic, if this is indeed a kernel issue, the current daily ISO would have the latest kernel Joesph is requesting via http://cdimage.ubuntu.com/daily-live/current/ .

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
David Balažic (xerces8) wrote :

I tried the todays daily * and it seems OK, with one thing (which I experienced before too):
when after installation the reboot is done, the shutdown scripts is waiting for a press of ENTER key, but the text saying so is not visible (see screenshot).
So it hangs there until I press ENTER.
After that it reboots into the installed Ubuntu system.

I guess the original bug is solved (it was a bit sporadic and frankly I have no will to pursue this further).

* http://cdimage.ubuntu.com/daily-live/current/saucy-desktop-i386.iso
md5sum eb8ff86ce4fc10a305b918ce28e0908e
.disk/info:
Ubuntu 13.10 "Saucy Salamander" - Beta i386 (20131005)

David Balažic, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1077440/comments/32 regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers