Ubuntu

[CS4213, Dell Inspiron 3420] Internal speaker does not show up in "Sound settings"

Reported by mlchen on 2012-11-09
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
James M. Leddy
Precise
High
James M. Leddy
Quantal
High
James M. Leddy
linux (Ubuntu)
Medium
David Henningsson
Precise
Undecided
Unassigned
Quantal
Undecided
David Henningsson
Raring
Medium
David Henningsson
pulseaudio (Ubuntu)
Medium
Unassigned
Precise
Undecided
David Henningsson
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned

Bug Description

[SRU Justification]

Impact: The "internal speaker" does not show up in the sound settings, which causes this to block certification.

Test case: With the affected machines, open sound settings without headphones plugged in. If the "Internal Speaker" does not show up, the bug is present.

Regression risk (Quantal): Cirrus is a rare codec, mostly used in macbooks. Upstream has reviewed and blessed the patch.

Regression risk (Precise): These machines are quirked individually and won't affect other machines (and even if they did, the worst thing that could happen would be a "speaker" output that shouldn't be there).

This is due to the "Internal Speaker Phantom Jack" kctrl not being created.

the same issue occurs in the following sysyems:
cid:201202-10591, Dell Inspiron 3420 (PCI SSID: 1028:0553)
cid:201202-10590, Dell Inspiron 3420 (PCI SSID: 1028:0553)
cid:201202-10557, Dell Inspiron 3520 (PCI SSID: 1028:0555)
cid:201202-10593, Dell Vostro 2420 (PCI SSID: 1028:0556)
cid:201202-10558, Dell Vostro 2520 (PCI SSID: 1028:0558)

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-3.5.0-17-generic 3.5.0-17.28
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1605 F.... pulseaudio
 /dev/snd/pcmC0D0c: ubuntu 1605 F...m pulseaudio
Date: Thu Nov 8 21:35:36 2012
HibernationDevice: RESUME=UUID=47ccd585-7def-4658-a811-0740ccc8d313
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: Dell Inc. Inspiron 3420
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=414de9d1-6779-4d25-94ee-402d7d076b1e ro quiet splash initcall_debug vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-17-generic N/A
 linux-backports-modules-3.5.0-17-generic N/A
 linux-firmware 1.95
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/15/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A03
dmi.board.vendor: Dell Inc.
dmi.board.version: A03
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: Not Specified
dmi.modalias: dmi:bvnDellInc.:bvrA03:bd08/15/2012:svnDellInc.:pnInspiron3420:pvrNotSpecified:rvnDellInc.:rn:rvrA03:cvnDellInc.:ct8:cvrNotSpecified:
dmi.product.name: Inspiron 3420
dmi.product.version: Not Specified
dmi.sys.vendor: Dell Inc.

mlchen (mlchen1876) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Ara Pulido (apulido) on 2012-11-12
tags: added: blocks-hwcert
removed: certification-grey
mlchen (mlchen1876) on 2012-11-13
description: updated

Screenshot as attach:

summary: - [Dell Inspiron 4320]No Audio Interface after disconnects HDMI
+ Audio Interface disappears
description: updated
mlchen (mlchen1876) on 2012-11-13
summary: - Audio Interface disappears
+ Audio Interface disappears and no audio output

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.7 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.7-rc5-raring/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Changed in linux (Ubuntu):
assignee: nobody → David Henningsson (diwic)
summary: - Audio Interface disappears and no audio output
+ [CS4213, Dell Inspiron 3420] Internal speaker does
summary: - [CS4213, Dell Inspiron 3420] Internal speaker does
+ [CS4213, Dell Inspiron 3420] Internal speaker does not show up in "Sound
+ settings"
description: updated

If this array is not cleared, the jack related code later might
fail to create "Internal Speaker Phantom Jack" on Dell Inspiron 3420 and
Dell Vostro 2420.

BugLink: https://bugs.launchpad.net/bugs/1076840
Cc: <email address hidden> (3.6+)
Signed-off-by: David Henningsson <email address hidden>
---
 sound/pci/hda/patch_cirrus.c | 1 +
 1 file changed, 1 insertion(+)

Notes:
 1) AlsaInfo at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1076840/+attachment/3428375/+files/AlsaInfo.txt
 2) The phantom jack feature was added in Linux 3.6, but was backported to Ubuntu's 3.5 kernel, so should be applied there as well.

diff --git a/sound/pci/hda/patch_cirrus.c b/sound/pci/hda/patch_cirrus.c
index f99cbf9..ed98172 100644
--- a/sound/pci/hda/patch_cirrus.c
+++ b/sound/pci/hda/patch_cirrus.c
@@ -473,6 +473,7 @@ static int parse_output(struct hda_codec *codec)
   memcpy(cfg->speaker_pins, cfg->line_out_pins,
          sizeof(cfg->speaker_pins));
   cfg->line_outs = 0;
+ memset(cfg->line_out_pins, 0, sizeof(cfg->line_out_pins));
  }

  return 0;
--
1.7.9.5

Takashi Iwai (tiwai) wrote :

At Wed, 21 Nov 2012 10:03:10 +0100,
David Henningsson wrote:
>
> If this array is not cleared, the jack related code later might
> fail to create "Internal Speaker Phantom Jack" on Dell Inspiron 3420 and
> Dell Vostro 2420.
>
> BugLink: https://bugs.launchpad.net/bugs/1076840
> Cc: <email address hidden> (3.6+)
> Signed-off-by: David Henningsson <email address hidden>

Thanks, applied.

Takashi

> ---
> sound/pci/hda/patch_cirrus.c | 1 +
> 1 file changed, 1 insertion(+)
>
> Notes:
> 1) AlsaInfo at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1076840/+attachment/3428375/+files/AlsaInfo.txt
> 2) The phantom jack feature was added in Linux 3.6, but was backported to Ubuntu's 3.5 kernel, so should be applied there as well.
>
> diff --git a/sound/pci/hda/patch_cirrus.c b/sound/pci/hda/patch_cirrus.c
> index f99cbf9..ed98172 100644
> --- a/sound/pci/hda/patch_cirrus.c
> +++ b/sound/pci/hda/patch_cirrus.c
> @@ -473,6 +473,7 @@ static int parse_output(struct hda_codec *codec)
> memcpy(cfg->speaker_pins, cfg->line_out_pins,
> sizeof(cfg->speaker_pins));
> cfg->line_outs = 0;
> + memset(cfg->line_out_pins, 0, sizeof(cfg->line_out_pins));
> }
>
> return 0;
> --
> 1.7.9.5
>

David Henningsson (diwic) wrote :

Patch committed upstream in Takashi's tree.

Changed in linux (Ubuntu):
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.7.0-4.12

---------------
linux (3.7.0-4.12) raring; urgency=low

  [ Tim Gardner ]

  * Revert "[Config] Use -j1 for headers_install"
  * Revert "[Config] install-arch-headers needs a valid config"
    Strayed into the weeds in search of the root cause of the periodic
    build failure.
    Fixes powerpc FTBS introduced in -4.11.
  * [Config] hmake -j1
    The kernel makefile appears to have parallel dependency
    problems for the install_headers target. This appears to be root
    cause for a periodic build failure on N-way machines.
 -- Leann Ogasawara <email address hidden> Tue, 27 Nov 2012 12:33:06 -0800

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Tim Chen (ctf) wrote :

Dell Vostro 2520(cid 201202-10558) has this bug on Precise.

tags: added: precise
Kent Baxley (kentb) on 2012-11-30
Changed in oem-priority:
importance: Undecided → High
David Henningsson (diwic) wrote :

The same patch should be applied to our quantal tree, but for precise we need something different. For 12.04, could you please try the following:

Edit /lib/udev/rules.d/90-pulseaudio.rules, and add the following line:

ATTRS{subsystem_vendor}=="0x1028", ATTRS{subsystem_device}=="0x0553", ENV{PULSE_PROFILE_SET}="force-speaker.conf"

(along the other lines that say approximately the same thing but different IDs.)

Then reboot your computer. Let me know if this resolves the problem on 12.04. Thanks!

description: updated
Yung Shen (kaxing) wrote :

to: @diwic cc:@ctf

for Dell Vostro 2520(cid 201202-10558) on Precise.

by add following line to /lib/udev/rules.d/90-pulseaudio.rules :

ATTRS{subsystem_vendor}=="0x1028", ATTRS{subsystem_device}=="0x0558", ENV{PULSE_PROFILE_SET}="force-speaker.conf"

it fixed this bug, and headset works properly as well.

David Henningsson (diwic) wrote :

Since the fix for 12.04 is quirking, I'll need to know if there are any more machines with the similar symptoms before trying to fix it in PulseAudio, so I catch 'em all.

description: updated
description: updated
Tim Gardner (timg-tpi) on 2012-12-03
Changed in linux (Ubuntu Precise):
status: New → Won't Fix
Changed in linux (Ubuntu Quantal):
assignee: nobody → David Henningsson (diwic)
status: New → Fix Committed
Kent Baxley (kentb) wrote :

The machines that we know of are:

Dell Vostro 2420
Dell Vostro 2520
Dell Inspiron 3420
Dell Inspiron 3520

James M. Leddy (jm-leddy) wrote :

I just double checked and these machines exist in hexr.

description: updated
Changed in pulseaudio (Ubuntu Quantal):
status: New → Invalid
Changed in pulseaudio (Ubuntu Raring):
status: New → Invalid
Changed in pulseaudio (Ubuntu Precise):
status: New → In Progress
assignee: nobody → David Henningsson (diwic)
description: updated
Tim Chen (ctf) wrote :

@diwic:
the 5 systems are currently we have tested and found the bugs. We will continue to test more systems, if we found systems have this bug, I will comment on this bug.

description: updated

Hello mlchen, or anyone else affected,

Accepted pulseaudio into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/pulseaudio/1:1.1-0ubuntu15.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in pulseaudio (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Quantal in -proposed solves the problem (3.5.0-20.31). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-quantal' to 'verification-done-quantal'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-quantal
Tim Chen (ctf) wrote :

3.5.0-20.31 has just been superseded by 3.5.0-20.32, I will test it when 3.5.0-20.32 is ready.

David Henningsson (diwic) wrote :

Hi Tim,

Could you still test the pulseaudio version in 12.04? Thanks.

Luis Henriques (henrix) wrote :

Tim, the new 3.5.0-21.32 kernel has been uploaded into -proposed. Could you please verify this bug? Also, are you able to verify it for Precise as well? Thanks

Luis Henriques (henrix) wrote :

Ups, please ignore my referrence to Precise in my previous comment. Only Quantal requires verification.

David Henningsson (diwic) wrote :

@Luis, Tim, both precise and quantal require verification at this point:

 * For quantal, the kernel is in proposed
 * For precise, pulseaudio is in proposed

Kent Baxley (kentb) wrote :

@Tim,

If at all possible, please test the pulseaudio fix first. For business reasons we need to make sure the certification block is lifted for this machine.

Luis Henriques (henrix) wrote :

I'm tagging this as verified, as the fix is a oneliner and its available in mainline kernels.

tags: added: verification-done-quantal
removed: verification-needed-quantal
Launchpad Janitor (janitor) wrote :
Download full text (24.2 KiB)

This bug was fixed in the package linux - 3.5.0-21.32

---------------
linux (3.5.0-21.32) quantal-proposed; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1088979
  * SAUCE: i915_hsw: move i915_hsw_enabled symbol to intel_ips
    - LP: #1087622

linux (3.5.0-20.31) quantal-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1086759

  [ Ben Widawsky ]

  * SAUCE: i915_hsw: Include #define I915_PARAM_HAS_WAIT_TIMEOUT
    - LP: #1085245
  * SAUCE: i915_hsw: Include #define DRM_I915_GEM_CONTEXT_[CREATE,DESTROY]
    - LP: #1085245
  * SAUCE: i915_hsw: drm/i915: add register read IOCTL
    - LP: #1085245
  * SAUCE: i915_hsw: Include #define i915_execbuffer2_[set,get]_context_id
    - LP: #1085245

  [ Chris Wilson ]

  * SAUCE: i915_hsw: Include #define I915_GEM_PARAM_HAS_SEMAPHORES
    - LP: #1085245
  * SAUCE: i915_hsw: Include #define I915_PARAM_HAS_SECURE_BATCHES
    - LP: #1085245

  [ Daniel Vetter ]

  * SAUCE: i915_hsw: drm/i915: call intel_enable_gtt
    - LP: #1085245
  * SAUCE: i915_hsw: drm: add helper to sort panels to the head of the
    connector list
    - LP: #1085245
  * SAUCE: i915_hsw: drm: extract dp link bw helpers
    - LP: #1085245
  * SAUCE: i915_hsw: drm: extract drm_dp_max_lane_count helper
    - LP: #1085245
  * SAUCE: i915_hsw: drm: dp helper: extract drm_dp_channel_eq_ok
    - LP: #1085245
  * SAUCE: i915_hsw: drm: extract helpers to compute new training values
    from sink request
    - LP: #1085245
  * SAUCE: i915_hsw: drm: dp helper: extract drm_dp_clock_recovery_ok
    - LP: #1085245

  [ Dave Airlie ]

  * SAUCE: i915_hsw: Include #define I915_PARAM_HAS_PRIME_VMAP_FLUSH
    - LP: #1085245

  [ Leann Ogasawara ]

  * SAUCE: i915_hsw: Provide an ubuntu/i915 driver for Haswell graphics
    - LP: #1085245
  * SAUCE: i915_hsw: Revert "drm: Make the .mode_fixup() operations mode
    argument a const pointer" for ubuntu/i915 driver
    - LP: #1085245
  * SAUCE: i915_hsw: Rename ubuntu/i915 driver i915_hsw
    - LP: #1085245
  * SAUCE: i915_hsw: Only support Haswell with ubuntu/i915 driver
    - LP: #1085245
  * SAUCE: i915_hsw: Include #define DRM_I915_GEM_WAIT
    - LP: #1085245
  * SAUCE: i915_hsw: drm: extract dp link train delay functions from radeon
    - LP: #1085245
  * SAUCE: i915_hsw: drm/dp: Update DPCD defines
    - LP: #1085245
  * SAUCE: i915_hsw: Update intel_ips.h file location
    - LP: #1085245
  * SAUCE: i915_hsw: Provide updated drm_mm.h and drm_mm.c for ubuntu/i915
    - LP: #1085245
  * SAUCE: i915_hsw: drm/i915: Replace the array of pages with a
    scatterlist
    - LP: #1085245
  * SAUCE: i915_hsw: drm/i915: Replace the array of pages with a
    scatterlist
    - LP: #1085245
  * SAUCE: i915_hsw: drm/i915: Stop using AGP layer for GEN6+
    - LP: #1085245
  * SAUCE: i915_hsw: Add i915_hsw_gpu_*() calls for ubuntu/i915
    - LP: #1085245
  * i915_hsw: [Config] Enable CONFIG_DRM_I915_HSW=m
    - LP: #1085245

  [ Paulo Zanoni ]

  * SAUCE: drm/i915: fix hsw_fdi_link_train "retry" code
    - LP: #1085245
  * SAUCE: drm/i915: reject modes the LPT FDI receiver can't handle
    - LP: #1085245
  * SAUCE: drm/i915: add support for mPHY destination on i...

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
Tim Chen (ctf) wrote :

I have verified it on Quantal, kernel 3.5.0-21.32, but bugs remains, internal speaker interface disappears, but sound actually works.
@kentb: you want me to test with updated pulseaudio under Quantal? The pulseaudio I installed on the system is 2.1-0ubuntu4.

David Henningsson (diwic) wrote :

Tim chen, I need you to verify on Precise, with PulseAudio from the proposed repository.

David Henningsson (diwic) wrote :

And, if it does not work, please post the output of "pacmd ls" and an alsa-info from when you're trying to use the internal speaker and it doesn't show up. Thanks!

Tim Chen (ctf) wrote :

The bug is fixed with pulseaudio 1.1-0ubuntu15.2 under Precise.

tags: added: verification-done
removed: verification-needed
BlackDalek (dalekky) wrote :

This bug also affects my Inspiron 3520.

This is probably related - I also found that plugging cable into the HDMI port then unpugging causes internal speakers to go dead. The only way to restore sound output through internal speakers is to plug into headphones port then unplug headphones port - sound then returns to internal speakers.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:1.1-0ubuntu15.2

---------------
pulseaudio (1:1.1-0ubuntu15.2) precise-proposed; urgency=low

  * 0622-Front-headphone.patch:
    Fix "Front headphone Jack" not being picked up by PulseAudio
    (LP: #1020471)
  * 0623-resampler-Fix-volume-on-downmix-to-mono.patch:
    Fix clipping audio on downmix to mono (LP: #416190)
  * 01PulseAudio:
    Don't mute Bluetooth devices on suspend, they might remain muted
    after resume (LP: #1038084)
  * 0624-alsa-mixer-Add-Phantom-Jack-support.patch:
    This will allow us to work better with devices on the backport
    stack by making use of a Quantal kernel feature (if it exists).
    (LP: #946232)
  * 0625-alsa-mixer-Add-a-few-more-machines-to-internal-mic-w.patch:
    Add a few more machines to the internal mic whitelist
    (LP: #1076840) (LP: #1073420)
 -- David Henningsson <email address hidden> Fri, 09 Nov 2012 12:31:19 +0100

Changed in pulseaudio (Ubuntu Precise):
status: Fix Committed → Fix Released
Tim Chen (ctf) on 2013-02-19
tags: added: 201202-10593 taipei-lab
Changed in pulseaudio (Ubuntu):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers