Ubuntu

Can boot without wifi material switch off

Reported by Olivier Febwin on 2012-11-02
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I cannot boot since I've upgrade to Quantal.

Reverse mainline kernel version bisect revealed:
v3.6.6-raring/ -> doesn't boot
v3.7-rc1-quantal/ -> OK

WORKAROUND: Have WiFi hardswitch off while booting up.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-3.5.0-18-generic 3.5.0-18.29
ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7
Uname: Linux 3.5.0-18-generic x86_64
ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: crash 2253 F.... pulseaudio
Date: Fri Nov 2 14:07:55 2012
HibernationDevice: RESUME=UUID=a36789bd-535f-4e7a-ae61-54aa51b1dc73
InstallationDate: Installed on 2011-11-16 (352 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: Dell Inc. Latitude E6520
MarkForUpload: True
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-18-generic root=UUID=34631d8e-69a5-49f8-b06b-f669585eb0b9 ro quiet splash
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-18-generic N/A
 linux-backports-modules-3.5.0-18-generic N/A
 linux-firmware 1.95
RfKill:
 1: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: yes
SourcePackage: linux
UpgradeStatus: Upgraded to quantal on 2012-10-12 (21 days ago)
dmi.bios.date: 08/15/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A15
dmi.board.name: 0NVF5K
dmi.board.vendor: Dell Inc.
dmi.board.version: A01
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA15:bd08/15/2012:svnDellInc.:pnLatitudeE6520:pvr01:rvnDellInc.:rn0NVF5K:rvrA01:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E6520
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.

Olivier Febwin (febcrash) wrote :
Brad Figg (brad-figg) on 2012-11-02
Changed in linux (Ubuntu):
status: New → Confirmed

Olivier FEBWIN, thank you for reporting this and helping make Ubuntu better. Could you please put the WiFi hardswitch into the On position, and provide the information following https://wiki.ubuntu.com/DebuggingKernelBoot ?

tags: added: needs-upstream-testing
description: updated
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Olivier Febwin (febcrash) wrote :

After following Boot Options instructions (replace $linux_gfx_mode with text, remove quiet splash and $vt_handoff) my system boots with text mode and i can see

 * Starting save kernel messages [ OK ]
 * Starting [ OK ]
 * Starting [ OK ]
 * Starting anac(h)ronistic cron [ OK ]
 * Starting ACPI daemon [ OK ]
 * Starting CPU interrupts balancing daemon [ OK ]
 * Starting crash report submission daemon [ OK ]
 * Starting deferred execution scheduler [ OK ]
* Stopping anac(h)ronistic cron [ OK ]
 * Stopping save kernel messages [ OK ]

And it stop here with WiFi hardswitch in Off position.
Ctrl+Alt+Del doesn't work. I must have to press power button for 4 seconds to power off my system.

With WiFi hardswitch in On position, it boots fine.

Olivier Febwin (febcrash) wrote :

Olivier FEBWIN, thank you for providing the requested information., could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the mainline kernels archive directory daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.7-rc4-raring

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

Please let us know your results. Thank you for your understanding.

Helpful bug reporting tips:
https://help.ubuntu.com/community/ReportingBugs

Olivier Febwin (febcrash) wrote :
tags: added: kernel-fixed-upstream-v3.7-rc2-quantal
removed: needs-upstream-testing
Olivier Febwin (febcrash) wrote :

With 3.6.3 64 bits / Quantal kernel i've the same problem.
Ubuntu stop to load just before le login screen (and no pointer displayed).

Without linux-image-extra-3.6.3-030603-generic it boots fine but i've no dual screen support, no usb mouse support and bad resolution (1280x1024 - 5:4 instead of 1920x1080 - 16:10)

Olivier FEBWIN, thank you for testing the mainline kernel. The next step would be to find the last known bad mainline kernel version, followed consecutively in version by the first good one (e.g. reverse mainline kernel version bisect). For more on bisecting please see https://wiki.ubuntu.com/Kernel/KernelBisection . Consulting http://kernel.ubuntu.com/~kernel-ppa/mainline/ we have:
v3.6.3-quantal/
v3.6.4-raring/
v3.6.5-raring/
v3.6.6-raring/
v3.7-rc1-quantal/
v3.7-rc1-raring/
v3.7-rc2-quantal/

Hence, could you please test http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6.6-raring/ ?

Thank you for your understanding.

Olivier Febwin (febcrash) wrote :

v3.6.3-quantal/ -> doesn't boot
v3.6.3-quantal/ -> doesn't boot
v3.6.4-raring/ -> doesn't boot
v3.6.5-raring/ -> doesn't boot
v3.6.6-raring/ -> doesn't boot
v3.7-rc1-quantal/ -> OK
v3.7-rc2-quantal/ -> OK

I've notice that the problem is present (my system doesn't boot) only when WiFi hardswitch is in Off position AND WiFi softswitch is in On position (in network-manager).

If WiFi hardswitch is in Off position and WiFi softswitch is in Off position, my system boots fine.
If WiFi hardswitch is in On position and WiFi softswitch is in On position, my system boots fine.
If WiFi hardswitch is in On position and WiFi softswitch is in Off position, my system boots fine.

I can boots my system with 3.5.0-18 kernel when WiFi hardswitch is in Off position AND WiFi softswitch is in Off position and when I turn On Wifi softswitch the system freeze and I can't do anything (ctrl+alt+del have no effect, crtl+alt+F1 have no effect too).

description: updated
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: needs-reverse-mainline-commit-bisect
Olivier Febwin (febcrash) wrote :

My problem is still present on 3.5.0-20-generic.
Is there anything new about this? Or must I wait for 13.04?

Olivier FEBWIN, the next step would be to identify the specific commit that fixes your problem, in order to find out if it may be backported. Unfortunately, this is not yet documented in https://wiki.ubuntu.com/Kernel/KernelBisection . Hence, you are welcome to request information on how to reverse mainline kernel commit bisect this problem from the Ubuntu Kernel Team via https://wiki.ubuntu.com/KernelTeam#Communications .

Olivier FEBWIN, as per http://www.dell.com/support/drivers/us/en/19/Product/latitude-e6520 an update is available for your BIOS (A16). If you update to this, does it change anything? If not, could you please test for this in Raring via http://cdimage.ubuntu.com/daily-live/ ?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: bios-outdated
Olivier Febwin (febcrash) wrote :

Christopher,

1. The updated A16 Bios doesn't change anything.
2. I can't boot on live-usb raring-desktop-amd64 (01-23-2013) when WiFi hardswitch is in Off position AND WiFi softswitch is in On position (in network-manager).

If WiFi hardswitch is in Off position and WiFi softswitch is in Off position, my system boots fine on raring live usb
If WiFi hardswitch is in On position and WiFi softswitch is in On position, my system boots fine on raring live usb
If WiFi hardswitch is in On position and WiFi softswitch is in Off position, my system boots fine on raring live usb

tags: removed: bios-outdated
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
assignee: nobody → Joe le Kiffeur (joelekiffeur)
Joe le Kiffeur (joelekiffeur) wrote :
Download full text (18.7 KiB)

It also affects Ubuntu 12.04 LTS.
3.5.x linux branch crashes during boot (Ubuntu logo appears and the system freezes).
I can't use CTRL+Fn to try to resolve it, because the keyboard is not responding.

sudo lshw :

desktop
    description: Ordinateur de Bureau
    produit: System Product Name (SKU)
    fabriquant: System manufacturer
    version: System Version
    numéro de série: System Serial Number
    bits: 64 bits
    fonctionnalités: smbios-2.7 dmi-2.7 vsyscall32
    configuration: boot=normal chassis=desktop family=To be filled by O.E.M. sku=SKU uuid=80B9EC79-DAD7-DD11-B5C7-10BF4882C747
  *-core
       description: Carte mère
       produit: P8Z77-V LK
       fabriquant: ASUSTeK COMPUTER INC.
       identifiant matériel: 0
       version: Rev X.0x
       numéro de série: MT7024009700523
       emplacement: To be filled by O.E.M.
     *-firmware
          description: BIOS
          fabriquant: American Megatrends Inc.
          identifiant matériel: 0
          version: 0908
          date: 11/16/2012
          taille: 64KiB
          capacité: 8128KiB
          fonctionnalités: pci upgrade shadowing cdboot bootselect socketedrom edd int13floppy1200 int13floppy720 int13floppy2880 int5printscreen int9keyboard int14serial int17printer acpi usb biosbootspecification
     *-cpu
          description: CPU
          produit: Intel(R) Core(TM) i5-3450 CPU @ 3.10GHz
          fabriquant: Intel Corp.
          identifiant matériel: 4
          information bus: cpu@0
          version: Intel(R) Core(TM) i5-3450 CPU @ 3.10GHz
          numéro de série: To Be Filled By O.E.M.
          emplacement: LGA1155
          taille: 3101MHz
          capacité: 3800MHz
          bits: 64 bits
          horloge: 100MHz
          fonctionnalités: x86-64 fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms cpufreq
          configuration: cores=4 enabledcores=1
        *-cache:0
             description: L1 cache
             identifiant matériel: 5
             emplacement: L1-Cache
             taille: 256KiB
             capacité: 256KiB
             fonctionnalités: internal write-back unified
        *-cache:1
             description: L2 cache
             identifiant matériel: 6
             emplacement: L2-Cache
             taille: 1MiB
             capacité: 1MiB
             fonctionnalités: internal varies unified
        *-cache:2 DÉSACTIVÉ
             description: L3 cache
             identifiant matériel: 7
             emplacement: L3-Cache
             taille: 6MiB
             capacité: 6MiB
             fonctionnalités: internal unified
     *-memory:0 NON-RÉCLAMÉ
          identifiant matériel: 1
        *-bank NON-RÉCLAMÉ
             description: DIMMProject-Id-Version: @(#) $Id$Report-Msgid-Bugs-To: POT-Creation-Date...

Changed in linux (Ubuntu):
assignee: Joe le Kiffeur (joelekiffeur) → nobody

Joe le Kiffeur, if you have a bug in Ubuntu, could you please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Kernel team article:
https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports

the Ubuntu Bug Control team and Ubuntu Bug Squad team article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report may delay your problem being addressed as quickly as possible.

Thank you for your understanding.

Olivier Febwin (febcrash) wrote :

It's OK on raring!

Linux Dell-Latitude-E6520 3.8.0-19-generic #29-Ubuntu SMP Wed Apr 17 18:16:28 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Olivier Febwin, did you need a backport to a release prior to Raring, or may we close this as Status Invalid?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Olivier Febwin (febcrash) wrote :

No, I stay on raring.
You can close this bug report.

Olivier Febwin, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1074349/comments/19 regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers