Ubuntu

general protection fault: 0000 [#1] SMP; RIP: 0010:[<ffffffffa042121f>] [<ffffffffa042121f>] HostIF_SafeRDMSR+0xf/0x30 [vmmon]

Reported by spectre on 2012-10-26
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Hi all,

and cast my cares on Ubuntu 12.04 LTS with on a Vmware Workstation 9 and since the update of Ubuntu this weekend 12.10 more way to start my VM because it appears this error:

Unable to change virtual machine power state: Failed to power on '/ home / spectrum / vmware / Ubuntu 64-64-bit/Ubuntu bit.vmx'.
Transport (VMDB) error -14: Pipe connection has-been broken.
When I try to uninstall the error given here:

The VMware Installer Could not shut down all running virtual machines. If You Have ACE VMs open, please shut them down or suspend em now and press 'Retry' to continue.
No way to uninstall or overwrite it with a clean reinstall ...

How to proceed?

Thank you.

---

Bonjour a tous,

mon soucis et que jetait sous Ubuntu 12.04 LTS avec dessus un Workstation 9 de Vmware et que depuis la mise a jour de Ubuntu ce week-end en 12.10 plus moyen de lancer mes VM car il s'affiche cette erreur:

Unable to change virtual machine power state: Failed to power on '/home/spectre/vmware/Ubuntu 64-bit/Ubuntu 64-bit.vmx'.
Transport (VMDB) error -14: Pipe connection has been broken.
Lorsque j'essai de desinstaller voici l'erreur donnée:

The VMware Installer could not shut down all running virtual machines. If you have ACE VMs open, please shut them down or suspend them now and press 'Retry' to continue.
Pas moyen de désinstaller correctement, ni écraser avec une réinstallation propre...

Comment procéder?

Merci.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-3.5.0-17-generic 3.5.0-17.28
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: spectre 4482 F.... pulseaudio
 /dev/snd/controlC0: spectre 4482 F.... pulseaudio
Date: Fri Oct 26 22:25:17 2012
DistributionChannelDescriptor:
 # This is a distribution channel descriptor
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-oneiric-amd64-20111116-1
EcryptfsInUse: Yes
InstallationDate: Installed on 2012-07-24 (94 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric" - Build amd64 LIVE Binary 20111116-18:24
MachineType: Dell Inc. Latitude E6530
MarkForUpload: True
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=0a4ed6b9-ac38-477f-95cc-ea6607a63523 ro vga=0x318 quiet splash
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-17-generic N/A
 linux-backports-modules-3.5.0-17-generic N/A
 linux-firmware 2.0-bt7
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: Upgraded to quantal on 2012-10-19 (7 days ago)
dmi.bios.date: 04/24/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A02
dmi.board.name: 07Y85M
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA02:bd04/24/2012:svnDellInc.:pnLatitudeE6530:pvr01:rvnDellInc.:rn07Y85M:rvrA00:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E6530
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.

spectre (spectre3brad) wrote :
Brad Figg (brad-figg) on 2012-10-26
Changed in linux (Ubuntu):
status: New → Confirmed
spectre (spectre3brad) on 2012-10-27
description: updated
spectre (spectre3brad) wrote :

Test 3 PC giving the same thing every time. Contact VMware: No response! Found no solution yet.

Victor Remmo (vicrem) wrote :

Check this out - it solved my problem..

http://communities.vmware.com/thread/415047

First I executed the patch then
sudo rm /lib/modules/$(uname -r)/misc/vm*
reboot
sudo vmware-modconfig --console --install-all

And now everything is working =)

spectre (spectre3brad) wrote :

It works great with this method, I tried with another patch but nothing. By working against it. thank you;)

I'll share the solution on the French Ubuntu community for others who have the same worries, hoping that it works for them too.

Changed in linux (Ubuntu):
status: Confirmed → Fix Committed

Not Fix Committed as per https://wiki.ubuntu.com/Bugs/Status .

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Fix Committed → Confirmed
tags: added: vmware
pst007x (turone) wrote :

Patch mentioned above is NOT for VMware 9...

The vmware forums do mention this, with reference to Fedora, but NOT Ubuntu 12.10.

I think best to downgrade back to an earlier Kernel or back to the poorly put together 12.04...

I do not believe there is currently a solution available..

spectre (spectre3brad) wrote :

Set with the updated official VMware Workstation 9.

The update from them arrived very late, almost a month after a "simple" patch a member of the Linux community. But VMware has teams of experts with CASH very important ... I hope that next time will be more reactive and VMware not wait to do a particular work in their place.

In short, I propose closing the bug.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Karma Dorje (taaroa) on 2012-12-11
summary: - Crash VMware Workstation 9 on Ubuntu 12.10 (Linux 3.5 Kernel)
+ general protection fault: 0000 [#1] SMP; RIP: 0010:[<ffffffffa042121f>]
+ [<ffffffffa042121f>] HostIF_SafeRDMSR+0xf/0x30 [vmmon]
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers