Hard Freeze (Kernel Panic) During Heavy Disk I/O on ext4

Bug #1071012 reported by tdeering on 2012-10-24
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

During heavy disk write activity (eg. swapping, writing large files to disk), the system freezes hard (becomes 100% unresponsive) with the CPU fan spun up high, and stays that way until a hard reset.

I've noticed this problem under two separate installs of 12.04 64-bit, on two different SSDs. There seems to be some race condition exposed by the pure speed of the writes?

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-32-generic 3.2.0-32.51
ProcVersionSignature: Ubuntu 3.2.0-32.51-generic 3.2.30
Uname: Linux 3.2.0-32-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu14
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: VT1802 Analog [VT1802 Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: tom 2101 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf7e10000 irq 45'
   Mixer name : 'Intel PantherPoint HDMI'
   Components : 'HDA:11068446,15582702,00100000 HDA:80862806,15582702,00100000'
   Controls : 33
   Simple ctrls : 18
Date: Wed Oct 24 15:24:35 2012
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=8b07a0c0-c9d4-4e2d-b6a0-f4c83e095727
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
MachineType: System76, Inc. Gazelle Professional
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-32-generic root=UUID=9aca9502-5d32-4ca7-b011-f53d95eb5d65 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-32-generic N/A
 linux-backports-modules-3.2.0-32-generic N/A
 linux-firmware 1.79.1
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/16/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 4.6.5
dmi.board.asset.tag: Tag 12345
dmi.board.name: Gazelle Professional
dmi.board.vendor: System76, Inc.
dmi.board.version: gazp7
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr4.6.5:bd05/16/2012:svnSystem76,Inc.:pnGazelleProfessional:pvrgazp7:rvnSystem76,Inc.:rnGazelleProfessional:rvrgazp7:cvnNoEnclosure:ct9:cvrN/A:
dmi.product.name: Gazelle Professional
dmi.product.version: gazp7
dmi.sys.vendor: System76, Inc.

tdeering (tomdeering7) wrote :
tdeering (tomdeering7) wrote :

This may have already been reported upstream. This seems to be what keeps happening to me.

https://bugzilla.kernel.org/show_bug.cgi?id=44731

tdeering (tomdeering7) wrote :

For both installs where I experienced this problem, ext4 was the file system in use.

Brad Figg (brad-figg) on 2012-10-24
Changed in linux (Ubuntu):
status: New → Confirmed

tdeering, thank you for reporting this and helping make Ubuntu better. Could you please capture the oops following https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Capturing_OOPs ?

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tdeering (tomdeering7) wrote :
description: updated
tdeering (tomdeering7) wrote :
tdeering (tomdeering7) wrote :

I don't see anything particularly exciting in the logs, but here you go.

tdeering, unfortunately the none of the logs you attached contained an oops or a call trace. Could you please capture the oops following https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Capturing_OOPs ?

Changed in linux (Ubuntu):
importance: Medium → High
tdeering (tomdeering7) wrote :

It looks like following https://wiki.ubuntu.com/Kernel/CrashdumpRecipe?action=show&redirect=KernelTeam%2FCrashdumpRecipe is fairly involved. I'm slightly concerned about borking my primary computer which I use for research. If anyone has comments or suggestions for a less invasive diagnosis, let me know.

summary: - Hard Freeze (Kernel Panic) During Heavy Disk Activity
+ Hard Freeze (Kernel Panic) During Heavy Disk I/O on ext4
tdeering (tomdeering7) wrote :

I'll try to set up netconsole and reproduce this weekend, since the nature of the problem doesn't allow the panic to get written to local log files.

tdeering (tomdeering7) wrote :

I apologize that I haven't had time to try to induce/capture the panic, but it's still on my radar.

This is particularly true since it just happened a moment ago, forcing a hard reset and loss of research data :(

tdeering (tomdeering7) wrote :

I should mention that I wasn't even doing heavy disk I/O when this occurred...

DiagonalArg (diagonalarg) wrote :

I'm having similar problems trying to copy 1/2T of data. The system is repeatedly freezing during a "cp" command. (12.04.2, fully updated.)

DiagonalArg, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

No need exists to comment here at this time. After reading the above documention in it's entirety, if you have further questions, you are welcome to redirect them to the appropriate mailing list or forum via http://www.ubuntu.com/support/community/mailinglists , or you may contact me directly.

Thank you for your understanding.

Dimitrenko (paviliong6) on 2017-07-04
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.