Ubuntu

Intermittent black screen or low graphics mode message

Reported by Matthew Eaton on 2012-10-23
432
This bug affects 86 people
Affects Status Importance Assigned to Milestone
Light Display Manager
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned

Bug Description

Update - 01.19.13

Some systems are intermittently booting to a black screen or message about low graphics mode but a graphical login display never loads.

Multiple GPU's are affected. Intel HD graphics driver and ATI open source driver are confirmed to have the issue. Nvidia binary driver and Nouveau driver still unconfirmed.

Multiple users are affected here:
http://ubuntuforums.org/showthread.php?t=2073483

There are currently three known workarounds to this issue:
1) Log in with CTRL+ALT+F1 and issue command "sudo service lightdm restart"
2) Add some sleep to /etc/init/lightdm.conf
3) Install and use GDM instead of lightdm

lsb_release -rd
Description: Ubuntu 12.10
Release: 12.10

uname -a
Linux matt-pc 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-3.5.0-17-generic 3.5.0-17.28
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: matt 2002 F.... pulseaudio
Date: Mon Oct 22 20:55:29 2012
HibernationDevice: RESUME=UUID=d9a43e39-0d27-4a5b-90ca-79dc0278afa2
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: System manufacturer System Product Name
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=85247ab4-6b7d-4d5a-a265-73b485861e24 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-17-generic N/A
 linux-backports-modules-3.5.0-17-generic N/A
 linux-firmware 1.95
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/16/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1606
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: P8Z77-V
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1606:bd08/16/2012:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnP8Z77-V:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Matthew Eaton (powder) wrote :
Matthew Eaton (powder) on 2012-10-23
description: updated
description: updated
Brad Figg (brad-figg) on 2012-10-23
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.7 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. Please only remove that one tag and leave the other tags. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.7-rc2-raring/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: needs-upstream-testing
fjgaude (tanzen) wrote :

I have this same issue with both 12.04 and 12.10... don't think it's a kernel problem. Using ctrl-alt-F1 at boot-up black screen and using terminal to issue these: sudo service lightdm restart immediately brings up the desktop, Unity3D, Intel HD3000, dual SSDs, 8GB RAM.

Seems the parsing of tests for hi-res video card is the issue.

frank

fjgaude (tanzen) wrote :

I installed gdm and selected it instead of lightdm, rebooted and login went directly to desktop, hi-res, 3DUnity.

Issue points to how tests is made to determine video card speed.

Matthew Eaton (powder) wrote :

Hi Frank,

Thanks for your feedback. I did confirm your workaround does provide a graphical login screen for me as well:

CTRL+ALT+F1
sudo service lightdm restart

If GDM works too then maybe this is a lightdm bug?

I did try to install the mainline kernel but got errors... (see errors.txt)

Matthew Eaton (powder) wrote :

Sorry, I was installing the wrong one. I just installed the mainline kernel but it does not resolve the problem.

uname -a
Linux matt-pc 3.7.0-030700rc2-generic #201210220428 SMP Mon Oct 22 08:29:33 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

tags: added: kernel-bug-exists-upstream
tags: added: lightdm
removed: needs-upstream-testing xorg
Maarten Kossen (mpkossen) wrote :

The workaround to restart lightdm makes me think this *may* be lightdm-related. I'll try and gather some logs next time I get a low graphics mode message and post them here.

petar dimitrov (pesho21) wrote :

I confirm, that lightdm restarting works. If lightdm is replaced by gdm the issue is gone and everything works very well. So I also think, that the problem is somewhere in the lightdm.

Maarten Kossen (mpkossen) wrote :

Also, this may be related: https://bugs.launchpad.net/lightdm/+bug/873495

When I just booted, lightdm wasn't running at all. So it either crashed or didn't start. Maybe this will help us narrow down the problem. I'll be testing now.

Maarten Kossen (mpkossen) wrote :

The sleep 1 && service lightdm start in /etc/rc.local didn't work. I'm attaching some logs.

Maarten Kossen (mpkossen) wrote :

The x-o.log from /var/log/lightdm

Maarten Kossen (mpkossen) wrote :

And finally the x-0-greeter.log from /var/log/lightdm

Sorry for the spam, but either LP doesn't allow me to upload more than one attachment at a time or I don't know how to.

Matthew Eaton (powder) on 2012-10-27
description: updated
Matthew Eaton (powder) wrote :

Here are my lightdm logs in case they're useful...

Changed in linux (Ubuntu):
status: Incomplete → New
Brad Figg (brad-figg) on 2012-11-05
Changed in linux (Ubuntu):
status: New → Confirmed
Michael (starkpc) wrote :

My System:
Mainboard: Gigabyte Z77M-D3H
CPU: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz
Screen: EIZO FlexScan S2411W @ DVI-D

My workaround:
1. login on tty1
2. ps aux | grep X
3. sudo kill PID (from "/bin/bash /usr/share/xdiagnose/failsafeXServer lightdm")
4. sudo start lightdm

Maarten Kossen (mpkossen) wrote :

Also, do not forget to exit the tty1 session, since you can go there even though your screen may be locked. I personally use this line:

sudo killall -9 lightdm; sudo service lightdm start && exit

Michael (starkpc) wrote :

I suspect lightdm starts before the "display-output" is ready.

new workaround:
1. sudo nano -c /etc/init/lightdm.conf
2. paste "sleep 2" between line 24 (script) and line 25 (if [ -n "$UPSTART_EVENTS" ])

I know it's a dirty edit, but it works on my system :-)

fjgaude (tanzen) wrote :

Michael, your fix doesn't work for me with Intel HD3000 graphics. I get the log-in screen over and over, can't log-in.

Michael (starkpc) wrote :

@ fjgaude
check out the attachment for comparison...
it works fine on my system #14.

fjgaude (tanzen) wrote :

Michael, I have the exact code that your attachment shows. No go! Do you use a SSD for boot?

fjgaude (tanzen) wrote :

I've tested this with SSD boot on 12.04, 12.10 and 13.04, all with success, no issues:

Place this line in /etc/rc.local just before exit 0:

sleep 2 && service lightdm restart

This works everytime for me and my setup. Should give a clue to the programmers as to what can solve the issue.

Michael (starkpc) wrote :

lightdm / X starts too fast and I don't know whether it's lightdm, upstart or somethings else fault...

@ fjgaude
Intel SSD 330 Series 120GB (SSDSC2CT120A3)

AnAkIn (anakin-cs) wrote :

I have exactly the same issue since upgrading to Ubuntu 12.10, but it happens like 1 out of 10 boots. I don't have a SSD.
I do get an other similar issue though, which is probably related, lightdm doesn't seem to start at all, the screen stays black. That issue seem to happen a lot more. Seem to be similar to #9.
I currently don't have any logs as I didn't get it on my last boots, will upload once it happens again.

Maarten Kossen (mpkossen) wrote :

The solution from #20 works for me as well!

Fiorenzo De Santis (fiod3s) wrote :

I was affected as well but after I upgraded with the software from xorg-edgers PPA, and I selected lightdm again, the problem has gone.

So I think that this isn't a problem of lightdm rather it's a problem of xorg related software.

If you want to upgrade too, you should refer to https://launchpad.net/~xorg-edgers/+archive/ppa

Matthew Eaton (powder) wrote :

Hi Fiorenzo,

I'm afraid the xorg-edgers ppa did not solve this bug for me.

Regards

Michael (starkpc) wrote :

With "xorg-edgers ppa" enabled I get a different behavior.
Ubuntu boot stuck on a black screen with few boot-messages and a moveable white X11 mouse cursor.
Lightdm itself is not visible. login on tty1 and a lightdm restart works.

Bhabba (bhabba) wrote :

I installed at first Ubuntu 12.04 , then 12.10 on a fresh built custom PC with a Intel Core i7 3770, OCZ Vertex 4 SSD and 16GB DDR3-1600 Ram on a ASRock Z77E-ITX Mainboard. After both installations I ended up randomly in this "low graphics mode".

Entering "sudo service lightdm restart" after login in the text console worked, but naturally this isn't a very comfortable solution

So I tried the workaround from Michael (starkpc) in post #16 and it did work for me – even with a sleep value of only 1. For now I'm good I suppose...

Matt (matthew-sigswitch) wrote :

Did a new install on friday with an i7-3570K, onboard graphics and crucial M4 ssd.
Was able to boot into ubuntu fine over the weekend, though suddenly today I get the same "Low graphics mode" problem. None of the fixes in the window that pops up work, so I have to drop down to console and manually `startx`.

Adding `service lightdm start` to `/etc/rc.local` "fixes" the problem for the time being, though isn't really ideal. It seems this bug might be related to #873495 (https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/873495) ?

I've attached my X logs. Xorg.0.* is when X fails to start, and I think Xorg.1.* is from when X starts after running startx from console

Matt (matthew-sigswitch) wrote :

Forgot to say that I'm using X 1.13(2012-09-05) and Ubuntu 12.10

Martin (vylik) wrote :

I have the same problem with Intel Core i5-2500K and onboard graphics, motherboard P8Z68-M PRO and Crucial M4 SSD. I'm using Ubuntu 12.10 x86_64.

Chris Bier (cbier) wrote :

I have this problem on my Dell Latitude E6500 with Intel Mobile 4 graphics using the i915 kernel driver.
Switching to gdm from lightdm just brought up the "low graphics mode" dialog.

I think this is more of an Xorg issue because of the X log message:
[drm] failed to set drm interface version.
Failed to become DRM master.
UnloadModule: "intel"

These seem related:
bug #982889
bug #966868

Matthew Eaton (powder) wrote :

Hi Chris,

Thanks for your comments.

Adding sleep to /etc/init/lightdm.conf seems to be a more elegant workaround for this bug:

https://bugs.launchpad.net/ubuntu/+source/libdrm/+bug/982889/comments/5

Saraphim (sbrofeldt) wrote :

I have a Lenovo T530 Thinkpad with an SSD, and I also experience this problem. Interestingly, I have another problem (which other people here may have too) that is more subtle. Sometimes, instead of low graphics mode, the system starts up with llvmpipe rendering, causing the compositing to chew through loads of CPU.

D. Sagar (dsagar) wrote :

I experience this on Intel HD2500. The workaround of sleep 2 && service lightdm restart in /etc/rc.local seems to be working so far

DAVID (gron-h) wrote :

I experience this problem too since my upgrade to Quantal, and use "sudo service lightdm restart" when it happens.
But since a few days, i have a new problem : my whole graphic environment sometimes vanishes completely when i press the ESC key while reading my e-mails with thunderbird !
I use "sudo service lightdm restart" and all is up again. Don't know if this new problem is related to the first.
(my conf: dell e6420 - SSD)

Holger Knust (hknust) wrote :

I had the same intermittent issue on my Dell laptop. I am booting 12.10 x64 from a SSD drive. Starting with 12.10, the boot time has improved significantly and apparently that is part of the problem. I experimented with placing a service lightdm restart in rc.local but that resulted in a non-functioning touchpad. Michael's tip (#16) works perfectly for me.

Thanks, Michael!

I had the same issue on my Samsung notebook (NP300E5X-A02IT, with Intel HD Graphics 4000). I solved the issue by installing gdm and selecting it instead of lightdm.

ChrisKelley (ckelley) wrote :

Same bug here. Fresh 12.10 install on Gateway DX4860-UR11P desktop:
Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
 Subsystem: Acer Incorporated [ALI] Device 0589
 Kernel driver in use: i915
 Kernel modules: i915
SSD: Crucial M4 CT128M4SSD2 2.5" 128GB SATA III MLC

Bought it, disconnected windows HDD, install fresh SSD + Ubuntu 12.04. 12.04 did not have this issue for me but I was unable to upgrade (uefi problems) so this is with format and fresh install of 12.10 on the SSD. Trying /etc/rc.local fix & if that doesn't work, I'll install gdm.

Lulzim (lulzimbilali) wrote :

I am having the same issue with a system with dual vga nvidia optimus and intel (I don't use nvidia proprietary drivers or any thing). I would be happy if intel starts always correctly.

I tryed to compare log files of xorg and they start differentiating with line "setversion 1.4 failed"
In the good log file (the one that system starts normally) the order of loading moduls is:
[ 6.071] (==) Matched intel as autoconfigured driver 0
[ 6.071] (==) Matched nvidia as autoconfigured driver 1
[ 6.071] (==) Matched nouveau as autoconfigured driver 2
[ 6.071] (==) Matched nv as autoconfigured driver 3
[ 6.071] (==) Matched intel as autoconfigured driver 4
[ 6.071] (==) Matched vesa as autoconfigured driver 5
[ 6.071] (==) Matched modesetting as autoconfigured driver 6
[ 6.071] (==) Matched fbdev as autoconfigured driver 7
[ 6.071] (==) Assigned the driver to the xf86ConfigLayout

in the other one the secuence is:
[ 7.362] (==) Matched nvidia as autoconfigured driver 0
[ 7.362] (==) Matched nouveau as autoconfigured driver 1
[ 7.362] (==) Matched nv as autoconfigured driver 2
[ 7.362] (==) Matched intel as autoconfigured driver 3
[ 7.362] (==) Matched vesa as autoconfigured driver 4
[ 7.362] (==) Matched modesetting as autoconfigured driver 5
[ 7.362] (==) Matched fbdev as autoconfigured driver 6
[ 7.362] (==) Assigned the driver to the xf86ConfigLayout

as you can see, it seems like the drivers are recing which one has to start first and if intel starts first it works other wise fails.

 if you need both full log files or any thing I can do to help please let me know.

another problem I have (not sure if related) is that when starting with a second monitor connected the system hangs with a black screen.
this happens after selecting to boot on ubuntu (I have dual boot sytem).

Matthew Eaton (powder) on 2013-01-19
summary: - Intermittent low graphics mode with Intel HD graphics
+ Intermittent low graphics mode or black screen with Intel HD graphics
Matthew Eaton (powder) on 2013-01-19
summary: - Intermittent low graphics mode or black screen with Intel HD graphics
+ Intermittent black screen or low graphics mode with Intel HD graphics
description: updated

If you are going to update the summary, please indicate that this affects other graphic drivers than just Intel. I have this problem with ATI open source drivers, no intel graphics at all on any of my computers.

Matthew Eaton (powder) on 2013-01-19
summary: - Intermittent black screen or low graphics mode with Intel HD graphics
+ Intermittent black screen or low graphics mode message
Matthew Eaton (powder) on 2013-01-19
description: updated
robled (robled) wrote :

The lightdm.conf sleep workaround in #16 works for me. I've got a Intel HD4000 graphics and a speedy SSD.

Computer boots too fast = firstworldproblems

Chascon (chascone) wrote :

Changing the greeter invoked worked like a charm for me. I wrote about the fix in https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1047156

phil (fongpwf) wrote :

I think I see the problem on an X230 with Intel graphics and a SSD. Does black screen mean text login screen? I get that more often than the low graphics messages.
When I get the text login and look at the Xorg log I see the X server failed to start with the following error:
(EE) intel(0): [drm] Failed to open DRM device for pci:0000:00:02.0: No such file or directory

emk2203 (erik-koennecke) wrote :

I have the same issue with a fresh update to the 13.04 (Raring Ringtail) alpha 2 from 2013-02-20.

It obviously affects the next version with the 3.8.0 kernel as well.

After I inserted a "sleep 1" line in /etc/init/lightdm.conf after line 36 (as the first line of the main script code), the problem went away.

Hardware: Intel Core2Duo processor T8300 @ 2.40 GHz x2, Intel 965GM graphics, laptop with external monitor and closed lid

Same problem on two systems (one with Intel and one with radeon) both with SSD.

The problem seems to be a race condition where the system boots so fast that the graphical stack is not ready for lightdm to work.

Ernie 07 (ernestboyd) wrote :

64-bit 3.8.0-9-generic #18-Ubuntu SMP Thu Feb 28 17:02:06 UTC 2013
Desktop with Intel e8500 cpu, Nvidia GT9500 and default (non-Nvidia) video driver.

I get this problem frequently following a restart from 12.04.

Pressing the reset button or executing a FULL power shutdown prior to completion of booting 13.04 will usually eliminate this problem. This would imply that a hardware state that is properly initialized following a reset or full power shutdown is NOT being properly initialized during a warm reboot.

On occasion, I have also had to update/install grub, either from 12.04 or a via fix a broken system from a server CD.

David Huber (david-huber) wrote :

I have had this problem ever since I started using Intel graphics that came with my processor. I have been scratching my head for about a year now. I have given up Linux almost because of this issue. Thank god I found the culprit It is the lightdm which has a bug. I switched to gdm and now the problem is solve. Please fix that piece of junk.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
robled (robled) wrote :

I'm still able to intermittently reproduce this issue. My Ubuntu 12.10 system (including kernel) is up to date.

markb (mark-blakeney) wrote :

Just add a comment here that I have a new fast PC + SSD + HD4000 graphics and I get both these problems on frequently updated Ubuntu 12.10. I "solved" the low graphics mode issue long ago by changing from lightdm to gdm. I have 2 screens and occasionally I boot up and get 1 black screen but I have found this corrects if I switch to a console terminal (i.e. ctrl+alt+f1) and then switch back to X (i.e. ctrl+alt+f7). Both these problems occur with or without xorg edgers ppa (which upgrades kernel to 3.7.0 currently). In fact I tried that ppa again today and still got a black screen.

Benny Bach (benny-bach) wrote :

Just want to confirm that I also have this issue. My PC is a dell xps 15 (l521x) with an ssd. The nvidia card is switched off, so using only hd4000.

Ubuntu is 12.10 - 3.5.0-26-generic #42-Ubuntu SMP Fri Mar 8 23:18:20 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Having this in rc.local
sleep 1 && service lightdm restart

Fixes the issue

styro (anton-list) wrote :

This has also hit me on fresh 12.10 AMD64 install with a Thinkpad T530 with Intel HD4000 and SSD.

But it only started after the last kernel update (3.5.0-26.42). Before then it was working fine.

The listed workaround of restarting lightdm also works for me.

phil (fongpwf) wrote :

The status in linux (Ubuntu) has been changed to fixed. What was fixed and which package version fixes this?

Byron du Preez (byron-dupreez) wrote :

I frequently experience black screen with cursor in top left and [OK] in top right on boot (occasionally still experience low graphics mode screen on boot too). More recently, I am starting to experience frequent same black screens while I am trying to work as well. My non-technical "workaround" for this problem (on boot or while I am working) is to plug in a VGA cable into the back of my laptop (even with second screen powered off). This gives me back my graphical screen and I can continue working for awhile. When it happens again later, I unplug the VGA cable and get my graphical screen back again. And so on, and so on ... Obviously, this is not a viable workaround, but only mentioning it in the hope it might shed some light on this incredibly irritating issue. My Ubuntu 12.10 is completely up-to-date and the problem still persists. Since, the intermittent black screens only started last week sometime, I assume a recent update has caused them. The low graphics mode screens on boot seem less frequent, but black screens on boot occur frequently.

Chascon (chascone) wrote :

I came across another fix, when changing the greeter stopped working. For those who removed Unity, removing it sometimes uninstalls unity-greeter and reinstalling it installs a whole lot of stuff some of which fixed my low resolution issue.

Chascon (chascone) wrote :

And don't list anything else but unity-greeter in lightdm.conf.

jnns (jnns) wrote :

I'm experiencing this bug on every other boot since a few months now. At first, I was using 12.10 but last week I updated to 13.04 and the issue remains;

 - the Ubuntu boot logo shows up
 - then the screen goes black
 - a movable mouse cursor becomes visible in the center of the screen
 - a blinking cursor appears in the top left corner
 - nothing happens until I switch to a console prompt via CTRL-ALT-F1…6

With the console, I can restart lightdm and everything works fine from there on.

Lenovo Thinkpad X230 with Ubuntu 13.04 x86_64 and Kernel 3.8.0-19
lightdm 1.6.0-0ubuntu2
xorg 1:7.7+1ubuntu4

Justin Watt (justincwatt) wrote :

Just wanted to mention that I ordered a new 512GB Samsung 840 Pro SSD, for my ThinkPad X220, in anticipation of installing 13.04 from scratch. And I can confirm what everyone else is saying.

The reboot after the installation hung. I powered down and powered it up again, and it hung at a black screen with a working arrow pointer. You can imagine that sinking feeling I got. I powered it off again and this time I was able to login. Immediately got a crash notification once I logged in, but without any real information as to why. Rebooted again (just to see), and this time it locked up at a screen with the error message "The system is running in low graphics mode" on a black background. Powered down again, probably got a black screen + cursor a few times, but eventually was able to log in. So it's been a pretty disappointing first impression, but otherwise, Ringtail has been Raring.

I found the advice to add some sleep to /etc/init/lightdm.conf, added some, and so far (a 2-3 reboots) I haven't had any issues.

This has just started happening today on my 13.04 64-bit install . Yesterday updates to 3.8.0-19 were installed, don't know if that's just a coincidence.

Have added "sleep 2" as per comment #16, still got the issue.

This install is only about 1 week old, and was done from fresh (not an upgrade).

"sudo service lightdm restart" gets me in at least, but it's a PITA.

Lenovo x121e, Intel Core i3-2367M with an Intel SSD.

I also have a SSD and experience the same problem with black screen and a blinking cursor on startup.
If I enter the password for my account then the black screen is displayed I am logged in but I don't see anything then I enter the text.

I thought the fix in #16 did the trick but today I once again experienced the black screen...
So it did not solve the problem entirely.

Tomáš Honzák (thonzak) wrote :

Affects me on fresh install of 64bit 13.10, Noveau drivers,

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers