Ubuntu

No audio from headphone jack on Ultrabase Series 3 with ThinkPad T430

Reported by Stefan Freyr on 2012-10-02
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Joseph Salisbury
Quantal
Medium
Joseph Salisbury

Bug Description

I have a Lenovo ThinkPad T430 and an UltraBase Series 3 docking station.

If I plug my headphones into the jack on the computer, everything works fine. The computer speakers mute and the audio is played in the headphones. However, if I plug into the docking station headphone jack the computer speakers are muted but there is no audio in the headphones.

I've found two other bugs that are similar, bug 893611 and bug 1026953, but they specify a different type of computer/tablet so I decided to file a new bug.

Also, the workaround mentioned in bug 893611, adding "options snd-hda-intel model=thinkpad" to alsa-base.conf does not work for me.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-3.5.0-16-generic 3.5.0-16.25
ProcVersionSignature: Ubuntu 3.5.0-16.25-generic 3.5.4
Uname: Linux 3.5.0-16-generic x86_64
ApportVersion: 2.6.1-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: stefan 2445 F.... pulseaudio
 /dev/snd/pcmC0D0p: stefan 2445 F...m pulseaudio
CRDA:
 country IS:
  (2402 - 2482 @ 40), (N/A, 20)
  (5170 - 5250 @ 40), (N/A, 20)
  (5250 - 5330 @ 40), (N/A, 20), DFS
  (5490 - 5710 @ 40), (N/A, 27), DFS
Date: Tue Oct 2 17:52:41 2012
HibernationDevice: RESUME=UUID=339a99de-eef3-452e-b55c-a229bee214e5
HotplugNewDevices:

HotplugNewMounts:

InstallationMedia: Kubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120905)
MachineType: LENOVO 2347W2U
ProcEnviron:
 LANGUAGE=
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-16-generic root=UUID=c8916e6c-a99f-43f1-9d8c-c1daf21fedac ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-16-generic N/A
 linux-backports-modules-3.5.0-16-generic N/A
 linux-firmware 1.94
SourcePackage: linux
Symptom: storage
UdevMonitorLog:
 monitor will print the received events for:
 UDEV - the event which udev sends out after rule processing
UdisksMonitorLog:
 Monitoring the udisks daemon. Press Ctrl+C to exit.
 17:52:50.750: The udisks-daemon is running (name-owner :1.71).
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/25/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: G1ET41WW (1.16 )
dmi.board.asset.tag: Not Available
dmi.board.name: 2347W2U
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrG1ET41WW(1.16):bd05/25/2012:svnLENOVO:pn2347W2U:pvrThinkPadT430:rvnLENOVO:rn2347W2U:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2347W2U
dmi.product.version: ThinkPad T430
dmi.sys.vendor: LENOVO

Stefan Freyr (stefan-freyr) wrote :
Brad Figg (brad-figg) on 2012-10-02
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.6 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. Please only remove that one tag and leave the other tags. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-quantal/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: needs-upstream-testing
Stefan Freyr (stefan-freyr) wrote :

Done... it exists upstream.

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Stefan Freyr (stefan-freyr) wrote :

Hi. Just checking up on this... it's my understanding that this is just a matter of adding the model name to a source file really and from what I can see this hasn't been done:
http://git.kernel.org/?p=linux/kernel/git/tiwai/sound.git;a=blob;f=sound/pci/hda/patch_realtek.c;h=bb93f927f7be97ac7280c87fe2cccbf448c73809;hb=4407be6ba217514b1bc01488f8b56467d309e416

There is a line for T430s there but none for T430.

But this brings me to a (potentially very stupid) question. Why in the world are these "quirktables" kept in a source file that needs rebuilding for each new model that comes along? Wouldn't it be a better idea to keep these in a config file that people can edit? This should simplify testing, instead of having to rebuild a kernel, you can just edit a config file and report if that worked. Am I missing something here?

Stefan Freyr (stefan-freyr) wrote :

Hi.

I decided to give fixing this a shot and it worked. So here is a patch that I've verified that works on my setup:

diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
index 739f968..18fce01 100644
--- a/sound/pci/hda/patch_realtek.c
+++ b/sound/pci/hda/patch_realtek.c
@@ -6172,6 +6172,7 @@ static const struct snd_pci_quirk alc269_fixup_tbl[] = {
        SND_PCI_QUIRK(0x17aa, 0x21e9, "Thinkpad Edge 15", ALC269_FIXUP_SKU_IGNORE),
        SND_PCI_QUIRK(0x17aa, 0x21f6, "Thinkpad T530", ALC269_FIXUP_LENOVO_DOCK),
        SND_PCI_QUIRK(0x17aa, 0x21fa, "Thinkpad X230", ALC269_FIXUP_LENOVO_DOCK),
+ SND_PCI_QUIRK(0x17aa, 0x21f3, "Thinkpad T430", ALC269_FIXUP_LENOVO_DOCK),
        SND_PCI_QUIRK(0x17aa, 0x21fb, "Thinkpad T430s", ALC269_FIXUP_LENOVO_DOCK),
        SND_PCI_QUIRK(0x17aa, 0x2203, "Thinkpad X230 Tablet", ALC269_FIXUP_LENOVO_DOCK),
        SND_PCI_QUIRK(0x17aa, 0x3bf8, "Quanta FL1", ALC269_FIXUP_PCM_44K),

Stefan Freyr (stefan-freyr) wrote :

Ok I guess it's better to send this in as a file and mark it as a patch. So here it is.

Joseph Salisbury (jsalisbury) wrote :

@Stefan,

I created a Quantal test kernel with a Quirk for the T430. The test kernel is available from:
http://people.canonical.com/~jsalisbury/lp1060372/

Ensure you install both the linux-image and linux-image-extra .deb packages.

Can you test this kernel and report back if it resolves this bug? If it does, I can submit a SRU request to the kernel team mailing list.

Changed in linux (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Joseph Salisbury (jsalisbury)
tags: added: patch
Stefan Freyr (stefan-freyr) wrote :

Hi.

I've tested this and it works fine. Please submit the SRU request.

Stefan Freyr (stefan-freyr) wrote :

So just out of curiosity, what versions of the kernel will this go into? 3.5? or only 3.6/3.7? Will this be an Ubuntu patch for the 3.5 kernel? I'm basically just trying to ask whether I'll see this in the official kernel for 12.10 at some point?

Joseph Salisbury (jsalisbury) wrote :

@Stefan,

This fix will be included in the official 12.10 kernel. I also sent your patch upstream, and will be applied against the mainline 3.7 kernel. Thanks again for all your help.

mark pendrick (mark-pendrick) wrote :

what about 12.04 64bit

Linux mark-Laptop-1 3.2.0-32-generic #51-Ubuntu SMP Wed Sep 26 21:33:09 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

I seem to have same issue sounds works fine till I put laptop in docking station

Simon Déziel (sdeziel) wrote :

@Mark, the patch was included in the upstream kernel 3.2.33. It should eventually arrives in 12.04.

Stefan Freyr (stefan-freyr) wrote :

Hi.

I just updated my kernel to 3.5.0-18 but the patch does not seem to be present in it. Did it not make it into that kernel build? When can we expect it to be in the official 12.10 kernel?

Andy Whitcroft (apw) on 2012-11-08
Changed in linux (Ubuntu Quantal):
assignee: nobody → Joseph Salisbury (jsalisbury)
importance: Undecided → Medium
status: New → Fix Committed
Changed in linux (Ubuntu):
status: In Progress → Fix Committed

The attachment "Adds a line to the quirk table for Lenovo T430 to enable audio on the Ultrabase docking station." of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

Herton R. Krzesinski (herton) wrote :

This bug is awaiting verification that the kernel in -proposed (3.5.0-19.30) solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-quantal' to 'verification-done-quantal'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-quantal
Stefan Freyr (stefan-freyr) wrote :

Tested and it works fine. Changed the tags as requested. Thanks for your effort.

tags: added: verification-done-quantal
removed: verification-needed-quantal

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.5.0-19.30

---------------
linux (3.5.0-19.30) quantal-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1078041

  [ Andy Whitcroft ]

  * [Config] update Vcs-git: to point to quantal
    - LP: #1069204

  [ Joseph Salisbury ]

  * SAUCE: ALSA: hda - add quirk for Thinkpad T430
    - LP: #1060372

  [ Tim Gardner ]

  * [Config] CONFIG_USB_OTG=n for all but armel/armhf
    - LP: #1047527
  * [Config] remove ndiswrapper from Provides:
    - LP: #1076395
  * [Config] ONFIG_AMD_IOMMU_V2=m
    - LP: #1071520

  [ Upstream Kernel Changes ]

  * kernel/sys.c: fix stack memory content leak via UNAME26
    - LP: #1065622, #1060521
    - CVE-2012-0957
  * use clamp_t in UNAME26 fix
    - LP: #1065622, #1060521
    - CVE-2012-0957
  * net: fix divide by zero in tcp algorithm illinois
    - LP: #1077091
    - CVE-2012-4565

  [ Wen-chien Jesse Sung ]

  * SAUCE: Bluetooth: Add a load_firmware callback to struct hci_dev
    - LP: #1065400
  * SAUCE: Bluetooth: Implement broadcom patchram firmware loader
    - LP: #1065400
  * SAUCE: Bluetooth: Add support for 13d3:3388 and 13d3:3389
    - LP: #1065400
 -- Luis Henriques <email address hidden> Tue, 13 Nov 2012 15:49:15 +0000

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
Herton R. Krzesinski (herton) wrote :

Fix is released in Raring (v3.7-rc3).

Changed in linux (Ubuntu):
status: Fix Committed → Won't Fix
status: Won't Fix → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers