External USB hard disks are not seen when connected to docking station

Bug #1052064 reported by Myriam Schweingruber on 2012-09-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Since using Quantal the external hard disks connected through the docking station of my Thinkpad X220 are not recognized anymore, they don't even show up in /dev/disk/. The hard disks are usable when connecting directly to the laptop with the same USB cable.

This is a regression since Precise as it has always worked before.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-3.5.0-14-generic 3.5.0-14.19
ProcVersionSignature: Ubuntu 3.5.0-14.19-generic 3.5.3
Uname: Linux 3.5.0-14-generic x86_64
ApportVersion: 2.5.2-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: myriam 3835 F.... pulseaudio
 /dev/snd/pcmC0D0p: myriam 3835 F...m pulseaudio
Date: Mon Sep 17 18:50:28 2012
HibernationDevice: RESUME=UUID=3aff683c-aff6-44d4-a477-7fe2f7e8b020
InstallationMedia: Kubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120724.2)
MachineType: LENOVO 429136G
ProcEnviron:
 LANGUAGE=
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-14-generic root=UUID=54b27238-1840-43c8-940d-1398776d6803 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-14-generic N/A
 linux-backports-modules-3.5.0-14-generic N/A
 linux-firmware 1.92
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/14/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: 8DET58WW (1.28 )
dmi.board.asset.tag: Not Available
dmi.board.name: 429136G
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8DET58WW(1.28):bd02/14/2012:svnLENOVO:pn429136G:pvrThinkPadX220:rvnLENOVO:rn429136G:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 429136G
dmi.product.version: ThinkPad X220
dmi.sys.vendor: LENOVO

Myriam Schweingruber (myriam) wrote :
description: updated
Brad Figg (brad-figg) on 2012-09-17
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.6 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. Please only remove that one tag and leave the other tags. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-rc6-quantal/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-bisect needs-upstream-testing regression-release
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Myriam Schweingruber (myriam) wrote :

I tested the upstream kernel and the problem is still the same.
If that is important: I can hear the disk spin on connection and the light goes on, so the USB port is functional. But connection a mouse to it doesn't make the mouse show up.

Joseph Salisbury (jsalisbury) wrote :

I'd like to perform a bisect to figure out what commit caused this regression. It would be very helpful to know the earliest kernel where the issue started happening as well as the latest kernel that did not have this issue.

Can you test the following kernels and report back? We are looking for the first kernel version that doesn't have this bug:

v3.3 final: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-precise/
v3.4 final: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-quantal/
v3.5-rc4: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc4-quantal/

Thanks in advance!

Changed in linux (Ubuntu):
status: Confirmed → Triaged
status: Triaged → Confirmed
tags: added: performing-bisect
removed: needs-bisect

From the log below:

The scsi block device has been recognized as /dev/sdc, so could you
run the below commands to mount it manually and see what will happen:

          mkdir ./mnt
          sudo mount /dev/sdc ./mnt

Maybe it is a udev or other utility problem and nothing to do with kernel.

Thanks,
--
Ming Lei

Myriam Schweingruber (myriam) wrote :

I am sorry, this will have to wait for the weekend, I am currently abroad without the docking station.

Christoph Lange (allegristas) wrote :

I have a similar problem in a related but different situation. My experience doesn't quite help you with the specific investigation of this case but may serve as a weak confirmation that this is indeed a kernel issue.

Similarities
* same hardware: ThinkPad X220 Tablet with an Ultrabase docking station; the tablet doesn't make a difference wrt. docking
* same symptoms: disk not recognized

Differences:
* I'm running Gentoo Linux with kernel 3.4.11 (original version plus a few Gentoo-specific patches, i.e. the package gentoo-sources) vs. 3.6.1.
* I think connecting a USB hard disk to the docking station worked with both kernels, but what stopped working in my case is attaching a hard disk via the SATA to Ultrabay adapter.

With kernel 3.4.11 I get the following log messages:

Oct 10 18:35:15 CLANGE-x220t kernel: [ 4301.613989] ACPI: \_SB_.PCI0.SAT1.PRT1 - docking
Oct 10 18:35:18 CLANGE-x220t kernel: [ 4305.356799] ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
Oct 10 18:35:18 CLANGE-x220t kernel: [ 4305.359664] ata2.00: ACPI cmd ef/02:00:00:00:00:a0 (SET FEATURES) succeeded
Oct 10 18:35:18 CLANGE-x220t kernel: [ 4305.359675] ata2.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
Oct 10 18:35:18 CLANGE-x220t kernel: [ 4305.362030] ata2.00: ATA-8: ST9500420ASG, 0002SDM1, max UDMA/133
Oct 10 18:35:18 CLANGE-x220t kernel: [ 4305.362039] ata2.00: 976773168 sectors, multi 16: LBA48 NCQ (depth 31/32)
Oct 10 18:35:18 CLANGE-x220t kernel: [ 4305.365187] ata2.00: ACPI cmd ef/02:00:00:00:00:a0 (SET FEATURES) succeeded
Oct 10 18:35:18 CLANGE-x220t kernel: [ 4305.365190] ata2.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
Oct 10 18:35:18 CLANGE-x220t kernel: [ 4305.367510] ata2.00: configured for UDMA/133
Oct 10 18:35:19 CLANGE-x220t kernel: [ 4305.378761] ata2: EH complete
Oct 10 18:35:19 CLANGE-x220t kernel: [ 4305.378890] scsi 1:0:0:0: Direct-Access ATA ST9500420ASG 0002 PQ: 0 ANSI: 5
Oct 10 18:35:19 CLANGE-x220t kernel: [ 4305.379009] sd 1:0:0:0: [sdb] 976773168 512-byte logical blocks: (500 GB/465 GiB)
Oct 10 18:35:19 CLANGE-x220t kernel: [ 4305.379052] sd 1:0:0:0: [sdb] Write Protect is off
Oct 10 18:35:19 CLANGE-x220t kernel: [ 4305.379055] sd 1:0:0:0: [sdb] Mode Sense: 00 3a 00 00
Oct 10 18:35:19 CLANGE-x220t kernel: [ 4305.379072] sd 1:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Oct 10 18:35:19 CLANGE-x220t kernel: [ 4305.379206] sd 1:0:0:0: Attached scsi generic sg1 type 0
Oct 10 18:35:19 CLANGE-x220t kernel: [ 4305.405429] sdb: sdb1 sdb2
Oct 10 18:35:19 CLANGE-x220t kernel: [ 4305.405788] sd 1:0:0:0: [sdb] Attached SCSI disk

But with 3.6.1:

Oct 10 17:21:00 CLANGE-x220t kernel: [63577.233313] ACPI: \_SB_.PCI0.SAT1.PRT1 - docking
<and then nothing else happens>

Myriam Schweingruber (myriam) wrote :

Sorry for the delay in my response:

the problem appears to be solved with the 3.6.0-17.27 kernel in Quantal. I am about to install the newest kernel and will report ASAP.

Myriam Schweingruber (myriam) wrote :

erm, 3.5.0-17.27, of course, sorry for the typo

tags: removed: performing-bisect
Christoph Lange (allegristas) wrote :

I solved the problem for me (see above – different but similar situation) by upgrading to 3.6.2

Myriam Schweingruber, as per http://download.lenovo.com/express/ddfm.html an update is available for your BIOS (1.38). If you update to this, does it change anything?

If not, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

Thank you for your understanding.

tags: added: bios-outdated-1.38 needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Myriam Schweingruber (myriam) wrote :

oops, seems I forgot to report back. As already mentioned in comment #8, this is solved with kernel 3.6.0-17.27

I have since then upgraded to Raring and haven't seen this happening again, even without a BIOS update. Since there is no Windows or Lenovo partition on this laptop anymore I wouldn't know how to upgrade the BIOS anyway.

Myriam Schweingruber, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1052064/comments/12 regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers