External USB keyboard stops working when d-i starts on mac mini

Bug #1050855 reported by Para Siva on 2012-09-14
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned
syslinux (Ubuntu)
Medium
Unassigned

Bug Description

Quantal server 20120914 and Precise server 20120913.1 on mac mini.

The keystrokes of the usb keyboard at the language selection menu of the quantal-server-amd64+mac installation are not recognised. Pressing the enter key does not enable the installation to progress and the installation is stuck at the language selection menu.

The behaviour is very similar to 1017879( fix released), but this time with mac mini on precise and quantal.

For desktop installations the keyboard is not recognised *only* during the human-keyboard screen. Because pressing the space bar during that menu does not bring the text only installation window, instead it progress to the screen (screen shot attached desk_inst.jpg). where we could either 'Install Ubuntu' or 'Try Ubuntu' using mouse. I could continue the installation using mouse and thereafter the installation starts in the graphical mode i was able to use the keyboard to enter the values such as selecting the regions, username passwords etc. Keyboard worked after the installation as well.

---
AcpiTables: Error: command ['pkexec', '/usr/share/apport/dump_acpi_tables.py'] failed with exit code 127: Error executing /usr/share/apport/dump_acpi_tables.py: Permission denied
ApportVersion: 2.5.1-0ubuntu7
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu2 1885 F.... pulseaudio
DistroRelease: Ubuntu 12.10
HibernationDevice: RESUME=UUID=e62441a3-3cab-4c4d-b104-51d6c90a7d63
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64+mac (20120914)
IwConfig:
 eth0 no wireless extensions.

 lo no wireless extensions.
MachineType: Apple Inc. Macmini5,1
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-14-generic root=UUID=856e20b0-c2e5-4497-be1e-bad633ced47d ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.5.0-14.17-generic 3.5.3
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-14-generic N/A
 linux-backports-modules-3.5.0-14-generic N/A
 linux-firmware 1.91
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
Tags: quantal running-unity
Uname: Linux 3.5.0-14-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
WifiSyslog:

dmi.bios.date: 10/20/2011
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MM51.88Z.0077.B0F.1110201309
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-8ED6AF5B48C039E1
dmi.board.vendor: Apple Inc.
dmi.board.version: Macmini5,1
dmi.chassis.type: 16
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-8ED6AF5B48C039E1
dmi.modalias: dmi:bvnAppleInc.:bvrMM51.88Z.0077.B0F.1110201309:bd10/20/2011:svnAppleInc.:pnMacmini5,1:pvr1.0:rvnAppleInc.:rnMac-8ED6AF5B48C039E1:rvrMacmini5,1:cvnAppleInc.:ct16:cvrMac-8ED6AF5B48C039E1:
dmi.product.name: Macmini5,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Para Siva (psivaa) wrote :

Did not try to go back in to an older build to see if that works, because of the failure on precise itself

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1050855

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Para Siva (psivaa) wrote :

The installation did not progress to a level where I could run apport-collect. Keyboard not getting recognised does not help either. Marking the bug confirmed. Thx

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Does this only happen with the server image and not desktop?

Changed in linux (Ubuntu):
importance: Undecided → High
Joseph Salisbury (jsalisbury) wrote :

If so, can you boot a a desktop or live image and post the output of 'lsmod'?

tags: added: kernel-da-key
Para Siva (psivaa) wrote :

This occurs even with desktop installations, where pressing the space bar during keyboard-person does not do anything but with desktop we have an option to continue the installation with the help of mouse.

The output of lsmod is attached.

Para Siva (psivaa) on 2012-09-17
tags: added: rls-q-incoming
Joseph Salisbury (jsalisbury) wrote :

Were you able to complete the desktop installation with the use of a mouse? If so, did the keyboard work after the installation? If it did, can you attach the apport data by running:

apport-collect 1050855

apport information

tags: added: apport-collected running-unity
description: updated

apport information

Para Siva (psivaa) wrote : CRDA.txt

apport information

apport information

Para Siva (psivaa) wrote : Lspci.txt

apport information

Para Siva (psivaa) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Joseph Salisbury (jsalisbury) wrote :

I see the following modules from your desktop install:

hid 100175 3 hid_generic,hid_apple,usbhid, Live 0x0000000000000000
hid_apple 13237 0 - Live 0x0000000000000000
hid_generic 12493 0 - Live 0x0000000000000000

Joseph Salisbury (jsalisbury) wrote :

It seems the keyboards are recognized at boot:
[ 4.126317] input: USB USB Keykoard as /devices/pci0000:00/0000:00:1d.7/usb2/2-1/2-1.3/2-1.3:1.0/input/input4
[ 4.126373] hid-generic 0003:1C4F:0002.0003: input,hidraw2: USB HID v1.10 Keyboard [USB USB Keykoard] on usb-0000:00:1d.7-1.3/input0
[ 4.126475] input: USB USB Keykoard as /devices/pci0000:00/0000:00:1d.7/usb2/2-1/2-1.3/2-1.3:1.1/input/input5

Joseph Salisbury (jsalisbury) wrote :

One additional question, do you happen to know if this issue happened on Precise or other earlier releases?

Para Siva (psivaa) wrote :

I think i saw this issue with precise as well but not sure about the earlier releases

Joseph Salisbury (jsalisbury) wrote :

Some additional questions:

1. Does the keyboard start working after the installation is complete? If not, how were you able to collect the apport data?
2. Does this issue only happen with the SiGma Micro Keyboard? Can you try another model of keyboard?

Para Siva (psivaa) wrote :

The answers,
1. For desktop installations the keyboard is not recognised *only* during the human-keyboard screen. Because pressing the space bar during that menu does not bring the text only installation window, instead it progress to the screen (screen shot attached desk_inst.jpg) where we could either 'Install Ubuntu' or 'Try Ubuntu' using mouse. So as per the comments #5, #6 and #7 I could continue the installation using mouse and thereafter the installation starts in the graphical mode i was able to use the keyboard to enter the values such as selecting the regions, username passwords etc. Keyboard worked after the installation as well and I was able to do an apport collect after the installation.

But for server installations, there is no way of bypassing the initial options menu without a keypress.(arrow keys and enter key). There fore I could not finish the installation.

2. Thus is not Sigma Micro Keyboard although could be a derivation of it,but it has the number pad separately. I don't have any other keyboards at the moment. I could try if that's absolutely important, but may take a while

Joseph Salisbury (jsalisbury) wrote :

It would be very helpful if you could try another keyboard type. Just to rule that out.

Colin Watson (cjwatson) wrote :

The "human-keyboard screen" is in fact the boot loader, in this case syslinux. It's important to distinguish between this and the running system.

Ordinarily the fact that the keyboard works during the desktop installation (once the kernel is up) but doesn't work in d-i (the server installer) would indicate that some module is not being delivered in the appropriate udeb. However, all of hid-generic, hid-apple, and usbhid are present in the input-modules udeb, which is used by d-i.

I don't suppose any of these modules require firmware or something?

Changed in syslinux (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Colin Watson (cjwatson) wrote :

(Note that Foundations cannot commit to any non-trivial development work on syslinux at this point, at least when it isn't a regression, which I would not expect to be the case here.)

Seth Forshee (sforshee) wrote :

Colin: No firmware is required.

I do note that two input devices are being created for the keyboard -- is it at all possible that something is only looking for keys on one of the devices and just happens to be using the wrong one?

Seth Forshee (sforshee) wrote :

Fwiw I just tested a (different) USB keyboard with the quantal server image from 2012-09-21 on a Mac Mini 5,2 and it worked fine for selecting the language and starting the install.

Colin Watson (cjwatson) wrote :

d-i doesn't do anything special with keyboards, as far as I know; it just relies on the kernel and udev to bring stuff up and then lets the normal console input layer do its work.

It's possible that something is missing from udev-udeb, I suppose. However, I just had a look through there and couldn't see anything obvious.

All the next steps I can think of are fairly non-trivial. One possibility would be to remaster the image to get rid of the "quiet" parameter in isolinux/isolinux.cfg (though this is relatively easy if you're booting from CD - just edit that file directly) and then video the startup process to capture kernel messages scrolling by.

Para Siva (psivaa) wrote :

Tried with Targus Compact USB keyboard and with quantal-desktop-amd64+mac 20120926 and it worked fine during the installations.

Brian Murray (brian-murray) wrote :

This looks to me like the same bug as bug 1057824 which was fixed recently in udev in Quantal. It would be quite helpful if you were to test this again.

Para Siva (psivaa) wrote :

@brian-murray
Sorry for the delay in replying.
The issue is still present when trying the final quantal server image with the keyboard based on which, the bug was originally reported.

tags: added: needs-upstream-testing
tags: added: bios-outdated-10

Parameswaran Sivatharman, as per http://support.apple.com/kb/HT1237 an update is available for your BIOS (MM51.0077.B10). If you update to this following https://help.ubuntu.com/community/BiosUpdate , does it change anything? If it doesn't, could you please both specify what happened, and just provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

Thank you for your understanding.

description: updated
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers