[Dell Vostro 1014]: Internal Mic not recognized.

Bug #1046434 reported by Jeff Marcom on 2012-09-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Jeff Marcom

Bug Description

[Dell Vostro 1014]: Internal Mic not recognized.

CID: 201010-6648

Hardware has an internal web cam, yet no internal mic device is detected or available to sound settings, sound recorder, or alsamixer.

Handle 0x0A01, DMI type 10, 6 bytes
On Board Device Information
        Type: Sound
        Status: Enabled
        Description: Conexant CX20587-11Z

Kernel tested:
Linux 201010-6648 3.2.0-30-generic #48

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu 12.04.1 LTS"

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-30-generic 3.2.0-30.48
ProcVersionSignature: Ubuntu 3.2.0-30.48-generic 3.2.27
Uname: Linux 3.2.0-30-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1627 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf6afc000 irq 48'
   Mixer name : 'Conexant CX20585'
   Components : 'HDA:14f15069,10280401,00100302'
   Controls : 9
   Simple ctrls : 6
Date: Wed Sep 5 12:43:05 2012
HibernationDevice: RESUME=UUID=c205fca2-5faa-43ce-8649-39b6e6617077
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
MachineType: Dell Inc. Vostro 1014
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-30-generic root=UUID=b57e842c-b02c-49e0-9c58-eb6566e9d889 ro quiet splash initcall_debug vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-30-generic N/A
 linux-backports-modules-3.2.0-30-generic N/A
 linux-firmware 1.79
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/19/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: X20
dmi.board.name: C2E3C1
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrX20:bd10/19/2010:svnDellInc.:pnVostro1014:pvr:rvnDellInc.:rnC2E3C1:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Vostro 1014
dmi.sys.vendor: Dell Inc.
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1627 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf6afc000 irq 48'
   Mixer name : 'Conexant CX20585'
   Components : 'HDA:14f15069,10280401,00100302'
   Controls : 9
   Simple ctrls : 6
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=c205fca2-5faa-43ce-8649-39b6e6617077
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
MachineType: Dell Inc. Vostro 1014
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-30-generic root=UUID=b57e842c-b02c-49e0-9c58-eb6566e9d889 ro quiet splash initcall_debug vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-30.48-generic 3.2.27
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-30-generic N/A
 linux-backports-modules-3.2.0-30-generic N/A
 linux-firmware 1.79
Tags: precise running-unity
Uname: Linux 3.2.0-30-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 10/19/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: X20
dmi.board.name: C2E3C1
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrX20:bd10/19/2010:svnDellInc.:pnVostro1014:pvr:rvnDellInc.:rnC2E3C1:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: Vostro 1014
dmi.sys.vendor: Dell Inc.

Jeff Marcom (jeffmarcom) wrote :
tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Brad Figg (brad-figg) on 2012-09-05
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.6 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. Please only remove that one tag and leave the other tags. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-rc4-quantal/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Jeff Marcom (jeffmarcom) on 2012-09-05
tags: added: blocks-hwcert
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Anthony Wong (anthonywong) wrote :

The problem existed during enablement phase and was "won't fix" by then (perplexed why 11.04 cert can pass, as 10.10 cert failed for the same reason).

The BIOS of this machine is quite old and I suggest to update it to the latest one - http://www.dell.com/support/drivers/us/en/04/DriverDetails/Product/vostro-1014?driverId=4C8W7&fileId=2731098807

Changed in linux (Ubuntu):
status: Expired → Confirmed
status: Confirmed → Incomplete
Yang Kun (YK) (dayangkuncn) wrote :

@acelan, please investigate this bug

Changed in linux (Ubuntu):
assignee: nobody → AceLan Kao (acelankao)
AceLan Kao (acelankao) on 2013-02-27
Changed in linux (Ubuntu):
status: Incomplete → In Progress
Changed in linux (Ubuntu):
assignee: AceLan Kao (acelankao) → Jeff Marcom (jeffmarcom)
status: In Progress → Incomplete
To post a comment you must log in.