Comment 18 for bug 1041883

But as Corentin states: This patch was merged by Canonical, so he is not in
the position to do anything about it, Alex might be.

On Sat, Sep 1, 2012 at 12:37 PM, PJ P <email address hidden> wrote:

> I can't give you specific pointers as I am in no way a kernel developer ;)
> but what it seems SSD users have this problem, while HDD users don't (might
> need more confirmation). So somewhere the execution of the program depends
> on a timing element. When booting from hdd, the boot is so slow that this
> timing is correct, when booting from SSD, this timing is off, because the
> system boots much faster.
>
> This also explains why the module works properly in recovery mode followed
> by 'resume normal boot', as the boot is much slower then (because it waits
> for you to confirm 'resume normal boot').
>
> The project lives here: http://acpi4asus.sourceforge.net/
>
> On Sat, Sep 1, 2012 at 12:24 AM, ambidextrvs <email address hidden>wrote:
>
>> Hi, I just tested with kernel 3.5.0-13, the bug is still there.
>> Is there anything I can do to help fix this bug? Maybe somebody could
>> give me some pointer on how to debug it? thanks
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1041883
>>
>> Title:
>> Recent patch to asus-wmi module makes system unbootable
>>
>> Status in “linux” package in Ubuntu:
>> Triaged
>>
>> Bug description:
>> There has been recently a patch to the asus-wmi module (see
>> http://comments.gmane.org/gmane.linux.kernel/1315719). This updated
>> module is part of the linux-image-3.5.0-11-generic package. Using this
>> module renders the system unbootable (For reasons probably described
>> in the logs, but currently beyond my knowledge, stacktraces can be
>> seen though)
>>
>> I have applied this patch before through dkms and had the exact same
>> problems. So I removed the patch, it is now part of the ubuntu kernel
>> though.
>>
>> The behaviour seems somewhat random, sometimes the system boots, and
>> the Function hotkeys (keyboard backlight, volume etc) work (except the
>> known problem with the brightness keys and ambient light sensor). But
>> most of the time the system simply wont boot. I can however first
>> start the system in recovery mode, and then proceed normal boot, the
>> problem does not occur then.
>>
>> Hardware: Asus Zenbook UX32V
>>
>> If further information/testing is needed, please contact me.
>>
>> ProblemType: Bug
>> DistroRelease: Ubuntu 12.10
>> Package: linux-image-3.5.0-11-generic 3.5.0-11.11
>> ProcVersionSignature: Ubuntu 3.5.0-10.10-generic 3.5.1
>> Uname: Linux 3.5.0-10-generic x86_64
>> ApportVersion: 2.5.1-0ubuntu2
>> Architecture: amd64
>> AudioDevicesInUse:
>> USER PID ACCESS COMMAND
>> /dev/snd/controlC0: peterrus 2343 F.... pulseaudio
>> /dev/snd/pcmC0D0c: peterrus 2343 F...m pulseaudio
>> /dev/snd/pcmC0D0p: peterrus 2343 F...m pulseaudio
>> Date: Sun Aug 26 18:08:05 2012
>> EcryptfsInUse: Yes
>> HibernationDevice: RESUME=UUID=2e120efe-dafa-40e8-868d-06223b0be158
>> InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64
>> (20120627)
>> MachineType: ASUSTeK COMPUTER INC. UX32VD
>> ProcEnviron:
>> TERM=xterm
>> PATH=(custom, user)
>> LANG=en_US.UTF-8
>> SHELL=/bin/bash
>> ProcFB: 0 inteldrmfb
>> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-10-generic
>> root=UUID=9bb3948b-2fd3-46c4-b0bb-0ae32a87278a ro quiet splash
>> pcie_aspm=force drm.vblankoffdelay=1 i915.semaphores=1 nmi_watchdog=0
>> RelatedPackageVersions:
>> linux-restricted-modules-3.5.0-10-generic N/A
>> linux-backports-modules-3.5.0-10-generic N/A
>> linux-firmware 1.90
>> SourcePackage: linux
>> StagingDrivers: rts5139
>> UpgradeStatus: No upgrade log present (probably fresh install)
>> dmi.bios.date: 06/29/2012
>> dmi.bios.vendor: American Megatrends Inc.
>> dmi.bios.version: UX32VD.207
>> dmi.board.asset.tag: ATN12345678901234567
>> dmi.board.name: UX32VD
>> dmi.board.vendor: ASUSTeK COMPUTER INC.
>> dmi.board.version: 1.0
>> dmi.chassis.asset.tag: No Asset Tag
>> dmi.chassis.type: 10
>> dmi.chassis.vendor: ASUSTeK COMPUTER INC.
>> dmi.chassis.version: 1.0
>> dmi.modalias:
>> dmi:bvnAmericanMegatrendsInc.:bvrUX32VD.207:bd06/29/2012:svnASUSTeKCOMPUTERINC.:pnUX32VD:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnUX32VD:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
>> dmi.product.name: UX32VD
>> dmi.product.version: 1.0
>> dmi.sys.vendor: ASUSTeK COMPUTER INC.
>>
>> To manage notifications about this bug go to:
>>
>> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1041883/+subscriptions
>>
>
>