Kernel update on 10 Aug 2012 affects nm-applet signal strength

Bug #1035590 reported by Budoc on 2012-08-11
96
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Linux Mint
Confirmed
Undecided
Unassigned
linux (Ubuntu)
High
Unassigned
Precise
Undecided
Unassigned
Quantal
High
Unassigned
network-manager (Ubuntu)
High
Unassigned
Precise
High
Mathieu Trudel-Lapierre
Quantal
High
Unassigned

Bug Description

[Impact]
Impacts all users of ipw2x00-based hardware, for the ipw2200 and ipw2100 drivers: this is fairly common Intel Corporation PRO/Wireless hardware present in at least quite a few Thinkpad laptops.

[Test Case]
On a system with an Intel PRO/Wireless card:
1) Click the network indicator/applet.
2) Observe the detected signal level.
3) Try to connect to a secured wireless network.

Connection should be successful and ask for the wifi network password (if it's not already entered)

Alternatively:
1) Run the command 'nmcli dev wifi'.

Signal level should be low (usually visible as simply '0').

[Regression Potential]
This change will modify the detection behavior for the wireless framework to use for wireless cards. It needs to be properly tested with the affected devices to make sure the signal level and encryption capabilities are properly detected; but should also be tested with other devices to make sure signal levels and encryption capabilities remain properly detected. A possible regression scenario would be if a device that works with nl80211 (without the patch) would get detected as needing wext when it is not implemented. This would likely cause such a device to not be able to see wireless networks and connect to them.

----

With 3.2.0-29-generic the nm-applet no longer reports the wireless signal strength. If I reboot into 3.2.0-27-generic this problem does not occur.

I am using a Toshiba Equium M70-339 laptop, and my wireless card is listed on the manufacturer's webpage as being an Intel® PRO/Wireless 2200 LAN Mini PCI adaptor integrated in Intel® Centrino™ mobile technology. I've purged and reinstalled network-manager to no effect. The only way for me to get the signal strength reported by the nm-applet is to use an earlier kernel. iwconfig reports the correct signal quality.

lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

apt-cache policy network-manager
network-manager:
  Installed: 0.9.4.0-0ubuntu4.1
  Candidate: 0.9.4.0-0ubuntu4.1
  Version table:
 *** 0.9.4.0-0ubuntu4.1 0
        500 http://mirrors.coreix.net/ubuntu/ precise-updates/main i386 Packages
        100 /var/lib/dpkg/status
     0.9.4.0-0ubuntu3 0
        500 http://mirrors.coreix.net/ubuntu/ precise/main i386 Packages

apt-cache policy linux-image-3.2.0-29-generic
linux-image-3.2.0-29-generic:
  Installed: 3.2.0-29.46
  Candidate: 3.2.0-29.46
  Version table:
 *** 3.2.0-29.46 0
        500 http://mirrors.coreix.net/ubuntu/ precise-updates/main i386 Packages
        500 http://mirrors.coreix.net/ubuntu/ precise-security/main i386 Packages
        100 /var/lib/dpkg/status

I expect nm-applet to display the signal strength of my WPA2 wireless AP, but instead no signal is reported. This behaviour is only observed with the newest kernel.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-29-generic 3.2.0-29.46
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Uname: Linux 3.2.0-29-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu12
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: andrew 1846 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'ICH6'/'Intel ICH6 with ALC250 at irq 17'
   Mixer name : 'Realtek ALC250 rev 2'
   Components : 'AC97a:414c4752'
   Controls : 33
   Simple ctrls : 21
CurrentDmesg:
 [ 30.415898] lib80211_crypt: registered algorithm 'TKIP'
 [ 41.056026] eth1: no IPv6 routers present
 [ 100.046529] ACPI: EC: GPE storm detected, transactions will use polling mode
Date: Sat Aug 11 10:54:17 2012
HibernationDevice: RESUME=UUID=2b27764c-cdb9-4a40-b4dd-e4148a6c0309
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: TOSHIBA 00000000000000000000
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-29-generic root=UUID=81d9afb8-c58e-4eea-8277-4a3a34732119 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-29-generic N/A
 linux-backports-modules-3.2.0-29-generic N/A
 linux-firmware 1.79
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: Upgraded to precise on 2012-04-26 (106 days ago)
UserAsoundrc:
 # ALSA library configuration file

 # Include settings that are under the control of asoundconf(1).
 # (To disable these settings, comment out this line.)
 </home/andrew/.asoundrc.asoundconf>
dmi.bios.date: 12/26/2005
dmi.bios.vendor: TOSHIBA
dmi.bios.version: V1.30
dmi.board.name: HTW00
dmi.board.vendor: TOSHIBA
dmi.board.version: Null
dmi.chassis.asset.tag: *
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnTOSHIBA:bvrV1.30:bd12/26/2005:svnTOSHIBA:pn00000000000000000000:pvr0000000000000000:rvnTOSHIBA:rnHTW00:rvrNull:cvnTOSHIBA:ct10:cvrN/A:
dmi.product.name: 00000000000000000000
dmi.product.version: 0000000000000000
dmi.sys.vendor: TOSHIBA

Budoc (budoc) wrote :
Budoc (budoc) wrote :
Brad Figg (brad-figg) on 2012-08-11
Changed in linux (Ubuntu):
status: New → Confirmed
James Silhacek (jadosi) wrote :

I am having the exact same problem on my Dell600m. When I upgraded to the new kernel 3.2.0-29, the signal strength applet shows zero (completely dimmed out) when it usually shows 3 out of 4 lines bright on my home network. Booting to the previous kernel 3.2.0-27 fixes the problem.

Christian Lins (cli) wrote :

Same here on my ThinkPad T40 also using the ipw2200 driver.

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: regression-update
BubbaJ (azstuenthome) wrote :

Same issue here after upgrade from 3.2.0-27 to 3.2.0-29 using Thinkpad T42. Reverting back to 3.2.0-27 also resolves issue for me.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
OrangeCrate (bluesan) wrote :

This bug also affects Xubuntu 12.04. Reverting to the previous kernel, 3.2.0-23, resolves the issue.

Could there have been changes to the wext interface for the ipw2200 driver in the new kernel revision? NM fallsback to wext for drivers such as ipw2200 (and ipw2100) which have an incomplete/broken nl80211 implementation.

I'm just about convinced it's not an issue in NetworkManager since it hasn't changed recently and we released with 0.9.4.0-0ubuntu3 which includes the patch to fallback to wext; which reportedly works properly at least on 3.2.0-23 and 3.2.0-27. If necessary and the nl80211 code was fixed, we can drop the patch, but there are some things to consider.

See https://bugs.launchpad.net/ubuntu/+source/linux/+bug/973241 for details.

See also:
http://article.gmane.org/gmane.linux.kernel.wireless.general/88613
https://bugzilla.kernel.org/show_bug.cgi?id=43049

Basically; including the device capability (encryption) patch will make the NM patch not fallback, but then the signal levels will be missing, because those are missing from nl80211 as well.

Changed in network-manager (Ubuntu):
status: Confirmed → Incomplete

The network applet is still usable and you can connect to networks even if the signal level is 0, right? (I mean this so it's an annoyance, not something that completely breaks wifi)

Perhaps I'll just remove the original workaround and cherry-pick a different, slightly more intrusive patch to NM, since we'll eventually backport newer kernels which will also have similar issues.

Changed in network-manager (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → High
Changed in linux (Ubuntu):
importance: Medium → High
Changed in network-manager (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Budoc (budoc) wrote :

Yes, I can still connect to networks- the issue is more of an annoyance than something that has completed broken wifi.

Herton R. Krzesinski (herton) wrote :

This bug should be a interaction between this kernel fix: http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-precise.git;a=commit;h=d5b65f764c414a8da02c479f7fa57cfaee603fd3 and nm on Ubuntu. Mathieu is going to handle this in network-manager as we talked on IRC (#ubuntu-kernel/freenode). Marking the linux task invalid.

Changed in linux (Ubuntu):
status: Confirmed → Invalid
BubbaJ (azstuenthome) wrote :

I can confirm that on my Thinkpad T42 (Intel 2200BG) I am also still able to connect to the wifi wireless network even with the signal strength applet showing dimmed out (zero strength). I noticed in the NM applet drop down, my wireless network does not show as "connected", even when I am connected. The wireless network to which I am connected shows in the "available" networks list along with other networks to which I am not connected. Not sure if this is related to the zero signal strength issue, or a different issue. Finally, in the NM applet drop down, when I click on "connection information", the correct network name, ip address, and signal strength is displayed. Let me know if I can provide any further information or can help testing fixes.

december0123 (december0123) wrote :

After today's update to 3.2.0-30-generic, it still doesn't work properly.

Changed in network-manager (Ubuntu):
status: Triaged → In Progress
description: updated
Changed in network-manager (Ubuntu Quantal):
status: In Progress → Triaged
Changed in network-manager (Ubuntu Precise):
status: New → Triaged
Changed in network-manager (Ubuntu Quantal):
status: Triaged → Fix Released
Changed in network-manager (Ubuntu Precise):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
importance: Undecided → High
Changed in network-manager (Ubuntu Quantal):
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → nobody
Changed in linux (Ubuntu Precise):
status: New → Invalid

I uploaded network-manager to precise-proposed yesterday, it's waiting in the queue to be reviewed by the SRU team.

I confirm that also after last kernel update (3.2.0-32-generic) the nm-applet indicator still shows zero signal and my AP doesn't appead as connected. Just wanted to remark that everythink is ok with 3.4 kernel (3.4.0-030400-generic).
Ubuntu 12.04, Asus W1N, 02:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)

Hello Budoc, or anyone else affected,

Accepted network-manager into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/network-manager/0.9.4.0-0ubuntu4.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in network-manager (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed
Budoc (budoc) wrote :

Hello Chris,

The network-manager package mentioned in #16 has now made it into precise-proposed and has, for me at least, fixed the issue. I will now change the bug tag to verification-done.

Thanks for your efforts.

tags: added: verification-done
removed: verification-needed
Glenn Moloney (g-moloney) wrote :

G'day Chris,

I just done a fresh installed of 12.04.1 on a Toshiba Tecra S2 which had the same issue. I enabled the precise-proposed, updated & rebooted which resolved the issue. Lucky me I came across this info at the right time :). Cheers.

Dimitrios Ntoulas (ntoulasd) wrote :

It fixed

OrangeCrate (bluesan) wrote :

I'm not interested in grabbing anything from the proposed repository. When can we expect this fix to be released through normal updates?

fontinalis (sfontinalis) wrote :

Confirmed that this is happening on Linux Mint 13 (Mate). Did an apt-get dist-upgrade after a fresh install and can see the grayed out nm-applet with no signal strength and not showing that it is connected even though it is. Connected AP shows up in list as if it were not connected.
Confirmed that this is still broken on kernel -32 and -33. Reverted to kernel 3.2.0-23 to get things working normally again. Hope this helps. I am not on that machine now so I can't get exact broken kernel numbers. Have not tried to enable "Romeo" unstable repository which is probably like the precise-proposed repo.

Changed in linuxmint:
status: New → Confirmed
OrangeCrate (bluesan) wrote :

I'm done traveling for the year on business, and have now had the time to enable the proposed repository, and grab the individual update. It works fine on Xubuntu 12.04.1, 3.2.0-35-generic. Thanks to all involved for info, and help.

taj (othertaj) wrote :

In contrast with OrangeCrate the problem still exists for me, running 3.2.0-35-generic.
To check I booted into 3.2.0-27-generic where signal strength is displayed correctly.
So, the bug is not fixed in the main kernel releases, yet.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.9.4.0-0ubuntu4.2

---------------
network-manager (0.9.4.0-0ubuntu4.2) precise-proposed; urgency=low

  * debian/patches/git_use_wpa_wext_methods_50435e1.patch: use the same kind
    of logic as wpasupplicant instead of just looking at whether a driver
    reports signal over nl80211 to decide whether to use that or fallback
    to wext. (LP: #1035590)
  * debian/patches/ipw2x00-no-nl80211.patch: replaced by the patch above.
  * debian/patches/git_ignore_ipconfig_dups_cca4052.patch: silently ignore
    duplicates in NMIP[46]Config objects; which tends to happen fairly
    regularly with RDNSS. (LP: #996032)
  * debian/patches/nm-ipv6-route-cache.patch: don't re-add routes we receive
    from kernel notifications to the routing table if they have the
    RTM_F_CLONED flag; since that means they're host routes used temporarily
    by the kernel to reach a specific destination; keeping them would cause at
    least issues with VPNs, and possibly confusion with routing daemons.
    Thanks to Ben Jenks for the patch. (LP: #1038541)
  * debian/ifblacklist_migrate.sh: make sure that "iface X inet6" entries added
    by d-i also get commented out if set up for dhcp or auto -- this follows
    what is already done for IPv4, where such devices should be handled by
    NetworkManager. This fixes issues where people installing using d-i and
    where IPv6 autoconfiguration is available would get their interfaces
    ignored by NetworkManager when installing desktop. (LP: #995165)
 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 10 Oct 2012 17:31:55 -0400

Changed in network-manager (Ubuntu Precise):
status: Fix Committed → Fix Released
BubbaJ (azstuenthome) wrote :

Mathieu, Thanks for fixing the bug. The recent release that included this and other fixes for network manager corrected the "no signal" issue with my Thinkpad T42. Thanks again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.