ACER aspire S3 track pad doesn't work with 12.04, backport needed from 12.10

Bug #1033568 reported by Kate Stewart
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Joseph Salisbury
Precise
Medium
Joseph Salisbury
Quantal
Medium
Joseph Salisbury

Bug Description

Initial install of 12.04 on ACER ASPIRE S3-951-6828 had trackpad not working properly when left/right button pressed. Specifically other motion on the trackpad was not detected when those buttons were pressed, but were detected otherwise. It did respond to button select and using the arrow keys.

12.04 was updated to the latest kernel in -updates (3.2.0-27.43) - and problem was still there.

update-manager -d to 12.10 seems to have resolved issue.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-3.5.0-8-generic 3.5.0-8.8
ProcVersionSignature: Ubuntu 3.5.0-8.8-generic 3.5.0
Uname: Linux 3.5.0-8-generic x86_64
ApportVersion: 2.4-0ubuntu6
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: kate 2279 F.... pulseaudio
CheckboxSubmission: f70e89339b764fe08f5941181b6acd1c
CheckboxSystem: 2954e74ba17fb0e37fc942cd1d9fab4e
Date: Mon Aug 6 11:14:48 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120131.2)
MachineType: Acer Aspire S3
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-8-generic root=UUID=34D852C9D85288CE loop=/ubuntu/disks/root.disk ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-8-generic N/A
 linux-backports-modules-3.5.0-8-generic N/A
 linux-firmware 1.88
SourcePackage: linux
StagingDrivers: rts5139
UpgradeStatus: Upgraded to quantal on 2012-08-06 (0 days ago)
dmi.bios.date: 09/28/2011
dmi.bios.vendor: INSYDE
dmi.bios.version: 1.16
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Aspire S3
dmi.board.vendor: Acer
dmi.board.version: 1.16
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvr1.16:bd09/28/2011:svnAcer:pnAspireS3:pvr1.16:rvnAcer:rnAspireS3:rvr1.16:cvnAcer:ct10:cvrChassisVersion:
dmi.product.name: Aspire S3
dmi.product.version: 1.16
dmi.sys.vendor: Acer

Revision history for this message
Kate Stewart (kate.stewart) wrote :
Changed in linux (Ubuntu Precise):
milestone: none → precise-updates
Brad Figg (brad-figg)
Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu Precise):
status: New → Confirmed
tags: added: quantal
Changed in linux (Ubuntu):
milestone: precise-updates → none
Changed in linux (Ubuntu Precise):
importance: Undecided → Medium
Changed in linux (Ubuntu):
importance: Undecided → Medium
Changed in linux (Ubuntu Precise):
assignee: nobody → Joseph Salisbury (jsalisbury)
Changed in linux (Ubuntu):
assignee: nobody → Joseph Salisbury (jsalisbury)
tags: added: performing-bisect
Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Hi Kate,

We know that the latest Precise kernel, which is based off of 3.2.14, has the bug. We next need to identify the first Quantal kernel that fixed the bug.

Can you test the following kernels and report back the first one that fixes the bug:

v3.3 final: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-precise/
v3.4 final: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-quantal/
v3.5-rc4: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc4-quantal/

The v3.3 kernel will only require one .deb file to be installed: linux-image-3.3.0-030300-generic_3.3.0-030300.201203182135_amd64.deb

However, the 3.4 and newer version require both the linux-image and linux-image-extra .deb packages to be installed.

You can install the .deb packages from the command line like the following(v3.4 example):
sudo dpkg -i linux-image-3.4.0-030400-generic_3.4.0-030400.201205221131_amd64.deb
sudo dpkg -i linux-image-extra-3.4.0-030400-generic_3.4.0-030400.201205221131_amd64.deb

A reboot is then required to boot the new kernel. You can access the GRUB menu while booting by holding the shift key. That will allow you boot back into the original kernel.

There are some notes on the topic of kernel bisects available at:
https://wiki.ubuntu.com/Kernel/KernelBisection

Revision history for this message
Kate Stewart (kate.stewart) wrote :

Hi Joe,
   v3.4 kernel has the fix in it (touchpad works as expected). v3.3 one does not.
Let me know if you have other experiments that you want me to try.

Thanks! Kate

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Now that we know the fix is in v3.4, we need to find out what release candidate has the fix, then we can bisect. Can you test v3.4-rc4:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc4-precise/

Revision history for this message
Kate Stewart (kate.stewart) wrote :

linux-image-3.4.0-030400rc2-generic_3.4.0-030400rc2.201204072235_amd64.deb - does not have fix
linux-image-3.4.0-030400rc3-generic_3.4.0-030400rc3.201204152235_amd64.deb - has fix

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Thanks for the update. I'll start a reverse bisect between v3.4-rc2 and v3.4-rc3. I'll post a test kernel shortly.

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Hi Kate,

The first test kernel is available and is built up to commit:
b3dfd76c945b879513b991bac23ffcb97fe88ec2

This kernel is available from:
http://people.canonical.com/~jsalisbury/lp1033568

Can you test that kernel and report back if it has the bug or not?

Revision history for this message
Kate Stewart (kate.stewart) wrote :

Hi Joe,
    That kernel fixes the bug. :)

Kate

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Hi Kate,

I built the next test kernel, which is up to commit:
e42bd6e4a666709fc3a56cf4577c1f6fdb1c193f

This kernel is available from:
http://people.canonical.com/~jsalisbury/lp1033568

Can you also test that kernel and report back if it has the bug or not?

Revision history for this message
Kate Stewart (kate.stewart) wrote :

The bug is fixed in this test kernel.

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Hi Kate,

I built the next test kernel, which is up to commit:
39f86a608a3e0f0164bd1540acf87696cfdfb5bb

This kernel is available from:
http://people.canonical.com/~jsalisbury/lp1033568

Can you test this latest kernel and report back if it has the bug or not?

Revision history for this message
Kate Stewart (kate.stewart) wrote :

The kernel you just pointed me to has the bug in it.

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Hi Kate,

I built the next test kernel, which is up to commit:
70f33fa5863458ec9f1ae3aabdb9c2401598ec3d

This kernel is available from:
http://people.canonical.com/~jsalisbury/lp1033568

Can you test this latest kernel and report back if it has the bug or not?

According to git bisect, there could be up to 5 or 6 more kernels to test. Thanks for taking the time to test!

Revision history for this message
Kate Stewart (kate.stewart) wrote :

Hi Joe,
   Latest candidate has the bug still. Will continue to test (between meetings etc.) as you get them ready for me.
Thanks for pushing forward with trying to get the fix for this in 12.04 :)

Kate

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Hi Kate,

I built the next test kernel, which is up to commit:
5ba7026b4467b55fedddf73d093ef3322e8e5b52

This kernel is available from:
http://people.canonical.com/~jsalisbury/lp1033568

Can you test this latest kernel and report back if it has the bug or not?

Revision history for this message
Kate Stewart (kate.stewart) wrote :

Hi Joe, this last one has the bug in it.

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Hi Kate,

I built the next test kernel, which is up to commit:
4abb663b641ee21024906dae45af7de50ebad2d8

This kernel is available from:
http://people.canonical.com/~jsalisbury/lp1033568

Can you test this latest kernel and report back if it has the bug or not?

Revision history for this message
Kate Stewart (kate.stewart) wrote :

Hi Joe,
    Last version you published has bug fixed in it. :)

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Hi Kate,

I built the next test kernel, which is up to commit:
e3dde4fba94e0ba5e1fd79ea9e5389eea1f0cfec

This kernel is available from:
http://people.canonical.com/~jsalisbury/lp1033568

Can you test this latest kernel and report back if it has the bug or not?

Revision history for this message
Kate Stewart (kate.stewart) wrote :

Hi Joe,

    The latest kernel doesn't have the bug in it.

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Hi Kate,

I built the next test kernel, which is up to commit:
d626dad58f02e13730ded6ac84d6a9e53123f0e8

This kernel is available from:
http://people.canonical.com/~jsalisbury/lp1033568

We're down to the last three commits that should be the fix for this bug so only a couple more kernels to test.

Revision history for this message
Kate Stewart (kate.stewart) wrote :

Hi Joe,
    Sorry for the delay in testing this last one, 12.04.1 got interesting.
Anyhow the current kernel I just tested has the bug.

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Hi Kate,

I built the next test kernel, which is up to commit:
a67ada7a7239b78250c1594b0e02ca68eae848dc

This kernel is available from:
http://people.canonical.com/~jsalisbury/lp1033568

I think this may be the commit that fixes this bug, we should know after your testing.

Revision history for this message
Kate Stewart (kate.stewart) wrote :

Hi Joe,
    Sorry no, bug is still there on that latest kernel.

Kate

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Hi Kate,

This looks like the fix for the bug:

commit e3dde4fba94e0ba5e1fd79ea9e5389eea1f0cfec
Author: JJ Ding <email address hidden>
Date: Tue Apr 10 00:30:12 2012 -0700

Input: elantech - v4 is a clickpad, with only one button

I'm going to cherry-pick this commit and build it into a Precise kernel. I'll post the kernel shortly.

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

I might need to do some work to get the commit to backport into Precise.

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

I found the following commit is also needed as a prereq to e3dde4:

3d95fd6ad8d3cf582a70ed65660017114b6e4065

I'm building a test kernel with these two commits now and will post it shortly.

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Hi Kate,

I created a Precise test kernel with the following commits backported to it:

b56b92a9a175faad4c182309a63f221219de9191
3d95fd6ad8d3cf582a70ed65660017114b6e4065
e3dde4fba94e0ba5e1fd79ea9e5389eea1f0cfec

The kernel .deb is named linux-image-3.2.0-30-generic_3.2.0-30.48~lp1033568v1_amd64.deb and is available from:
http://people.canonical.com/~jsalisbury/lp1033568

It would be great if you could test that kernel to verify these commits fix the bug.

Thanks again for all the help testing.

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Hi Kate,

I was wondering if you had a chance to test the kernel posted in comment #28? If that kernel fixes the bug, I can submit an SRU request to see if the fix can be applied to Precise.

Revision history for this message
Kate Stewart (kate.stewart) wrote :

Hi Joe,
    Sorry for the delay, beta 1 kept me a bit too busy last week. Anyhow, just tried: linux-image-3.2.0-30-generic_3.2.0-30.48~lp1033568v1_amd64.deb and it fixes the issue. Let me know if there's anything else you need me to test.

Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Thanks for testing, Kate. It appears the following commits fix this bug:

b56b92a9a175faad4c182309a63f221219de9191
3d95fd6ad8d3cf582a70ed65660017114b6e4065
e3dde4fba94e0ba5e1fd79ea9e5389eea1f0cfec

I can submit these commits for SRU consideration into Precise. I'm not certain if these are too many changes for a stable release or not.

tags: removed: performing-bisect
Tim Gardner (timg-tpi)
Changed in linux (Ubuntu Precise):
status: Confirmed → Fix Committed
Tim Gardner (timg-tpi)
Changed in linux (Ubuntu Quantal):
status: Confirmed → Fix Released
Revision history for this message
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Precise in -proposed solves the problem (3.2.0-32.51). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-precise' to 'verification-done-precise'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-precise
Revision history for this message
Luis Henriques (henrix) wrote :

Hi Kate, could you please test the kernel in -proposed as stated in comment #32 so that we can close this bug report? Thank you.

Revision history for this message
Kate Stewart (kate.stewart) wrote :

Sorry, this fix came in while I was doing the Beta 2 release for quantal, which took priority.
I'll try find time to set this up on a system now, and see if we can get this resolved.

Revision history for this message
Kate Stewart (kate.stewart) wrote :

Verified that the new kernel has the fix. Touchpad working as good on precise as on quantal now. :)

kate@adelie:~$ uname -a
Linux adelie 3.2.0-32-generic #51-Ubuntu SMP Wed Sep 26 21:33:09 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

tags: added: verification-done-precise
removed: verification-needed-precise
Revision history for this message
Kate Stewart (kate.stewart) wrote :

Thanks Joe, Luis, Brad, Tim! :) tag switched.

Revision history for this message
Adam Conrad (adconrad) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (18.4 KiB)

This bug was fixed in the package linux - 3.2.0-32.51

---------------
linux (3.2.0-32.51) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1056036

  [ Keng-Yu Lin ]

  * SAUCE: Intel xhci: Only switch the switchable ports
    - LP: #1034814

  [ Kyle Fazzari ]

  * SAUCE: input: Cypress PS/2 Trackpad fix disabling tap-to-click
    - LP: #1048816

  [ Seth Forshee ]

  * SAUCE: Input: synaptics - Adjust threshold for treating position values
    as negative
    - LP: #1046512

  [ Stefan Bader ]

  * Revert "SAUCE: Force xsave off on older Xen hypervisors"
    - LP: #1044550

  [ Upstream Kernel Changes ]

  * Revert "HID: wiimote: fix invalid power_supply_powers call"
    - LP: #1048605
  * Revert "drm/radeon: fix bo creation retry path"
    - LP: #1049899
  * HID: wiimote: fix invalid power_supply_powers call
    - LP: #1048605
  * HID: add ASUS AIO keyboard model AK1D
    - LP: #1027789, #1049899
  * nfs: tear down caches in nfs_init_writepagecache when allocation fails
    - LP: #1049899
  * NFS: Use kcalloc() when allocating arrays
    - LP: #1049899
  * NFSv4.1 fix page number calculation bug for filelayout decode buffers
    - LP: #1049899
  * fix page number calculation bug for block layout decode buffer
    - LP: #1049899
  * pnfs: defer release of pages in layoutget
    - LP: #1049899
  * ext4: avoid kmemcheck complaint from reading uninitialized memory
    - LP: #1049899
  * fuse: verify all ioctl retry iov elements
    - LP: #1049899
  * Bluetooth: Fix legacy pairing with some devices
    - LP: #1049899
  * xhci: Increase reset timeout for Renesas 720201 host.
    - LP: #1049899
  * xhci: Add Etron XHCI_TRUST_TX_LENGTH quirk.
    - LP: #1049899
  * USB: ftdi_sio: Add VID/PID for Kondo Serial USB
    - LP: #1049899
  * USB: option: Add Vodafone/Huawei K5005 support
    - LP: #1049899
  * USB: add USB_VENDOR_AND_INTERFACE_INFO() macro
    - LP: #1049899
  * USB: support the new interfaces of Huawei Data Card devices in option
    driver
    - LP: #1049899
  * usb: serial: mos7840: Fixup mos7840_chars_in_buffer()
    - LP: #1049899
  * usb: gadget: u_ether: fix kworker 100% CPU issue with still used
    interfaces in eth_stop
    - LP: #1049899
  * ARM: 7483/1: vfp: only advertise VFPv4 in hwcaps if CONFIG_VFPv3 is
    enabled
    - LP: #1049899
  * ARM: 7488/1: mm: use 5 bits for swapfile type encoding
    - LP: #1049899
  * ARM: 7489/1: errata: fix workaround for erratum #720789 on UP systems
    - LP: #1049899
  * drm/i915: ignore eDP bpc settings from vbt
    - LP: #1049899
  * ALSA: hda - fix Copyright debug message
    - LP: #1049899
  * sched: fix divide by zero at {thread_group,task}_times
    - LP: #1049899
  * ath9k: fix decrypt_error initialization in ath_rx_tasklet()
    - LP: #1049899
  * drm/nvd0/disp: mask off high 16 bit of negative cursor x-coordinate
    - LP: #1049899
  * drm/i915: reorder edp disabling to fix ivb MacBook Air
    - LP: #1049899
  * audit: don't free_chunk() after fsnotify_add_mark()
    - LP: #1049899
  * audit: fix refcounting in audit-tree
    - LP: #1049899
  * vfs: canonicalize create mode in build_open_flags()
    - LP: #1049899
  * PCI: EHCI: Fix crash d...

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
Revision history for this message
AceLan Kao (acelankao) wrote :

Hi Kate,

Are you still around?
We encountered a issue, bug 1188025, that introduced by the commit that fixed your problem.
I have to do some test to figure out a solution to make both happy.
So, could you give me a hand to test the code from my directory?

http://people.canonical.com/~acelan/bugs/lp1188025/

1. download the tarball and do 'tar zxvf mouse.tgz'
2. cd mouse ; make
3. sudo rmmod psmouse
4. sudo insmod ./psmouse.ko
5. and then see if your clickpad right click works
6. to revert the work above
   sudo rmmod psmouse
   sudo modprobe psmouse

Thanks.

Revision history for this message
Zoltan Palagyi (palagyi) wrote :

Hi AceLan,

your solution works for me until reboot. How do I make it permanent? Thanks for your help!

Zoltan

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers