Special keys don't work on ASUS N56VZ

Bug #1030556 reported by sami on 2012-07-29
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Special keys don't work on ASUS N56VZ.

This is very simlar to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=679158#62 but with very small differences.

Here is a list of the available special keys:
     Key Description
Fn+
      F1 Sleep
      F2 Wireless on/off
      F3 decrease keyboard backlight brightness
      F4 increase keyboard backlight brightness
      F5 decrease screen brightness
      F6 increase screen brightness
      F7 enable/disable screen
      F8 toggle screen/external
      F9 disable touchpad
     F10 mute sound
     F11 decrease volume
     F12 increase volume
       C ? (maybe "Splendid Video Intelligent Technology" on/off, maybe not)
       V start webcam application
   Space cycle through power saving modes
      Up (multimedia) stop
    Down (multimedia) play/pause
    Left (multimedia) backward
    Right (multimedia) forward
Enter (on the keypad) calc

On a fresh ubuntu 12.04 install, nothing works, except F1, F2 and F7.
I set up an upstream 3.5 kernel and patched it according to http://permalink.gmane.org/gmane.linux.drivers.platform.x86.devel/3537

With the patch: everything works but F5, F6, C, V.
- C and V can be configurated through keyboard settings, so there is nothing to worry about
- F5 and F6 give nothing to dmesg and are not recognized by keyboard settings (i cannot use them on any shortut)...
- I don't know if space is working (let me know and i will do the test)

--> Finally,
- there is a need to backport the fix mentionned above
- there is really something wrong with F5 and F6 that are still not working even after the fix...

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-generic 3.2.0.27.29
ProcVersionSignature: Ubuntu 3.2.0-27.43-generic 3.2.21
Uname: Linux 3.2.0-27-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC663 Analog [ALC663 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu11
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC663 Analog [ALC663 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: sam 1732 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf7a10000 irq 44'
   Mixer name : 'Realtek ALC663'
   Components : 'HDA:10ec0663,10431477,00100002'
   Controls : 23
   Simple ctrls : 13
CheckboxSubmission: 54021779511d0213081a2b1707bf951c
CheckboxSystem: 4c773cd91921f9618cc2f1893bc1a87a
Date: Sun Jul 29 18:15:21 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: ASUSTeK COMPUTER INC. N56VZ
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-27-generic root=UUID=e0784b72-afa1-4bdb-bc89-fef934982476 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-27-generic N/A
 linux-backports-modules-3.2.0-27-generic N/A
 linux-firmware 1.79
SourcePackage: linux
StagingDrivers: mei keucr
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/11/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: N56VZ.204
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: N56VZ
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrN56VZ.204:bd05/11/2012:svnASUSTeKCOMPUTERINC.:pnN56VZ:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnN56VZ:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: N56VZ
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

sami (miaousami) wrote :
Brad Figg (brad-figg) on 2012-07-29
affects: linux-meta (Ubuntu) → linux (Ubuntu)
Brad Figg (brad-figg) on 2012-07-29
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.5kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc7-quantal/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
sami (miaousami) wrote :

Hi,
I tested the latest kernel as you asked me but it didn't change anything...

#uname -r : 3.5.0-030500rc7-generic

This isn't a surprise, because as I said in my initial post I had to patch the 3.5 kernel from kernel.org to make it partially work (see post above)...

Sam

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Tomasz Kus (tomek-kus) wrote :

The problem is reproducible on my machine too (ASUS N56VZ).

sami (miaousami) wrote :

This commit http://git.iksaif.net/?p=acpi4asus-dkms.git;a=commit;h=9af1225e31ef5f82eaff4c0e8abf6e0b2702ffd7 fixes all the Fn+x keys but Fn+F5/F6 (brightness).

- how to backport the fix mentionned above
- how to fix Fn+F5/F6 that are still not working even after the fix...

sami (miaousami) wrote :

Hi,
the patch mentionned above has been backported in ubuntu linux kernel 3.2.0-30.

All Fn+x keys are working, except Fn+F5/F6 that are still not working even after the fix...

--> Do you know how to fix it ?

Wildbat (letter-junk) wrote :

The problem is reproducible on my laptop too (ASUS N56VZ).
on Ubuntu 12.10

WhiteWind (temkaveter) wrote :

After a fresh installation of Ubuntu 12.10 with 3.5.0-generic i have all working special keys, except Fn+F5/F6 (brightness). I used a workaround with xbacklight (assigned to Ctrl+F5/F6), but it`s annoying to use such a "solution". What can I do to help fix it?

D Tenebrator (detenebrator) wrote :

Fresh install of 12.10, all keys appear to work except Fn+F5/F6 (screen brighness). They're apparently dead in the keyboard driver,
as 'showkeys -s' doesn't respond at all when they're pressed, so there's nothing to map.

Fn+F3/F4 show up in the kernel keymaps, but not in X,
xmodmap <<EOF
keycode 229 = XF86KbdBrightnessDown
keycode 230 = XF86KbdBrightnessUp
EOF
works.

sami (miaousami) wrote :

Hi,

good news : Fn+F5/F6 (screen brighness) is working on Ubuntu 13.04 beta2.
Does anyone know how to backport it in 12.04 ?

Paweł Szafer (pszafer) wrote :

Hello,

I'd like to add that in Ubuntu 13.04 latest beta almost all Fn Keys working except:
Fn+F1, Fn+F2, Fn+C, Fn+V. Don't know about Fn+F8, because I don't use this key.

sami (miaousami) wrote :

Hi,

as of 3.2.0-41-generic, all special keys are working.

The change happened between 2013-04-06 and 3.2.0-41, but I don't know in wich kernel version exactly...

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
bobzer (bobzer) wrote :

before to close and forget forever this thread, someone do know what is the fix ?
i have a custom kernel 3.8.5 and it's not working so i think i need to add some option during the compilation but which one , i never found.

thanks
ps and it could be usefull for other :-)

Download full text (5.1 KiB)

F5 + Fn and F6 + Fn (screen brightness) still does not work with kernel
3.5.0-28-generic #48~precise1-Ubuntu

2013/5/14 sami <email address hidden>

> Hi,
>
> as of 3.2.0-41-generic, all special keys are working.
>
> The change happened between 2013-04-06 and 3.2.0-41, but I don't know in
> wich kernel version exactly...
>
> ** Changed in: linux (Ubuntu)
> Status: Confirmed => Fix Released
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1030556
>
> Title:
> Special keys don't work on ASUS N56VZ
>
> Status in “linux” package in Ubuntu:
> Fix Released
>
> Bug description:
> Special keys don't work on ASUS N56VZ.
>
> This is very simlar to http://bugs.debian.org/cgi-
> bin/bugreport.cgi?bug=679158#62 but with very small differences.
>
> Here is a list of the available special keys:
> Key Description
> Fn+
> F1 Sleep
> F2 Wireless on/off
> F3 decrease keyboard backlight brightness
> F4 increase keyboard backlight brightness
> F5 decrease screen brightness
> F6 increase screen brightness
> F7 enable/disable screen
> F8 toggle screen/external
> F9 disable touchpad
> F10 mute sound
> F11 decrease volume
> F12 increase volume
> C ? (maybe "Splendid Video Intelligent Technology" on/off,
> maybe not)
> V start webcam application
> Space cycle through power saving modes
> Up (multimedia) stop
> Down (multimedia) play/pause
> Left (multimedia) backward
> Right (multimedia) forward
> Enter (on the keypad) calc
>
> On a fresh ubuntu 12.04 install, nothing works, except F1, F2 and F7.
> I set up an upstream 3.5 kernel and patched it according to
> http://permalink.gmane.org/gmane.linux.drivers.platform.x86.devel/3537
>
> With the patch: everything works but F5, F6, C, V.
> - C and V can be configurated through keyboard settings, so there is
> nothing to worry about
> - F5 and F6 give nothing to dmesg and are not recognized by keyboard
> settings (i cannot use them on any shortut)...
> - I don't know if space is working (let me know and i will do the test)
>
> --> Finally,
> - there is a need to backport the fix mentionned above
> - there is really something wrong with F5 and F6 that are still not
> working even after the fix...
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.04
> Package: linux-image-generic 3.2.0.27.29
> ProcVersionSignature: Ubuntu 3.2.0-27.43-generic 3.2.21
> Uname: Linux 3.2.0-27-generic x86_64
> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
> AplayDevices:
> **** List of PLAYBACK Hardware Devices ****
> card 0: PCH [HDA Intel PCH], device 0: ALC663 Analog [ALC663 Analog]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> ApportVersion: 2.0.1-0ubuntu11
> Architecture: amd64
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: PCH [HDA Intel PCH], device 0: ALC663 Analog [ALC663 Analog]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> A...

Read more...

sami (miaousami) wrote :

Hi guys,
I tested the latest vanilla kernel (3.9.4) and a lot of special keys were broken... :-(
This is quite strange as I thought that some patch had been backported from upstream...

I hope everything will be fixed in the next release (keyboard backlight and brightness).

In the meantime, I suggest you downgrade to "standard ubuntu kernel" which should be 3.2 where everything is working...

sami (miaousami) wrote :

Hi,

still not working on vanilla 3.10 :-(

I tried "acpi_osi='!Windows 2012'" as suggested here but it has no effects...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers