not have bluetooth usb 0489:e046 Foxconn / Hon Hai

Bug #1030233 reported by Watcharapol Tadtiang on 2012-07-28
36
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Debian)
Fix Released
Unknown
linux (Ubuntu)
Medium
Jesse Sung
Precise
Undecided
Jesse Sung
Quantal
Medium
Jesse Sung

Bug Description

not have bluetooth usb 0489:e046 Foxconn / Hon Hai

# Version
Ubuntu 3.2.0-27.43-generic 3.2.21

# usb-deveices
T: Bus=01 Lev=02 Prnt=02 Port=02 Cnt=03 Dev#= 5 Spd=12 MxCh= 0
D: Ver= 2.00 Cls=ff(vend.) Sub=01 Prot=01 MxPS=64 #Cfgs= 1
P: Vendor=0489 ProdID=e046 Rev=01.12
S: Manufacturer=Broadcom Corp
S: Product=BCM20702A0
S: SerialNumber=C01885F67F9E
C: #Ifs= 4 Cfg#= 1 Atr=e0 MxPwr=0mA
I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=01 Prot=01 Driver=(none)
I: If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=01 Prot=01 Driver=(none)
I: If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
I: If#= 3 Alt= 0 #EPs= 0 Cls=fe(app. ) Sub=01 Prot=01 Driver=(none)

# lsusb
Bus 001 Device 005: ID 0489:e046 Foxconn / Hon Hai

References Topic
http://askubuntu.com/questions/111584/bluetooth-not-working

References Bugs
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=682971

ps. attach patch

Thank You.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-27-generic 3.2.0-27.43
ProcVersionSignature: Ubuntu 3.2.0-27.43-generic 3.2.21
Uname: Linux 3.2.0-27-generic x86_64
NonfreeKernelModules: wl
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu11
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC271X Analog [ALC271X Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 2557 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xc0710000 irq 45'
   Mixer name : 'Intel PantherPoint HDMI'
   Components : 'HDA:10ec0269,10250721,00100100 HDA:80862806,10250721,00100000'
   Controls : 26
   Simple ctrls : 12
Date: Sat Jul 28 13:43:17 2012
HibernationDevice: RESUME=UUID=72e649a9-2068-490a-bef9-d6a4a6ac395e
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: Acer TravelMate P243
ProcEnviron:
 SHELL=/bin/bash
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-27-generic root=UUID=b4d7c9a7-c7d4-4c7e-aea6-019ccd54564d ro acpi_osi=Linux acpi_backlight=intel quiet splash vt.handoff=7
PulseList:
 Error: command ['pacmd', 'list'] failed with exit code 1: Home directory /home/ubuntu not ours.
 No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-27-generic N/A
 linux-backports-modules-3.2.0-27-generic N/A
 linux-firmware 1.79
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/31/2012
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: V1.03
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: BA40_HC
dmi.board.vendor: Acer
dmi.board.version: Type2 - Board Version
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsydeCorp.:bvrV1.03:bd05/31/2012:svnAcer:pnTravelMateP243:pvrV1.03:rvnAcer:rnBA40_HC:rvrType2-BoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: TravelMate P243
dmi.product.version: V1.03
dmi.sys.vendor: Acer

Changed in linux (Ubuntu):
assignee: nobody → aborigines (aborigines)
assignee: aborigines (aborigines) → nobody
Brad Figg (brad-figg) on 2012-07-28
Changed in linux (Ubuntu):
status: New → Confirmed

The attachment "btusb.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Jesse Sung (wenchien) wrote :

Hi aborigines,

Could you try this and see if bluetooth works:

* do a cold boot
* open a terminal and run following commands:
sudo -i
modprobe -r bluetooth
modprobe btusb
echo "0489 e046" >> /sys/bus/usb/drivers/btusb/new_id
modprobe bluetooth

Thank you!

Download full text (4.5 KiB)

Hi Jesse,
it's work , thank you .
but i don't want to see the newbie work hard with linux .

On Mon, Jul 30, 2012 at 4:26 PM, Jesse Sung <email address hidden>wrote:

> Hi aborigines,
>
> Could you try this and see if bluetooth works:
>
> * do a cold boot
> * open a terminal and run following commands:
> sudo -i
> modprobe -r bluetooth
> modprobe btusb
> echo "0489 e046" >> /sys/bus/usb/drivers/btusb/new_id
> modprobe bluetooth
>
> Thank you!
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1030233
>
> Title:
> not have bluetooth usb 0489:e046 Foxconn / Hon Hai
>
> Status in “linux” package in Ubuntu:
> Confirmed
> Status in “linux” package in Debian:
> Unknown
>
> Bug description:
> not have bluetooth usb 0489:e046 Foxconn / Hon Hai
>
> # Version
> Ubuntu 3.2.0-27.43-generic 3.2.21
>
> # usb-deveices
> T: Bus=01 Lev=02 Prnt=02 Port=02 Cnt=03 Dev#= 5 Spd=12 MxCh= 0
> D: Ver= 2.00 Cls=ff(vend.) Sub=01 Prot=01 MxPS=64 #Cfgs= 1
> P: Vendor=0489 ProdID=e046 Rev=01.12
> S: Manufacturer=Broadcom Corp
> S: Product=BCM20702A0
> S: SerialNumber=C01885F67F9E
> C: #Ifs= 4 Cfg#= 1 Atr=e0 MxPwr=0mA
> I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=01 Prot=01 Driver=(none)
> I: If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=01 Prot=01 Driver=(none)
> I: If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
> I: If#= 3 Alt= 0 #EPs= 0 Cls=fe(app. ) Sub=01 Prot=01 Driver=(none)
>
> # lsusb
> Bus 001 Device 005: ID 0489:e046 Foxconn / Hon Hai
>
> References Topic
> http://askubuntu.com/questions/111584/bluetooth-not-working
>
> References Bugs
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=682971
>
> ps. attach patch
>
> Thank You.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.04
> Package: linux-image-3.2.0-27-generic 3.2.0-27.43
> ProcVersionSignature: Ubuntu 3.2.0-27.43-generic 3.2.21
> Uname: Linux 3.2.0-27-generic x86_64
> NonfreeKernelModules: wl
> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
> ApportVersion: 2.0.1-0ubuntu11
> Architecture: amd64
> ArecordDevices:
> **** List of CAPTURE Hardware Devices ****
> card 0: PCH [HDA Intel PCH], device 0: ALC271X Analog [ALC271X Analog]
> Subdevices: 1/1
> Subdevice #0: subdevice #0
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: ubuntu 2557 F.... pulseaudio
> CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1:
> nl80211 not found.
> Card0.Amixer.info:
> Card hw:0 'PCH'/'HDA Intel PCH at 0xc0710000 irq 45'
> Mixer name : 'Intel PantherPoint HDMI'
> Components : 'HDA:10ec0269,10250721,00100100
> HDA:80862806,10250721,00100000'
> Controls : 26
> Simple ctrls : 12
> Date: Sat Jul 28 13:43:17 2012
> HibernationDevice: RESUME=UUID=72e649a9-2068-490a-bef9-d6a4a6ac395e
> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64
> (20120425)
> MachineType: Acer TravelMate P243
> ProcEnviron:
> SHELL=/bin/bash
> TERM=xterm
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> ProcFB: 0 inteld...

Read more...

Changed in linux (Ubuntu):
importance: Undecided → Medium
Jesse Sung (wenchien) wrote :

aborigines,

Since you already have a patch for this device, would you mind to send it to upstream?
mailing list: <email address hidden>

Please also attach the output of usb-devices, like this commit:
http://git.kernel.org/?p=linux/kernel/git/bluetooth/bluetooth.git;a=commit;h=2096ae6ca647302d50a68aa36cb66a00e7dfac70

Thank you!

hi Jesse Sung ,

Finish report to kernel.org

https://lkml.org/lkml/2012/8/12/18

Wait for Review Patch and Commit To Kernel

Thank You .

Changed in linux (Debian):
status: Unknown → New
Changed in linux (Debian):
status: New → Confirmed
NANODUDE (nanodude) wrote :

Hello, having the same problem on my Acer V5 Laptop.
I could manage to enable my Bluetooth / Wireless Combo adapter by using Fn + F3.
The only thing that doesnt work is browsing for devices.
It simply doesnt list any device in the Applet.
Anyone who can help me with with this issue?

jascha (jaschak) wrote :

Have this problem also on an Acer V5-171 Laptop.

Yo, every body!

i'm make package with dkms , it's override kernel source.

try it with my ppa or get only .deb

my ppa:
https://launchpad.net/~aborigines/+archive/ppa

get .deb:
https://launchpad.net/~aborigines/+archive/ppa/+build/3885864/+files/btusb-bcfoxhon_0.1-0ubuntu1_all.deb

---
kernel.org make patch slowly.
them finish patch for support this device on kernel 3.6

try it,
Thank You

NANODUDE (nanodude) wrote :

Hello, getting this error on 12.10 Beta 2:

Selecting previously unselected package btusb-bcfoxhon.
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 290671 files and directories currently installed.)
Unpacking btusb-bcfoxhon (from .../btusb-bcfoxhon_0.1-0ubuntu1_all.deb) ...
Setting up btusb-bcfoxhon (0.1-0ubuntu1) ...

Creating symlink /var/lib/dkms/btusb-bcfoxhon/0.1/source ->
                 /usr/src/btusb-bcfoxhon-0.1

DKMS: add completed.

Kernel preparation unnecessary for this kernel. Skipping...

Building module:
cleaning build area....
make KERNELRELEASE=3.5.0-17-generic KVERSION=3.5.0-17-generic......(bad exit status: 2)
ERROR (dkms apport): unable to determine source package for btusb-bcfoxhon
Error! Bad return status for module build on kernel: 3.5.0-17-generic (x86_64)
Consult /var/lib/dkms/btusb-bcfoxhon/0.1/build/make.log for more information.
dpkg: error processing btusb-bcfoxhon (--install):
 subprocess installed post-installation script returned error exit status 10

@Andriy (cyberhero)

my package for ubuntu 12.04 only

Thx.

NANODUDE (nanodude) wrote :

Thank you anyway, I hope your solution will help those who are still using 12.04.
How long do you think it will take kernel.org to implement the patch and to release 3.6 kernel?

@Andriy (cyberhero)

kerne.org all ready for support this device.

i view patch on kerne.org , they ready patch on version 3.4.12 , 3.5.5 and 3.6 .

if u view patch, u will see , this world , it mean this device
/*Broadcom devices with vendor specific id */
{ USB_VENDOR_AND_INTERFACE_INFO(0x0a5c, 0xff, 0x01, 0x01) },

but ubuntu 12.10 (beta2) use kernel v.3.5.0 and base on v.3.5.4 .

not sure for support this device when they release 12.04

refer kernel
http://article.gmane.org/gmane.linux.bluez.kernel/28348

refer ubuntu tech overview 12.04 beta2
https://wiki.ubuntu.com/QuantalQuetzal/TechnicalOverview/Beta2

thx.

@Andriy (cyberhero)

I have some problem with patch.

i view source of kernel 3.5.0-17.27 , i see ubuntu get patch same as kernel.org

i don't know , why not work with this device

i will check and report it.

thx.

@Andriy (cyberhero)

sry , my missing for #13 and #14 , it worng!!!

they not patch wait for v 3.6 plz

next friday i will make package for ubuntu 12.10

Jesse Sung (wenchien) on 2012-10-08
Changed in linux (Ubuntu):
assignee: nobody → Jesse Sung (wenchien)
Tim Gardner (timg-tpi) on 2012-10-08
Changed in linux (Ubuntu Quantal):
status: Confirmed → Fix Committed
Changed in linux (Ubuntu Precise):
assignee: nobody → Jesse Sung (wenchien)
status: New → In Progress
Tim Gardner (timg-tpi) on 2012-10-08
Changed in linux (Ubuntu Precise):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.5.0-17.28

---------------
linux (3.5.0-17.28) quantal-proposed; urgency=low

  [ Andy Whitcroft ]

  * [packaging] we already have a valid src_pkg_name
  * [packaging] allow us to select which builds have uefi signed versions

  [ James M Leddy ]

  * SAUCE: input: fix weird issue of synaptics psmouse sync lost after
    resume
    - LP: #717970

  [ Paolo Pisati ]

  * SAUCE: omap3 clocks .dev_id = NULL
    - LP: #1061599
  * [Config] omap: disable USB_[EHCI|OHCI]_HCD_PLATFORM
    - LP: #1061599
  * [Config] omap: enforce USB_[EHCI|OHCI]_HCD_PLATFORM=n
    - LP: #1061599

  [ Stefan Bader ]

  * SAUCE: net/ipv4: Always flush route cache on unregister batch call
    - LP: #1021471

  [ Upstream Kernel Changes ]

  * Bluetooth: Add USB_VENDOR_AND_INTERFACE_INFO() for Broadcom/Foxconn
    - LP: #1030233

  [ Wen-chien Jesse Sung ]

  * SAUCE: Bluetooth: Remove rules for matching Broadcom vendor specific
    IDs
    - LP: #1030233
 -- Leann Ogasawara <email address hidden> Tue, 09 Oct 2012 11:23:41 -0700

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released

On ubuntu 12.10 , it's work.

Thank you very much

Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Precise in -proposed solves the problem (3.2.0-33.52). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-precise' to 'verification-done-precise'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-precise

On 12.04 , it's work
Thank You Very Much!

tags: added: verification-done-precise
removed: verification-needed-precise
Changed in linux (Debian):
status: Confirmed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :
Download full text (9.1 KiB)

This bug was fixed in the package linux - 3.2.0-33.52

---------------
linux (3.2.0-33.52) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1067666

  [ Andy Whitcroft ]

  * [Config] add fs/udf to linux-image to support DVD/CD formats in virtual
    instances
    - LP: #1066921

  [ James M Leddy ]

  * SAUCE: input: fix weird issue of synaptics psmouse sync lost after
    resume
    - LP: #717970

  [ Paolo Pisati ]

  * [SRU] [Config] enable TIDSPBRIDGE for omap arm[el|hf] flavours
    - LP: #1058022

  [ Sarveshwar Bandi ]

  * SAUCE: bridge: Pull ip header into skb->data before looking into ip
    header.
    - LP: #1065150

  [ Upstream Kernel Changes ]

  * Revert "drm/radeon: rework pll selection (v3)"
    - LP: #1065047
  * sched: Fix migration thread runtime bogosity
    - LP: #1057593
  * Bluetooth: Add support for Sony Vaio T-Series
    - LP: #1054307
  * drm/radeon: properly handle mc_stop/mc_resume on evergreen+ (v2)
    - LP: #1058303
  * Bluetooth: Use USB_VENDOR_AND_INTERFACE() for Broadcom devices
    - LP: #1058303
  * Bluetooth: Add USB_VENDOR_AND_INTERFACE_INFO() for Broadcom/Foxconn
    - LP: #1030233, #1058303
  * target: Fix ->data_length re-assignment bug with SCSI overflow
    - LP: #1065047
  * ASoC: samsung dma - Don't indicate support for pause/resume.
    - LP: #1065047
  * fs/proc: fix potential unregister_sysctl_table hang
    - LP: #1065047
  * mm/ia64: fix a memory block size bug
    - LP: #1065047
  * nbd: clear waiting_queue on shutdown
    - LP: #1065047
  * drivers/rtc/rtc-twl.c: ensure all interrupts are disabled during probe
    - LP: #1065047
  * mm/page_alloc: fix the page address of higher page's buddy calculation
    - LP: #1065047
  * memory hotplug: fix section info double registration bug
    - LP: #1065047
  * cciss: fix handling of protocol error
    - LP: #1065047
  * vfs: dcache: use DCACHE_DENTRY_KILLED instead of DCACHE_DISCONNECTED in
    d_kill()
    - LP: #1065047
  * workqueue: reimplement work_on_cpu() using system_wq
    - LP: #1065047
  * cpufreq/powernow-k8: workqueue user shouldn't migrate the kworker to
    another CPU
    - LP: #1065047
  * sched: Fix ancient race in do_exit()
    - LP: #1065047
  * hpwdt: Fix kdump issue in hpwdt
    - LP: #1065047
  * rtlwifi: rtl8192ce: Log message that B_CUT device may not work
    - LP: #1065047
  * brcmfmac: fix big endian bug in i-scan.
    - LP: #1065047
  * brcmfmac: Fix big endian host configuration data.
    - LP: #1065047
  * dmaengine: at_hdmac: fix comment in atc_prep_slave_sg()
    - LP: #1065047
  * dmaengine: at_hdmac: check that each sg data length is non-null
    - LP: #1065047
  * ARM: 7532/1: decompressor: reset SCTLR.TRE for VMSA ARMv7 cores
    - LP: #1065047
  * drm/i915: Reduce a pin-leak BUG into a WARN
    - LP: #1065047
  * bnx2i: Fixed NULL ptr deference for 1G bnx2 Linux iSCSI offload
    - LP: #1065047
  * mpt2sas: Fix for issue - Unable to boot from the drive connected to HBA
    - LP: #1065047
  * hwmon: (ads7871) Add 'name' sysfs attribute
    - LP: #1065047
  * DMA: PL330: Check the pointer returned by kzalloc
    - LP: #1065047
  * hpsa: fix handling of protocol error
    -...

Read more...

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.