Internal laptop SD/MMC/etc... card reader not recognized

Bug #1019127 reported by MacDaddy on 2012-06-29
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

My internal SD card reader is unusable and does not show up in either lspci or lsusb.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-26-generic 3.2.0-26.41
ProcVersionSignature: Ubuntu 3.2.0-26.41-generic 3.2.19
Uname: Linux 3.2.0-26-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu8
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: fatpie 4053 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf6b10000 irq 46'
   Mixer name : 'Intel PantherPoint HDMI'
   Components : 'HDA:10ec0892,15585105,00100302 HDA:80862806,80860101,00100000'
   Controls : 52
   Simple ctrls : 23
Date: Thu Jun 28 22:01:56 2012
HibernationDevice: RESUME=UUID=e8ed344b-5391-4b1e-9bba-b3d87ec7efde
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: CLEVO P15xEMx
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-26-generic root=UUID=81f74ee5-b3ac-4cb5-8f4a-83e390407f81 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-26-generic N/A
 linux-backports-modules-3.2.0-26-generic N/A
 linux-firmware 1.79
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/14/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 4.6.5
dmi.board.asset.tag: Not Applicable
dmi.board.name: P15xEMx
dmi.board.vendor: CLEVO
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: Not Applicable
dmi.chassis.type: 10
dmi.chassis.vendor: CLEVO
dmi.chassis.version: Not Applicable
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr4.6.5:bd04/14/2012:svnCLEVO:pnP15xEMx:pvrNotApplicable:rvnCLEVO:rnP15xEMx:rvrNotApplicable:cvnCLEVO:ct10:cvrNotApplicable:
dmi.product.name: P15xEMx
dmi.product.version: Not Applicable
dmi.sys.vendor: CLEVO

Brad Figg (brad-figg) on 2012-06-29
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Did this issue start happening after an update/upgrade? Was there a kernel version where you were not having this particular problem? This will help determine if the problem you are seeing is the result of the introduction of a regression, and when this regression was introduced.

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.5kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc4-quantal/

Changed in linux (Ubuntu):
status: Confirmed → Incomplete

I'll give it a shot once I get some time. From other posts, I'm not sure if testing an upstream kernel will work. Does anybody know if 12.04 will be receiving a kernel update?

tags: removed: needs-upstream-testing
Download full text (3.7 KiB)

Got some time to play with this. Updated the kernel.
```
fatpie@fatpatty:~$ uname -a
Linux fatpatty 3.5.0-030500rc4-generic #201206241635 SMP Sun Jun 24 20:36:03 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
```

Looked in jockey. It magically appeared, but it was disabled, but in use. Not sure what that means. Anyway:
```
fatpie@fatpatty:~$ jockey-text --list
kmod:kvm_intel - kvm_intel (Free, Enabled, In use)
kmod:coretemp - Intel Core temperature monitor (Free, Enabled, In use)
kmod:mac_hid - mac_hid (Free, Enabled, In use)
kmod:nvidia_current - nvidia_current (Proprietary, Enabled, Not in use)
kmod:mxm_wmi - MXM WMI Driver (Free, Enabled, In use)
kmod:rtl8192ce - Realtek 8192C/8188C 802.11n PCI wireless (Free, Enabled, In use)
kmod:firewire_ohci - Driver for PCI OHCI IEEE1394 controllers (Free, Enabled, In use)
kmod:i2c_i801 - I801 SMBus driver (Free, Disabled, In use)
kmod:snd_hda_intel - Intel HDA driver (Free, Enabled, In use)
kmod:nouveau - nVidia Riva/TNT/GeForce (Free, Disabled, Not in use)
kmod:pcspkr - PC Speaker beeper driver (Free, Disabled, Not in use)
kmod:mei - Intel(R) Management Engine Interface (Free, Enabled, In use)
kmod:nvidiafb - Framebuffer driver for nVidia graphics chipset (Free, Disabled, Not in use)
kmod:i915 - Intel Graphics (Free, Enabled, In use)
kmod:uvcvideo - USB Video Class driver (Free, Enabled, In use)
kmod:lpc_ich - LPC interface for Intel ICH (Free, Enabled, In use)
kmod:r8169 - RealTek RTL-8169 Gigabit Ethernet driver (Free, Enabled, In use)
```

So I tried to enable it.
```
fatpie@fatpatty:~$ sudo jockey-text --enable kmod:i2c_i801

Sorry, installation of this driver failed.

Please have a look at the log file for details: /var/log/jockey.log
```

The logfile jockey.log says nothing, so I tried to load the module with modprobe. Now I see the card reader under lspci
```
fatpie@fatpatty:~$ lspci
00:00.0 Host bridge: Intel Corporation Ivy Bridge DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Ivy Bridge PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation Panther Point USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation Panther Point MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 2 (rev c4)
00:1c.2 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 3 (rev c4)
00:1c.3 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Panther Point LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Panther Point 6 port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Panther Point SMBus Controller (rev 04)
01:00.0 VGA compatible contro...

Read more...

Sorry, my mistake, it doesn't show up under lspci here in this instance. I got it to show up twice, and now it doesn't. Hmmm. Said SD reader Intel blah blah blah.

Please see bug #971876 (https://bugs.launchpad.net/ubuntu/+source/udisks/+bug/971876). This solved my problem.

How do I tag this report now?

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Jay Kamat (jgkamat) on 2013-09-21
Changed in linux (Ubuntu):
status: Expired → Confirmed
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers